Overzicht synchronisatie Outlook 12

Synchronisatie Outlook 12 is een functie waarmee u de entiteiten van Microsoft Dynamics NAV en Outlook up-to-date kunt houden. Met behulp va deze functie kunt u objecten van Microsoft Dynamics NAV bijwerken met Outlook-entiteiten of Outlook-entiteiten met objecten van Microsoft Dynamics NAV.

Om de synchronisatie te kunnen uitvoeren moet de beheerder eerst de synchronisatie-instellingen uitvoeren in Microsoft Dynamics NAV, waar hij/zij opgeeft welke objecten van Microsoft Dynamics NAV moeten deelnemen aan de synchronisatie. Vervolgens moeten in Outlook de synchronisatieopties worden ingesteld, waarbij wordt aangegeven waar de synchronisatie-entiteiten moeten worden opgeslagen, hoe synchronisatieconflicten moeten worden opgelost als deze optreden, en nog enkele andere opties.

De synchronisatie wordt aan de kant van Outlook automatisch gestart op vooraf ingestelde tijden die u opgeeft in Outlook, of handmatig door op de knop Synchroniseren te klikken op de werkbalk Synchronisatie van Microsoft Dynamics NAV. Synchronisatie Outlook 12 biedt u de volgende mogelijkheden:

  • Zorgen voor handige, betrouwbare en instelbare synchronisatie tussen Microsoft Dynamics NAV en Outlook-clients;
  • Bieden van een geavanceerde oplossing als verrijking van de integratie van Office voor kleine en middelgrote bedrijven;
  • Verminderen van de benodigde tijd voor implementatie en aanpassing voor NSC's;
  • Bieden van een flexibele en intuïtieve gebruikersinterface naar Outlook-synchronisatie-instellingen binnen Microsoft Dynamics NAV en Outlook.
De oplossing werkt op zowel rich als thin Microsoft Dynamics NAV-clients. Dit betekent dat u niet noodzakelijkerwijs Microsoft Dynamics NAV hoeft te hebben geïnstalleerd op uw computer om entiteiten van Microsoft Dynamics NAV en Outlook te kunnen synchroniseren.

Belangrijkste aandachtsgebieden

Microsoft Dynamics NAV contactpersonen/verkopers die worden gesynchroniseerd met contactpersonen van Outlook. De tabel bevat al uw contacten, zowel bedrijven als personen. Deze kunnen toekomstige klanten, klanten, leveranciers, adviseurs of concurrenten zijn, of een ander soort contact weergeven. Verkopers en marketingmedewerkers vinden het handig om contactpersonen uit Microsoft Dynamics NAV ook in Outlook te hebben, om met hen te kunnen communiceren wanneer ze geen verbinding hebben met Microsoft Dynamics NAV.

Taken uit Microsoft Dynamics NAV die worden gesynchroniseerd met afspraken en taken van Outlook. Taken worden gewoonlijk toegewezen aan verkoopmedewerkers, maar ook aan teams. Verkopers maken steeds vaker gebruik van laptops of PDA's om offline te werken en zodoende te profiteren van de offline mogelijkheden in Microsoft Outlook. Om efficiënt gebruik te kunnen maken van taken in Verkoop & Marketing, moeten verkopers taken en vergaderingen kunnen ophalen uit Verkoop & Marketing, deze importeren in Outlook, en vervolgens hiermee (mogelijkerwijze offline) direct aan de slag te gaan in Outlook. Zodra de verkoper online komt, wordt hij of zij opnieuw gesynchroniseerd met Verkoop & Marketing. Op die manier kunnen managers hun gedelegeerde taken volgen en hoeft er niet handmatig op twee plaatsen te worden bijgewerkt in beide toepassingen, met het risico van fouten en verkeerde combinaties.

U kunt alle termen die worden gebruikt in de oplossing Synchronisatie Outlook 12 vinden in de betreffende onderwerpen van het overzicht van deze online Help.

Verwante onderwerpen

Meer informatie

Identiteitstoewijzing

C/AL-gedeelte

Veldkoppelingsschema

Aanpassingskader

Laatste wijzing (datum/tijd)

Feedbackdocument

Laatst gesynchroniseerd

Geïsoleerde opslag

Niveaus van synchronisatie

Hoofdtabel

Koppelingsschema

Middle-tier server

Microsoft Dynamics NAV-entiteit

Microsoft Dynamics NAV-wijzigingslogbestand

Outlook-item

Microsoft Dynamics NAV rich en thin client

Outlook-synchronisatiefunctie

Outlook-invoegtoepassing

Synchronisatie-instellingen

OLHandler

Specificiteit van de synchronisatie

Outlook-objectmodel

Synchronisatie-entiteit

Hoofdgebruiker

Synchronisatie-uitzondering

Supergebruiker

Synchronisatie-interval

Outlook-synchronisatiegebruiker

Synchronisatieniveaus

Transportlaag

Synchronisatieproces

Webservicebeschrijvingstaal

Synchronisatieschema


Identiteitstoewijzing

U kunt entiteitstoewijzing uitvoeren wanneer u instelt welke Microsoft Dynamics NAV-entiteiten moeten worden gekoppeld aan specifieke Outlook-items. Entiteitstoewijzing maakt deel uit van de synchronisatie-instellingen.

De synchronisatie-instellingen worden uitgevoerd in Microsoft Dynamics NAV. Dit proces bestaat uit een aantal stappen. U kunt drie niveaus van synchronisatie instellen. Afhankelijk van het synchronisatieniveau definieert u verschillende sets Microsoft Dynamics NAV- en Outlook-objecten - van de kant van Microsoft Dynamics NAV kunnen dit tabellen en velden zijn, van de kant van Outlook gaat het om items, verzameling en eigenschappen.

Verwante onderwerpen

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Veldkoppelingsschema

Dit is de verzameling instellingen waarmee koppelingen tussen velden van synchronisatieniveau 1 worden gedefinieerd in Microsoft Dynamics NAV en de eigenschappen van niveau 1 in Outlook, tussen een veld van niveau 3 van de synchronisatie in Microsoft Dynamics NAV en eigenschappen van niveau 3 in Outlook.

Er zijn drie niveaus van synchronisatie. Om een veldkoppeling te kunnen definiëren, moet u het eerste of het eerste en het tweede niveau instellen.

Verwante onderwerpen

Entiteitstoewijzingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Laatste wijzing (datum/tijd)

Dit is de meest recente wijziging van een Microsoft Dynamics NAV-entiteit. De gewijzigde items worden opgehaald uit het wijzigingslogbestand. De datum/tijd van de laatste wijziging wordt vergeleken met de laatste synchronisatietijd. Als de datum/tijd van de laatste wijziging eerder is dan de laatste synchronisatietijd, worden er geen entiteiten gesynchroniseerd, tenzij u alle entiteiten gedwongen laat synchroniseren. Als de datum/tijd van de laatste wijziging later is, wordt de synchronisatie uitgevoerd.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Laatst gesynchroniseerd

Dit is de tijd waarop het meest recente synchronisatieproces is uitgevoerd. Deze tijd wordt per entiteit opgeslagen in de tabel Gebruiker instellen Outlook-synch. Met de laatste synchronisatietijd wordt rekening gehouden om te berekenen wanneer de volgende automatische synchronisatie moet worden uitgevoerd.

De volgen de automatische synchronisatie wordt uitgevoerd na de vooraf vastgelegde periode in Outlook, gerekend vanaf de laatste synchronisatietijd.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Niveaus van synchronisatie

Synchronisatieniveaus vormen een hiërarchische structuur die bestaat uit Microsoft Dynamics NAV-entiteiten en specifieke Outlook-items waaraan die entiteiten moeten worden gekoppeld. Er zijn in totaal drie synchronisatieniveaus. De hogere niveaus zijn hoofdniveaus voor de lagere.

  • Synchronisatie van niveau 1: het hoogste synchronisatieniveau, waarop de meest algemene Microsoft Dynamics NAV-entiteiten kunnen worden opgegeven, zoals hoofdtabellen. Omdat deze zich boven aan de hiërarchie van synchronisatieniveaus bevinden, specificeren deze welke Microsoft Dynamics NAV-entiteiten van synchronisatie van niveau 2 hieraan logisch zijn gerelateerd, opgenomen en direct gekoppeld aan de gekozen Outlook-items.

  • Synchronisatie van niveau 2: op dit synchronisatieniveau worden een of meer verzamelingen Microsoft Dynamics NAV-records gedefinieerd die logisch horen bij een bepaalde Microsoft Dynamics NAV-entiteit die is gedefinieerd op synchronisatieniveau 1. Microsoft Dynamics NAV-entiteiten van synchronisatieniveau 2 moeten altijd worden gekoppeld aan de overeenkomstige Outlook-eigenschap of verzameling. Alleen het tweede niveau specificeren is niet mogelijk.

  • Synchronisatie van niveau 3: een Microsoft Dynamics NAV-entiteit wordt geacht zich te bevinden op synchronisatieniveau 3 als deze deel uitmaakt van een Microsoft Dynamics NAV-entiteit van synchronisatieniveau 1 en 2. Velden van Microsoft Dynamics NAV-entiteiten van synchronisatieniveau 3 moeten altijd worden gekoppeld aan het overeenkomstige element uit de Outlook-verzameling.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Microsoft Dynamics NAV-entiteit

Een Microsoft Dynamics NAV-object dat de gegevens bevat die moeten worden gesynchroniseerd.

Het zijn Microsoft Dynamics NAV-tabellen of -velden die een Microsoft Dynamics NAV-entiteit kunnen vormen.

Een Microsoft Dynamics NAV-entiteit wordt gekoppeld aan Outlook-items en de eigenschappen daarvan voor het uitvoeren van de synchronisatie.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Outlook-item

Dit is een Outlook-object, dat de gegevens bevat die moeten worden gesynchroniseerd. Een Outlook-item kan een afspraak, contactpersoon, vergadering, taak, logboekvermeldingen, notities, e-mailberichten, enzovoort zijn. Het Outlook-item kan worden gekoppeld aan het overeenkomstige Microsoft Dynamics NAV-object voor het uitvoeren van de synchronisatie.

Outlook-items nemen deel aan het eerste van de drie niveaus van de synchronisatie. Op dit niveau worden Outlook-items gekoppeld aan Microsoft Dynamics NAV-tabellen. Eigenschappen van Outlook-verzamelingen en Outlook-verzamelingselementen die deelnemen op het tweede en derde niveau van synchronisatie, maken deel uit van een Outlook-item.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Outlook-synchronisatiefunctie

De functionaliteit van Outlook die een interface biedt voor het aanpassen van de synchronisatie-instellingen, het opgeven van probleemoplossingsopties en het uitvoeren van het synchronisatieproces. Als er tegelijkertijd wijzigingen plaatsvinden in Microsoft Dynamics NAV en in Outlook, moet de gebruiker besluiten welk van de twee prioriteit heeft. De gebruiker kan een van de vier beschikbare opties kiezen om conflicten op te lossen die zich voordoen tijdens de synchronisatie: het Outlook-item of de overeenkomstige Microsoft Dynamics NAV-records negeren, oudere entiteiten vervangen door nieuwere, of alleen de opgetreden conflicten registreren om deze later handmatig te laten oplossen. De laatste optie is de standaardoptie.

Outlook-item heeft eigen eigenschappen (waaronder Verzamelingen). Alle verzamelingselementen hebben eigen eigenschappen. De synchronisatiefunctie van Outlook biedt een interface voor het koppelen van deze eigenschappen aan de overeenkomstige velden in Microsoft Dynamics NAV-tabellen.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Synchronisatie-entiteit

Dit is een object van Outlook of van Microsoft Dynamics NAV dat gegevens bevat die moeten worden gesynchroniseerd. Microsoft Dynamics NAV-objecten zijn tabellen en velden; Outlook-objecten zijn items, verzamelingen en eigenschappen.

Voor elke Outlook-synchronisatie-entiteit zijn drie niveaus beschikbaar:

  • Outlook-item (AfspraakItem, ContactpersoonItem, DistLijstItem, DocumentItem, LogboekItem, E-mailItem, VergaderingItem, NotitieItem, PostItem, ExternItem, RapportItem, TaakverzoekAcceptatieItem, TaakverzoekWeigeringItem, TaakverzoekItem, TaakverzoekUpdateItem).

  • Verzameling (Acties, AdresInvoer, AdresLijsten, Bijlagen, Conflicten, Uitzonderingen, Mappen, Koppelingen, Ontvangers, Herinneringen).

  • Verzamelingelement (Actie, AdresLijst, AdresInvoer, Bijlage, Conflict, DistLijstItem, Uitzondering, FormulierBeschrijving, MAPIMap, Ontvanger, Koppeling, Terugkeerpatroon, Herinnering).

Outlook-item heeft eigen eigenschappen (sommige hiervan zijn verzamelingen). Alle verzamelingelementen hebben eigen eigenschappen.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Synchronisatie-uitzondering

Een synchronisatie-uitzondering is een instelling in Outlook die bepaalt welke categorieën Outlook-items niet moeten deelnemen aan de synchronisatie.

U wilt bijvoorbeeld afspraken synchroniseren, maar vastleggen dat afspraken die in het onderwerp "niet-zakelijk" hebben staan, niet moeten worden gesynchroniseerd. In dat geval definieert u een synchronisatie-uitzondering.

U kunt instellingen voor synchronisatie-uitzonderingen definiëren op het tabblad Filters van het formulier Instellingen van de Outlook-invoegtoepassing.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Synchronisatie-interval

U geeft een synchronisatie-interval op voor de Microsoft Dynamics NAV-synchronisatie-invoegtoepassing aan de kant van Outlook, waarin staat hoeveel tijd moet verstrijken voordat de volgende automatische synchronisatie wordt uitgevoerd.

Dit tijdsinterval wordt alleen ingesteld voor de automatische synchronisatie, omdat u voor handmatig synchroniseren op de knop Synchroniseren klikt op de werkbalk van de Outlook-invoegtoepassing.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Synchronisatieproces

U voert een synchronisatieproces uit wanneer u de informatie die is opgeslagen in Outlook-items of in Microsoft Dynamics NAV-entiteiten bijwerkt. Het synchronisatieproces kan van Outlook naar Microsoft Dynamics NAV of van Microsoft Dynamics NAV naar Outlook lopen. Het omvat het maken en parsen van XML-berichten die gegevens bevatten uit Outlook-items en Microsoft Dynamics NAV-entiteiten die zijn gedefinieerd in het koppelingsschema.

Bidirectionele synchronisatie is ook mogelijk. Als de synchronisatie in de richting van Outlook naar Microsoft Dynamics NAV loopt, ontvangt het programma alleen wijzigingen die zijn aangebracht in Outlook. Als de richting is ingesteld op Microsoft Dynamics NAV naar Outlook, worden alleen wijzigingen die zijn aangebracht in Microsoft Dynamics NAV verzonden. Als de richting wordt ingesteld op bidirectioneel, worden entiteiten in beide richtingen gesynchroniseerd.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieschema

Synchronisatie-instellingen


Synchronisatie-instellingen

Een proces waarbij wordt opgegeven welke Microsoft Dynamics NAV-entiteiten en Outlook-objecten (items, eigenschappen en verzamelingen) op elk synchronisatieniveau moeten worden geplaatst. Daarnaast moeten in de synchronisatie-instellingen de relaties van specifieke objecten die deelnemen aan de synchronisatie worden gedefinieerd.

De synchronisatie-instellingen worden uitgevoerd aan de kant van Microsoft Dynamics NAV. De synchronisatie-instellingen worden opgeslagen in een XML-schema.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema


Synchronisatieschema

Dit zijn de instellingen die zijn gemaakt aan de kant van Microsoft Dynamics NAV. In dit schema definieert u welke Microsoft Dynamics NAV-tabellen en welke velden van deze tabellen moeten worden gesynchroniseerd met welke Outlook-items en -verzamelingen. Een synchronisatieschema is een document waarin is vastgelegd hoe Microsoft Dynamics NAV-records en Outlook-items aan elkaar zijn gekoppeld. Het wordt gegenereerd door Microsoft Dynamics NAV aan het begin van het synchronisatieproces voor de Outlook-client.

Het synchronisatieschema wordt gemaakt in Microsoft Dynamics NAV om het volgende vast te leggen:

  • De Microsoft Dynamics NAV-tabellen die moeten worden gesynchroniseerd

  • Outlook-objecten die moeten worden gesynchroniseerd met

  • Microsoft Dynamics NAV-velden die deelnemen aan het proces en de bijbehorende Outlook-eigenschappen

Het plaatselijke exemplaar van het huidige synchronisatieschema wordt bewaard aan de kant van Outlook in de geïsoleerde opslag in XML-indeling – net zoals het is ontvangen van Microsoft Dynamics NAV.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatie-instellingen


Specificiteit van de synchronisatie

De specificiteit van de synchronisatie tussen Outlook en Microsoft Dynamics NAV is gelegen in twee mogelijke manieren om deze uit te voeren:

  • automatisch en

  • handmatig

Het Outlook-synchronisatieproces wordt geïnitieerd door de Outlook-invoegtoepassing. De synchronisatie wordt dus alleen uitgevoerd wanneer de toepassing Outlook actief is. De automatische synchronisatie wordt uitgevoerd in een vooraf gedefinieerde tijdsperiode. Deze periode begint te tellen onmiddellijk nadat de vorige synchronisatie is voltooid.

Als u niet wilt wachten totdat de volgende automatische synchronisatie begint, kunt u handmatig een synchronisatie uitvoeren.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


C/AL-gedeelte

Dat gedeelte van de projectgerelateerde functionaliteit dat verantwoordelijk is voor een aantal bewerkingen:

  1. aan de service-tier-kant van Microsoft Dynamics NAV het parsen van een XML-document dat is ontvangen van de invoegtoepassing Synchronisatie van Microsoft Dynamics NAV;
  2. valideren van de gebruiker (controleert of de synchronisatie is ingeschakeld voor deze gebruiker);
  3. gegevenswijziging uitvoeren in de database van Microsoft Dynamics NAV;
  4. de fouten of conflicten die zijn geconstateerd tijdens het synchroniseren registeren in een feedbackdocument;
  5. de wijzigingen sinds de vorige synchronisatie verzamelen in het Microsoft Dynamics NAV-wijzigingslogbestand (opgeslagen per gebruiker in Microsoft Dynamics NAV) en het eveneens opnemen hiervan in het feedbackdocument;
  6. terugzenden van het feedbackdocument naar de invoegtoepassing Synchronisatie van Microsoft Dynamics NAV.

Verwante onderwerpen

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Aanpassingskader

Hetzelfde als de functie Synchronisatie van Outlook.

Verwante onderwerpen

C/AL-gedeelte

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Feedbackdocument

Dit is een document dat vanuit Microsoft Dynamics NAV wordt verzonden naar Outlook als reactie op een synchronisatieverzoek.

Het feedbackdocument bevat alle fouten en conflicten die tijdens het synchroniseren zijn geconstateerd. Deze fouten en conflicten worden verzameld door de C/AL-code die aan de kant van de service-tier van Microsoft Dynamics NAV het document dat is ontvangen van Outlook parst, de gebruiker valideert (controleert of de synchronisatie is ingeschakeld voor deze gebruiker), en de wijziging van gegevens uitvoert in de database van Microsoft Dynamics NAV.

Na het verzamelen van fouten en conflicten van de kant van Outlook verzamelt C/AL-code de wijzigingen die verschenen in het Microsoft Dynamics NAV wijzigingslogbestand sinds de laatste synchronisatie en voegt deze toe aan het feedbackdocument. Vervolgens wordt het feedbackdocument teruggezonden naar de invoegtoepassing Synchronisatie van Microsoft Dynamics NAV.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Geïsoleerde opslag

Geïsoleerde opslag is een .NET gegevensopslagmechanisme dat isolatie en veiligheid biedt door het definiëren va gestandaardiseerde manieren van het koppelen van code aan opgeslagen gegevens. Standaardisatie biedt ook nog andere voordelen.

Beheerders kunnen gebruikmaken van hulpmiddelen die ontworpen zijn om geïsoleerde opslag te manipuleren om zodoende bestandsopslagruimte te configureren, beveiligingsbeleid in te stellen en ongebruikte gegevens te verwijderen. Als het programma geen toegangsrechten heeft tot het bestandssysteem, kunnen beheerders nog steeds geïsoleerde opslag gebruiken.

Met geïsoleerde opslag kunnen ontwikkelaars hun programmagegevens opslaan en voorkomen dat andere .NET programma's hiertoe toegang hebben.

De geïsoleerde opslag in deze oplossing wordt gebruikt voor het opslaan van:

  • Instellingen van de invoegtoepassing Synchronisatie van Microsoft Dynamics NAV.

  • Synchronisatiefouten en -conflicten.

  • Interne programmagegevens voor synchronisatie.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Hoofdtabel

Een tabel van Microsoft Dynamics NAV die deelneemt aan het synchronisatieproces. Deze geeft die Microsoft Dynamics NAV-tabel weer die de Microsoft Dynamics NAV-entiteit vormt van het hoofdniveau. Een hoofdtabel wordt opgegeven voor elk synchronisatieniveau.

Er is geen hoofdtabel voor synchronisatieniveau 1.

De hoofdtabel voor synchronisatieniveau 2 is de tabel waarop de daaraan gerelateerde Microsoft Dynamics NAV-entiteit van synchronisatieniveau 1 is gebaseerd.

De hoofdtabel voor synchronisatieniveau 3 is de tabel waarop de daaraan gerelateerde Microsoft Dynamics NAV-entiteit van synchronisatieniveau 2 is gebaseerd.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Middle-tier server/NST (Microsoft Dynamics NAV-service-tier)

Het deel van de synchronisatiefunctionaliteit dat via een webservice toegang biedt tot Microsoft Dynamics NAV-gegevens vanuit andere programma's.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Microsoft Dynamics NAV-wijzigingslogbestand

Een standaardfunctie van Microsoft Dynamics NAV waarmee wijzigingen worden geregistreerd die gebruikers van Microsoft Dynamics NAV aanbrengen in vooraf gedefinieerde tabellen. In het wijzigingslogbestand staan de items in chronologische volgorde, waarbij wordt aangegeven hoe de gebruiker het betreffende veld van een bepaalde tabel heeft gewijzigd.

Attentie

In het wijzigingslogbestand worden uitsluitend die wijzigingen verzameld die zijn gemaakt door de gebruiker vanuit de grafische gebruikersinterface. De wijzigingen die zijn aangebracht via de C/AL-code worden niet geregistreerd. U moet de functionaliteit van het wijzigingslogbestand inschakelen vanuit het instellingenformulier, en het bedrijf zelf sluiten en openen. Als u wijzigingen wilt registreren die zijn aangebracht via de C/AL-code, moet u procedures invoegen en gebruiken waarmee records kunnen worden toegevoegd aan de tabel Wijzigingslogbestand.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Microsoft Dynamics NAV rich en thin client

Er kunnen twee versies van Microsoft Dynamics NAV-clients zijn: rich en thin.

Rich client: de volledige Microsoft Dynamics NAV-client die de bedrijfslogica en de programma-interface bevat.

Thin client: een versie van de Microsoft Dynamics NAV-client die alleen de programma-interface heeft.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Outlook-invoegtoepassing/Microsoft Dynamics NAV-synchronisatie-invoegtoepassing

Het synchronisatieonderdeel dat dient voor het aanpassen van de instellingen van de synchronisatie zelf en voor het oplossen van synchronisatieconflicten en -problemen. De Microsoft Dynamics NAV-synchronisatie-invoegtoepassing wordt geïnstalleerd aan de kant van Outlook.

In onze oplossing wordt de Microsoft Dynamics NAV-server-tier direct geïntegreerd met Microsoft Outlook. Ze zijn met elkaar verbonden via de Outlook-invoegtoepassing aan de kant van de client en de webservice Microsoft Dynamics NAV-service-tier, die het mogelijk maakt vanuit andere programma's toegang te krijgen tot Microsoft Dynamics NAV-gegevens. De entiteiten die zijn geselecteerd voor synchronisatie worden tekens wanneer de gebruiker gegevens opvraagt uit de Microsoft Dynamics NAV-database doorgegeven aan de Outlook-invoegtoepassing.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


OLHandler.DLL

Een COM-onderdeel dat wordt gebruikt voor het synchroniseren van Outlook met de vorige versie van Microsoft Dynamics NAV.

Voor het implementeren van deze oplossing werd dit onderdeel niet gebruikt omdat het hoofdprincipe van de synchronisatie is gewijzigd - deze wordt nu geïnitieerd door Outlook. Dit is een van de belangrijkste specificiteiten van deze versie van de synchronisatie.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Outlook-objectmodel

Een set klassen die de Outlook-objecten openstelt om programmatisch toegang te krijgen tot de functionaliteit van Outlook.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Outlook-synchronisatiegebruiker

Een persoon wiens rechten beperkt zijn tot het instellen, bekijken en filteren van gegevens die met synchronisatie te maken hebben. De gebruiker kan echter geen objecten die met de synchronisatie te maken hebben wijzigen of verwijderen.

In tegenstelling tot de hoofdgebruiker kan een synchronisatiegebruiker niet de aanmeldingsgegevens en voorkeuren van andere gebruikers wijzigen in Microsoft Dynamics NAV. Hij/zij kan alleen werken met de functie Gebruikersinstellingen.

In tegenstelling tot de supergebruiker heeft een synchronisatiegebruiker geen systeembeheerdersrechten. Dit betekent dat hij/zij niet de richtingen van de synchronisatie kan definiëren en ook niet het koppelingsschema kan wijzigen dat geldt voor alle synchronisatiegebruikers.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Transportlaag

Webservicebeschrijvingstaal


Hoofdgebruiker

Een gebruiker die toestemming heeft om de aanmeldingsgegevens en instellingen van andere gebruikers te wijzigen. Hij/zij kan ook Microsoft Dynamics NAV-velden toevoegen om te synchroniseren of velden die eerder voor de synchronisatie gedefinieerd waren verwijderen.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Supergebruiker

Een gebruiker die volledige controle heeft over het synchronisatieproces. Supergebruikers hebben systeembeheerdersrechten, hetgeen de reden is waarom ze ook beheerders worden genoemd. Supergebruikers kunnen bijvoorbeeld de richting van de synchronisatie bepalen. Ze kunnen ook het koppelingsschema wijzigen dat voor alle synchronisatiegebruikers geldt.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Outlook-synchronisatiegebruiker

Transportlaag

Webservicebeschrijvingstaal


Transportlaag

Het deel van de synchronisatiefunctionaliteit dat zorgt voor de complete overdracht van gegevens tussen Microsoft Dynamics NAV en Outlook zonder dat daarbij verlies optreedt. De transportlaag is verantwoordelijk voor het regelen van de gegevensstroom en foutherstel tussen de eindpunten. De transportlaag is een transparante webservice die is geïnstalleerd aan de kant van de Microsoft Dynamics NAV-service-tier. De webservice bevat onderdelen die van belang zijn voor zowel de backoffice als de lagen van de hosttoepassing en beschikt over alle standaardfuncties, waaronder de juiste beveiliging, schaalbaarheid, prestaties (inclusief gegevenscompressie), en licentiebeheer.

De webservice biedt API die ontwikkelaars kunnen gebruiken bij het maken van toepassingen die voorzien in hun behoeften en vereisten bij het ophalen en verwerken van gegevens van een backoffice-toepassing en het uitvoeren van de bedrijfslogica van de backoffice-toepassing.

De webservice van de Microsoft Dynamics NAV-service-tier moet de volgende functionaliteit ondersteunen:

  • Een flexibele API voor hosttoepassingen;

  • Vastleggen en leiden van NST-runtimefouten;

  • Secure Sockets-communicatie (gegevenscodering) via een firewall;

  • Verificatie en machtiging;

  • Compressie van berichten als deze de opgegeven maximumgrootte overschrijden;

  • Logboekregistratie- en traceringsfunctionaliteit;

  • Standaard toepassingsprotocolberichten;

Vanuit de nieuwe Microsoft Dynamics NAV-service-tier worden twee sets services aangeboden:

  • Een service op laag niveau waarmee de nieuwe client

  • Gegevens op basis van een tabel kan maken, lezen, bijwerken en verwijderen.

  • De tabeltriggers worden uitgevoerd als onderdeel hiervan

  • Records kunnen worden gelezen in pagina's van sets met filters en sortering

  • Functies aanroepen in code-units en op tabellen

  • Veldvalidatietriggers aanroepen.

  • Metagegevens van tabellen en formulieren lezen

  • En service op hoog niveau waarmee andere toepassingen toegang kunnen krijgen tot bedrijfsentiteiten en -logica.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Webservicebeschrijvingstaal


Webservicebeschrijvingstaal

Een interface die wordt geïmplementeerd met de indeling van XML-berichten voor het omschrijven van de netwerkservices die worden aangeboden door de server.

WSDL (Web Services Description Language, of webservicebeschrijvingstaal) wordt gebruikt om een bestand te maken waarin de services worden aangegeven die door de server worden geboden en de set bewerkingen binnen elke service die de server ondersteunt.

Ten behoeve van de bewerking wordt in het WSDL-bestand ook beschreven welke indeling de client moet volgen bij het aanvragen van een bewerking.

In een WSDL-bestand worden vijf primaire elementen gebruikt bij het definiëren van de netwerkservice. Deze staan in de volgende volgorde:

  1. het element <soorten> definieert de verschillende soorten gegevens die worden gebruikt bij het uitwisselen van berichten.

  2. het element <bericht> omschrijft welke berichten worden gecommuniceerd.

  3. het element <poorttype> geeft een set bewerkingen aan en de bijbehorende berichten bij elk van deze bewerkingen.

  4. het element <binding> geeft de protocoldetails aan voor verschillende bewerkingen van de service en omschrijft hoe de abstracte inhoud van deze berichten moet worden gekoppeld aan een concrete indeling.

  5. met het element <service> wordt een set bij elkaar horende poorten gegroepeerd.

Verwante onderwerpen

C/AL-gedeelte

Aanpassingskader

Feedbackdocument

Geïsoleerde opslag

Hoofdtabel

Middle-tier server

Microsoft Dynamics NAV-wijzigingslogbestand

Microsoft Dynamics NAV rich en thin client

Outlook-invoegtoepassing

OLHandler

Outlook-objectmodel

Hoofdgebruiker

Supergebruiker

Outlook-synchronisatiegebruiker

Transportlaag


Synchronisatie van niveau 1 instellen

Voordat u uw Microsoft Dynamics NAV-entiteiten kunt laten bijwerken met Outlook-items, moet u definiëren welke Microsoft Dynamics NAV-objecten dit betreft. U kunt een aantal instellingen aanpassen aan uw behoeften. Let echter op dat de mogelijkheid om deze instellingen te wijzigen, afhangt van de toegangsrechten die door de beheerder zijn verstrekt.

In dit onderwerp wordt uitgelegd hoe u kunt opgeven welke Outlook-items moeten worden gesynchroniseerd op het eerste niveau.

U stelt als volgt de synchronisatie op niveau 1 in:

  1. Open het venster [image] Entiteit Outlook-synch..

  2. Druk op F3 om een nieuwe synchronisatie-entiteit te maken en voer de naam ervan in het veld Code in.

  3. Voer in het veld Omschrijving tekst in waarmee de entiteit wordt omschreven. Onthoud dat deze omschrijving in Outlook wordt gebruikt als label voor het tekstvak dat de Outlook-mappen bevat die zijn geselecteerd voor synchronisatie.

  4. U kunt een hoofdtabel opgeven die moet deelnemen aan de synchronisatie van de kant van Microsoft Dynamics NAV.

  5. Om de voorwaarde te definiëren op basis van de records uit de hoofdtabel die wordt gebruikt voor synchronisatie, kunt u een filter toepassen op de hoofdtabel.

  6. Om de voorwaarde op te geven op basis van welke records uit de hoofdtabel de verzameling vormen voor synchronisatie, klikt u op de AssistButton rechts naast het veld Outlook-item. Select één van de beschikbare Outlook-items en klik op OK.

Opmerking

De enige Microsoft Dynamics NAV-hoofdtabel die is opgegeven in de kop van dit venster leidt naar synchronisatie op niveau 1. Als u de synchronisatie op niveau 2 wilt organiseren, moet u een of meer aanvullende Microsoft Dynamics NAVtabellen definiëren op de regels van dit venster.

Verwante onderwerpen

Synchronisatie van niveau 2 instellen

Velden van Microsoft Dynamics NAV koppelen aan Outlook-eigenschappen

Een hoofdtabel opgeven

Tabelfilters toepassen


Een hoofdtabel opgeven

U moet de hoofdtabel opgeven om andere synchronisatie-entiteitsobjecten te definiëren. De hoofdtabel is het eerste Microsoft Dynamics NAV-object dat u selecteert om te worden bijgewerkt met een Outlook-item.

U geeft als volgt een hoofdtabel op:

  1. Open het venster [image] Entiteit Outlook-synch..

  2. Blader naar de synchronisatie-entiteit waarvoor u een hoofdtabel wilt opgeven.

  3. Klik op de AssistButton rechts naast het veld Tabelnr. in de kop van het venster.

  4. Selecteer in het venster Tabellijst Outlook-synch. dat wordt weergegeven een tabel. Klik op OK om uw keuze te bevestigen.

  5. In het veld Tabelnaam in de kop van het venster Entiteit Outlook-synch. wordt automatisch de naam ingevuld van de geselecteerde hoofdtabel.

Verwante onderwerpen

Synchronisatie van niveau 1 instellen


Tabelfilters definiëren

Filters worden gebruikt om te definiëren welke specifieke items uit uw Microsoft Dynamics NAV-tabel moeten deelnemen aan de synchronisatie.

U definieert als volgt tabelfilters:

  1. Open het venster [image] Entiteit Outlook-synch..

  2. Blader naar de synchronisatie-entiteit en vervolgens naar de aanvullende tabel waarop u een filter wilt toepassen.

  3. Klik op de AssistButton rechts naast het veld Voorwaarde op de regel met de aanvullende tabel waarvoor u filters wilt definiëren.

  4. Klik in het venster Filters Outlook-synch. dat wordt weergegeven op de AssistButton rechts naast het veld Veldnaam om het veld te selecteren.

  5. Selecteer in het venster Tabelvelden Outlook-synch. een veld en klik op OK om uw keuze te bevestigen.

  6. Klik in het veld Soort op de AssistButton en selecteer CONST of FILTER.

  7. Geef in het veld Waarde de waarde op die in het veld Veldnaam moet worden toegepast. Het programma gebruikt deze afhankelijk van wat u hebt geselecteerd in het veld Soort. Als de soort CONST is geselecteerd, kunt u tekstconstanten invoeren als standaard Microsoft Dynamics NAV-filter. Als FILTER is geselecteerd in het veld Soort, kunt u een filterexpressie invoeren met behulp va gereserveerde woorden als <, >, OR, AND. De expressie in dit veld is samengesteld volgens de filtersyntaxis van Microsoft Dynamics NAV.

    8. Opmerking

    Als u het venster Filter Outlook-synch. opent vanuit het veld Voorwaarde van het venster Entiteit Outlook-synch., kunt u de optie FIELD niet gebruiken als filtersoort.

De uiteindelijk voorwaarde-expressie wordt weergegeven in het veld Filterexpressie van dat venster en in het veld Voorwaarde van het venster Entiteit Outlook-synch..

Verwante onderwerpen

Synchronisatie van niveau 1 instellen

Een hoofdtabel opgeven


Synchronisatie van niveau 2 instellen

U kunt uw Microsoft Dynamics NAV-entiteiten niet alleen bijwerken met Outlook-items, maar ook met Outlook-verzamelingen. Hiervoor moeten eveneens beslissingen worden genomen met betrekking tot de Microsoft Dynamics NAV-objecten waarvoor dit geldt.

In dit onderwerp wordt uitgelegd hoe u kunt opgeven welke Outlook-verzamelingen moeten worden gesynchroniseerd op het tweede niveau.

U stelt als volgt de synchronisatie op niveau 2 in:

  1. Open het venster [image] Entiteit Outlook-synch. en blader naar de bestaande entiteit waarvoor u synchronisatie op niveau 2 wilt instellen.

  2. Geef een aanvullende tabel op die moet deelnemen aan de synchronisatie op niveau 2.

  3. Definieer een filter voor de geselecteerde tabel die moet deelnemen aan de synchronisatie. Hier moet u ook relaties definiëren tussen tabellen die zijn geselecteerd voor synchronisatie op niveau 1 en niveau 2.

    4. Opmerking

    Als u het venster Filters Outlook-synch. opent vanuit de regels van het venster Entiteit Outlook-synch., definieert u tabelrelaties tussen de hoofdtabel en aanvullende tabel van Microsoft Dynamics NAV. Als u daarentegen het venster Filters Outlook-synch. opent vanuit de kop van het venster Entiteit Outlook-synch., definieert u alleen filters voor de hoofdtabel die vermeld staat in de kop van dit venster.

  4. Selecteer een Outlook-verzameling die moet worden gesynchroniseerd met de Microsoft Dynamics NAV-tabel.

  5. Voer het aantal afhankelijkheden in.

    6. Opmerking

    Als de verzameling die u hebt geselecteerd afhankelijk is van andere entiteiten, moet u deze afhankelijkheden definiëren in het venster Afhankelijkheden Outlook-synch. Als er geen afhankelijkheden zijn, blijft het veld Aantal afhankelijke items leeg. Als u meer wilt weten over afhankelijkheden van verzamelingen, raadpleegt u dan de online Help van Outlook.

Verwante onderwerpen

Synchronisatie van niveau 1 instellen

Velden van Microsoft Dynamics NAV koppelen aan Outlook-eigenschappen


Een aanvullende tabel opgeven

U geeft een aanvullende tabel op voor uw synchronisatie-entiteit als u de Microsoft Dynamics NAV-tabel wilt synchroniseren met een Outlook-verzameling. Door een aanvullende tabel op te geven, stelt u een tweede niveau van synchronisatie in.

Deze tabel heeft een hoofdtabel die wordt opgegeven in de kop van het venster Entiteit Outlook-synch.. Op zijn beurt dient deze tabel weer als hoofdtabel voor de tabel die is opgegeven op niveau 3.

U geeft als volgt een aanvullende tabel op:

  1. Open het venster [image] Entiteit Outlook-synch..

  2. Blader naar de synchronisatie-entiteit waarvoor u een aanvullende tabel voor synchronisatie van niveau 2 wilt opgeven.

  3. Klik op de AssistButton rechts naast het veld Tabelnr. op de eerste lege regel.

  4. Selecteer in het venster Tabellijst Outlook-synch. dat wordt weergegeven de tabel en klik op OK.

    5. Opmerking

    U kunt geen tabel selecteren waarvan het nummer vermeld staat in de kop van het venster Entiteit Outlook-synch. Een tabel kan niet hoofdtabel en tegelijkertijd aanvullende tabel zijn.

  5. In het veld Tabelnaam wordt automatisch de tabelnaam ingevuld zodra u het nummer ervan opgeeft.

  6. Voor elke aanvullende tabel die u opgeeft op de regels, moet u tabelrelatie definiëren tussen de hoofdtabel en de aanvullende tabellen.

Verwante onderwerpen

Synchronisatie van niveau 2 instellen

Een veldfilter toepassen

Tabelrelaties definiëren

Outlook-verzamelingen selecteren


Tabelrelaties definiëren

U definieert tabelrelaties om hoofdtabel en aanvullende tabellen aan elkaar te koppelen in de synchronisatie-entiteit. Dit gebeurt door velden van de hoofdtabel te koppelen aan velden van de aanvullende tabel.

U geeft als volgt tabelrelaties op:

  1. Open het venster [image] Entiteit Outlook-synch..

  2. Blader naar de synchronisatie-entiteit waarvoor u een aanvullende tabel voor synchronisatie van niveau 2 wilt opgeven.

  3. Klik in het veld Tabelrelatie op de AssistButton rechts ernaast. Het venster Filters Outlook-synch. wordt weergegeven.

  4. Klik in het veld Veldnaam op de AssistButton om de lijst met velden voor de geselecteerde tabel op de regels te openen.

  5. Selecteer in het venster Tabelvelden Outlook-synch. een tabel en klik op OK.

  6. Selecteer in het veld Soort van het venster Filters Outlook-synch. de optie FIELD.

  7. Klik in het veld Waarde op de AssistButton rechts ernaast. Hiermee opent u het venster Tabelvelden Outlook-synch. met een lijst van velden van de hoofdtabel die is geselecteerd in de kop van het venster Entiteit Outlook-synch.

  8. Selecteer een veld en klik op OK om het in te voegen in het veld Waarde.

  9. De uiteindelijke filterexpressie wordt weergegeven in het veld Filterexpressie. Wanneer u klaar bent met de filters, klikt u op OK om ze toe te passen.

Verwante onderwerpen

Synchronisatie van niveau 2 instellen

Een veldfilter toepassen


Outlook-verzamelingen selecteren

U moet een aanvullende tabel selecteren op de regels van het venster Entiteit Outlook-synch. om te koppelen aan een Outlook-verzameling. Met deze koppeling maakt u een synchronisatie op niveau 2. Als er geen Outlook-verzameling wordt gedefinieerd, worden de synchronisatie-instellingen op niveau 2 niet uitgevoerd. Bovendien kunt u geen synchronisatie op niveau 3 instellen voor de tabellen die vermeld staan op de regels.

U selecteert als volgt een Outlook-verzameling:

  1. Open het venster [image] Entiteit Outlook-synch..

  2. Blader naar de synchronisatie-entiteit met de aanvullende tabel waarvoor u een Outlook-verzameling wilt selecteren.

  3. Klik in het veld Outlook-verzameling op de AssistButton rechts naast het veld.

  4. Selecteer in het venster Opzoeknamen Outlook-synch. een verzameling die u wilt synchroniseren met de Microsoft Dynamics NAV-tabel die u hebt geselecteerd op de regels van het venster Entiteit Outlook-synch.

  5. Klik op OK om uw keuze te bevestigen.

Verwante onderwerpen

Synchronisatie van niveau 2 instellen


Afhankelijkheden definiëren

Als de verzameling die is geselecteerd voor de aanvullende tabel op de regels van het venster Entiteit Outlook-synch. afhankelijk is van andere entiteiten, moet u de afhankelijkheden specifiek definiëren.

U definieert als volgt afhankelijkheden van verzamelingen:

  1. Open het venster [image] Entiteit Outlook-synch. en blader naar de bestaande entiteit waarvoor u afhankelijkheden wilt definiëren.

  2. Selecteer op de regels van deze entiteit een Outlook-verzameling waarvoor u afhankelijkheden wilt definiëren.

  3. Klik op de AssistButton rechts naast het veld Aantal afhankelijk items.

  4. Klik in het venster Afhankelijkheden Outlook-synch. dat wordt weergegeven op de AssistButton rechts naast het veld Entiteitcode synch. om de entiteit te selecteren waarvan de verzameling afhankelijk is.

    5. Opmerking

    Er moeten tabelrelaties worden opgegeven voor de aanvullende tabel, waarvoor u afhankelijkheden wilt definiëren.

  5. Selecteer in het venster Entiteitlijst Outlook-synch. een entiteit en klik op OK. Het veld Omschrijving in het venster Afhankelijkheden Outlook-synch. wordt automatisch ingevuld.

    6. Opmerking

    Voor elke synchronisatie-entiteit met afhankelijkheden moet u tabelrelaties definiëren.

  6. Sluit na het selecteren van de entiteiten het venster Afhankelijkheden Outlook-synch.. Het aantal geselecteerde afhankelijkheden wordt weergegeven in het veld Aantal afhankelijke items voor de huidige verzameling.

Als u meer wilt weten over afhankelijkheden van Outlook-verzamelingen, raadpleeg dan de online Help bij Outlook.

Verwante onderwerpen

Synchronisatie van niveau 2 instellen

Een aanvullende tabel opgeven

Een veldfilter toepassen

Tabelrelaties definiëren

Outlook-verzamelingen selecteren


Velden van Microsoft Dynamics NAV koppelen aan Outlook-eigenschappen

Wanneer u de synchronisatie voor specifieke velden wilt instellen en niet alleen voor Microsoft Dynamics NAV-tabellen, moet u uw velden koppelen aan de betreffende Outlook-eigenschappen. Bij het maken van deze koppeling wordt een koppelingsschema gemaakt.

Let op dat u voor het maken van veldkoppelingen eerst de tabellen voor niveau 1 of niveau 2 van de synchronisatie-entiteit moet definiëren.

U kunt als volgt Microsoft Dynamics NAV-velden koppelen aan Outlook-eigenschappen:

  1. Open het venster [image] Entiteit Outlook-synch..

  2. Als u de velden voor de geselecteerde hoofdtabel in de kop wilt definiëren, klikt u op Synch.-entiteit, Velden. Als u de velden voor de aanvullende tabel die is geselecteerd op de regels wilt definiëren, klikt u op Regels, Velden. In beide gevallen wordt het venster Velden Outlook-synch. weergegeven.

  3. Als u een veld wilt opgeven dat moet worden gekoppeld aan een Outlook-eigenschap, klikt u op de AssistButton in het veld Veldnr. en selecteert u het veld.

    4. Opmerking

    Als het veld Tabelnr. leeg is wanneer u een veldnaam selecteert, kiest u een veld uit de lijst met velden voor de hoofdtabel of de op dat moment geselecteerde aanvullende tabel, afhankelijk van waaruit het venster Velden Outlook-synch. is geopend. Het nummer van de tabel is afkomstig uit het veld Hoofdtabelnr. van de brontabel voor dit venster. U kunt het nummer van een andere tabel opgeven waarvan de velden moeten deelnemen aan de synchronisatie. Als u een ander tabelnummer opgeeft, moet u tabelrelaties definiëren tussen de geselecteerde en de hoofdtabel.

  4. Als u een voorwaarde wilt definiëren voor velden die moeten deelnemen aan de synchronisatie, past u een filter toe voor de huidige hoofdtabel.

  5. Voer in het veld Outlook-eigenschap de naam in van de Outlook-eigenschap die moet worden gesynchroniseerd met het Microsoft Dynamics NAV-tabelveld. U hebt het nummer van het Microsoft Dynamics NAV-tabelveld opgegeven in het veld Veldnr.

  6. Als u Microsoft Dynamics NAV-tabelvelden wilt koppelen aan de Outlook-eigenschap, klikt u op de AssistButton rechts naast het veld Veldnr. In het venster Tabelvelden Outlook-synch. dat wordt weergegeven selecteert u een veld dat u wilt koppelen. De set velden hangt af van de tabel die is opgegeven in het veld Tabelnaam. Wanneer u het veldnummer hebt geselecteerd, wordt in het veld Veldnaam automatisch de veldnaam ingevuld.

Vul in het venster Velden Outlook-synch. de velden met Outlook-eigenschappen en de Microsoft Dynamics NAV-tabelvelden om de koppeling in te stellen. U vult de andere velden van dit venster naar behoefte in.

Verwante onderwerpen

Synchronisatie van niveau 1 instellen

Synchronisatie van niveau 2 instellen


Extra tabellen definiëren

Bij het synchroniseren zijn sommige velden die nodig zijn voor het koppelen aan Outlook-eigenschappen niet beschikbaar in Microsoft Dynamics NAV-tabellen. In dat geval kunt u een of meer tabellen toevoegen om met de velden ervan te kunnen werken.

U definieert als volgt extra tabellen:

  1. Open het venster [image] Velden Outlook-synch. voor de synchronisatie-entiteit waarvoor u een extra tabel wilt definiëren.

  2. Klik als u een extra tabel wilt selecteren op de AssistButton rechts naast het veld Tabelnr.
  3. Selecteer in het venster Tabellijst Outlook-synch. dat wordt weergegeven een tabel en klik op OK. Het nummer van de geselecteerde tabel wordt weergegeven in het veld Tabelnr. van het venster Velden Outlook-synch. De tabelnaam staat in het veld Tabelnaam van hetzelfde venster.

    4. Opmerking

    Voor elke extra tabel die u opgeeft, moet u tabelrelaties definiëren.

  4. Klik in het veld Veldnr. in het venster Velden Outlook-synch. op de AssistButton rechts ernaast en selecteer het nummer van het veld dat moet deelnemen aan de synchronisatie. Het veldnummer dat u selecteert, komt uit de lijst velden van deze extra tabel.

Verwante onderwerpen

Velden van Microsoft Dynamics NAV koppelen aan Outlook-eigenschappen


Aanmeldingsgegevens van gebruikers voor synchronisatie definiëren

U dient Outlook-aanmeldingsgegevens en synchronisatievoorkeuren te definiëren voor elke gebruiker met betrekking tot de Microsoft Dynamics NAV-entiteiten die de gebruikers kunnen synchroniseren. U geeft een set synchronisatie-entiteiten op waarmee de gebruiker kan werken, de richting van de synchronisatie, en indien nodig past u aanvullende voorwaarden toe op de Microsoft Dynamics NAV-entiteiten die deze gebruikers kunnen synchroniseren.

Om aanmeldingsgegevens en voorkeuren te kunnen opgeven, moet u over beheerderstoegangsrechten beschikken.

U kunt als volgt aanmeldingsgegevens van gebruikers voor synchronisatie definiëren:

  1. Open het venster [image] Gebruiker instellen Outlook-synch..

  2. Klik op de eerste lege regel op de AssistButton rechts naast het veld Gebruikers-id en selecteer de naam van de gebruiker. Deze gebruiker moet al in het systeem zijn geregistreerd.

  3. Wijs een synchronisatie-entiteit toe aan de betreffende gebruiker.

  4. Klik in het veld Richting op de AssistButton om de synchronisatierichting te selecteren: Bidirectioneel, Microsoft Dynamics NAV naar Outlook of Outlook naar Microsoft Dynamics NAV.

Opmerking

De gebruiker wiens naam wordt ingevoerd in dit venster kan synchronisatie uitvoeren met alleen de instellingen van die synchronisatie-entiteiten die aan hem/haar zijn toegewezen. Herhaal stap 2 en 4 van de bovenstaande procedure als u meer dan één synchronisatie-entiteit aan dezelfde gebruiker wilt toewijzen.

Verwante onderwerpen

Synchronisatie van niveau 1 instellen

Synchronisatie van niveau 2 instellen

Velden van Microsoft Dynamics NAV koppelen aan Outlook-eigenschappen


Synchronisatie-entiteiten koppelen aan gebruikers

Voor elke geregistreerde gebruiker moet u de synchronisatie-entiteiten opgeven waarmee moet worden gewerkt. Zodra synchronisatie-entiteiten zijn toegewezen, kunnen gebruikers alleen synchronisatie uitvoeren van de Microsoft Dynamics NAV-entiteiten en Outlook-items die zijn opgegeven in de synchronisatie-entiteiten die hieraan zijn toegewezen.

Alleen hoofdgebruikers met voldoende toegangsrechten of supergebruikers kunnen entiteiten toewijzen aan synchronisatiegebruikers.

U wijst als volgt een synchronisatie-entiteit toe aan een gebruiker:

  1. Open het venster [image] Gebruiker instellen Outlook-synch..

  2. Ga naar de geselecteerde gebruiker voor wie u een synchronisatie-entiteit wilt opgeven.

  3. Als u synchronisatie-entiteiten aan de opgegeven gebruiker wilt toewijzen, klikt u op de AssistButton rechts naast het veld Entiteitcode synch..

  4. Selecteer in het venster Entiteitlijst Outlook-synch. een entiteit uit de lijst beschikbare entiteiten. Klik op OK om uw keuze te bevestigen. In het veld Omschrijving wordt automatisch de omschrijving van de geselecteerde synchronisatie-entiteit ingevuld.

Opmerking

Herhaal stap 2 en 4 van de hierboven beschreven procedure als u meer dan een synchronisatie-entiteit aan dezelfde gebruiker wilt toewijzen.

Verwante onderwerpen

Aanmeldingsgegevens van gebruikers voor synchronisatie definiëren


Opties voor het oplossen van synchronisatieconflicten instellen

Voordat u een synchronisatie uitvoert, moet u synchronisatieopties instellen. U moet met name instellen hoe synchronisatieconflicten moeten worden opgelost.

Er zijn vier manieren om synchronisatieconflicten op te lossen:

  • Outlook-items vervangen door Microsoft Dynamics NAV-records

  • Microsoft Dynamics NAV-items vervangen door Outlook-records

  • Oude entiteiten vervangen door nieuwe entiteiten

  • Conflicten handmatig corrigeren (standaard geselecteerd)

Als u de standaardoptie niet wijzigt, worden alle conflicten in het logboek geregistreerd na afloop van de synchronisatie en moet u deze handmatig oplossen.

U stelt als volgt opties voor het oplossen van synchronisatieconflicten in:

  1. Klik op de werkbalk van Microsoft Dynamics NAV-synchronisatie in Outlook op de knop Instellingen om het venster Instellingen te openen.

  2. Ga op het tabblad Algemeen naar het gedeelte Correctie van synchronisatieconflicten en selecteer een van de vier beschikbare opties:

    • Outlook-items vervangen door Microsoft Dynamics NAV-records - als u wilt dat Outlook-items worden overschreven door Microsoft Dynamics NAV-records.

    • Microsoft Dynamics NAV-records vervangen door Outlook-items - als u wilt dat Microsoft Dynamics NAV-records worden ververst met Outlook-items.

    • Oude entiteiten vervangen door nieuwe entiteiten - als u wilt dat alle oude entiteiten worden vervangen door nieuwe records ongeacht waar deze vandaan komen.

    • Conflicten handmatig corrigeren - conflicten die optreden worden niet automatisch gecorrigeerd; alle conflicten worden geregistreerd en moeten later handmatig worden gecorrigeerd.

  3. Klik na het selecteren van de optie op OK om uw keuze voor het automatisch corrigeren van conflicten te bevestigen.

Verwante onderwerpen

Synchronisatieconflicten handmatig oplossen


Synchronisatieconflicten handmatig oplossen

Een van de belangrijkste voordelen van de Outlook-Microsoft Dynamics NAV-synchronisatiefunctie is de mogelijkheid om synchronisatieconflicten voor items Outlook en Microsoft Dynamics NAV op te lossen.

De opties voor het oplossen van conflicten moeten worden ingesteld voordat de synchronisatie wordt gestart. Anders moet u handmatig kiezen hoe het conflict moet worden opgelost. Hoe u conflicten handmatig oplost, wordt in dit onderwerp beschreven.

Wanneer het synchronisatieproces is voltooid, wijzigt de kleur van de knop Troubleshooting op de werkbalk van Microsoft Dynamics NAV-synchronisatie, afhankelijk van het resultaat van de synchronisatie. Het pictogram kan drie statussen hebben:

  • Synchronisatie is gelukt (de knop is groen).

  • Er zijn tijdens de synchronisatie conflicten opgetreden (de knop is rood).

  • Er zijn tijdens de synchronisatie fouten opgetreden (de knop is rood).

U kunt als volgt een synchronisatieconflict oplossen:

  1. Klik op de werkbalk van Microsoft Dynamics NAV-synchronisatie op de knop Troubleshooting. Het venster Troubleshooting wordt weergegeven.

  2. Selecteer op het tabblad Conflicten het conflict dat u wilt oplossen.

  3. Kies hoe u het conflict wilt oplossen. Als u de wijzigingen in Microsoft Dynamics NAV wilt vervangen door Outlook-gegevens, klikt u op Conflictoplossing, Alle Outlook-items vervangen. Als u de wijzigingen in Outlook wilt vervangen door Microsoft Dynamics NAV-gegevens, klikt u op Conflictoplossing, Alle Microsoft Dynamics NAV-records vervangen. Als u conflictitems wilt verwijderen, selecteert u Alles verwijderen in hetzelfde menu.

Zodra u het conflict hebt opgelost, verdwijnt de bijbehorende vermelding uit de lijst met conflicten.

Opmerking

Het venster Troubleshooting bevat mogelijk niet alleen synchronisatieconflicten, maar ook synchronisatiefouten. Als er na het oplossen van conflicten nog fouten achterblijven in dit venster, raadpleegt u de technische documentatie of neemt u contact op met de systeembeheerder om deze fouten te verhelpen.

Verwante onderwerpen

Opties voor het oplossen van synchronisatieconflicten instellen


Afhankelijkheid Outlook-synch. (tabel)

De tabel Afhankelijkheid Outlook-synch.

Lijst met velden in de tabel

In deze tabel staat een lijst entiteiten die moet worden gesynchroniseerd voor de huidige Outlook-verzameling. U selecteert deze entiteiten uit de lijst bestaande entiteiten.


Configuratiedetails Outlook-synch. (tabel)

De tabel Configuratiedetails Outlook-synch.

Lijst met velden in de tabel

Deze tabel bevat een lijst van de verzamelingen die moeten worden gesynchroniseerd. Als u geen verzameling opgeeft voor synchronisatie in deze tabel, worden alleen Outlook-items gesynchroniseerd ook al hebt u verzamelingen opgegeven in het veld Outlook-verzameling in de tabel Entiteit Outlook-synch. voor de huidige gebruiker.

De verzamelingen die u wilt synchroniseren kunt u selecteren uit de verzamelingen die zijn opgegeven in het veld Outlook-verzameling van de tabel Entiteitelement Outlook-synch.


Entiteit Outlook-synch. (tabel)

De tabel Entiteit Outlook-synch.

Lijst met velden in de tabel

Deze tabel bevat alle instellingen die nodig zijn om synchronisatie van Outlook-items met Microsoft Dynamics NAV-entiteiten mogelijk te maken.

Het programma past de informatie uit deze tabel toe op synchronisatie op niveau 1.


Entiteitelement Outlook-synch. (tabel)

De tabel Entiteitelement Outlook-synch.

Lijst met velden in de tabel

In deze tabel staat welke sets items uit Microsoft Dynamics NAV-tabellen moeten overeenkomen met specifieke Outlook-verzamelingen.

In deze tabel komt elke set items, hetzij hele tabellen, hetzij beperkte groepen items, overeen met een Outlook-verzameling.

Het programma past de informatie uit deze tabel toe op synchronisatie op niveau 2.


Filter Outlook-synch. (tabel)

De tabel Filter Outlook-synch.

Lijst met velden in de tabel

Deze tabel bevat de filterexpressies die blijvend moeten worden opgeslagen. Deze tabel wordt gebruikt om beperkte sets items te definiëren die moeten deelnemen aan het synchronisatieproces.


Gebruiker instellen Outlook-synch. (tabel)

De tabel Gebruiker instellen Outlook-synch.

Lijst met velden in de tabel

In deze tabel worden de vereiste instellingen opgeslagen voor de gebruikers die synchronisatie met Outlook uitvoeren. De tabel bevat een lijst met codes van de synchronisatie-entiteiten die u moet synchroniseren met Outlook.


Koppeling Outlook-synch. (tabel)

De tabel Koppeling Outlook-synch.

Lijst met velden in de tabel

In deze tabel worden de id's opgeslagen van gesynchroniseerde Outlook-items en de overeenkomstige Microsoft Dynamics NAV-records.

Deze tabel bevat in twee gevallen records:

  • Er zijn nieuwe items gemaakt in Outlook. Wanneer een nieuw Outlook-item vanuit Outlook is gekomen en de overeenkomstige nieuwe record is gemaakt in Microsoft Dynamics NAV, wordt een nieuwe record aangemaakt in deze tabel.

  • Er zijn nieuwe records gemaakt in Microsoft Dynamics NAV. Wanneer een nieuwe record is gemaakt in Microsoft Dynamics NAV, wordt het nieuwe item ingevoegd in deze tabel nadat de record is gesynchroniseerd met Outlook.


Optiecorrel. Outlook-synch. (tabel)

De tabel Optiecorrel. Outlook-synch.

Lijst met velden in de tabel

In deze tabel worden optievelden van Microsoft Dynamics NAV en de overeenkomstige Outlook-eigenschap opsomming en integer opgeslagen. De overeenkomst tussen de optievelden van Microsoft Dynamics NAV en Outlook-opties kan onjuist zijn - een optieveld van Microsoft Dynamics NAV kan gekoppeld zijn aan een verkeerde Outlook-eigenschap. In dit venster stelt u handmatig relaties in tussen optievelden van Microsoft Dynamics NAV en Outlook-opties.


Opzoeknaam Outlook-synch. (tabel)

De tabel Opzoeknaam Outlook-synch.

Lijst met velden in de tabel

In deze tabel worden de namen opgeslagen van de Outlook-objecten die deelnemen aan het synchronisatieproces, en hun eigenschappen - namen van items, verzamelingen, verzamelingselementen, verzamelingseigenschappen.


Veld Outlook-synch. (tabel)

De tabel Veld Outlook-synch.

Lijst met velden in de tabel

Deze tabel bevat de koppelingsinstellingen voor specifieke velden in Microsoft Dynamics NAV-tabellen en de overeenkomstige eigenschapen van het Outlook-item. Afhankelijk van de gegevens die zijn opgeslagen in deze tabel, kan worden bepaald of synchronisatie plaatsvindt voor de synchronisatie-entiteiten op niveau 1 of niveau 2 van de synchronisatie.


Wijzingslogbestandinstel. Outlook-synch. (batchverwerking)

De batchverwerking Wijzingslogbestandinstel. Outlook-synch.

Met de batchverwerking [image] Wijzingslogbestandinstel. Outlook-synch. kunt u instellingen van het wijzigingslogbestand registreren.

Tabblad Entiteit Outlook-synch.

Op het tabblad Entiteit Outlook-synch. kunt u door filters in te stellen definiëren wat er moet worden opgenomen in de batchverwerking.

Codeveld: voer de code in van de Outlook-synchronisatie-entiteit. Dit veld is standaard geselecteerd in de batchverwerking.

Als u meer informatie wilt opnemen, kunt u extra velden selecteren om op te nemen in de batchverwerking. Klik hiervoor op de AssistButton in het veld Veld en selecteer de relevante velden.

Als u geen filters instelt, worden alle records in de batchverwerking opgenomen.

Wanneer u de batchverwerking hebt uitgevoerd, moet u het bedrijf sluiten en opnieuw openen om de nieuwe instellingen van het wijzigingslogbestand van kracht te laten zijn.


Entiteit Outlook-synch. (venster)

Het venster Entiteit Outlook-synch.

In dit venster kunt u definiëren welke Microsoft Dynamics NAV-entiteiten moeten worden gesynchroniseerd met Outlook-items.

Dit is het hoofdinstellingenvenster voor het organiseren van het synchronisatieproces. Hier voert u algemene informatie in over Microsoft Dynamics NAV-entiteiten, zoals tabelnummer, tabelnaam, filter en het Outlook-item waarmee de synchronisatie zal plaatsvinden.

U moet dergelijke instellingen uitvoeren voor elk Microsoft Dynamics NAV-item en Outlook-tabel die u wilt synchroniseren. In de kop van dit venster geeft u een Microsoft Dynamics NAV-hoofdtabel voor synchronisatie op niveau 1 op. Op de regels geeft u een aanvullende, gebonden Microsoft Dynamics NAV-tabel op. Als er een aanvullende tabel is gedefinieerd op de regels, wordt de synchronisatie op niveau 2 uitgevoerd.

Klik voor Help over een bepaald veld op het betreffende veld en druk op F1.

Verwante taken

Meer informatie


Entiteitlijst Outlook-synch. (venster)

Het venster Entiteitlijst Outlook-synch.

In dit venster wordt een lijst van alle Outlook-synchronisatie-entiteiten weergegeven.

In het venster Entiteitlijst Outlook-synch. kunt u zoeken naar bestaande synchronisatie-entiteiten.

Klik voor Help over een bepaald veld op het betreffende veld en druk op F1.

Verwante taken

Meer informatie


Filters Outlook-synch. (venster)

Het venster Filters Outlook-synch.

Met behulp van dit venster kunt u een aantal filters maken die moeten worden toegepast op het veld van een Microsoft Dynamics NAV-tabel tijdens het synchronisatieproces. Het filter kan het aantal records dat deelneemt aan het synchronisatieproces aan de kant van Microsoft Dynamics NAV beperken.

Klik voor Help over een bepaald veld op het betreffende veld en druk op F1.

Verwante taken

Meer informatie


Filterexpressie

In dit veld wordt een filter weergegeven dat is gedefinieerd op de regels van het venster Filters Outlook-synch. De expressie in dit veld is samengesteld volgens de filtersyntaxis van Microsoft Dynamics NAV.


Velden Outlook-synch. (venster)

Het venster Velden Outlook-synch.

Gebruik dit venster voor het koppelen van velden van Microsoft Dynamics NAV aan de overeenkomstige Outlook-eigenschappen. In dit venster stelt u de synchronisatie van niveau 3 in.

Dit venster heeft een andere set velden, afhankelijk van waaruit het wordt geopend. Dit verschil heeft te maken met de manier waarop de velden voor twee tabellen van Microsoft Dynamics NAV worden gekoppeld:

  • de hoofdtabel die is opgegeven in de kop van het venster Entiteit Outlook-synch.

en

  • de aanvullende tabel die is opgegeven op de regels van hetzelfde venster.

Klik voor Help over een bepaald veld op het betreffende veld en druk op F1.

Verwante taken

Meer informatie


Gebruiker instellen Outlook-synch. (venster)

Het venster Gebruiker instellen Outlook-synch.

Het venster geeft aan welke synchronisatie-items aan bepaalde gebruikers zijn toegewezen.

U ziet alle records van alle synchronisatiegebruikers. U kunt items invoegen, wijzigen en verwijderen als u beschikt over de juiste toegangsrechten om dergelijke acties uit te voeren.

U kunt ook voorwaarden opgeven die moeten worden toegepast op entiteiten van Microsoft Dynamics NAV wanneer deze naar Outlook worden geëxporteerd.

Klik voor Help over een bepaald veld op het betreffende veld en druk op F1.

Verwante taken

Meer informatie


Opzoeknamen Outlook-synch. (venster)

Het venster Opzoeknamen Outlook-synch.

Gebruik dit venster om aanvullende informatie weer te geven, zoals een lijst met namen van Outlook-items, verzamelingen en eigenschappen. In dit venster ziet u ook een lijst van elementen van het optieveld voor Microsoft Dynamics NAV en Outlook.

Meer informatie


Optiecorrel. Outlook-synch. (venster)

Het venster Optiecorrel. Outlook-synch.

Gebruik dit venster om de optievelden van Microsoft Dynamics NAV en de overeenkomstige Outlook-eigenschap in te stellen die dezelfde structuur heeft (opsommingen en integer). Het optieveld van Microsoft Dynamics NAV kan anders zijn dan de overeenkomstige Outlook-optie (andere elementnamen, andere elementvolgorde). In dit venster stelt u relaties tussen optie-elementen in.

Meer informatie


Tabellijst Outlook-synch. (venster)

Het venster Tabellijst Outlook-synch.

In dit venster worden alle tabellen van Microsoft Dynamics NAV weergegeven die deel kunnen nemen aan synchronisatie met Outlook-items. In dit venster kunt u niets bewerken.

Klik voor Help over een bepaald veld op het betreffende veld en druk op F1.


Tabelvelden Outlook-synch. (venster)

Het venster Tabelvelden Outlook-synch.

In dit venster worden alle tabelvelden weergegeven die kunnen worden gekoppeld aan de overeenkomstige Outlook-eigenschappen.

Klik voor Help over een bepaald veld op het betreffende veld en druk op F1.


Configuratiedetails Outlook-synch. (venster)

Het venster Configuratiedetails Outlook-synch.

In dit venster wordt een lijst van Outlook-verzamelingen weergegeven die deelnemen aan de synchronisatie voor de huidige entiteit. Verzamelingen die niet vermeld staan in dit venster, maar wel zijn gedefinieerd in het venster Entiteit Outlook-synch. worden niet gesynchroniseerd.

Verwante taken

Meer informatie


Afhankelijkheden Outlook-synch. (venster)

Het venster Afhankelijkheden Outlook-synch.

In dit venster worden de entiteiten weergegeven die moeten worden gesynchroniseerd voordat de overeenkomstige verzameling wordt gesynchroniseerd. Deze entiteiten worden geselecteerd voor Outlook-verzamelingen die afhankelijk zijn van andere entiteiten.

Als u meer wilt weten over Outlook-verzamelingen, raadpleeg dan de online Help bij Outlook.

Verwante taken

Meer informatie


Koppelingsschema

Een document waarin wordt gedefinieerd hoe Microsoft Dynamics NAV-records en Outlook-items aan elkaar zijn gekoppeld. Een koppelingsschema bevat uitsluitend entiteiten die u hebt geselecteerd in het venster Gebruiker instellen Outlook-synch. De invoegtoepassing Synchronisatie van Microsoft Dynamics NAV die is geïnstalleerd aan de kant van Outlook ontvangt het koppelingsschema van Microsoft Dynamics NAV in XM-indeling en bewaart dit in de geïsoleerde opslag.

Verwante onderwerpen

Identiteitstoewijzing

Veldkoppelingsschema

Laatste wijzing (datum/tijd)

Laatst gesynchroniseerd

Niveaus van synchronisatie

Microsoft Dynamics NAV-entiteit

Outlook-item

Outlook-synchronisatiefunctie

Specificiteit van de synchronisatie

Synchronisatie-entiteit

Synchronisatie-uitzondering

Synchronisatie-interval

Synchronisatieproces

Synchronisatieschema

Synchronisatie-instellingen


Code, Entiteit Outlook-synch. (tabel)

Het veld Code

De tabel Entiteit Outlook-synch.

Dit veld bevat een unieke identificatie voor elke vermelding in de tabel Entiteit Outlook-synch.

U kunt een code van maximaal 10 alfanumerieke tekens opgeven.


Omschrijving, Entiteit Outlook-synch. (tabel)

Het veld Omschrijving

De tabel Entiteit Outlook-synch.

Dit veld bevat een beknopte omschrijving van de synchronisatie-entiteit die u hebt gemaakt.

De waarde in dit veld wordt gebruikt als label voor de Outlook-map waarin de gesynchroniseerde gegevens worden opgeslagen.

De omschrijving mag niet langer zijn dan 50 tekens.


Tabelnr., Entiteit Outlook-synch. (tabel)

Het veld Tabelnr.

De tabel Entiteit Outlook-synch.

Dit veld bevat het nummer van de Microsoft Dynamics NAV-tabel die moet worden gesynchroniseerd met een Outlook-item.

Klik op de AssistButton in dit veld om een lijst weer te geven met alle tabellen waaruit u kunt kiezen.


Tabelnaam, Entiteit Outlook-synch. (tabel)

Het veld Tabelnaam

De tabel Entiteit Outlook-synch.

Dit veld bevat de naam van de Microsoft Dynamics NAV-tabel die u wilt synchroniseren. Dit veld wordt telkens wanneer u een tabelnummer opgeeft in het veld Tabelnr. ingevuld.


Voorwaarde, Entiteit Outlook-synch. (tabel)

Het veld Voorwaarde

De tabel Entiteit Outlook-synch.

Dit veld bevat de criteria voor het definiëren van een set specifieke items die moeten worden gebruikt bij het synchronisatieproces. Dit filter wordt toegepast op de tabel die u hebt opgegeven in het veld Tabelnr. Voor deze soort filter kunt u uitsluitend Microsoft Dynamics NAV-filters van de soort CONST en FILTER definiëren.

Als u alle beschikbare items wilt synchroniseren, laat u dit veld leeg.


Outlook-item, Entiteit Outlook-synch. (tabel)

Het veld Outlook-item

De tabel Entiteit Outlook-synch.

Dit veld bevat de naam van het Outlook-item dat overeenkomt met de Microsoft Dynamics NAV-tabel die u hebt opgegeven in het veld Tabelnr.


Record-GUID, Entiteit Outlook-synch. (tabel)

Het veld Record-GUID

De tabel Entiteit Outlook-synch.

Dit veld bevat de unieke id van elke post. Dit veld is bedoeld voor intern gebruik.


Entiteitcode synch., Entiteitelement Outlook-synch. (tabel)

Het veld Entiteitcode synch.

De tabel Entiteitelement Outlook-synch.

Dit veld bevat de code van de vereiste Outlook-synchronisatie-entiteit. In dit veld wordt de waarde van het veld Code in de tabel Entiteit Outlook-synch. ingevuld.


Elementnr., Entiteitelement Outlook-synch. (tabel)

Het veld Elementnr.

De tabel Entiteitelement Outlook-synch.

Dit veld bevat het volgordenummer van elk item. Dit veld wordt automatisch ingevuld.


Tabelnr., Entiteitelement Outlook-synch. (tabel)

Het veld Tabelnr.

De tabel Entiteitelement Outlook-synch.

Dit veld bevat het nummer van de Microsoft Dynamics NAV-tabel die overeenkomt met het Outlook-item waarvan een verzameling is opgegeven in het veld Outlook-verzameling.


Tabelnaam, Entiteitelement Outlook-synch. (tabel)

Het veld Tabelnaam

De tabel Entiteitelement Outlook-synch.

Dit veld bevat de naam van de Microsoft Dynamics NAV-tabel die u wilt synchroniseren. Dit veld wordt ingevuld wanner u een tabelnummer opgeeft in het veld Tabelnr.


Tabelrelatie, Entiteitelement Outlook-synch. (tabel)

Het veld Tabelrelatie

De tabel Entiteitelement Outlook-synch.

Dit veld bevat een filterexpressie die bepaalt welke Microsoft Dynamics NAV-items worden geselecteerd voor synchronisatie. Dit wordt gebruikt om relaties te definiëren tussen tabellen die zijn opgegeven in de velden Tabelnr. en Tabelnr.

U kunt dit filter definiëren in het venster Filters Outlook-synch. U kunt voor dit filter alleen de opties van FIELD gebruiken.


Outlook-verzameling, Entiteitelement Outlook-synch. (tabel)

Het veld Outlook-verzameling

De tabel Entiteitelement Outlook-synch.

Dit veld bevat de naam van de Outlook-verzameling die overeenkomt met de set Microsoft Dynamics NAV-records die zijn geselecteerd voor synchronisatie in het veld Tabelnr.


Hoofdtabelnr., Entiteitelement Outlook-synch. (tabel)

Het veld Hoofdtabelnr.

De tabel Entiteitelement Outlook-synch.

Dit veld bevat het nummer van de tabel die is opgegeven voor de synchronisatie op niveau 1. Dit veld wordt gevuld met de juiste waarde uit het veld Tabelnr. in de tabel Entiteit Outlook-synch.


Record-GUID, Entiteitelement Outlook-synch. (tabel)

Het veld Record-GUID

De tabel Entiteitelement Outlook-synch.

Dit veld bevat de unieke id van elke post. Dit veld is bedoeld voor intern gebruik.


Aantal afhankelijke items, Entiteitelement Outlook-synch. (tabel)

Het veld Aantal afhankelijke items

De tabel Entiteitelement Outlook-synch.

In dit veld wordt het aantal afhankelijke entiteiten weergegeven dat moet worden gesynchroniseerd. Als deze entiteiten zijn gesynchroniseerd, wordt het synchronisatieproces geacht voltooid te zijn voor de huidige entiteit. U wijst deze afhankelijke entiteiten toe in de tabel Afhankelijk Outlook-synch.


Gebruikers-id, Koppeling Outlook-synch. (tabel)

Het veld Gebruikers-id

De tabel Koppeling Outlook-synch.

Dit veld bevat de id van een gebruiker die de Databaseverificatie gebruikt om zich aan te melden bij Microsoft Dynamics NAV om toegang te krijgen tot de huidige database.


Record-id, Koppeling Outlook-synch. (tabel)

Het veld Record-id

De tabel Koppeling Outlook-synch.

Dit veld bevat het recordnummer dat een combinatie weergeeft van het tabelnummer en de primaire sleutel van de record van de Microsoft Dynamics NAV-hoofdtabel, die een Microsoft Dynamics NAV-entiteit vertegenwoordigt.


Id Outlook-gegeven, Koppeling Outlook-synch. (tabel)

Het veld Id Outlook-gegeven

De tabel Koppeling Outlook-synch.

Dit veld bevat het unieke nummer van het Outlook-item.


Id-hash Outlook-gegeven, Koppeling Outlook-synch. (tabel)

Het veld Id-hash Outlook-gegeven

De tabel Koppeling Outlook-synch.

Dit veld bevat de hash code die is berekend op basis van de waarde van het veld Id Outlook-gegeven.


Zoeken naar record-id, Koppeling Outlook-synch. (tabel)

Het veld Zoeken naar record-id

De tabel Koppeling Outlook-synch.

Dit veld bevat het recordnummer dat een combinatie weergeeft van het tabelnummer en de primaire sleutel van de record van de Microsoft Dynamics NAV-hoofdtabel, die een Microsoft Dynamics NAV-entiteit vertegenwoordigt. De waarde in dit veld wordt weergegeven als tekst.


Synchronisatiedatum, Koppeling Outlook-synch. (tabel)

Het veld Synchronisatiedatum

De tabel Koppeling Outlook-synch.

Dit veld bevat de tijd waarop de records die werden gesynchroniseerd, tijdens de synchronisatie zijn gewijzigd.


Record-GUID, Filter Outlook-synch. (tabel)

Het veld Record-GUID

De tabel Filter Outlook-synch.

Dit veld bevat de unieke id van elke post. Dit veld is bedoeld voor intern gebruik.


Filtertype, Filter Outlook-synch. (tabel)

Het veld Filtertype

De tabel Filter Outlook-synch.

De waarde in dit veld geeft de soort Microsoft Dynamics NAV-filtering aan die moet worden toegepast. Dit veld kan een van de volgende opties bevatten:

  • Voorwaarde: voor deze soort filter is het instellen van een tabel-naar-tabel-relatie niet mogelijk. U kunt hier alleen Microsoft Dynamics NAV-filters van de soorten CONST en FILTER definiëren.

  • Tabelfilter: naast de filters die u kunt definiëren in soort Voorwaarde, kunt u ook de tabel-naar-tabel-filtering definiëren.


Regelnr., Filter Outlook-synch. (tabel)

Het veld Regelnr.

De tabel Filter Outlook-synch.

Dit veld bevat het volgordenummer van de huidige regel. Dit veld is bedoeld voor intern gebruik.


Tabelnr., Filter Outlook-synch. (tabel)

Het veld Tabelnr.

De tabel Filter Outlook-synch.

Dit veld bevat het nummer van de tabel waarvan de records moeten worden gefilterd.


Veldnr., Filter Outlook-synch. (tabel)

Het veld Veldnr.

De tabel Filter Outlook-synch.

Dit veld bevat het nummer van het veld waarvan de waarden worden gebruikt in de filterexpressie. Een waarde in dit veld is toepasselijk als u het nummer van de tabel hebt opgegeven in het veld Tabelnr.


Veldnaam, Filter Outlook-synch. (tabel)

Het veld Veldnaam

De tabel Filter Outlook-synch.

Dit veld bevat de naam van het veld waarvan de waarden worden gebruikt in de filterexpressie. Dit veld wordt ingevuld wanneer u het nummer van het veld opgeeft in het veld Veldnr.


Soort, Filter Outlook-synch. (tabel)

Het veld Soort

De tabel Filter Outlook-synch.

Dit veld geeft aan welke filtering wordt toegepast. U kunt kiezen uit drie opties:

  • CONST: de filterexpressie moet de exacte tekst bevatten die u invoert.

  • FILTER: de filterexpressie kan gebruikmaken van de syntaxis die aanvaardbaar is voor gebruik in Microsoft Dynamics NAV.

  • FIELD: in de filterexpressie worden tabel-naar-tabel-relaties gedefinieerd.


Waarde, Filter Outlook-synch. (tabel)

Het veld Waarde

De tabel Filter Outlook-synch.

Dit veld bevat de waarde die wordt vergeleken met de waarde in het veld Veldnr.

Welke filterexpressie u in dit veld kunt invoeren is afhankelijk van de waarde die u opgeeft in het veld Soort.


Hoofdtabelnr., Filter Outlook-synch. (tabel)

Het veld Hoofdtabelnr.

De tabel Filter Outlook-synch.

Dit veld bevat het nummer van de aanvullende tabel die is opgegeven in het veld Tabelnr. in de tabel Entiteit Outlook-synch.


Veldnr. hoofdtabel, Filter Outlook-synch. (tabel)

Het veld Veldnr. hoofdtabel

De tabel Filter Outlook-synch.

Dit veld bevat het nummer van het veld uit de hoofdtabel die is geselecteerd in het veld Hoofdtabelnr.


Entiteitcode synch., Veld Outlook-synch. (tabel)

Het veld Entiteitcode synch.

De tabel Veld Outlook-synch.

Dit veld bevat de code van de vereiste Outlook-synchronisatie-entiteit. In dit veld wordt de waarde uit het veld Code in de tabel Entiteit Outlook-synch. ingevuld.


Elementnr., Veld Outlook-synch. (tabel)

Het veld Elementnr.

De tabel Veld Outlook-synch.

In dit veld staat de Outlook-entiteit die zal worden gebruikt bij het synchronisatieproces. Om dit veld in te vullen, wordt de waarde van het veld Elementnr. gekopieerd uit de tabel Entiteitelement Outlook-synch. die overeenkomt met synchronisatie op niveau 2. Als het nummer van het element gelijk is aan nul, wordt ervan uitgegaan dat de synchronisatie plaatsvindt op niveau 1.


Regelnr., Veld Outlook-synch. (tabel)

Het veld Regelnr.

De tabel Veld Outlook-synch.

Dit veld bevat het volgordenummer van de huidige regel. Dit veld is bedoeld voor intern gebruik.


Hoofdtabelnr., Veld Outlook-synch. (tabel)

Het veld Hoofdtabelnr.

De tabel Veld Outlook-synch.

Dit veld bevat het nummer van de tabel waarvoor u specifieke koppelingsinstellingen wilt definiëren. Dit veld wordt automatisch ingevuld. U kunt de set items beperken met behulp van een filter in het veld Voorwaarde.


Outlook-object, Veld Outlook-synch. (tabel)

Het veld Outlook-object

De tabel Veld Outlook-synch.

In dit veld wordt de naam van het Outlook-object opgeslagen. In het veld staat de nam van één van de Outlook-objecten die vermeld staan in de kop van het venster Entiteit Outlook-synch. of op de regels van dat venster.

  • Als het venster Velden Outlook-synch. wordt geopend voor de kop van het venster Entiteit Outlook-synch., wordt de naam van het Outlook-object gekopieerd uit het veld Outlook-item.

  • Als het venster Velden Outlook-synch. wordt geopend voor de regels van het venster Entiteit Outlook-synch., wordt de naam van het Outlook-object gekopieerd uit het veld Outlook-verzameling.


Outlook-eigenschap, Veld Outlook-synch. (tabel)

Het veld Outlook-eigenschap

De tabel Veld Outlook-synch.

Dit veld bevat het nummer van de eigenschap van het Outlook-item die wordt gesynchroniseerd met het Microsoft Dynamics NAV-tabelveld dat is opgegeven in het veld Veldnr.


Door gebruiker gedefinieerd, Veld Outlook-synch. (tabel)

Het veld Door gebruiker gedefinieerd

De tabel Veld Outlook-synch.

Een vinkje in dit veld geeft aan dat dit veld is gedefinieerd door de gebruiker en niet behoort tot de standaardset velden. Deze optie verwijst alleen naar eigenschappen van Outlook-items.


Zoekveld, Veld Outlook-synch. (tabel)

Het veld Zoekveld

De tabel Veld Outlook-synch.

Een vinkje in dit veld geeft aan dat het veld de sleuteleigenschap vormt waarop de zoekactie Outlook wordt gebaseerd.


Voorwaarde, Veld Outlook-synch. (tabel)

Het veld Voorwaarde

De tabel Veld Outlook-synch.

Dit veld bevat de criteria voor het definiëren van een set specifieke items die moeten worden gebruikt bij het synchronisatieproces. Dit filter wordt toegepast op de tabel die u hebt opgegeven in het veld Tabelnr. Als het veld Tabelnr. niet is ingevuld, wordt de waarde in het veld Hoofdtabelnr. gebruikt.

Als u alle items beschikbaar wilt maken, laat u dit veld leeg.


Tabelnr., Veld Outlook-synch. (tabel)

Het veld Tabelnr.

De tabel Veld Outlook-synch.

Dit veld bevat het nummer van de aanvullende tabel, die wordt gebruikt bij het synchronisatieproces wanneer meer details nodig zijn dan is opgegeven in het veld Hoofdtabelnr.

Twee verschillende situaties bepalen of dit veld wordt ingevuld of niet:

  • De waarde voor dit veld komt overeen met het veld Tabelnr. uit de tabel Entiteit Outlook-synch. In dit geval blijft het veld leeg.

  • In andere gevallen komt, om een Outlook-eigenschap te koppelen aan een Microsoft Dynamics NAV-veld, de waarde voor dit veld uit een andere tabel dan de hoofdtabel. In dat geval bevat het veld het nummer van een subtabel.


Tabelnaam, Veld Outlook-synch. (tabel)

Het veld Tabelnaam

De tabel Veld Outlook-synch.

Dit veld bevat de naam van de Microsoft Dynamics NAV-tabel die u wilt synchroniseren. Dit veld wordt ingevuld wanneer u een tabelnummer opgeeft in het veld Tabelnr.


Tabelrelatie, Veld Outlook-synch. (tabel)

Het veld Tabelrelatie

De tabel Veld Outlook-synch.

Dit veld bevat een filterexpressie. Deze wordt gebruikt om relaties te definiëren tussen tabellen die zijn opgegeven in de velden Tabelnr. en Tabelnr.

Voor dit filter kunt u alleen de optie FIELD gebruiken.


Veldnr., Veld Outlook-synch. (tabel)

Het veld Veldnr.

De tabel Veld Outlook-synch.

Dit veld bevat het nummer van het veld waarvan de waarden worden gebruikt in de filterexpressie. De waarde in dit veld is toepasselijk als u het nummer van de tabel hebt opgegeven in het veld Tabelnr. Als u het tabelnummer niet opgeeft, wordt het nummer van de hoofdtabel gebruikt.


Veldnaam, Veld Outlook-synch. (tabel)

Het veld Veldnaam

De tabel Veld Outlook-synch.

Dit veld bevat de naam van het veld dat is geselecteerd in het veld Veldnr. De veldnaam die wordt weergegeven, wordt gebruikt bij het synchronisatieproces.


Alleen-lezen, Veld Outlook-synch. (tabel)

Het veld Alleen-lezen

De tabel Veld Outlook-synch.

Dit veld geeft de synchronisatiestatus van het gekoppelde tabelveld weer. Het veld heeft drie opties:

  • Alleen-lezen in Outlook: er worden alleen wijzigingen ontvangen die zijn gedaan in Outlook voor het betreffende veld van Microsoft Dynamics NAV.

  • Alleen-lezen in Microsoft Dynamics NAV: er worden alleen wijzigingen verzonden die zijn gedaan in Microsoft Dynamics NAV voor de betreffende Outlook-eigenschap.

  • Leeg: dit tabelveld wordt op beide manier gesynchroniseerd. Alleen wijzigingen die zijn gedaan in Outlook worden ontvangen voor het betreffende veld van Microsoft Dynamics NAV.

Dit veld is bedoeld voor intern gebruik en de waarde ervan wordt ingesteld door het programma.


Standaardwaarde veld, Veld Outlook-synch. (tabel)

Het veld Standaardwaarde veld

De tabel Veld Outlook-synch.

Dit veld bevat een waarde die automatisch wordt ingevoegd in het veld waarvan het nummer is opgegeven in het veld Veldnr.

De waarde in dit veld wordt gebruikt wanneer de synchronisatie loopt van Outlook naar Microsoft Dynamics NAV. Als het synchronisatieschema niet de waarde van een specifiek veld bevat, wordt de standaardwaarde uit dit veld ingevoegd.


Record-GUID, Veld Outlook-synch. (tabel)

Het veld Record-GUID

De tabel Veld Outlook-synch.

Dit veld bevat een uniek identificatienummer voor het huidige record. Dit veld is bedoeld voor intern gebruik.


Gebruikers-id, Gebruiker instellen Outlook-synch. (tabel)

Het veld Gebruikers-id

De tabel Gebruiker instellen Outlook-synch.

Dit veld bevat de id van een gebruiker die de Windows-serververificatie gebruikt om zich aan te melden bij Microsoft Dynamics NAV om toegang te krijgen tot de huidige database. In Microsoft Dynamics NAV bestaat de gebruikers-id uitsluitend uit een gebruikersnaam.

Attentie

In Outlook bestaat de gebruikers-id uit de domeinnaam en de gebruikersnaam. Wanneer Outlook tijdens het synchroniseren de gebruikersnaam naar Microsoft Dynamics NAV stuurt, wordt de domeinnaam eraf geknipt en ontvangt Microsoft Dynamics NAV alleen de gebruikersnaam. Als twee gebruikers beide met deze Outlook-client werken met dezelfde naam maar met verschillende domeinen, vormen zij in Microsoft Dynamics NAV slechts één persoon. Deze situatie geldt alleen als bij het synchroniseren van Microsoft Dynamics NAV-records en Outlook-items.


Entiteitcode synch., Gebruiker instellen Outlook-synch. (tabel)

Het veld Entiteitcode synch.

De tabel Gebruiker instellen Outlook-synch.

Dit veld bevat de code van de synchronisatie-entiteit. Deze code is gekopieerd uit het veld Code van de tabel Entiteiten Outlook-synch.


Omschrijving, Gebruiker instellen Outlook-synch. (tabel)

Het veld Omschrijving

De tabel Gebruiker instellen Outlook-synch.

Dit veld bevat een beknopte omschrijving van de synchronisatie-entiteit. Deze omschrijving wordt gekopieerd uit het veld Omschrijving van de tabel Entiteit Outlook-synch. Dit veld wordt ingevuld wanneer u een code invoert in het veld Entiteitcode synch.


Voorwaarde, Gebruiker instellen Outlook-synch. (tabel)

Het veld Voorwaarde

De tabel Gebruiker instellen Outlook-synch.

Dit veld bevat de criteria voor het definiëren van een set specifieke items die moeten worden gebruikt bij het synchronisatieproces. Dit filter wordt toegepast op de tabel die u hebt opgegeven in het veld Tabelnr. Voor dit filter kunt u alleen de opties CONST en FILTER gebruiken.

De voorwaarde die u opgeeft in dit veld wordt toegepast op entiteiten van Microsoft Dynamics NAV wanneer deze naar Outlook worden geëxporteerd.


Richting, Gebruiker instellen Outlook-synch. (tabel)

Het veld Richting

De tabel Gebruiker instellen Outlook-synch.

Dit veld geeft de richting aan van de synchronisatie van het huidige item. De volgende opties zijn beschikbaar:

  • Outlook naar Microsoft Dynamics NAV: alleen wijzigingen die zijn doorgevoerd in Outlook voor het overeenkomstige Microsoft Dynamics NAV-veld worden ontvangen.

  • Microsoft Dynamics NAV naar Outlook: alleen wijzigingen die zijn doorgevoerd in Microsoft Dynamics NAV voor de overeenkomstige Outlook-eigenschap worden verzonden.

  • Bidirectioneel: de synchronisatie wordt in beide richtingen uitgevoerd.


Laatst gesynch., Gebruiker instellen Outlook-synch. (tabel)

Het veld Laatst gesynch.

De tabel Gebruiker instellen Outlook-synch.

Dit veld bevat de tijd van de meest recente geslaagde synchronisatie.


Record-GUID, Gebruiker instellen Outlook-synch. (tabel)

Het veld Record-GUID

De tabel Gebruiker instellen Outlook-synch.

Dit veld bevat een uniek identificatienummer voor het huidige record. Dit veld is bedoeld voor intern gebruik.


Aantal elementen, Gebruiker instellen Outlook-synch. (tabel)

Het veld Aantal elementen

De tabel Gebruiker instellen Outlook-synch.

In dit veld staat het aantal verzamelingen dat is geselecteerd voor de synchronisatie. De gebruiker definieert deze verzamelingen in het formulier Configuratiedetails Outlook-synch.


Volgnummer, Opzoeknaam Outlook-synch. (tabel)

Het veld Volgnummer

De tabel Opzoeknaam Outlook-synch.

Dit veld bevat het volgordenummer van de huidige record.


Naam, Opzoeknaam Outlook-synch. (tabel)

Het veld Naam

De tabel Opzoeknaam Outlook-synch.

Dit veld bevat de naam van het Outlook-object dat u wilt synchroniseren. Dit object kan een Outlook-item, -verzameling of -eigenschap zijn.


Entiteitcode synch., Optiecorrel. Outlook-synch. (tabel)

Het veld Entiteitcode synch.

De tabel Optiecorrel. Outlook-synch.

In dit veld staat de code van de synchronisatie-entiteit. Dit veld wordt automatisch ingevuld met de waarde van Entiteitcode synch. van de tabel Veld Outlook-synch.


Elementnr., Optiecorrel. Outlook-synch. (tabel)

Het veld Elementnr.

De tabel Optiecorrel. Outlook-synch.

In dit veld staat het elementnummer van de synchronisatie-entiteit. Dit wordt automatisch opgehaald uit het veld Elementnr. van de tabel Veld Outlook-synch.


Veldregelnr., Optiecorrel. Outlook-synch. (tabel)

Het veld Veldregelnr.

De tabel Optiecorrel. Outlook-synch.

Dit veld bevat het volgordenummer van de tabel Veld Outlook-synch. Dit wordt automatisch opgehaald uit het veld Regelnr. in de tabel Veld Outlook-synch.


Regelnr., Optiecorrel. Outlook-synch. (tabel)

Het veld Regelnr.

De tabel Optiecorrel. Outlook-synch.

Dit wordt gebruikt voor het opslaan van het volgordenummer van de huidige record.


Outlook-object, Optiecorrel. Outlook-synch. (tabel)

Het veld Outlook-object

De tabel Optiecorrel. Outlook-synch.

Het veld bevat de naam van het Outlook-object. Dit object kan een Outlook-item of -verzameling zijn.


Outlook-eigenschap, Optiecorrel. Outlook-synch. (tabel)

Het veld Outlook-eigenschap

De tabel Optiecorrel. Outlook-synch.

Het veld bevat de naam van de Outlook-eigenschap.


Outlook-waarde, Optiecorrel. Outlook-synch. (tabel)

Het veld Outlook-waarde

De tabel Optiecorrel. Outlook-synch.

Het veld bevat de waarde van de Outlook-eigenschap.


Tabelnr., Optiecorrel. Outlook-synch. (tabel)

Het veld Tabelnr.

De tabel Optiecorrel. Outlook-synch.

Het veld bevat het nummer van de tabel waarvan het veld deelneemt aan de synchronisatie-optiecorrelatie.


Veldnr., Optiecorrel. Outlook-synch. (tabel)

Het veld Veldnr.

De tabel Optiecorrel. Outlook-synch.

Het veld bevat het nummer van het veld dat deelneemt aan de synchronisatie-optiecorrelatie.


Veldwaarde, Optiecorrel. Outlook-synch. (tabel)

Het veld Veldwaarde

De tabel Optiecorrel. Outlook-synch.

Het veld bevat de waarde van het veld dat is geselecteerd in het veld Veldnr.


Optienr., Optiecorrel. Outlook-synch. (tabel)

Het veld Optienr.

De tabel Optiecorrel. Outlook-synch.

In dit veld wordt het nummer opgeslagen van het optie-element dat is geselecteerd.


Gebruikers-id, Configuratiedetails Outlook-synch. (tabel)

Het veld Gebruikers-id

De tabel Configuratiedetails Outlook-synch.

Dit veld bevat de id van de gebruiker wiens nummer afkomstig is uit het veld Gebruikers-id in de tabel Gebruiker instellen Outlook-synch.


Entiteitcode synch., Configuratiedetails Outlook-synch. (tabel)

Het veld Entiteitcode synch.

De tabel Configuratiedetails Outlook-synch.

Dit veld bevat de entiteitcode waarvan het nummer afkomstig is uit het veld Entiteitcode synch. van de tabel Gebruiker instellen Outlook-synch.


Elementnr., Configuratiedetails Outlook-synch. (tabel)

Het veld Elementnr.

De tabel Configuratiedetails Outlook-synch.

Met dit veld wordt de Outlook-entiteit gedefinieerd die zal worden gebruikt in het synchronisatieproces. Om dit veld in te vullen, wordt de waarde van het veld Elementnr. gekopieerd uit de tabel Entiteitelement Outlook-synch. die overeenkomt met Synchronisatieniveau 2.


Outlook-verzameling, Configuratiedetails Outlook-synch. (tabel)

Het veld Outlook-verzameling

De tabel Configuratiedetails Outlook-synch.

In dit veld staat de naam van de Outlook-verzameling die is geselecteerd om te worden gesynchroniseerd.


Entiteitcode synch., Afhankelijkheid Outlook-synch. (tabel)

Het veld Entiteitcode synch.

De tabel Afhankelijkheid Outlook-synch.

In dit veld staat de entiteitcode die is gekopieerd uit het veld Entiteitcode synch. van de tabel Entiteitelement Outlook-synch.


Elementnr., Afhankelijkheid Outlook-synch. (tabel)

Het veld Elementnr.

De tabel Afhankelijkheid Outlook-synch.

Met dit veld wordt de Outlook-entiteit gedefinieerd die zal worden gebruikt in het synchronisatieproces. Om dit veld in te vullen, wordt de waarde van het veld Elementnr. gekopieerd uit de tabel Entiteitelement Outlook-synch. die overeenkomt met Synchronisatieniveau 2.


Entiteitcode afhank. synch., Afhankelijkheid Outlook-synch. (tabel)

Het veld Entiteitcode afhank. synch.

De tabel Afhankelijkheid Outlook-synch.

Dit veld bevat de code van de synchronisatie-entiteit. Deze code wordt gekopieerd uit het veld Code van de tabel Entiteiten Outlook-synch.


Omschrijving, Afhankelijkheid Outlook-synch. (tabel)

Het veld Omschrijving

De tabel Afhankelijkheid Outlook-synch.

Dit veld bevat een beknopte omschrijving van de entiteit waarvan de code is opgegeven in het veld Omschrijving van de tabel Entiteit Outlook-synch.


Voorwaarde, Afhankelijkheid Outlook-synch. (tabel)

Het veld Voorwaarde

De tabel Afhankelijkheid Outlook-synch.

Dit veld bevat de filterexpressie die wordt toegepast op de tabel van de verzameling die is gedefinieerd met de velden Entiteitcode afhank. synch. en Elementnr. Deze voorwaarde is vereist wanneer één zoekveld van de verzameling gekoppeld is aan verschillende tabellen (de voorwaardetabelrelatie).

U kunt dit filter definiëren in het venster Filters Outlook-synch. U kunt voor dit filter de optie CONST of FILTER gebruiken.


Tabelrelatie, Afhankelijkheid Outlook-synch. (tabel)

Het veld Tabelrelatie

De tabel Afhankelijkheid Outlook-synch.

Dit veld bevat een filterexpressie. Deze wordt gebruikt om de record te selecteren uit de tabel waarop Entiteit afhank. synch. is gebaseerd.

U kunt dit filter definiëren in het venster Filters Outlook-synch. U kunt voor dit filter alleen de opties van FIELD gebruiken.


Record-GUID, Afhankelijkheid Outlook-synch. (tabel)

Het veld Record-GUID

De tabel Afhankelijkheid Outlook-synch.

In dit veld staat de unieke id van de huidige record zodat deze makkelijk te herkennen is tussen andere objecten.

Deze wordt gebruikt om relaties tot stand te brengen met de tabel Filter Outlook-synch.