De Employee Portal-instellingenkaart

Voordat u Employee Portal gebruikt, moet u bepaalde basisinstellingen invoeren die van toepassing zijn op uw portal. U moet eerst de Employee Portal-instellingenkaart invullen. Wanneer u de Employee Portal-instellingenkaart invult, worden de vooraf gedefinieerde acties voor u beschikbaar gemaakt.

Wanneer u een webonderdeel aan uw portal-pagina toevoegt, moet u het webonderdeel configureren door aan te geven welke gegevens het webonderdeel bij Microsoft Dynamics NAV opvraagt. U doen dit in de aangepaste eigenschapsvelden in het SharePoint-toolsvenster.

De aangepaste eigenschappen zijn de eigenschappen die zijn gemaakt om de Employee Portal-functionaliteit in het webonderdeel te introduceren. De aangepaste eigenschapsvelden zijn de velden die van toepassing zijn.

De aangepaste eigenschapsvelden zijn specifiek voor Microsoft Dynamics NAV en de bijschriften voor deze velden moeten in Microsoft Dynamics NAV worden gedefinieerd.

Op het tabblad Toolsvenster configuratie geeft u de bijschriften op voor de configuratie van de webonderdelen Kaart, Lijst en Kop-Regel.

Op het tabblad Toolsvenster zoeken geeft u de bijschriften voor de configuratie van zoekonderdelen op.

Open het venster [image] Employee Portal-instellingenkaart om deze gegevens in te voeren. Vul de velden aan de hand van deze richtlijnen in:

Veld | Opmerkingen
Tabblad Toolsvenster configuratie: |
Bijschrift toolsvenster config. | Voer het bijschrift in dat u in het toolsvenster als kop van het aangepaste eigenschapsgebied van de Employee Portal voor de webonderdelen Kaart, Lijst en Kop-Regel wilt weergeven. U kunt bijvoorbeeld Employee Portal invoeren.
Bijschrift WO-verzoek toolsvenster config. | Voer het bijschrift in dat u als kop wilt weergeven van het veld waarin u het webonderdeelverzoek kunt selecteren dat het webonderdeel moet gebruiken. U kunt bijvoorbeeld Webonderdeelverzoek invoeren.
Bijschrift eerste verzoek toolsvenster config. | Voer het bijschrift in dat u als kop wilt weergeven van het veld waarin u het webonderdeel kunt selecteren om een eerste verzoek uit te voeren. U kunt bijvoorbeeld Geen eerste verzoek invoeren.
Bijschrift groep toolsvenster config. | Voer het bijschrift in dat u als kop wilt weergeven van het veld waarin u de groep verzoeken kunt selecteren. U kunt bijvoorbeeld Groep invoeren.
Tabblad Toolsvenster zoeken |
Bijschrift toolsvenster zoeken | Voer het bijschrift in dat u in het toolsvenster als kop van het aangepaste eigenschapsgebied van de Employee Portal voor het webonderdeel Zoeken wilt weergeven. U kunt bijvoorbeeld Employee Portal invoeren.
Bijschrift configuratietabel zoeken | Voer het bijschrift in dat u als kop wilt weergeven van het veld waarin u de tabel kunt selecteren die met de zoekactie wordt doorzocht. U kunt bijvoorbeeld Tabel invoeren.
Bijschrift alle tabellen toolsvenster zoeken | Voer het bijschrift in dat u wilt weergeven in het veld waarin u de tabel selecteert als optie om alle tabellen te doorzoeken. U kunt bijvoorbeeld Alle tabellen invoeren.
Zoeklimiet | Voer het maximum aantal records in dat op elk tabblad in een zoekresultaat moet worden weergeven.

Verwante onderwerpen

Bijschriften in Employee Portal

Webonderdelen voor Employee Portal maken

Zoekconfiguraties definiëren


De Instellingenkaart Application Server EP

Microsoft Dynamics NAV Application Server wordt gebruikt om de communicatie te verzorgen tussen Microsoft Dynamics NAV en SharePoint. U moet zowel de instelling van de codering als het verzoek opgeven voordat de communicatie kan worden gestart.

U moet een application server-kaart maken voor elke application server die u instelt.

Open de [image] Instellingenkaart Application Server EP en vul de velden aan de hand van deze richtlijnen in:

Veld | Opmerkingen
Tabblad Algemeen |
Code | Voer de code van de application server in. De code moet gelijk zijn aan de opstartparameter voor de application server.
Omschrijving | Voer een omschrijving in van de taken van de application server.
Codering gebruiken | Schakel dit selectievakje in om de codering te activeren van de gegevens die van Microsoft Dynamics NAV naar de front-end worden verzonden. De corresponderende waarden moeten in de front-end in het bestand Web.config zijn ingesteld.
Compressie gebruiken | Schakel dit selectievakje in om de compressie te activeren van de gegevens die van Microsoft Dynamics NAV naar de front-end worden verzonden. De corresponderende waarden moeten in de front-end in het bestand Web.config zijn ingesteld.
Tabblad Front-end |
Front-end verwerking | Schakel dit selectievakje in om aan te geven dat deze application server de communicatie verzorgt tussen Microsoft Dynamics NAV en de front-end.
Verzoekwachtrij | Voer het label in van de berichtenwachtrij die de inkomende berichten bij Microsoft Dynamics NAV verwerkt.
Antwoordenwachtrij | Voer het label in van de berichtenwachtrij die de uitgaande berichten van Microsoft Dynamics NAV verwerkt.
Tabblad Vertrouwd |
Sleuteluitwisseling verwerken | Schakel dit selectievakje in om aan te geven dat deze application server de vertrouwensverzoeken van de front-end verwerkt.
Verzoekwachtrij sleuteluitwisseling | Voer het label in van de berichtenwachtrij waarin de inkomende berichten bij Microsoft Dynamics NAV van vertrouwde partners worden verwerkt.
Antwoordenwachtrij sleuteluitwisseling | Voer het label in van de berichtenwachtrij waarin de uitgaande berichten van Microsoft Dynamics NAV naar vertrouwde partners worden verwerkt.

Meer informatie

Meer informatie over Microsoft Dynamics NAV Application Server vindt u in de handleiding Installation & System Management: Microsoft Dynamics NAV Application Server.

Meer informatie over het coderen van gegevens vindt u in de handleiding Installation & System Management: Microsoft Dynamics NAV Employee Portal.


Bijschriften in Employee Portal

In Employee Portal moet u bijschriften definiëren voor tekst die u in uw webonderdelen nodig hebt voor de navigatie en voor informatieve doeleinden die niet als toepassingsgegevens worden opgeslagen. Het is belangrijk dat u een bijschrift voor alle bijschriftelementen definieert. Als u dit niet doet, geeft Navision een fout terug aan de portal-pagina.

U moet bijschriften voor de volgende elementen definiëren:

  • EP-instellingen

  • Groepen

  • Webonderdeelverzoeken

  • Tabbladen

  • Acties

Voordat u een bijschrift aan een element kunt toevoegen, moet u het bijschrift definiëren in de lijst met bijschriften van het element.

De aangepaste eigenschappen die in de volgende tabel worden genoemd, zijn eigenschappen die ontwikkelaars hebben gemaakt om functionaliteit of gedrag van Employee Portal in het webonderdeel te introduceren. De aangepaste eigenschapsvelden zijn de velden die van toepassing zijn.

Bijschriften | Het bijschrift wordt weergegeven als:
EP-instellingen | Kop van een aangepast eigenschapsveld in het SharePoint-toolsvenster
Groepen | Een optie in het aangepaste eigenschapsveld waarin u de groep kunt selecteren waaruit u een webonderdeelverzoek wilt selecteren
Webonderdeelverzoek | Een optie in het aangepaste eigenschapsvenster van waaruit u een webonderdeelverzoek kunt selecteren
Tabblad | De naam op het tabblad in uw webonderdeel
Actie | De naam van de actie op de knop of koppeling, afhankelijk van de HTML-indeling die u hebt geselecteerd
Als u een webonderdeel ontwerpt dat in verschillende talen en door verschillende gebruikers zal worden gebruikt, moet u het bijschrift in elke taal een definitie geven. Meer informatie hierover vindt u in het onderwerp Meerdere talen in Employee Portal.

Verwante onderwerpen

De Employee Portal-instellingenkaart

Bijschriften voor groepen definiëren

Bijschriften voor sjablonen van webonderdeelverzoeken definiëren

Bijschriften voor groepen definiëren

Bijschriften voor acties definiëren


Gebruikers en groepen

In Employee Portal kunt u verschillende groepen webonderdeelverzoeken definiëren. Dit houdt in dat u meerdere typen portal-gebruikers kunt instellen die in uw portal kunnen bladeren en zakelijke activiteiten kunnen uitvoeren. Er kunnen aan verschillende gebruikers verschillende machtigingen worden toegewezen om verschillende activiteiten uit te voeren, zoals zakelijke activiteiten, onderhoud of administratieve activiteiten.

In Employee Portal kunt u gebruikers maken, de gebruikers aan groepen toewijzen en vanuit Microsoft Dynamics NAV de rechten van deze gebruikers wijzigen.

Als u portal-gebruikers wilt maken, moet u ze in Microsoft Dynamics NAV een identiteit geven zodat ze zich bij uw portal kunnen aanmelden. Wanneer gebruikers in uw portal werken, kunnen ze taken uitvoeren in overeenstemming met de machtigingen die aan de gebruikers zijn verleend. U kunt uw eigen groepen maken om aan uw specifieke behoeften te voldoen. U moet beslissen welke rollen u aan uw webportal-gebruikers wilt toewijzen.

Voordat u Employee Portal-gebruikers in Microsoft Dynamics NAV kunt maken, moet u de gebruikers als Windows- en SharePoint Server-gebruikers maken en configureren.

Groepen

Een groep is een verzameling webonderdeelverzoeken. Webonderdeelverzoeken zijn gebaseerd op gegevens van Microsoft Dynamics NAV en/of functionaliteit waarmee de gebruiker een taak kan uitvoeren. U kunt de webonderdeelverzoeken zo combineren dat ze precies aan uw behoeften voldoen.

U kunt een paar algemene groepen instellen die elk alle machtigingen voor één gebruikerstype bevatten of een groep instellen voor elke taak of deeltaak die gebruikers moeten kunnen uitvoeren. Vervolgens kunt u de rechten en mogelijkheden van elke gebruiker aanpassen.

Gebruikers

Gebruikers kunnen aan een groep worden toegewezen om toegang te krijgen tot de webonderdeelverzoeken die aan die groep zijn toegewezen.

U kunt de taal opgeven waarin de gegevens in de portal-pagina voor de gebruiker worden weergegeven. Alle anderen instellingen worden overgenomen van de groep.

Verwante onderwerpen

Employee Portal-gebruikers maken

Employee Portal-groepen maken

Webonderdeelverzoeken


Employee Portal-gebruikers maken

Als er eenmaal een Employee Portal-groep is ingesteld, kunt u gebruikers aan de groep toevoegen.

Een gebruiker maken

  1. Controleer of de gebruiker in SharePoint is gemaakt.

  2. Open het venster [image] EP-gebruikers.

  3. Voer in het veld Gebruikers-id de id van de gebruiker in. Zorg ervoor dat de id identiek is aan de id die in SharePoint voor de gebruiker is gedefinieerd.

  4. Voer in het veld Taal-id de unieke taal-id van Windows in om de taal van de gebruiker te identificeren.

Verwante onderwerpen

Gebruikers en groepen

Employee Portal-groepen maken

Employee Portal-gebruikers aan groepen toevoegen

Zoekconfiguraties aan gebruikers toevoegen


Employee Portal-groepen maken

Een groep is een verzameling webonderdeelverzoeken. Webonderdeelverzoeken zijn gebaseerd op gegevens van Microsoft Dynamics NAV en/of functionaliteit waarmee de gebruiker een taak kan uitvoeren. U kunt de webonderdeelverzoeken zo in een groep combineren dat de groep precies aan uw behoeften voldoet.

U kunt een paar algemene groepen instellen die elk alle machtigingen voor één gebruikerstype bevatten of een groep instellen voor elke (deel-) taak die gebruikers moeten kunnen uitvoeren. Vervolgens kunt u de rechten en mogelijkheden van elke gebruiker aanpassen.

Nadat u een groep hebt gemaakt, kunt u gebruikers aan de groep toevoegen om ze toegang tot de webonderdeelverzoeken te geven die aan die gebruikersgroep zijn toegewezen.

Een gebruikersgroep maken

  1. Open het venster [image] EP-groepskaart.

  2. Druk op F3 om een nieuwe gebruikersgroep in te stellen.

  3. Vul de velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

Verwante onderwerpen

Gebruikers en groepen

Employee Portal-gebruikers maken

Bijschriften voor groepen definiëren

Employee Portal-gebruikers aan groepen toevoegen


Bijschriften voor groepen definiëren

In Employee Portal moet u bijschriften definiëren voor de teksten in uw webonderdeel die niet als toepassingsgegevens worden opgeslagen. Voorbeelden van dergelijke teksten zijn de kopregel van het webonderdeel, de namen van de tabbladen en de namen van de acties.

Wanneer u een nieuwe groep maakt, moet u een bijschrift voor de groep definiëren. Het bijschrift wordt een optie in het aangepaste eigenschapsveld in het toolsvenster in SharePoint waarin de groepen worden weergegeven waaruit u een webonderdeelverzoek voor uw webonderdeel kunt selecteren.

U moet er echter eerst voor zorgen dat de volgende taak is voltooid:

Voorwaarden

  • Employee Portal-groepen maken

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Een nieuw bijschrift voor een groep maken

  1. Open het venster [image] Bijschriften EP-groepen.

  2. Klik op Bijschrift, Nieuwe maken. Het venster Overzicht EP-talen wordt weergegeven.

  2. Selecteer de taal waarvoor u het bijschrift wilt maken. Klik op OK.

  3. Voer in het veld Bijschrift op de bijschriftregel die u zojuist hebt gemaakt het nieuwe bijschrift in. Sluit het venster.

Een bijschrift aan een groep toevoegen

  1. Open het venster [image] EP-groepskaart.

  2. Selecteer de groep waarvoor u een bijschrift wilt maken.

  3. Klik in het veld Bijschrift op de AssistButton om het venster Overzicht bijschriften EP-groepen weer te geven.

  4. Selecteer het bijschrift dat u voor de groep hebt gemaakt. Klik op OK.

Als u een webonderdeel ontwerpt dat in verschillende talen en door verschillende gebruikers zal worden gebruikt, moet u het bijschrift in elke taal een definitie geven. Meer informatie hierover vindt u in het onderwerp Meerdere talen in Employee Portal.

Verwante onderwerpen

Bijschriften in Employee Portal

Employee Portal-groepen maken

Gebruikers en gebruikersgroepen

Employee Portal-gebruikers aan groepen toevoegen

Meerdere talen in Employee Portal

Webonderdelen voor Employee Portal maken


Employee Portal-gebruikers aan groepen toevoegen

Als er eenmaal een Employee Portal-groep is ingesteld, kunt u gebruikers aan de groep toevoegen.

Een gebruiker aan een groep toevoegen

  1. Open het venster [image] EP-groepskaart.

  2. Selecteer de groep waaraan u een gebruiker wilt toevoegen.

  3. Klik op EP-groepen, Gebruiker. Het venster Overzicht EP-groepen per gebruiker wordt weergegeven.

  4. Selecteer de gebruiker die u aan de groep wilt toevoegen. Sluit het venster.

Verwante onderwerpen

Employee Portal-gebruikers maken

Employee Portal-groepen maken

Gebruikers en gebruikersgroepen


Webonderdelen voor Employee Portal maken

Als u Microsoft Dynamics NAV Employee Portal hebt geïnstalleerd, kunt u webonderdelen definiëren voor het weergeven van de Microsoft Dynamics NAV-gegevens in Microsoft SharePoint-webonderdelen. U doet dit door webonderdeelverzoeken in Microsoft Dynamics NAV te maken. In webonderdeelverzoeken worden de gegevens gedefinieerd die het webonderdeel bij Microsoft Dynamics NAV aanvraagt en wordt aangegeven hoe de gegevens in het webonderdeel worden weergegeven.

Bij het definiëren van webonderdeelverzoeken voert u meerdere taken uit. De taken die u moet uitvoeren voor een volledig functioneel webonderdeelverzoek, worden hieronder weergegeven met koppelingen naar onderwerpen met gedetailleerde beschrijvingen van de taken:

Onderwerp

Opmerking

Sjablonen voor webonderdeelverzoeken maken

Wanneer u een sjabloon ontwerpt, beslist u welke eigenschappen (kenmerken) de webonderdelen krijgen die op die sjabloon zijn gebaseerd. U beslist welke indeling elk webonderdeel krijgt en welke typen gegevens het webonderdeel kan bevatten. U kunt vervolgens vele webonderdelen maken die op dezelfde sjabloon zijn gebaseerd, maar die andere gegevens bevatten.

Groepen maken

Een groep is een reeks verwante webonderdeelverzoeken die beschikbaar is op uw Employee Portal voor gebruikers die u aan deze groep hebt toegewezen.

U kunt een paar algemene groepen instellen die elk alle machtigingen voor een gebruikerstype bevatten of een groep instellen voor elke (deel-) taak die gebruikers moeten kunnen uitvoeren. Vervolgens kunt u de rechten en mogelijkheden van elke gebruiker aanpassen.

Webonderdeelverzoeken maken

In een webonderdeelverzoek worden de inhoud en het gedrag gedefinieerd van het webonderdeel waaraan het verzoek is toegewezen.

Als u eenmaal websjablonen voor uw website hebt ingesteld, kunt u de feitelijke webpagina's voor de portal-pagina maken. In dit onderwerp wordt beschreven hoe u dit doet.

Elk van uw webonderdeelverzoeken is gebaseerd op een sjabloon voor een webonderdeelverzoek. Dit houdt ook in dat u meerdere webonderdeelverzoeken kunt maken op basis van dezelfde sjabloon voor de webonderdeelverzoeken. Deze webpagina's vormen samen uw webportal.

Tabbladen definiëren

Definieer tabbladen voor uw webonderdeelverzoeken. U kunt meerdere tabbladen definiëren voor hetzelfde webonderdeelverzoek om verwante velden te groeperen.

Velden aan webonderdelen toevoegen

Geef aan welke velden van de geselecteerde tabbladen u beschikbaar wilt maken in het webonderdeel en definieer de eigenschappen van de velden.

Acties maken

Als u acties in uw webonderdelen gebruikt, kunt u uw gebruikers de mogelijkheid geven vanuit een webonderdeel te communiceren met Microsoft Dynamics NAV.

U kunt bijvoorbeeld een actie definiëren om een nieuwe regel in een webonderdeel Kop-Regel te maken of een actie definiëren in een webonderdeel Kaart zodat de gegevens kunnen worden bewerkt.

In dit onderwerp wordt beschreven hoe u een actie definieert waarmee binnen het webonderdeel een opdracht wordt gegeven.

Webonderdelen verbinden

U kunt acties ook gebruiken om webonderdelen te verbinden.

Wanneer u twee of meer webonderdelen hebt gemaakt, kan het handig zijn om met acties een verbinding tussen de webonderdelen tot stand te brengen. Op deze manier kunt u bijvoorbeeld een verbinding maken tussen de webonderdelen Lijst en Kaart om gegevens van de elementen in het webonderdeel Lijst weer te geven in het webonderdeel Kaart.

Filters voor webonderdeelverzoeken definiëren

U kunt opgeven welke records in het webonderdeel worden opgenomen door filters in te stellen.

Zoekacties maken

U kunt zoekacties maken vanuit een veld in een webonderdeel naar een veld in een andere tabel om gegevens vanuit die tabel te kopiëren.

Verwante onderwerpen

Meerdere talen in Employee Portal

Gebruikers en groepen

Webonderdeelverzoeken


Webonderdeelverzoeken

In dit overzicht wordt uitgelegd wat een webonderdeelverzoek is en wat de relatie is tussen een sjabloon van een webonderdeelverzoek en een webonderdeelverzoek in Microsoft Dynamics NAV. Ook wordt beschreven wat de relatie is tussen een webonderdeelverzoek in Microsoft Dynamics NAV, de eigenschappen van een webonderdeelverzoek en het webonderdeel in SharePoint.

U definieert de Employee Portal-webonderdelen die u voor uw gebruikers beschikbaar wilt maken in SharePoint door een webonderdeelverzoek in Microsoft Dynamics NAV te maken. In een webonderdeelverzoek worden de indeling van het webonderdeel, de gegevens voor het webonderdeel, de basiseigenschappen van de gegevens en de besturingselementen gedefinieerd die voor de communicatie en navigatie tussen webonderdelen worden gebruikt. Met andere woorden, in het webonderdeelverzoek worden de gegevens gedefinieerd die het webonderdeel bij Microsoft Dynamics NAV aanvraagt en wordt aangegeven hoe de gegevens in het webonderdeel worden weergegeven.

Elk webonderdeelverzoek is gebaseerd op een sjabloon voor een webonderdeelverzoek. Dit houdt in dat u verschillende webonderdeelverzoeken voor verschillende gebruikersgroepen kunt maken op basis van dezelfde websjabloon. Deze webonderdeelverzoeken vormen samen uw Employee Portal.

U kunt webonderdeelverzoeken voor verschillende doeleinden definiëren. U kunt een keuze maken uit een van de volgende drie typen:

  • Lijst (om een lijst met items weer te geven)

  • Kaart (om een record in een kaart weer te geven)

  • Kop-Regel (om een kop met gekoppelde regels weer te geven)

In de tabel Webonderdeelverzoek vindt u een vierde type webonderdeelverzoek, genaamd Systeem. Het webonderdeelverzoek Systeem is door het programma voor bepaalde acties gedefinieerd. Meer informatie over dit type webonderdeelverzoek vindt u in Een actie maken.

Sjablonen voor webonderdeelverzoeken

Een sjabloon in Employee Portal is vergelijkbaar met een sjabloon in een tekstverwerkingsprogramma. Het is een document met opmaak, soms algemene tekst of andere inhoud. Acties voor interactie en navigatie moeten echter nog steeds op de afzonderlijke webonderdeelverzoeken worden ingevuld. U kunt één sjabloon voor een webonderdeelverzoek gebruiken als model voor vele verschillende webonderdeelverzoeken.

Wanneer u een sjabloon ontwerpt, beslist u welke eigenschappen (kenmerken) de onderdelen krijgen die op die sjabloon zijn gebaseerd. U beslist welke indeling elk webonderdeel krijgt en welke typen gegevens het webonderdeel kan bevatten. U kunt vervolgens vele webonderdelen maken die op dezelfde sjabloon zijn gebaseerd, maar die andere gegevens bevatten.

Als u bijvoorbeeld een webonderdeel maakt van het type Lijst, kunt u dezelfde sjabloon als basis gebruiken voor vele webonderdeelverzoeken van het type Lijst. U kunt vervolgens kenmerken aan het webonderdeelverzoek toevoegen om het webonderdeelverzoek Lijst zo te wijzigen dat het aan uw behoeften voldoet. U kunt dit doen door velden en tabbladen toe te voegen of te verwijderen en door acties en zoekacties te definiëren.

Webonderdeelverzoeken

Als u eenmaal sjablonen voor webonderdeelverzoeken voor uw portal-pagina hebt ingesteld, kunt u het afzonderlijke webonderdeelverzoek maken waaruit uw webonderdeel is opgebouwd. Een webonderdeelverzoek moet aan een gebruikersgroep worden toegewezen om het beschikbaar te maken voor de gebruikers die aan de groep zijn toegewezen.

Wanneer u de sjabloon selecteert waarop u uw nieuwe webonderdeelverzoek wilt baseren, worden de eigenschappen van de sjabloon voor het webonderdeelverzoek naar het nieuwe webonderdeelverzoek gekopieerd. Sommige eigenschappen krijgen een standaardwaarde van de sjabloon voor het webonderdeelverzoek, maar u kunt de waarde wijzigen. Definieer besturingselementen in het webonderdeelverzoek, zoals actieknoppen en koppelingen, om interactie en navigatie in de webonderdelen mogelijk te maken. Als u eenmaal de waarden voor de eigenschappen en de besturingselementen hebt ingevuld, is het webonderdeelverzoek voltooid en beschikbaar op uw portal-pagina.

Meerdere talen in webonderdeelverzoeken

Net als voor andere onderdelen van Microsoft Dynamics NAV kunt u ook voor webonderdeelverzoeken meerdere talen gebruiken. Omdat u meerdere talen kunt gebruiken, kunt u de teksten in bijschriften, titels van webonderdelen, tabbladen, acties enzovoort in Employee Portal in meerdere talen weergeven.


Sjablonen voor webonderdeelverzoeken maken

Een sjabloon in Employee Portal is een exemplaar van een webonderdeelverzoek met de basisdefinities van een webonderdeelverzoek. De sjabloon kan worden gebruikt als model voor het maken van vele webonderdeelverzoeken. De sjabloon bevat opmaak van tabellen en tabbladen en soms zoekacties en sorteersleutels. Acties voor interactie en navigatie moeten echter nog steeds op de afzonderlijke webonderdeelverzoeken worden ingevuld.

Webonderdeelsjablonen worden ook gebruikt om acties te definiëren. Als dit het geval is, is het type webonderdeel Systeem.

U moet het type webonderdeelverzoek selecteren om aan te geven hoe de gegevens in het webonderdeel worden weergegeven.

De typen zijn:

  • Lijst (om een lijst met records weer te geven)

  • Kaart (om een record in een kaart weer te geven)

  • Kop-Regel (om een kop met gekoppelde regels weer te geven)

  • Systeem (voor acties). Deze webonderdeelverzoeken zijn vooraf gedefinieerd door het programma en kunnen alleen worden gebruikt voor acties. Zie Een actie maken voor meer informatie over acties.

Een sjabloon voor een webonderdeelverzoek maken

  1. Open het venster [image] Kaart WO-aanvraagsjabloon EP en druk op F3 om een leeg webonderdeelverzoek te maken. Vul alle velden in de kop van het webonderdeelverzoek in. Klik voor Help over een specifiek veld in het veld en druk op F1.

  2. Selecteer in het veld Tabelnr. de relevante tabel.

  3. Geef in het veld Kop of Regel aan aan welke sectie de tabel wordt toegewezen. Als het type webonderdeelverzoek Kaart is, moet u Kop selecteren. Als het type webonderdeelverzoek Overzicht is, moet u Regel selecteren. Als het type webonderdeel Kop-Regel is, moet u twee tabellen toewijzen: één voor de kop en één voor de regels.

Als u een webonderdeel Kop-Regel wilt maken, moet u één tabel voor de regels en één tabel voor de kop maken.

Verwante onderwerpen

Webonderdeelverzoeken

Webonderdelen voor Employee Portal maken

Bijschriften voor sjablonen van webonderdeelverzoeken definiëren

Webonderdeelverzoeken maken


Bijschriften voor sjablonen van webonderdeelverzoeken definiëren

Wanneer u een webonderdeelverzoek maakt, moet u bijschriften definiëren voor de teksten in uw webonderdeel die niet als toepassingsgegevens worden opgeslagen. Voorbeelden van dergelijke teksten zijn de kopregel van het webonderdeel, de namen van de tabbladen en de namen van de acties.

Wanneer u een bijschrift voor een sjabloon van een webonderdeelverzoek definieert, wordt het bijschrift overgenomen door het webonderdeelverzoek dat op de sjabloon is gebaseerd. U kunt het bijschrift dat is overgenomen, wel wijzigen door de onderstaande stappen te nemen.

De bijschriften van de webonderdeelverzoeken zijn opties in het veld in het toolsvenster in SharePoint waarin u een webonderdeelverzoek voor uw webonderdeel kunt selecteren.

Een nieuw bijschrift voor een sjabloon van een webonderdeelverzoek maken

  1. Open het venster [image] Bijschriften WO-aanvraag EP.

  2. Klik op Bijschrift, Nieuwe maken. Het venster Overzicht EP-talen wordt weergegeven.

  2. Selecteer de taal waarvoor u een bijschrift wilt maken. Klik op OK.

  3. Voer in het veld Bijschrift op de bijschriftregel die u zojuist hebt gemaakt het nieuwe bijschrift in. Sluit het venster.

Als u een webonderdeel ontwerpt dat in verschillende talen en door verschillende gebruikers zal worden gebruikt, moet u het bijschrift in elke taal een definitie geven. Meer informatie hierover vindt u in het onderwerp Meerdere talen in Employee Portal.

Een nieuw bijschrift aan een sjabloon van een webonderdeelverzoek toevoegen

  1. Open het venster [image] Kaart webonderdeelaanvraag EP.

  2. Selecteer de sjabloon van het webonderdeelverzoek waarvoor u een bijschrift wilt maken.

  3. Klik in het veld Bijschrift op de AssistButton om het venster Overzicht bijschriften WO-verzoek EP weer te geven.

  4. Selecteer het bijschrift dat u voor de sjabloon van het webonderdeelverzoek hebt gemaakt. Klik op OK.

Verwante onderwerpen

Bijschriften in Employee Portal

Meerdere talen in Employee Portal

Sjablonen voor webonderdeelverzoeken maken

Webonderdeelverzoeken maken


Webonderdeelverzoeken maken

Nadat u uw sjablonen voor webonderdeelverzoeken hebt gemaakt, kunt u ze gebruiken voor de webonderdeelverzoeken die u aan uw gebruikersgroepen wilt toewijzen. U kunt ook zonder sjabloon uw eigen webonderdeelverzoek maken.

U moet het type webonderdeelverzoek selecteren om aan te geven hoe de gegevens in het webonderdeel worden weergegeven.

De typen zijn:

Lijst (om een lijst met records weer te geven)

Kaart (om een record in een kaart weer te geven)

Kop-Regel (om een kop met gekoppelde regels weer te geven)

U moet er echter eerst voor zorgen dat de volgende taken zijn voltooid voor het webonderdeelverzoek waarvoor u een tabblad wilt definiëren:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Een webonderdeelverzoek maken

  1. Open het venster EP-groepskaart.

  2. Druk op de regels op F3 om een nieuw webonderdeelverzoek toe te voegen.

  3. Selecteer in het veld Code de code van de sjabloon van het webonderdeelverzoek waarop u uw webonderdeelverzoek wilt baseren. Klik op Webonderdeelverzoek, Kaart. Het venster Kaart WO-tabel EP wordt weergegeven.

  4. Vul alle velden op de kop van het webonderdeelverzoek in. Het webonderdeelverzoek heeft de meeste gegevens overgenomen, inclusief de tabellen van de sjabloon van het webonderdeelverzoek waarop u het webonderdeelverzoek hebt gebaseerd.

U hebt nu de basisconfiguraties van het webonderdeelverzoek gedefinieerd. U kunt de configuratie van het webonderdeel voltooien door tabbladen en acties te definiëren en de configuratie zo aan te passen dat deze aan uw behoeften voldoet door verbindingen tussen webonderdelen, zoekacties en filters te definiëren.

Verwante onderwerpen

Webonderdeelverzoeken

Sjablonen voor webonderdeelverzoeken maken

Tabbladen definiëren

Acties maken


Tabbladen definiëren

Het besturingselement Tabblad is vergelijkbaar met de scheidingslijnen in een notitieboek of de labels van een groep bestandsmappen. Door gebruik te maken van het besturingselement Tabblad, kunt u meerdere pagina's voor hetzelfde webonderdeelverzoek definiëren om verwante velden te groeperen.

U moet er echter eerst voor zorgen dat de volgende taken zijn voltooid voor het webonderdeelverzoek waarvoor u een tabblad wilt definiëren:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Een tabblad voor een webonderdeel definiëren

  1. Open het venster Kaart webonderdeelverzoek EP.

  2. Selecteer het webonderdeelverzoek waarvoor u een tabblad wilt instellen.

  3. Klik op Tabel, Kaart. Het venster Kaart webonderdeelverzoek EP wordt geopend.

  4. Maak een regel voor het nieuwe tabblad. Vul de velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

Opmerking

Voor elk webonderdeelverzoek moet ten minste één tabblad zijn ingesteld. Als dit niet het geval is, stopt Microsoft Dynamics NAV de verwerking met een toepasselijk bericht in het gebeurtenislogbestand na de ontvangst van een verzoek van de portal-pagina.

Nadat u een tabblad hebt gedefinieerd, kunt u velden aan het tabblad toewijzen en zoekacties definiëren om webonderdelen van de velden op het tabblad weer te geven.

Verwante onderwerpen

Velden aan webonderdelen toevoegen

Zoekacties maken

Sorteersleutels definiëren


Bijschriften voor groepen definiëren

Wanneer u een webonderdeelverzoek maakt, moet u bijschriften definiëren voor de teksten in uw webonderdeel die niet als toepassingsgegevens worden opgeslagen. Voorbeelden van dergelijke teksten zijn de kopregel van het webonderdeel, de namen van de tabbladen en de tekst in de acties.

Wanneer u een actie maakt die in een webonderdeel wordt weergegeven, moet u een bijschrift voor de actie definiëren. Het bijschrift wordt als een koppeling of op een knop in het webonderdeel weergegeven, afhankelijk van de HTML-indeling die u voor de actie hebt gedefinieerd.

Een nieuw bijschrift voor een tabblad maken

  1. Open het venster [image] Bijschriften WO-tabeltabbladen EP.

  2. Klik op Bijschrift, Nieuwe maken. Het venster Overzicht EP-talen wordt weergegeven.

  2. Selecteer de taal waarvoor u het bijschrift wilt maken. Klik op OK.

  3. Voer in het veld Bijschrift op de bijschriftregel die u zojuist hebt gemaakt het nieuwe bijschrift in. Sluit het venster.

Als u een webonderdeel ontwerpt dat in verschillende talen en door verschillende gebruikers zal worden gebruikt, moet u het bijschrift in elke taal een definitie geven. Meer informatie hierover vindt u in het onderwerp Meerdere talen in Employee Portal.

Een bijschrift aan een tabblad toevoegen

  1. Open het venster [image] Kaart webonderdeelaanvraag EP.

  2. Selecteer het webonderdeelverzoek waarvoor u een bijschrift wilt definiëren.

  3. Selecteer de relevante tabel.

  4. Klik op Tabel, Kaart. Het venster Tabel wordt weergegeven.

  5. Selecteer het tabblad waarvoor u het bijschrift wilt definiëren.

  6. Klik in het veld Bijschrift op de AssistButton om het venster Overzicht bijschriften WO-tabbladen EP weer te geven.

  7. Selecteer het bijschrift dat u voor het tabblad hebt gemaakt. Klik op OK.

Verwante onderwerpen

Bijschriften in Employee Portal

Meerdere talen in Employee Portal


Velden aan webonderdelen toevoegen

Wanneer u uw webonderdeelverzoek hebt gemaakt, kunt u elk veld weergeven uit de tabel(len) die u voor het webonderdeelverzoek in uw webonderdeel hebt geselecteerd.

U moet er echter eerst voor zorgen dat de volgende taken zijn voltooid voor het webonderdeelverzoek waaraan u een veld wilt toevoegen:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

  • Tabbladen definiëren

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Een veld aan een webonderdeel toevoegen

  1. Open het venster Kaart webonderdeelverzoek EP.

  2. Selecteer het relevante tabblad. Klik op Tabblad. Het venster Kaart webonderdeelverzoek EP wordt weergegeven.

  3. Maak een regel voor elk veld dat u in het webonderdeel wilt weergeven.

  4. Voer in het veld Veldnr. het nummer in van het veld dat u aan het webonderdeel wilt toevoegen. Vul de resterende velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

Opmerking

Voor elk webonderdeelverzoek moet ten minste één veld aan elk tabblad zijn toegevoegd. Als dit niet het geval is, stopt Microsoft Dynamics NAV de verwerking met een toepasselijk bericht op de portal-pagina.

Verwante onderwerpen

Zoekacties maken

Sorteersleutels definiëren


Acties maken

In Employee Portal worden acties gebruikt om opdrachten vanuit uw webonderdelen uit te voeren. U kunt bijvoorbeeld een actie definiëren om een nieuwe regel te maken in een webonderdeel Kop-Regel of u kunt een actie definiëren in het webonderdeel Lijst om de record in een webonderdeel Kaart te openen. Door gebruik te maken van acties in uw webonderdelen, kunnen uw gebruikers met de gegevens communiceren en tussen webonderdelen navigeren.

In dit onderwerp wordt beschreven hoe u een actie definieert waarmee binnen het webonderdeel een opdracht wordt gegeven. In het onderwerp Webonderdelen verbinden leest u meer over het definiëren van acties voor het verbinden van webonderdelen.

Voordat u een actie definieert, moet u er echter eerst voor zorgen dat de volgende taken zijn voltooid voor het webonderdeelverzoek waarvoor u een actie wilt maken:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Een actie maken

  1. Open het venster Kaart webonderdeelverzoek EP.

  2. Selecteer het webonderdeelverzoek waarvoor u een actie wilt definiëren.

  3. Selecteer de relevante tabel.

  4. Klik op Tabel, Kaart. Het venster Tabel wordt weergegeven.

  5. Klik op Tabel, Acties. Het venster Overzicht acties WO-tabel EP wordt weergegeven. Klik op F3 om een nieuwe regel te maken.

  6. Selecteer in het veld Type de relevante actie. Selecteer Huidige in het veld Doel. Vul de resterende velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

Afbeeldingen in acties

Wanneer u acties voor het webonderdeel Kaart maakt, kunt u de SharePoint-stijl hanteren door een afbeelding voor de actie te definiëren. U kunt hiervoor de afbeeldingen gebruiken die in SharePoint beschikbaar zijn. U kunt naar ze verwijzen en ze gebruiken in uw webonderdelen.

Verwante onderwerpen

SharePoint-afbeeldingen aan acties toevoegen

Bijschriften voor acties definiëren

Lijsten van webonderdelen uitvoeren

Webonderdelen verbinden


Bijschriften voor acties definiëren

Wanneer u een webonderdeelverzoek maakt, moet u bijschriften definiëren voor de teksten in uw webonderdeel die niet als toepassingsgegevens worden opgeslagen. Voorbeelden van dergelijke teksten zijn de kopregel van het webonderdeel, de namen van de tabbladen en de tekst in de acties.

Wanneer u een actie maakt die in een webonderdeel wordt weergegeven, moet u een bijschrift voor de actie definiëren. Het bijschrift wordt als een koppeling of op een knop in het webonderdeel weergegeven, afhankelijk van de HTML-indeling die u voor de actie hebt gedefinieerd.

Een nieuw bijschrift voor een actie maken

  1. Open het venster [image] Bijschriften WO-acties EP.

  2. Klik op Bijschrift, Nieuwe maken. Het venster Overzicht EP-talen wordt weergegeven.

  3. Selecteer de taal waarvoor u het bijschrift wilt maken. Klik op OK.

  4. Voer in het veld Bijschrift op de bijschriftregel die u zojuist hebt gemaakt het nieuwe bijschrift in. Sluit het venster.

Als u een webonderdeel ontwerpt dat in verschillende talen en door verschillende gebruikers zal worden gebruikt, moet u het bijschrift in elke taal een definitie geven. Meer informatie hierover vindt u in het onderwerp Meerdere talen in Employee Portal.

Een bijschrift aan een actie toevoegen

  1. Open het venster [image] Kaart webonderdeelaanvraag EP.

  2. Selecteer het webonderdeelverzoek waarvoor u een bijschrift wilt definiëren.

  3. Selecteer de relevante tabel.

  4. Klik op Tabel, Kaart. Het venster Tabel wordt weergegeven.

  5. Klik op Tabel, Acties. Het venster Overzicht acties WO-tabel EP wordt weergegeven. Selecteer de actie waarvoor u een bijschrift wilt definiëren.

  6. Klik in het veld Bijschrift op de AssistButton om het venster Overzicht bijschriften WO-acties EP weer te geven.

  7. Selecteer het bijschrift dat u voor de sjabloon van het webonderdeelverzoek hebt gemaakt. Klik op OK.

Verwante onderwerpen

Bijschriften in Employee Portal

Acties maken

Meerdere talen in Employee Portal


SharePoint-afbeeldingen aan acties toevoegen

Wanneer u acties maakt voor webonderdeelverzoeken, kunt u uw actie er net zo uit laten zien als SharePoint-acties door een afbeelding voor de actie te definiëren. U kunt hiervoor de afbeeldingen gebruiken die in SharePoint beschikbaar zijn. U kunt naar ze verwijzen en ze gebruiken in uw webonderdelen.

Voordat u een afbeelding aan een actie toevoegt, moet u er echter eerst voor zorgen dat de volgende taken zijn voltooid voor het webonderdeelverzoek waaraan u een afbeelding wilt toevoegen:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

  • Acties maken

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Naar een afbeelding verwijzen

  1. Open het venster Overzicht pad SharePoint-systeemkopie EP.

  2. Voer in het veld Code een code voor het afbeeldingspad in.

  3. Voer in het veld Pad het SharePoint-pad in naar de locatie waar de afbeelding is opgeslagen waarnaar u wilt verwijzen.

Een afbeelding aan een actie toevoegen

  1. Open het venster Kaart webonderdeelverzoek EP.

  2. Selecteer het webonderdeelverzoek waarvoor u een afbeelding wilt definiëren.

  3. Selecteer de relevante tabel.

  4. Klik op Tabel, Kaart. Het venster Tabel wordt weergegeven.

  5. Klik op Tabel, Acties. Het venster Overzicht acties WO-tabel EP wordt weergegeven. Selecteer de actie waaraan u een afbeelding wilt toevoegen.

  6. Selecteer in het veld Afbeeldingcode de code voor de afbeelding die u aan de actie wilt toevoegen.

Verwante onderwerpen

Acties maken

Webonderdelen voor Employee Portal maken

Webonderdeelverzoeken


Filters voor webonderdeelverzoeken definiëren

Wanneer u een webonderdeelverzoek hebt gemaakt, kunt u een filter definiëren om specifieke gegevens te selecteren die in het webonderdeel worden weergegeven. Voor een webonderdeel Lijst met daarin al uw klanten kunt u bijvoorbeeld een filter definiëren waarmee alleen klanten uit een bepaalde regio of een bepaald land worden opgenomen.

Voordat u een filter maakt, moet u er echter eerst voor zorgen dat de volgende taken zijn voltooid voor het webonderdeelverzoek waarvoor u een filter wilt maken:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Filters aan webonderdeelverzoeken toevoegen

  1. Open het venster Kaart WO-tabel EP.

  2. Selecteer de tabel waarop u wilt filteren.

  3. Klik op Tabel, Standaardfilter, Velden. Het venster Overzicht filtervelden WO-tabel EP wordt weergegeven.

  4. Voer in het veld Filterveld het nummer in van het veld waarop u wilt filteren.

  5. Vul de resterende velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

Opmerking

Het filter wordt pas actief wanneer het venster wordt gesloten.

Verwante onderwerpen

Webonderdelen voor Employee Portal maken

Webonderdeelverzoeken

Bijschriften voor groepen definiëren


Sorteersleutels definiëren

Wanneer u een webonderdeelverzoek hebt gemaakt voor het webonderdeel Lijst, kunt u sorteersleutels definiëren om te bepalen in welke volgorde de records worden weergegeven.

Een sorteersleutel voor een webonderdeel definiëren

  1. Open het venster [image] Kaart webonderdeelaanvraag EP.

  2. Selecteer het webonderdeelverzoek waarvoor u een tabblad wilt instellen.

  3. Klik op Tabel, Kaart. Het venster Kaart WO-tabel EP wordt geopend.

  4. Klik op Tabblad, Kaart. Het venster Kaart WO-tabeltabblad EP wordt geopend.

  5. Klik op Veld, Sorteersleutels. Het venster Overzicht sorteersleutels WO-tabel wordt geopend.

  6. Klik op Sorteersleutel, Sleutel ophalen. Het venster Tijdel. EP-tabelsleutels wordt geopend.

  7. Selecteer een sorteersleutel. De opties in het venster Keys for Table Customer worden gedefinieerd door het systeem en kunnen niet worden gewijzigd. Sluit de vensters.

Opmerking

Sorteersleutels zijn niet van invloed op de webonderdeelverzoeken Kaart of Kop-Regel.

Verwante onderwerpen

Velden aan webonderdelen toevoegen


Webonderdelen verbinden

Wanneer u een webonderdeel Lijst of Kop-Regel hebt gemaakt, kan het erg handig zijn om de details van een record op de regels in een webonderdeel Kaart weer te geven. U kunt dit doen door een actie te gebruiken om de twee webonderdelen te verbinden. Op deze manier kunt u bijvoorbeeld een verbinding maken tussen een lijst met klanten en een klantenkaart met de details over de geselecteerde klant.

U moet er echter eerst voor zorgen dat de volgende taken zijn voltooid voor de webonderdeelverzoeken waartussen u een verbinding wilt maken:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

  • Tabbladen definiëren

  • Velden aan webonderdelen toevoegen

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Twee webonderdelen verbinden

  1. Open het venster Kaart webonderdeelverzoek EP.

  2. Selecteer het webonderdeelverzoek van waaruit u een verbinding wilt maken. Selecteer de relevante tabel. Als het webonderdeelverzoek van het type Kop-Regel is, moet dit de tabel zijn die voor de regels is gedefinieerd.

  3. Klik op Tabel, Kaart. Het venster Kaart WO-tabel EP wordt geopend.

  4. Klik op Tabel, Acties. Het venster Overzicht acties WO-tabel EP wordt weergegeven. Klik op F3 om een nieuwe regel te maken.

  5. Selecteer in het veld Type de optie Verbinden met ander WO-verzoek. Selecteer in het veld WO-verzoeksoort (Doel) de optie Overige. Vul de resterende velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

  6. Klik op Acties, Verbinding tussen WO-verzoeken, Velden. Het venster Overzicht filtervelden WO-acties EP wordt geopend.

  7. Vul de velden in. Sluit het venster.

U moet nu naar uw webonderdelen op de portal-pagina gaan.

  1. Klik op Gedeelde pagina wijzigen, Deze pagina ontwerpen.

  2. Klik op de driehoek in de rechterbovenhoek van het webonderdeel waarvandaan u een verbinding wilt maken. Klik op Verbindingen, Provide Parameters To en selecteer het webonderdeel waarmee u verbinding wilt maken. De verbinding wordt nu tot stand gebracht.

Verwante onderwerpen

Een actie maken

Meerdere talen in Employee Portal


Zoekacties maken

In Microsoft Dynamics NAV kunt u gegevens kopiëren van de ene tabel naar de andere tabel door een zoekactie in een veld te maken. U kunt hetzelfde doen in uw webonderdelen in Employee Portal.

U moet er echter eerst voor zorgen dat de volgende taken zijn voltooid voor zowel het webonderdeelverzoek van waaruit u een zoekactie wilt maken als voor het webonderdeelverzoek dat u als doel hebt opgegeven:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

  • Tabbladen definiëren

  • Velden aan webonderdelen toevoegen

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Een zoekactie voor een veld maken

  1. Open het venster [image] Kaart webonderdeelaanvraag EP.

  2. Selecteer het webonderdeelverzoek van waaruit u een zoekactie wilt maken. Selecteer de relevante tabel.

  3. Klik op Tabel, Kaart. Het venster Tabel wordt weergegeven. Selecteer het relevante tabblad.

  4. Klik op Tabel, Kaart. Het venster Kaart WO-tabeltabblad EP wordt weergegeven. Selecteer het veld van waaruit u een zoekactie wilt maken.

  5. Klik op Veld, Zoekacties. Het venster Overzicht WO-zoekvelden EP wordt weergegeven.

  6. Vul de velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

  7. Klik op Opzoeken, Condities. Het venster Condities WO-zoekvelden EP wordt geopend. Vul de velden in.

  8. Klik op Opzoeken, Veldkoppelingen. Het venster Koppelingen WO-zoekvelden EP wordt geopend. Definieer de doel- en bronvelden.

Verwante onderwerpen

Meerdere talen in Employee Portal

Velden aan webonderdelen toevoegen

Webonderdeelverzoeken


Zoekconfiguraties definiëren

Wanneer uw Employee Portal-gebruikers aan hun portal-pagina werken, moeten ze mogelijk naar verschillende records in Microsoft Dynamics NAV zoeken. U kunt zoekconfiguraties voor tabellen definiëren om ze voor gebruikers beschikbaar te maken zodat ze in deze tabellen kunnen zoeken. In een zoekconfiguratie wordt gedefinieerd op welke velden de gebruiker kan zoeken en welke velden in de zoekresultaten worden weergegeven.

Een tabel toevoegen aan het overzicht van tabellen waarin moet worden gezocht

  1. Open het venster [image] Zoekconfiguratie EP.

  2. Druk op F3 om een nieuwe zoekconfiguratie toe te voegen.

  3. Vul de velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

  4. Klik op Configuratie, Zoekvelden. Het venster Overzicht EP-zoekvelden wordt weergegeven.

  5. Definieer de velden waarin u wilt dat gebruikers kunnen zoeken in de geselecteerde tabel. Sluit het venster.

  6. Klik op Configuratie, Weergavevelden. Het venster Overzicht zoek-/weergavevelden EP wordt weergegeven.

  7. Definieer de velden die u in de zoekresultaten wilt opnemen. Sluit het venster.

Herhaal de bovenstaande stap voor elke tabel waarin u wilt dat gebruikers kunnen zoeken.

Nadat u de zoekconfiguraties hebt gedefinieerd, zijn ze beschikbaar voor de configuratie van het webonderdeel Zoeken.

Verwante onderwerpen

Zoekconfiguraties aan gebruikers toevoegen


Zoekconfiguraties aan gebruikers toevoegen

Als u de zoekconfiguratie voor een tabel hebt gedefinieerd, kunt u de zoekconfiguratie aan de gebruiker toewijzen.

Een gebruiker aan een zoekactie toevoegen

  1. Open het venster [image] EP-gebruikers.

  2. Selecteer de gebruiker aan wie u een zoekconfiguratie wilt toewijzen.

  3. Klik op Gebruiker, Zoekconfiguratie. Het venster Zoekconfiguratie EP wordt weergegeven.

  4. Druk op F3 om een nieuwe zoekconfiguratie toe te voegen.

  5. Klik in het veld Tabelnr. op de AssistButton. Het venster Overzicht zoektabellen EP wordt weergegeven.

  6. Selecteer de tabel waarin u wilt dat de gebruiker kan zoeken.

  7. Vul de resterende velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

Verwante onderwerpen

Zoekconfiguraties definiëren

Employee Portal-groepen maken

Gebruikers en gebruikersgroepen


Lijsten van webonderdelen uitvoeren

U kunt uw Microsoft Dynamics NAV-lijsten vanuit uw webonderdelen uitvoeren door een actie voor dit doel te definiëren.

U kunt acties voor het weergeven van lijsten definiëren voor de webonderdelen Kaart, Lijst en Kop-Regel.

Voordat u een actie kunt definiëren om een lijst uit te voeren, moet u ervoor zorgen dat de lijst in de code-eenheid 6828 EP Report Mgt is gedeclareerd. Meer informatie hierover vindt u in de handleiding Installation & System Management: Microsoft Dynamics NAV Employee Portal.

Voordat u acties definieert, moet u er bovendien voor zorgen dat de volgende taken zijn voltooid voor het webonderdeelverzoek waarvoor u een actie wilt maken:

Voorwaarden

  • Sjablonen voor webonderdeelverzoeken maken

  • Employee Portal-groepen maken

  • Webonderdeelverzoeken maken

  • Tabbladen definiëren

  • Velden aan webonderdelen toevoegen

In het onderwerp Webonderdelen voor Employee Portal maken vindt u een overzicht van alle taken die u moet voltooien om een webonderdeel te maken.

Een actie maken voor het uitvoeren van een lijst

  1. Open het venster Kaart webonderdeelverzoek EP.

  2. Selecteer het webonderdeelverzoek waarvoor u een actie wilt definiëren.

  3. Selecteer de relevante tabel.

  4. Klik op Tabel, Kaart. Het venster Tabel wordt weergegeven.

  5. Klik op Tabel, Acties. Het venster Overzicht acties WO-tabel EP wordt weergegeven. Klik op F3 om een nieuwe regel te maken.

  6. Selecteer in het veld Type de optie Lijst tonen en in het veld Doel de optie Huidige. Voer in het veld Lijst-id de id van de lijst in die u beschikbaar wilt maken vanuit uw webonderdeel. Vul de resterende velden in. Klik voor Help over een specifiek veld in het veld en druk op F1.

Afbeeldingen in acties

Wanneer u acties voor het webonderdeel Kaart maakt, kunt u de SharePoint-stijl hanteren door een afbeelding voor de actie te definiëren. U kunt hiervoor de afbeeldingen gebruiken die in SharePoint beschikbaar zijn. U kunt naar ze verwijzen en ze gebruiken in uw webonderdelen.

Verwante onderwerpen

Bijschriften voor acties definiëren

Acties maken


Meerdere talen in Employee Portal

Net als in de andere onderdelen van Microsoft Dynamics NAV, kunt u ook in Employee Portal meerdere talen gebruiken. Dit houdt in dat een gelokaliseerde versie van Microsoft Dynamics NAV in verschillende talen in uw webonderdelen kan worden weergegeven.

Omdat u meerdere talen kunt gebruiken, kunt u de teksten die in bijschriften voor tekstvakken worden weergegeven, in meerdere talen aanbieden. U kunt echter ook meerdere talen opgeven voor de bijschriften die u voor opdrachtknoppen, menu's enzovoort definieert.

Het wijzigen van de teksten die als toepassingsgegevens worden opgeslagen, vormt geen onderdeel van de functie voor meerdere talen. Dit heeft te maken met het ontwerp van de toepassing. Voorbeelden van dergelijke teksten zijn de namen van artikelen in de voorraad of de opmerkingen voor een klant. Deze typen tekst worden niet vertaald.

In Employee Portal kunt u meerdere talen instellen voor de volgende elementen:

  • Groepen

  • Webonderdeelverzoeken

  • Tabbladen

  • Acties

  • EP-instellingen

Als u een webonderdeel ontwerpt dat in verschillende talen en door verschillende gebruikers zal worden gebruikt, moet u het element in elke taal een definitie geven.

Wanneer u het venster Overzicht bijschriften EP-groepen opent, bevat het veld Bijschrift-id het getal dat door het programma aan de definitie voor meerdere talen is toegewezen. Het veld Taal-id bevat de code voor de taal die u op uw computer gebruikt en het veld Bijschrift bevat de waarde die in het webonderdeel wordt weergegeven.

Meerdere talen aan een bijschrift toevoegen

  1. Open de lijst Bijschrift van het element waaraan u een bijschrift voor meerdere talen wilt toevoegen. Bijvoorbeeld het venster [image] Bijschriften EP-groepen.

  2. Klik op Bijschrift, Nieuwe taal voor huidige regel maken. Het venster Overzicht EP-talen wordt weergegeven.

  3. Selecteer de nieuwe taal waarvoor u het bijschrift wilt maken. Klik op OK.

  4. Voer in het veld Bijschrift op de bijschriftregel die u zojuist hebt gemaakt het nieuwe bijschrift in. Sluit het venster.

Een taal definiëren

De taalkeuze voor een gebruiker kan op gebruikers- of groepsniveau worden geconfigureerd. Als u een taal in het veld Taal-id in de tabel EP User definieert, worden de webonderdelen in de gedefinieerde taal weergegeven. Als u alleen een taal in het veld Taal-id in de tabel Employee Portal Group definieert, is dit de taal waarin de webonderdelen worden weergegeven.

Als u geen waarde invoert in het veld Taal-id in de tabel Employee Portal Group en in het veld Taal-id in de tabel EP User, worden de webonderdelen in de standaardtaal van uw Microsoft Dynamics NAV Application Server weergegeven.

U kunt alleen de talen selecteren waarvoor u een licentie hebt.