About Extended Standard Sales Code

For some customers, companies send sales invoices with similar information. Often these documents contain one single invoice line, which is practically always to be posted on the same account, and which contains the same amount.

In order to facilitate sales document entry, the standard sales codes have been introduced in Microsoft Dynamics™ NAV . Standard sales codes allow you to setup sales lines to be used regularly. You can setup any number of standard sales codes, and each of them can consist of any number of standard sales lines.

You can let the program insert standard sales lines in different ways. You can specify this in the field Insert Std. Cust. Sales Lines on the Sales & Receivables Setup window.

Depending on the method you have selected in the field Insert Std. Cust. Sales Lines, you have the possibility to decide on which sales window you want to activate this functionality. Place a check mark in the fields Quotes, Orders, Invoices and Credit Memos on the Sales & Receivables Setup window, if you want to insert standard sales lines on respectively sales quotes, sales orders, sales invoices or sales credit memos.


About Extended Standard Purchase Code

For some vendors, companies receive purchase invoices with similar information. Often these documents contain one single invoice line, which is practically always to be posted on the same account, and which contains the same amount. For example; the rent for the company building.

In order to facilitate purchase document entry, the standard purchase codes have been introduced in Microsoft Dynamics™ NAV. Standard purchase codes allow you to setup purchase lines to be used regularly. You can setup any number of standard purchase codes, and each of them can consist of any number of standard purchase lines.

You can let the program insert standard purchase lines in different ways. You can specify this in the field Insert Std. Vend. Purch. Lines on the Purchases & Payables Setup window.

Depending on the method you have selected in the field Insert Std. Vend. Purch. Lines, you have the possibility to decide on which purchase window you want to activate this functionality. Place a check mark in the fields Quotes, Orders, Invoices and Credit Memos on the Purchases & Payables Setup window, if you want to insert standard purchase lines on respectively purchase quotes, purchase orders, purchase invoices or purchase credit memos.


Sales & Receivables Setup (window)

You use the Sales & Receivables Setup window to set up certain basic rules to be used in the Sales & Receivables application area.

On the General tab, you specify options such as how you want to calculate and post discounts and what warnings you would like to have displayed.

On the Numbering tab, you must specify the number series that will be used for customers, sales documents, reminders, and so on.

On the Std. Customer Sales Codes tab you must specify how you want to use the standard sales codes in the application.

Related Tasks

More Information


Purchases & Payables Setup (window)

You use the Purchases & Payables Setup window to specify how you want the program to manage certain aspects of your purchases & payables.

On the General tab you specify options such as how you want to calculate and post discounts and whether you want to round invoices.

On the Numbering tab you must specify the number series that will be used for vendors, purchase documents, and so on.

On the Std. Vendor Purchase Codes tab you must specify how you want to use the standard purchase codes in the application.

Related Tasks

More Information


Insert Std. Cust. Sales Lines, Sales & Receivables Setup (table)

Insert Std. Cust. Sales Lines Field

The Sales & Receivables Setup Table

Here you can specify how you want to use standard sales codes in Microsoft Dynamics™ NAV . You can assign standard sales codes to customers. Later, when you set up a sales document for a customer to which you assigned a standard sales code, you can let the program insert standard sales lines in different ways. Determine the method by clicking the AssistButton to the right of the field and selecting one of the three options:

  • Manual
  • Automatic
  • Always Ask

If you select Manual, the program will not automatically insert standard sales lines on sales documents that you create for a customer. In that case, you must use the Get Std. Cust. Sales Codes function to insert the standard sales lines that you set up for that customer.

If you select Automatic, the program will automatically insert standard sales lines on sales documents that you create for a customer. If you have set up more than one standard sales code for a customer, a window with all the existing codes for that customer will appear from which you can select the code you want to use. If no codes are set up, nothing will happen.

If you select Always Ask, the program will always show a window with all the existing standard sales codes that you set up for the customer. If no codes are set up, nothing will happen.

No matter which method you choose here, you can always change the information that is inserted on the lines afterwards.


Quotes, Sales & Receivables Setup (table)

Quotes Field

The Sales & Receivables Setup Table

Place a check mark in this field if you want to insert standard sales lines on sales quotes, based on the method you selected in the Insert Std. Cust. Sales Lines field.


Orders, Sales & Receivables Setup (table)

Orders Field

The Sales & Receivables Setup Table

Place a check mark in this field if you want to insert standard sales lines on sales orders, based on the method you selected in the Insert Std. Cust. Sales Lines field.


Invoices, Sales & Receivables Setup (table)

Invoices Field

The Sales & Receivables Setup Table

Place a check mark in this field if you want to insert standard sales lines on sales invoices, based on the method you selected in the Insert Std. Cust. Sales Lines field.


Credit Memos, Sales & Receivables Setup (table)

Credit Memos Field

The Sales & Receivables Setup Table

Place a check mark in this field if you want to insert standard sales lines on sales credit memos, based on the method you selected in the Insert Std. Cust. Sales Lines field


Insert Std. Vend. Purch. Lines, Purchases & Payables Setup (table)

Insert Std. Vend. Purch. Lines Field

The Purchases & Payables Setup Table

Here you can specify how you want to use standard purchase codes in Microsoft Dynamics™ NAV . You can assign standard purchase codes to vendors. Later, when you set up a purchase document for a vendor to which you assigned a standard purchase code, you can let the program insert standard purchase lines in different ways. Determine the method by clicking the AssistButton to the right of the field and selecting one of the three options:

  • Manual
  • Automatic
  • Always Ask

If you select Manual, the program will not automatically insert standard purchase lines on purchase documents that you create for a vendor. In that case, you must use the Get Std. Vend. Purchase Codes function to insert the standard purchase lines that you set up for that vendor.

If you select Automatic, the program will automatically insert standard purchase lines on purchase documents that you create for a vendor. If you have set up more than one standard purchase code for a vendor, a window with all the existing codes for that vendor will appear from which you can select the code you want to use. If no codes are set up, nothing will happen.

If you select Always Ask, the program will always show a window with all the existing standard purchase codes that you set up for the vendor. If no codes are set up, nothing will happen.

No matter which method you choose here, you can always change the information that is inserted on the lines afterwards.


Quotes, Purchases & Payables Setup (table)

Quotes Field

The Purchases & Payables Setup Table

Place a check mark in this field if you want to insert standard purchase lines on purchase quotes, based on the method you selected in the Insert Std. Vend. Purch. Lines field.


Orders, Purchases & Payables Setup (table)

Orders Field

The Purchases & Payables Setup Table

Place a check mark in this field if you want to insert standard purchase lines on purchase orders, based on the method you selected in the Insert Std. Vend. Purch. Lines field.


Invoices, Purchases & Payables Setup (table)

Invoices Field

The Purchases & Payables Setup Table

Place a check mark in this field if you want to insert standard purchase lines on purchase invoices, based on the method you selected in the Insert Std. Vend. Purch. Lines field.


Credit Memos, Purchases & Payables Setup (table)

Credit Memos Field

The Purchases & Payables Setup Table

Place a check mark in this field if you want to insert standard purchase lines on purchase credit memos, based on the method you selected in the Insert Std. Vend. Purch. Lines field.