EP Appln. Server Setup (table)

List of Fields in the Table

In the Employee Portal Appln. Server Setup table, you can specify how you want the application server to handle the communication between Microsoft Dynamics NAV and SharePoint.

Before you begin working with Employee Portal, you specify the application server and the queues for the front end and the trusted sites that will be used for the communication.


Employee Portal Setup (table)

List of Fields in the Table

This table contains the caption you have defined for the custom property fields in the SharePoint tool pane. The custom properties are the properties that have been created to introduce Employee Portal functionality to the Web Part. The custom property fields are the applying fields. The custom property fields are specific for Microsoft Dynamics NAV and the captions for these fields need to be defined in the EP Setup Card in Microsoft Dynamics NAV.


EP Group (table)

List of Fields in the Table

In the Employee Portal Group table you group your Web Part Requests to make them available to your users of Employee Portal.

You can group your Web Part Requests in any way you find convenient – for example, make a group that contains all the Web Part Requests that you will use when you contact your customer.

You can enter captions for each group to make the appropriate language available to the user.


EP Caption (table)

List of Fields in the Table

All captions for the Employee Portal which can not be extracted from the existing Microsoft Dynamics NAV object captions are stored in this table. These captions are displayed on the portal page depending on the configured language for the user or group. All captions for groups, actions, web part requests, tabs and web part properties have to be created in this table.


EP Group/User (table)

List of Fields in the Table

This table contains the users you have created for you Employee Portal.

Before you can create Employee Portal users in Microsoft Dynamics NAV, you have to create and configure the users as Windows users and as SharePoint Server users.


EP Search Configuration (table)

List of Fields in the Table

This table contains the search configuration defined for the tables that the users are able to search in. The configuration defines what fields the user can search on and which fields will be shown in the search result.


EP Search Display Field (table)

List of Fields in the Table

This table contains the fields that will be listed in the search result.

You can configure the lists to contain up to five fields. The fields will be listed in the result area of the search web part.


EP Search Field (table)

List of Fields in the Table

This table contains the fields of the configured tables in which a search can be performed.


EP Search Result (table)

List of Fields in the Table

This table is only used internally by the program to store the search results temporarily. After the result is shown, all data are deleted in the table.


EP Search Table (table)

List of Fields in the Table

This table contains the tables you have configured for the users to search in.


EP SharePoint Image Path (table)

List of Fields in the Table

This table contains the path to the images you have defined in your Web Part Requests. The images that are stored in the relative image path of SharePoint can be assigned to the actions in Microsoft Dynamics NAV to appear next to the action in the Web Part.


EP Temporary Filter (table)

List of Fields in the Table

This table is used internally by the program.

When a request to modify some data in the application is received from the front end, the information about the request is stored in this table to be used for the response to the front end.


EP Trusted Site (table)

List of Fields in the Table

This table contains the sites that are in the process of being acknowledged as a trusted sites or has been acknowledged as trusted sites.

When using Secure Communication (which means encrypted communication by using certificates), each front end portal has to be trusted in the back end.

The front end service creates a so called Trust Request and sends it to Microsoft Dynamics NAV. In Microsoft Dynamics NAV the administrator has to accept this request and send a reply.

Afterwards the communication can be encrypted by using the certificates.


EP User (table)

List of Fields in the Table

The User table contains the users who are going to use Employee Portal to access Microsoft Dynamics NAV. You can also use this table to define a language ID for the user.


EP User Login (table)

List of Fields in the Table

This table is only used temporarly to get access to the already existing windows user logins in the Microsoft Dynamics NAV database security configuration when you configure new user accounts for Employee Portal.


EP Web Part Request (table)

List of Fields in the Table

The EP Web Part Request table is used to record all information about your Web Part Request templates and your Web Part Requests.

A Web Part Request defines the format of the Web Part, the data that it will present, the basic properties of the data and the control elements that will be used for interaction and to navigate between Web Parts. Each of your Web Part Requests is based on a Web Part Request template. This also means that you can create different Web Part Requests for different user groups but based on the same Web template. These Web Part Requests will make up your Employee Portal.

A template can be used in any Employee Portal group, whereas a Web Part request belongs to one Employee Portal group and can only be used with that group.


EP WP Request Tab Field (table)

List of Fields in the Table

In the Employee Portal Field table you can define the fields you want to be available to the users on your Web Part. The fields that are available are identical to the fields that are included in the table you have selected in the EP WP Request Table Tab table.


EP WP Request Table (table)

List of Fields in the Table

This table is used to connect the table to the Web Part Request and the basic definitions of the Web Part Request.


EP WP Request Table Action (table)

List of Fields in the Table

The EP WP Request Table Action table contains all the actions you have set op for your Web Part Requests and information about how they will behave in the Web Part.


EP WP Request Table Sort Key (table)

List of Fields in the Table

This table contains all the sort keys that you have defined for your tables. Sort keys can only be defined for list Web Parts.


EP WP Request Table Tab (table)

List of Fields in the Table

In the EP WP Request Table Tab table you can define the appearance of the tabs you want to be available to the users.


EP WPR Field Lookup (table)

List of Fields in the Table

This table contains the lookups you have defined the Web Part Request.

You can only make a lookup to a list Web Part Request, and only to one that is assigned to the same group as the Web Part Request you make the lookup from.


EP WPR Field Lookup Condition (table)

List of Fields in the Table

This table contains the conditions for the lookups which have been configured for a field. The program compares the value in the Field Value field with the value in the field you have defined in the Field No. field in the source table. The first comparison where the values are identical will cause the front end to request this lookup request.


EP WPR Field Lookup Mapping (table)

List of Fields in the Table

This table contains the mapping between the current Web Part and the Web Part you have defined a lookup to. You can define from which field in the current Web Part you want to make the lookup and to which field in the other Web Part you want to map it.


EP WPR Header Create Criterion (table)

List of Fields in the Table

This table contains all the default values for actions based on the system Web Part Request INSERTHEAD. The system Web Part Request INSERTHEAD will give you the basic values, but you can define an extra criterion by setting a default value. For example, if you want the action to create a new sales quote in the Sales Header table, you need to enter 1 in the Field No. field for Document Type and enter 1 in the Default Value field for sales quote.

The rest of the field in the EP WPR Header Create Criterion table is filled in automatically by the program when you define the criterion.


EP WPR Header/Line Connection (table)

List of Fields in the Table

The EP WPR Head/Line Connection table contains all the connections you have defined between the header and the line section for the header + line Web Parts. They can be real database references or they can contain criteria to narrow down the records shown.


EP WPR Table Action Filter (table)

List of Fields in the Table

The EP WPR Table Action Filter table contains all the filters configured for actions calling other Web Part Request. In the EP WPR Table Action Filter table you can both use value from the calling Web Part Request and fixed values that are not a part of the calling Web Part Request. For example, to filter on document type.


EP WPR Table Edit Criterion (table)

List of Fields in the Table

This table contains criteria for records that can be edited by the user.


EP WPR Table Filter Field (table)

List of Fields in the Table

This table contains the filters you have defined for your Web Part Requests.

You use the filter field to ensure that a Web Part displays only the records that meet certain conditions. For example, you can specify that the collection of customer cards that will be displayed will include only those with Peter Schmidt in the Salesperson Code field.


EP WPR Table Filter Key (table)

List of Fields in the Table

This table contains the key fields you can set for the filter fields. Setting keys on filter fields will optimize the performance, especially if you are using the SQL server option and you have many records in your database.

All fields in this table are filled in automatically by the program, when you select a key in the EP WP Table Filter Field List window.


EP Language List (window)

The EP Language List contains the languages that you can select for your users. The languages are used for the captions of the different elements of the Web Parts. For example, tab names, action names and Web Part names. You can define languages for your users on user or group levels.

You can only select languages for which you have licenses.

Related Tasks

More Information


Search Limit, Employee Portal Setup (table)

Search Limit Field

The Employee Portal Setup Table

Enter the maximum number of records you want to list on each tab in a search result.


Back End Public Key, Employee Portal Setup (table)

Back End Public Key Field

The Employee Portal Setup Table

This field contains the public key used for encrypted messages. The key has been created by the program.


Back End Private Key, Employee Portal Setup (table)

Back End Private Key Field

The Employee Portal Setup Table

This field contains the private key used for encrypted messages. The key has been created by the program.


Write Debugging Info., Employee Portal Setup (table)

Write Debugging Info. Field

The Employee Portal Setup Table

A checkmark in this field indicates that all incoming and outgoing messages will be dumped to the file system.


Config Tool Pane Caption ID, Employee Portal Setup (table)

Config Tool Pane Caption ID Field

The Employee Portal Setup Table

This field contains the caption ID that Microsoft Dynamics NAV uses to identify the caption that you have defined in the Config Tool Pane Caption field.


Config TP WP Request Capt ID, Employee Portal Setup (table)

Config TP WP Request Capt ID Field

The Employee Portal Setup Table

This field contains the caption ID that Microsoft Dynamics NAV uses to identify the caption that you have defined in the Config TP WP Request Caption field.


Config TP Initial Req. Capt ID, Employee Portal Setup (table)

Config TP Initial Req. Capt ID Field

The Employee Portal Setup Table

This field contains the caption ID that Microsoft Dynamics NAV uses to identify the caption that you have defined in the Config TP Initial Req. Caption field.


Config TP Group Capt ID, Employee Portal Setup (table)

Config TP Group Capt ID Field

The Employee Portal Setup Table

This field contains the caption ID that Microsoft Dynamics NAV uses to identify the caption that you have defined in the Config TP Group Caption field.


Search Tool Pane Caption ID, Employee Portal Setup (table)

Search Tool Pane Caption ID Field

The Employee Portal Setup Table

This field contains the caption ID that Microsoft Dynamics NAV uses to identify the caption that you have defined in the Search Tool Pane Caption field.


Search Config Table ID, Employee Portal Setup (table)

Search Config Table ID Field

The Employee Portal Setup Table

This field contains the caption ID that Microsoft Dynamics NAV uses to identify the caption that you have defined in the Search TP All Tables Caption field.


Search TP All Tables Capt ID, Employee Portal Setup (table)

Search TP All Tables Capt ID Field

The Employee Portal Setup Table

This field contains the caption ID that Microsoft Dynamics NAV uses to identify the caption that you have defined in the Search TP All Tables Caption field.


Config Tool Pane Caption, Employee Portal Setup (table)

Config Tool Pane Caption Field

The Employee Portal Setup Table

When you add a Web Part to your portal page, you need to configure the Web Part by defining which Web Part Request it must use. You do this by selecting the configuration from the fields in the custom property in the SharePoint tool pane. The captions for these fields have to be defined in Microsoft Dynamics NAV.

This field contains the caption that will show in the tool pane as the heading of the Employee Portal custom property area for Card, List and Header-Line Web Parts.


Config TP WP Request Caption, Employee Portal Setup (table)

Config TP WP Request Caption Field

The Employee Portal Setup Table

When you add a Web Part to your portal page, you need to configure the Web Part by defining which Web Part Request it must use. You do this by selecting the configuration from the fields in the custom property in the SharePoint tool pane. The captions for these fields have to be defined in Microsoft Dynamics NAV.

This field contains the caption that will show as the heading of the field in which you can select the request you want the Web Part to use.


Config TP Initial Req. Caption, Employee Portal Setup (table)

Config TP Initial Req. Caption Field

The Employee Portal Setup Table

When you add a Web Part to your portal page, you need to configure the Web Part by defining which Web Part Request it must use. You do this by selecting the configuration from the fields in the custom property in the SharePoint tool pane. The captions for these fields have to be defined in Microsoft Dynamics NAV.

This field contains the caption that will show as the heading of the field in which you can select if you want the Web Part to perform an initial request.


Config TP Group Caption, Employee Portal Setup (table)

Config TP Group Caption Field

The Employee Portal Setup Table

When you add a Web Part to your portal page, you need to configure the Web Part by defining which Web Part Request it must use. You do this by selecting the configuration from the fields in the custom property in the SharePoint tool pane. The captions for these fields have to be defined in Microsoft Dynamics NAV.

This field contains the caption that will show as the heading of the field in which you can select the group of request.


Search Tool Pane Caption, Employee Portal Setup (table)

Search Tool Pane Caption Field

The Employee Portal Setup Table

When you add a search Web Part to your portal page, you need to configure the Web Part by defining which tables to search in. You do this by selecting the table from the field in the custom property in the SharePoint tool pane. The captions for this field have to be defined in Microsoft Dynamics NAV.

This field contains the caption that will show in the tool pane as the heading of the Employee Portal custom property area for Search Web Parts.


Search Config Table Caption, Employee Portal Setup (table)

Search Config Table Caption Field

The Employee Portal Setup Table

When you add a search Web Part to your portal page, you need to configure the Web Part by defining which tables to search in. You do this by selecting the table from the field in the custom property in the SharePoint tool pane. The captions for this field have to be defined in Microsoft Dynamics NAV.

This field contains the caption that will show as the heading of the field in which you can select the table that the search will run through.


Search TP All Tables Caption, Employee Portal Setup (table)

Search TP All Tables Caption Field

The Employee Portal Setup Table

When you add a search Web Part to your portal page, you need to configure the Web Part by defining which tables to search in. You do this by selecting the table from the field in the custom property in the SharePoint tool pane. The captions for this field have to be defined in Microsoft Dynamics NAV.

This field contains the caption that will show in the field in which you select the table as an option to search through all tables. You can, for example, enter All Tables.


Debugging Path, Employee Portal Setup (table)

Debugging Path Field

The Employee Portal Setup Table

Enter the path for the folder on the Web server where you want your incoming and outgoing messages to be dumped for debugging.


Code, EP Group (table)

Code Field

The EP Group Table

This field contains the code that identifies the group.

The program uses the code when connecting Web Parts to the group.


No. of WP Requests, EP Group (table)

No. of WP Requests Field

The EP Group Table

This field contains the number of Web Part Requests connected to the Employee Portal Group.


Language ID, EP Group (table)

Language ID Field

The EP Group Table

This field contains the language ID that defines which language the Web Part attached to this group will be presented in on the Portal Page. If you define a language ID for an individual member of the group, the language ID of the member will overwrite the language ID of the group.

If you leave Language ID field in the EP Users table and this field empty, the Web Parts will be shown in the default language of your Microsoft Dynamics NAV Application Server.


Caption ID, EP Group (table)

Caption ID Field

The EP Group Table

This field contains the number that has been assigned to the caption definition by the program. The field is filled in automatically by the program.


Caption, EP Group (table)

Caption Field

The EP Group Table

This field contains the caption that will show in the tool pane when you configure your Web Part on your portal page. The caption will show as an option in the field in which you can select the group you want to add a request from.


Group Code, EP Web Part Request (table)

Group Code Field

The EP Web Part Request Table

This field shows the code of the Group that this Web Part Request belongs to, if any. The field will only contain a group code if the Web Part Request belongs to a group.

The program automatically retrieves the name from the Code field in the Employee Portal Group window, when the Web Part Request is added to the group.


Code, EP Web Part Request (table)

Code Field

The EP Web Part Request Table

This field contains the code that identifies the Web Part Request.

The program uses the code when connecting components to the Web Part Request.


Editable, EP Web Part Request (table)

Editable Field

The EP Web Part Request Table

Insert a checkmark in this field if you want the Web Part to be editable. You can only make Header + Line and Card Web Parts editable. List Web Parts can not be made editable.


Type, EP Web Part Request (table)

Type Field

The EP Web Part Request Table

Here you can define the type of the Web Part Request. The type you select in this field defines the basic format of the Web Part.

The types are: List (to show a list of records), Card (to show a record in a card), Header + Line (to show a header with attached lines) and System (for actions). A system request is a special type of request defined in the program to run actions against the database.


Defined by System, EP Web Part Request (table)

Defined by System Field

The EP Web Part Request Table

This field contains a checkmark if the Web Part Request is pre-configured in the system. The administrator of your system is able to change the tables, tabs and fields for a pre-configured Web Part Request. But the type of the pre-configured Web Part Request can not be changed, nor can it be deleted.


No. of Where-Used Groups, EP Web Part Request (table)

No. of Where-Used Groups Field

The EP Web Part Request Table

This field contains the number of groups that the Web Part Request is assigned to.


Caption ID, EP Web Part Request (table)

Caption ID Field

The EP Web Part Request Table

This field contains the number that has been assigned to the caption definition by the program. The field is filled in automatically by the program.


Caption, EP Web Part Request (table)

Caption Field

The EP Web Part Request Table

This field contains the caption that will show in the tool pane when you configure your Web Part on your portal page. The caption will show as an option in the field in which you select the request you want to add to your Web Part.


Table No., EP WP Request Table Tab (table)

Table No. Field

The EP WP Request Table Tab Table

This field contains the number of the table from where the fields shown on this tab originate.


Header or Line, EP WP Request Table Tab (table)

Header or Line Field

The EP WP Request Table Tab Table

In this field you must define to which section the tab is assigned. If the parent table is assigned to the header of a Header + Line Web Part or to a Card Web Part, you must select Head. If the parent table is assign to the lines of a Header + Line Web Part or to a List Web Part, you must select Line.


No. of Columns, EP WP Request Table Tab (table)

No. of Columns Field

The EP WP Request Table Tab Table

This field contains the number of columns that are available on the tab. This field is only relevant if the Web Part Request type is either Card Web Part or Header-Line Web Part.


Position, EP WP Request Table Tab (table)

Position Field

The EP WP Request Table Tab Table

In this field you can define on what position the tab is displayed in the Web Part. The tabs will be listed in ascending order, where the tab with the position value 0 will be first in the list.


Caption ID, EP WP Request Table Tab (table)

Caption ID Field

The EP WP Request Table Tab Table

This field contains the number that has been assigned to the caption definition by the program. The field is filled in automatically by the program.


Caption, EP WP Request Table Tab (table)

Caption Field

The EP WP Request Table Tab Table

This field contains the caption that will show on the tab in your Web part. The caption will only show on card Web Parts and header + line Web parts, not on list Web Parts.


Table No., EP WP Request Tab Field (table)

Table No. Field

The EP WP Request Tab Field Table

This field contains the number of the table that the field belongs to. The table number is automatically copied from the Table No. field in the EP WP Request Table Tab table when you add the field to the tab.


Tab Code, EP WP Request Tab Field (table)

Tab Code Field

The EP WP Request Tab Field Table

This field contains the code of the tab that the field belongs to. The table number is automatically copied from the Code field in the EP WP Request Table Tab table when you add the field to the tab.


Line No., EP WP Request Tab Field (table)

Line No. Field

The EP WP Request Tab Field Table

The number in this field defines the order in which the fields will be displayed on the tab. The fields are displayed in ascending order.


Field No., EP WP Request Tab Field (table)

Field No. Field

The EP WP Request Tab Field Table

This field contains the number of the field that is to be displayed on the tab.


Name, EP WP Request Tab Field (table)

Name Field

The EP WP Request Tab Field Table

This field contains a name of the field. The program retrieves the name automatically from the source table when the Field No. field is filled in.


Length, EP WP Request Tab Field (table)

Length Field

The EP WP Request Tab Field Table

In this field you can define the length you want the field to be displayed in. The program automatically copies the default length of the field, but you can change the length to fit the Web Part.


Appearance, EP WP Request Tab Field (table)

Appearance Field

The EP WP Request Tab Field Table

In this field you can define how you want the field on the tab to appear in the Web Part.

Determine the appearance of the field by clicking the AssistButton in the field and select one of the four options:

Visible

Editable

Hidden

Editing (Indirect)

If you select Visible, the field will be shown as text or if the field is of the type boolean the field will be shown as a checkbox.

If you select Editable, the field will be editable and shown as it has been configured in the HTML layout.

If you select Hidden, the field will not be visible but be put into a hidden HTML form field. The field can only be edited through lookups.

If you select Editing (Indirect), the field can only be edited through a lookup mapping.


HTML Layout, EP WP Request Tab Field (table)

HTML Layout Field

The EP WP Request Tab Field Table

In this field you can define the HTML layout of the field if you have selected Editable in the Appearance field. If the field has any other appearance than editable, the field will be shown as simple text.

Determine the appearance of the field by clicking the AssistButton in the field and selecting one of the five options:

Text Field

Text Area

Dropdown

Checkbox

Radio Button

Picture Indicator

Picture

If you select Text Field, the field will be shown as a HTML input box.

If you select Text Area, the field will be shown in a HTML text area tag. The text entered in a field with this layout will be stored in Microsoft Dynamics NAV in a single text column. You can not enter multiple lines or extensions in a field with this layout.

If you select Dropdown, the field will be shown as a HTML drop down box. This layout can only be used for option fields.

If you select Checkbox, the field will be shown as a checkbox. This layout can only be used for fields of the type boolean.

If you select Radio Button, the field will be shown line by line. The user can then select one of the lines.

If you select Picture Indicator, the field will contain an indicator to tell the user that a picture is available. The user can then click on the indicator to view the picture.

If you select Picture, the field can show a picture attached to the record.

If you want to show the picture in another size than full size, you can define the size in the Scale Ratio field.


Required, EP WP Request Tab Field (table)

Required Field

The EP WP Request Tab Field Table

If this field contains a check mark, the field is required to be filled in by the user. If a field is required to be filled in, the user can not complete the action before the field is filled in.

The program will automatically check if the value entered by the user is valid. For the value entered by the user to be valid it must have the format defined in the HTML Layout field.


Sortable, EP WP Request Tab Field (table)

Sortable Field

The EP WP Request Tab Field Table

This field contains a check mark if a sorting key is defined for this line. The field is automatically filled in by the program, when you define a sorting key for the table.


Lookup, EP WP Request Tab Field (table)

Lookup Field

The EP WP Request Tab Field Table

A check mark in this field indicates that a lookup has been defined for the field. The field is automatically filled in by the program when you define a lookup for this field.


Scale Ratio, EP WP Request Tab Field (table)

Scale Ratio Field

The EP WP Request Tab Field Table

If you have selected Picture in the HTML field you can use this field to define the size of the picture when it is shown in your Web Part. The size you define in this field is in percentage. That means that if you enter 50 the picture will be shown in half size.

If you do not enter a value in this field, the picture will be shown in full size.


Code, EP WP Request Table Action (table)

Code Field

The EP WP Request Table Action Table

This field contains the code of the request that the action will call.

If the action defined in the Type field is anything else than Connect to another WP Request, the Code field contains a System Request. A system request is a special type of request defined in the program to run actions against the database.

If the action defined in the Type field is Connect to another WP Request, the Code field contains the Web Part Request that the action connects to.


Target WP Request, EP WP Request Table Action (table)

Target WP Request Field

The EP WP Request Table Action Table

In this field you can define the target of action.

Determine the target by clicking the AssistButton in the field and select one of the following options:

Current

Other

If you select Current, the action will run on the same Web Part.

If you select Other, the action will run on the Web Part Request you have selected in the Code field. You can only select this target if you have selected Connect to another WP Request in the Type field.


HTML Layout, EP WP Request Table Action (table)

HTML Layout Field

The EP WP Request Table Action Table

In this field you can define how you want the action to appear in the Web Part.

Determine the appearance by clicking the AssistButton in the field and selecting one of the following options:

Link

Button

If you select Link, the action will appear as a simple HTML link.

If you select Button, the action will appear as a HTML button.


Position, EP WP Request Table Action (table)

Position Field

The EP WP Request Table Action Table

In this field you can define the position of the action. The action with the lowest position will be placed at the leftmost position.

The default value in the first action you create is 10000 and will be increased by 10000 in the next new action you create. If you want an action to be positioned between two actions, you can enter a position between the two actions' positions.


Field Validation Required, EP WP Request Table Action (table)

Field Validation Required Field

The EP WP Request Table Action Table

If this field contains a check mark, the front end will make a validation check on the data entered by the user before the data is sent to Microsoft Dynamics NAV.


Restrict to Editable, EP WP Request Table Action (table)

Restrict to Editable Field

The EP WP Request Table Action Table

If this field contains a check mark, the action will only be shown if the Web Part Request is editable.

If the action is defined for lines in a header + line Web Part, this field has no effect.


Table No., EP WP Request Table Action (table)

Table No. Field

The EP WP Request Table Action Table

This field contains the number of the table that the action will call. The table number is automatically copied from the Table No. field in the EP WP Request Table Tab table when you add the action to the Web Part request.


Header or Line, EP WP Request Table Action (table)

Header or Line Field

The EP WP Request Table Action Table

This field defines the position of the action. The field is automatically copied from the Header or Line field in the EP WP Request Table Tab table.


Type, EP WP Request Table Action (table)

Type Field

The EP WP Request Table Action Table

In this field you can define the type of action.

Determine the action type by clicking the AssistButton in the field and select one of the following options:

Insert Head

Insert Line

Save Record

Delete Record

Set Line to Modify

Cancel Modify Line

Connect to another WP Request

Show Report

If you select Insert Head, the action will create a new card Web Part. This action can be used in card Web Parts and header + line Web Parts.

If you select Insert Line, the action will create a new line in the Web Part. This action can be used in header + line Web Parts.

If you select Save Record, the action will save the modifications you have made on the Web Part. This action can be used in card Web Parts and header + line Web Parts.

If you select Delete Record, the action will delete the line, header + line or the card it has been defined for. This action can be used in card Web Parts and header + line Web Parts.

If you select Set Line to Modify, the action will make the fields in the line editable, if they are set to Editable in the Appearance field in the EP Web Part Field table. This action can be used on the lines in header + line Web Parts.

If you select Cancel Modify Line, the action will cancel modifications made to the line that have not been saved yet. This action can be used on the lines in header + line Web Parts.

If you select Connect to another WP Request, the action can call another Web Part. This action can be used in all Web Parts.

If you select Show Report, the action will create the report you have defined in the Report ID field. This action can be used on all Web Parts.


Show in Mode, EP WP Request Table Action (table)

Show in Mode Field

The EP WP Request Table Action Table

This field is only valid for header + line Web Part Requests. In this field you can define when an action defined for the lines in a header line Web Part Request is visible to the user. It will, for example, only make sense that an action that saves modifications to a line is visible when the line is in edit mode.

To determine when the action is visible, select one of the following options:

View

Edit

Both

If you select View, the action will only be visible when the line is visible but not editable.

If you select Edit, the action will only be visible when the line is editable.

If you select Both, the action will always be visible.


Target WP Request Type, EP WP Request Table Action (table)

Target WP Request Type Field

The EP WP Request Table Action Table

This field contains the type of the Web Part Request that the action connects to. The field is only valid if the action is of the type Connect to another WP Request.

The field is automatically filled in by the program when you select an action in the Action field.


Target Table No., EP WP Request Table Action (table)

Target Table No. Field

The EP WP Request Table Action Table

This field contains the number of the table in which the action will run.


Caption ID, EP WP Request Table Action (table)

Caption ID Field

The EP WP Request Table Action Table

This field contains the number that has been assigned to the caption definition by the program. The field is filled in automatically by the program.


Report ID, EP WP Request Table Action (table)

Report ID Field

The EP WP Request Table Action Table

Enter the object number of the report that you want to be shown on your portal page when the action is activated. The field will only have effect if the action is of the type SHOWREPORT.


Caption, EP WP Request Table Action (table)

Caption Field

The EP WP Request Table Action Table

In this field you can define a caption for the action. The caption will be shown to indicate that an action is available.


Group Code, EP WPR Table Edit Criterion (table)

Group Code Field

The EP WPR Table Edit Criterion Table

This field contains the group code of the Web Part Request that the modification criteria belongs to.


WP Request Code, EP WPR Table Edit Criterion (table)

WP Request Code Field

The EP WPR Table Edit Criterion Table

This field contains the code of the Web Part Request that the modification criteria belongs to.


Table No., EP WPR Table Edit Criterion (table)

Table No. Field

The EP WPR Table Edit Criterion Table

This field contains the number of the table in which the comparison will run. The table number is automatically copied from the Table No. field in the EP Web Part table when you create a new criterion.


Field No., EP WPR Table Edit Criterion (table)

Field No. Field

The EP WPR Table Edit Criterion Table

This field contains the number of the field you want to use for comparison.


Comparison, EP WPR Table Edit Criterion (table)

Comparison Field

The EP WPR Table Edit Criterion Table

You can use this field to perform a comparison on the values you enter in the Comparison Value 1 field and Comparison Value 2 field.

The result of the comparison will appear in the Web Part created by the Web Part Request defined in the Web Part Request field.

You can use the following symbols:

< = Numbers less than the value defined in the Comparison Value 1 field

> = Numbers greater than the value defined in the Comparison Value 1 field

= = Numbers equal to the value defined in the Comparison Value 1 field

<> = All numbers except the value defined in the Comparison Value 1 field

.. = Numbers between the values defined in the Comparison Value 1 field and Comparison Value 2 field.


Comparison Value 1, EP WPR Table Edit Criterion (table)

Comparison Value 1 Field

The EP WPR Table Edit Criterion Table

In this field you can enter a value if you only want a certain range of records to be visible to the user.

To make this field work, you must enter a comparison symbol value in the Comparison field.


Comparsion Value 2, EP WPR Table Edit Criterion (table)

Comparsion Value 2 Field

The EP WPR Table Edit Criterion Table

In this field you can enter a value if you only want a certain range of records to be visible to the user.

This field is only used if you have entered the .. (values between) comparison symbol in the Comparison field.


Header or Line, EP WP Request Table (table)

Header or Line Field

The EP WP Request Table Table

In the this field you must define to which section of the Web Part the table is assigned. If the Web Part Request type is Card, you must select Head. If the Web Part Request type is List, you must select Line. If the Web Part Request type is Header-Line, you must assign two tables, one for the head and one for the lines.


First Record Shown, EP WP Request Table (table)

First Record Shown Field

The EP WP Request Table Table

In this field you can define the number of the record you want to be shown as the first record in the list the first time the user opens the Web Part.

The field is only used for list Web Part Requests.


No. of Records Shown, EP WP Request Table (table)

No. of Records Shown Field

The EP WP Request Table Table

In this field you can define how many records you want the application to forward to the front end to show when the Web Part is opened.


Sorting Order, EP WP Request Table (table)

Sorting Order Field

The EP WP Request Table Table

This field contains the sorting method for the list Web Part Request. It indicates the direction of the listing order the first time a Web Part is opened. The program uses the first field as sorting field. Afterwards the sorting order can be changed by the user by clicking a column header which has a sorting key defined.

There are two options: Ascending and Descending.

This field is only valid for list Web Part Requests.


Group Code, EP WPR Table Action Filter (table)

Group Code Field

The EP WPR Table Action Filter Table

This field contains the group code of the Web Part Request that the action filter belongs to.


Action Code, EP WPR Table Action Filter (table)

Action Code Field

The EP WPR Table Action Filter Table

This field contains the code of the action that the action filter is set up for.


Apply Filter to, EP WPR Table Action Filter (table)

Apply Filter to Field

The EP WPR Table Action Filter Table

This field defines the type of the action filter.

Determine the type by clicking the AssistButton in the field and select one of the following options:

Field: The value in the specified field has to match in the source Web Part and in the target Web Part.

Key: The value in the filter key has to match in the source Web Part and in the target Web Part.


Line No., EP WPR Table Action Filter (table)

Line No. Field

The EP WPR Table Action Filter Table

This field is automatically filled in by the program when you create a new filter for an action. The number starts at 10000 and is automatically increased by 10000 for each filter you define an action.


Source Field No., EP WPR Table Action Filter (table)

Source Field No. Field

The EP WPR Table Action Filter Table

This field contains the number of the field from the calling Web Part request that the action filter is filtering on. This field can only contain fields that belong to tables assigned to the Web Part Request defined in the Web Part Request field.


Target Field No., EP WPR Table Action Filter (table)

Target Field No. Field

The EP WPR Table Action Filter Table

This field contains the number of the field called and filtered on in the target Web Part Request. This field can only contain fields that belong to the tables assigned to the called Web Part Request.


Target Field Default Value, EP WPR Table Action Filter (table)

Target Field Default Value Field

The EP WPR Table Action Filter Table

This field is only used if the value you want to filter on in the source field does not exist in the tables assigned to the calling Web Part Request. For example, if you want to filter on the Document Type field in the Sales Header table, you can set the value in this field to "1" to filter on quotes.


Key Field No., EP WPR Table Action Filter (table)

Key Field No. Field

The EP WPR Table Action Filter Table

This field contains the number of the key field in the table assigned to the target Web Part Request. This will optimize the performance if you are using SQL Server option.


Table No., EP WPR Table Action Filter (table)

Table No. Field

The EP WPR Table Action Filter Table

This field contains the number of the table that the action filter is based on. The table number is automatically copied from the Table No. field in the EP Web Part Table Tab table when you add the action filter to the Web Part Request.


Header or Line, EP WPR Table Action Filter (table)

Header or Line Field

The EP WPR Table Action Filter Table

This field contains the header or line status of the EP Web Part that the action filter is based on. The header/line status is automatically copied from the Header or Line field in the EP Web Part Tab table when you add the action filter to the Web Part Request.


Header Table No., EP WPR Header/Line Connection (table)

Header Table No. Field

The EP WPR Header/Line Connection Table

This field contains the table that the header + line connection is connected to.

The field is filled in automatically by the program.


Apply Filter to, EP WPR Header/Line Connection (table)

Apply Filter to Field

The EP WPR Header/Line Connection Table

This field indicates that the connection is a part of a key or a connection filter. The link type can be one of the following options:

Field

Key

If the link type is Field, the connection is part of a filter.

If the link type is Key, the connection is part of a key.


Header Field No., EP WPR Header/Line Connection (table)

Header Field No. Field

The EP WPR Header/Line Connection Table

In this field you can define the field on the header you want to set the connection on. You can only select fields that are part of the table in the header.


Line Field No., EP WPR Header/Line Connection (table)

Line Field No. Field

The EP WPR Header/Line Connection Table

In this field you can define the field in the lines you want to set the connection on. You can only select fields from the table in the lines.


Line Field Default Value, EP WPR Header/Line Connection (table)

Line Field Default Value Field

The EP WPR Header/Line Connection Table

This field is used if the value of the line fielddoes not existing in the head table selected in the Head Table No field.

This field is only used if the value you want to filter on in the Line field does not exist in the tables assigned to the calling Web Part Request. For example, if you want to filter on Line Type you can set the default value to “1” (which means “Item”) to only get the lines of the type Item.


Line Key Field No., EP WPR Header/Line Connection (table)

Line Key Field No. Field

The EP WPR Header/Line Connection Table

In this field you can define the field in the key in the lines you want to set the connection on. You can only select fields that are a part of the table in the lines.


Tab Code, EP WP Request Table Sort Key (table)

Tab Code Field

The EP WP Request Table Sort Key Table

This field contains the code of the tab that the sort key belongs to. The field is a part of the primary key.


Field Line No., EP WP Request Table Sort Key (table)

Field Line No. Field

The EP WP Request Table Sort Key Table

This field is automatically filled in by the program when you create the first sort key for a table. The number starts at 10000 and is automatically increased by 10000 for each new table you define a sort key for.

The field is a part of the primary key.


Line No., EP WP Request Table Sort Key (table)

Line No. Field

The EP WP Request Table Sort Key Table

This field is automatically filled in by the program when you create a new sort key for a table. The number starts at 10000 and is automatically increased by 10000 for each new field you define for the same table.


Key Field No., EP WP Request Table Sort Key (table)

Key Field No. Field

The EP WP Request Table Sort Key Table

This field contains the number of the field you have selected as sort key field. This field can only contain fields that belong to the tables assigned to the Web Part Request. The field number is copied from the appropriate field in the table indicated in the Table No. field when you select the field in the EP WP Table Sort Key List window.


Field No., EP WPR Header Create Criterion (table)

Field No. Field

The EP WPR Header Create Criterion Table

In this field you can enter the number of the field on which you want to define a criterion. This field can only contain fields that belong to the tables assigned to the Web Part Request.


Default Value, EP WPR Header Create Criterion (table)

Default Value Field

The EP WPR Header Create Criterion Table

In this field you can enter the value of the criterion.


Tab Code, EP WPR Field Lookup (table)

Tab Code Field

The EP WPR Field Lookup Table

This field contains the code of the tab that the lookup belongs to. The field is a part of the primary key.


Line No., EP WPR Field Lookup (table)

Line No. Field

The EP WPR Field Lookup Table

This field is automatically filled in by the program when you create a new lookup for a table. The number starts at 10000 and is automatically increased with 10000 for each new lookup you define for the same table.


Position, EP WPR Field Lookup (table)

Position Field

The EP WPR Field Lookup Table

In this field you can define the order in which the lookup will be processed if you have defined more than one lookup for the same field number.


Lookup WP Request Code, EP WPR Field Lookup (table)

Lookup WP Request Code Field

The EP WPR Field Lookup Table

In this field you can define the Web Part Request that the lookup will lead to. You can only make a lookup to a list Web Part Request, and only to one that is assigned to the same group.

The field is a part of the primary key.


Field No., EP WPR Field Lookup Condition (table)

Field No. Field

The EP WPR Field Lookup Condition Table

Enter the field number from the source table to which the condition value of the current record must be compared.


Field Value, EP WPR Field Lookup Condition (table)

Field Value Field

The EP WPR Field Lookup Condition Table

Enter the value that you want the program to compare in the records.

If the value is identical to the value in the current record, then this lookup request will be called, otherwise the next lookup condition will be checked.


Source Field No., EP WPR Field Lookup Mapping (table)

Source Field No. Field

The EP WPR Field Lookup Mapping Table

Enter the field number you want to base the lookup on. The value of the field will automatically be copied to the Target Field No. field.


Target Field No., EP WPR Field Lookup Mapping (table)

Target Field No. Field

The EP WPR Field Lookup Mapping Table

The value in this field is automatically copied from the Source Field No. field, but you can change it if you want the lookup to lead to another field.


Filter Field No., EP WPR Table Filter Field (table)

Filter Field No. Field

The EP WPR Table Filter Field Table

In this field you can define the number of the field you want to set a filter on.

The field is a part of the primary key.


Filter Field Value, EP WPR Table Filter Field (table)

Filter Field Value Field

The EP WPR Table Filter Field Table

You can use this field to filter on the records shown in the Web Part defined in the Web Part Request field.

You can use the following symbols:

< = Numbers less than, combined with a value. For example, <5000. If you have defined "1" for Customer No. in the Customer table in this field in the Customer table, the Web part will only show customers with a customer number lower than 5000.

> = Numbers greater than , combined with a value. For example, >5000. If you have defined "1" for Customer No. in the Customer table in this field in the Customer table, the Web part will only show customers with a customer number higher than 5000.

= = Numbers equal, combined with a value. For example, =5000. If you have defined "1" for Customer No. in the Customer table in this field in the Customer table, the Web part will only show customer number 5000.

<> = All numbers except the value defined , combined with a value. For example, <>5000. If you have defined "1" for Customer No. in the Customer table in this field in the Customer table, the Web part will show all customers except customer number 5000.

.. = Numbers between the values. For example, 5000..6000. If you have defined "1" for Customer No. in the Customer table in this field in the Customer table, the Web part will only show customers with a customer number between 5000 and 6000.


Table No., EP WPR Table Filter Field (table)

Table No. Field

The EP WPR Table Filter Field Table

This field contains the number of the table that the field in the Filter Field No. belongs to. The number is automatically filled in by the program.


Path, EP SharePoint Image Path (table)

Path Field

The EP SharePoint Image Path Table

Enter the path to where the image you want to define for your action is stored.


Table No., EP Search Table (table)

Table No. Field

The EP Search Table Table

This field contains the number of the table that you have configured for searching.


Table Caption, EP Search Table (table)

Table Caption Field

The EP Search Table Table

This field contains the caption that will show in the tool pane when you configure your search Web Part on your portal page. The caption will show as an option in the field in which you select the table you want the search to run through.


Table No., EP Search Field (table)

Table No. Field

The EP Search Field Table

This field contains the number of the table that you have configured for searching.


Field No., EP Search Field (table)

Field No. Field

The EP Search Field Table

This field contains the number of the field on which a search can be performed.


Field Caption, EP Search Field (table)

Field Caption Field

The EP Search Field Table

This field contains the caption of the field defined in the Field No. field.


Field No., EP Search Display Field (table)

Field No. Field

The EP Search Display Field Table

This field contains the number of the field that will be listed in the search result.


Display Field, EP Search Display Field (table)

Display Field Field

The EP Search Display Field Table

In this field you can define in what order the field is displayed in the search result. The options are Field 1..Field 5. The fields will be listed in ascending order, where the field with the value Field 1 will be first in the list.


Field Caption, EP Search Display Field (table)

Field Caption Field

The EP Search Display Field Table

This field contains the caption that will show in the search result for the field.


User ID, EP Search Configuration (table)

User ID Field

The EP Search Configuration Table

This field contains the user ID of the user that the search configuration is assigned to.


Table No., EP Search Configuration (table)

Table No. Field

The EP Search Configuration Table

Select the number of the table that you want to assign a search configuration to your user for.


Group Code, EP Search Configuration (table)

Group Code Field

The EP Search Configuration Table

Enter the group code of the Web Part Request for the Web Part that you want to show the search result in.


WP Request Code, EP Search Configuration (table)

WP Request Code Field

The EP Search Configuration Table

Select the Web Part Request that you want to be called when the user clicks a single instance of the search result.

Note that you can only use Web Part Requests containing the same table as the table defined in the Table No. field.


WP Request Type, EP Search Configuration (table)

WP Request Type Field

The EP Search Configuration Table

This field is automatically copied from the Type field in the EP Web Part Request table.


Target Link, EP Search Configuration (table)

Target Link Field

The EP Search Configuration Table

Enter the path to your Web Part page where you have configured the Web part in which you want to show single instances of the search result.


Group Code, EP Group/User (table)

Group Code Field

The EP Group/User Table

This field contains the code of the EP group that the user is assigned to. The group code is copied from the Group Code field in the Employee Portal Group table.


User ID, EP Group/User (table)

User ID Field

The EP Group/User Table

This field contains the User ID. The ID is copied from the User ID field in the EP Users table when you assign the user to the group.


Windows Login ID, EP User Login (table)

Windows Login ID Field

The EP User Login Table

This field contains the user's Logon Security Identifier (SID). The Logon SID is a unique identifier for the user's Logon Session.


Name, EP User Login (table)

Name Field

The EP User Login Table

This field contains the user's Windows login name.


User ID, EP User (table)

User ID Field

The EP User Table

In this field you can define the user ID of the user. Make sure that the ID is identical to the one defined for the user in SharePoint. The format of the user ID must be DOMAIN\USERID.


Language ID, EP User (table)

Language ID Field

The EP User Table

This field contains the ID of the language that is defined for this user.

The language ID can be configured at user or group level. If you leave the Language ID field in the Employee Portal Group table as well as this field empty, the Web Parts will be shown in the default language of your Microsoft Dynamics NAV Application Server.

You can only select the languages that you have licenses for.


Caption ID, EP Caption (table)

Caption ID Field

The EP Caption Table

This field contains the number that has been assigned to the caption definition by the program. The field is filled in automatically by the program.


Table No., EP Caption (table)

Table No. Field

The EP Caption Table

This field contains the number of the table that the caption is assigned to. The field is filled in automatically by the program.


Language ID, EP Caption (table)

Language ID Field

The EP Caption Table

This field contains the code of the language that this caption is defined for.

The language ID can be configured at user or group level. If you leave the Language ID field in the Employee Portal Group table as well as this field empty, the Web Parts will be shown in the default language of your Microsoft Dynamics NAV Application Server.

You can only select the languages that you have licenses for.


Caption, EP Caption (table)

Caption Field

The EP Caption Table

This field contains the value that will be shown to the user.


Language Name, EP Caption (table)

Language Name Field

The EP Caption Table

This field contains the name of the language that this caption is defined for.


Code, EP Appln. Server Setup (table)

Code Field

The EP Appln. Server Setup Table

This field contains the code for the application server. The code must be equal to the startup parameter for the application server.


Front End Processing, EP Appln. Server Setup (table)

Front End Processing Field

The EP Appln. Server Setup Table

Enter a check mark in this field to activate the application server to handle the communication between Microsoft Dynamics NAV and the front end.


Request Queue, EP Appln. Server Setup (table)

Request Queue Field

The EP Appln. Server Setup Table

This field contains the label of the incoming message queue.


Reply Queue, EP Appln. Server Setup (table)

Reply Queue Field

The EP Appln. Server Setup Table

This field contains the label of the outgoing message queue.


Reply Queue Timeout, EP Appln. Server Setup (table)

Reply Queue Timeout Field

The EP Appln. Server Setup Table

Enter the length of time that replies can remain in the queue. If they are not received by the front end (for example, if the user closes the browser), they will be deleted when the time has run out.


Reply Queue Priority, EP Appln. Server Setup (table)

Reply Queue Priority Field

The EP Appln. Server Setup Table

Enter a priority level for your reply messages. A reply queue priority determines how quickly messages between Microsoft Dynamics NAV and the Employee Portal are handled when other messages are sent to the same message queue.


Use Compression, EP Appln. Server Setup (table)

Use Compression Field

The EP Appln. Server Setup Table

Place a checkmark in this field to activate compression of messages handled by this application server. The corresponding values have to be set in the front end in the Web.config file.


Use Encryption, EP Appln. Server Setup (table)

Use Encryption Field

The EP Appln. Server Setup Table

Place a checkmark in this field to activate encryption of messages handled by this application server. The corresponding values have to be set in the front end in the Web.config file.


Handle Key Exchange, EP Appln. Server Setup (table)

Handle Key Exchange Field

The EP Appln. Server Setup Table

Place a checkmark in this field to activate the application server to handle the trusted requests from the front end.


Key Exchange Request Queue, EP Appln. Server Setup (table)

Key Exchange Request Queue Field

The EP Appln. Server Setup Table

Enter the label of the incoming message queue used for trusted sites.


Key Exchange Reply Queue, EP Appln. Server Setup (table)

Key Exchange Reply Queue Field

The EP Appln. Server Setup Table

Enter the label of the outgoing message queue used for trusted sites.


KE Reply Queue Timeout, EP Appln. Server Setup (table)

KE Reply Queue Timeout Field

The EP Appln. Server Setup Table

Enter the length of time that replies can remain in the queue. If they are not received by the front end (for example, if the user closes the browser), they will be deleted when the time has run out.


KE Reply Queue Priority, EP Appln. Server Setup (table)

KE Reply Queue Priority Field

The EP Appln. Server Setup Table

Enter a priority level for your reply messages. A reply queue priority determines how quickly messages between Microsoft Dynamics NAV and SharePoint are handled when other messages are sent to the same message queue.


Site Name, EP Trusted Site (table)

Site Name Field

The EP Trusted Site Table

This field contains the name of the trusted site.


Request Date, EP Trusted Site (table)

Request Date Field

The EP Trusted Site Table

This field contains the date of the trust request. The content of this field is only for your information.


Request Time, EP Trusted Site (table)

Request Time Field

The EP Trusted Site Table

This field contains the time of the trust request. The content of this field is only for your information.


Partner Public Key, EP Trusted Site (table)

Partner Public Key Field

The EP Trusted Site Table

This field contains the public part of the site certificate. The site public key is used to check the signature of the incoming messages from the trusted site.


Req. Message GUID, EP Trusted Site (table)

Req. Message GUID Field

The EP Trusted Site Table

This field contains the GUID of the request. The GUID is returned as a part of the reply for the front end service to identify the requesting portal.


Site Identifier, EP Trusted Site (table)

Site Identifier Field

The EP Trusted Site Table

This field contains the unique ID of the portal. It is included in every reply to the site to help the application server identify the right keys for encryption and decryption.


Site Trust, EP Trusted Site (table)

Site Trust Field

The EP Trusted Site Table

A check mark in this field indicates that you have accepted the trust request.


Trust Date, EP Trusted Site (table)

Trust Date Field

The EP Trusted Site Table

In this field contains the date you accepted the trust request. The content of this field is only for your information.


Trust Time, EP Trusted Site (table)

Trust Time Field

The EP Trusted Site Table

This field contains the time you accepted the trust request. The content of this field is only for your information.


Answer Sent, EP Trusted Site (table)

Answer Sent Field

The EP Trusted Site Table

A check mark in this field indicates that the acceptance of the trust request has been successfully sent to the front end.


Sent Date, EP Trusted Site (table)

Sent Date Field

The EP Trusted Site Table

This field contains the date you accepted the trust request. The content of this field is only for your information.


Sent Time, EP Trusted Site (table)

Sent Time Field

The EP Trusted Site Table

This field contains the time you accepted the trust request. The content of this field is only for your information.