Microsoft Dynamics NAV Classic integreren met Microsoft Dynamics Mobile

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Microsoft Dynamics NAV Classic integreren met Microsoft Dynamics Mobile

In deze sectie wordt de Mobile-functionaliteit van Microsoft Dynamics NAV 2009 beschreven waarmee Microsoft Dynamics NAV verbinding kan maken met een mobiel apparaat en waarbij de bedrijfstoepassing kan worden gebruikt wanneer de gebruiker niet op zijn werk is, bijvoorbeeld voor het maken of wijzigen van verkooporders. Met deze onderdelen van Microsoft Dynamics NAV kunnen gebruikers vanaf een mobiel apparaat verbinding maken met de server. Om echter van de volledige functionaliteit te kunnen gebruikmaken moeten Microsoft Dynamics® Mobile – Serveronderdelen en de databaseonderdelen voor Microsoft Dynamics® Mobile – Mobile Sales zijn geïnstalleerd en geconfigureerd.

In deze sectie komen de volgende onderwerpen aan bod

Beschikbare Mobile-functionaliteit in Microsoft Dynamics NAV Classic

Application Server configureren voor Microsoft Dynamics NAV voor Mobile-integratie

Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren

Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken

Referentie

Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV

© 2009 Microsoft Corporation. Alle rechten voorbehouden.


Beschikbare Mobile-functionaliteit in Microsoft Dynamics NAV Classic

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Beschikbare Mobile-functionaliteit in Microsoft Dynamics NAV Classic
Zie ook

Microsoft Dynamics NAV 2009 bevat onderdelen waarmee de toepassing met mobiele mogelijkheden kan worden uitgebreid. Hierdoor kunnen gebruikers vanaf een mobiel apparaat verbinding maken met de server voor bijvoorbeeld het maken of wijzigen van verkooporders wanneer zij niet op kantoor zijn. Om dit mogelijk te maken moet u Application Server voor Microsoft Dynamics NAV configureren, waarmee de interactie tussen mobiele apparaten en Microsoft Dynamics NAV wordt beheerd, en moet u beveiligingsrollen toewijzen aan gebruikers voor toegang tot Mobile-functionaliteit. Bovendien moet u documenthandlers en documentsoorten definiëren en instellen die de aanvraagdocumenten verwerken. Deze aanvraagdocumenten bevatten gegevens en aanvragen die van mobiele apparaten naar de server worden verstuurd. In de volgende tabel wordt een korte omschrijving van deze scenario's gegeven.

Functie | Zie
Instellen van een Application Server-instance voor elke Microsoft Dynamics NAV-rol die documenten vanaf mobiele apparaten verstuurt. | Application Server configureren voor Microsoft Dynamics NAV voor mobiele integratie
Mobile-gebruikers instellen, er beveiligingsrollen voor toegang tot Mobile-functionaliteit aan toewijzen en de Mobile-gebruikers in Mobile-groepen groeperen. | Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen
Documenthandlers definiëren die de inkomende aanvragen van mobiele apparaten verwerken. | Documenthandlers in Microsoft Dynamics NAV definiëren
Mobile-documentsoorten instellen die de soort gegevens bepalen die in een aanvraagdocument kunnen worden uitgewisseld. | Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen
Inkomende XML-aanvraagdocumenten valideren en documentschema's aan documentsoorten toevoegen. | Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven
Mobile-aanvraagdocumenten controleren. | De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
De taal van de mobiele toepassing opgeven. | Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen
Mobile-verkoopactiviteiten laten communiceren met taken. | Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen
De nieuwe functionaliteit van Mobile Sales in verkoop en marketing gebruiken. | Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken

Zie ook

Concepten

Application Server configureren voor Microsoft Dynamics NAV voor mobiele integratie
De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken
Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic

Overige informatiebronnen

Microsoft Dynamics NAV Classic integreren met Microsoft Dynamics Mobile
Mobile Development Tools - Server Components
Mobile Sales - Overzicht


Application Server configureren voor Microsoft Dynamics NAV voor mobiele integratie

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Application Server configureren voor Microsoft Dynamics NAV voor mobiele integratie
Zie ook

Microsoft Dynamics NAV gebruikt Application Server voor het beheren van de interactie tussen mobiele apparaten en Microsoft Dynamics NAV. Zie Application Server configureren in de installatie- en configuratiehandleiding voor Microsoft Dynamics NAV voor meer informatie over Application Server voor Microsoft Dynamics NAV.

Stel tijdens het configureren van Application Server dit programma in om een van de taken uit de volgende tabel uit te voeren.

Taak | Omschrijving
Mobile Document Dispatcher | Ontvangt aanvragen van de Mobile-documentservice en slaat die aanvragen op in de Mobile-documentenwachtrij waarin die aanvragen onmiddellijk of op een later tijdstip worden verwerkt. Zie Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Document Dispatcher voor meer informatie.
Mobile-wachtrijprocessor | Verwerkt die aanvragen in de documentenwachtrij die zijn opgeslagen om op een later tijdstip te worden verwerkt. Zie Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile-wachtrijprocessor voor meer informatie.
Opmerking Opmerking

Als u Mobile-functionaliteit wilt gebruiken tijdens de bewerkingstijd, moet u Microsoft Dynamics® Mobile installeren en configureren. Zie de Microsoft Dynamics Mobile Installation and Configuration Guide online voor meer informatie.

Overzicht van de integratie tijdens de uitvoering

Application Server ontvangt aanvragen van de Microsoft Dynamics Mobile–documentservice voor Serveronderdelen en moet worden geconfigureerd om de aanvragen te verwerken. Microsoft Dynamics Mobile – Serveronderdelen communiceert met Application Server via het TCP-poortnummer dat aan het Application Server-exemplaar is toegewezen. Als Application Server aanvragen van de documentservice ontvangt, worden deze opgeslagen in een mobiele documentenwachtrij om te worden verwerkt en in de database te worden opgeslagen. In de volgende afbeelding ziet u dit Application Server-exemplaar, genaamd NAS1, op poort 8081.

Mobile instellen met meerdere Application Servers

U kunt meerdere Application Server-exemplaren instellen voor het behandelen van aanvraagdocumenten. U kunt de Application Server-exemplaren instellen op dezelfde server of op verschillende servers. Als u de Application Server-exemplaren op dezelfde server wilt instellen, moet u elk exemplaar op een andere poort configureren zoals aangegeven in de afbeelding met NAS2 op poort 8082. Als u de Application Server-exemplaren instelt op verschillende servers, maakt de serverhostnaam onderscheid tussen de Application Server-exemplaren. Het instellen van meerdere Application Server-exemplaren is handig omdat de Microsoft Dynamics Mobile-documentservice aanvraagdocumenten kan verzenden van verschillende mobiele apparaten, na elkaar. Met meerdere Application Server-exemplaren kan de documentservice, als deze detecteert dat een poort bezet is, deze naar de volgende poort proberen te verzenden.

Elk Application Server-exemplaar moet worden geconfigureerd in het bestand web.config van de Microsoft Dynamics Mobile-documentservice, zodat de documentservice kan communiceren met de Application Server-exemplaren. Zie de Microsoft Dynamics Mobile Installation and Configuration Guide online voor meer informatie.

Aanvraagdocumenten verwerken die in de wachtrij staan

In Microsoft Dynamics NAV kan worden ingesteld dat aanvraagdocumenten direct of vanuit de wachtrij worden verwerkt. Bij de directe verwerking worden aanvraagdocumenten direct naar de Microsoft Dynamics NAV-database verwerkt als deze documenten in de Mobile-documentenwachtrij worden geplaatst. Bij verwerking vanuit de wachtrij blijven de aanvraagdocumenten in de wachtrij staan totdat zij handmatig of door een geplande verwerking worden verwerkt. Om verwerking vanuit de wachtrij in Microsoft Dynamics NAV mogelijk te maken moet u een afzonderlijke toepassingsserver instellen, zoals in de volgende afbeelding.

Application Server verwerkt mobiele aanvragen

Ook moet u dan verwerkingen plannen die documenten vanuit de wachtrij gaan verwerken.

Beveiliging

Wanneer een Mobile-gebruiker een aanvraagdocument naar Microsoft Dynamics NAV verstuurt, wordt de toegang van die gebruiker tot de specifieke documentsoort door de Mobile Document Dispatcher gevalideerd. Als de Mobile-gebruiker geen lid is van een Mobile-groep die aan die documentsoort is toegewezen, wordt de aanvraag geweigerd. Aanvraagdocumenten die in de wachtrij staan, worden opnieuw gevalideerd wanneer zij worden verwerkt. Voordat een aanvraagdocument wordt verwerkt, kan de toegang van de Mobile-gebruiker tot de tabellen ook door een documenthandler worden gevalideerd.

Als de vereiste gebruikersrechten tussen de tijd van verzending en de tijd van verwerking van het document niet waren toegewezen, wordt het document niet door de documentenwachtrijprocessor verwerkt en verschijnt er een foutmelding. De beheerder moet dan de vereiste gebruikersrechten toewijzen of het aanvraagdocument verwijderen.

U maakt de implementatie veiliger door voor elke Microsoft Dynamics NAV-rol die documenten vanaf mobiele apparaten moet versturen, een Application Server-instance in te stellen, zodat Application Server alleen de toegang heeft die door de rol is gedefinieerd. Als u bijvoorbeeld de rol S&R-Q/O/I/R/C aan een groep Mobile-gebruikers toewijst, kunt u een Application Server-instance maken en deze instance toewijzen aan de rol S&R-Q/O/I/R/C.

Vervolgens moet u in de configuratie van Microsoft Dynamics Mobile-documentservice voor Serveronderdelen eindpunten definiëren die specifiek zijn voor elk van de relevante rollen. Deze eindpunten moeten wijzen naar het juiste Application Server-exemplaar. Zie de Microsoft Dynamics Mobile Installation and Configuration Guide online voor meer informatie.

Zie ook

Taken

Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Document Dispatcher
Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile-wachtrijprocessor


Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Document Dispatcher

Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Document Dispatcher
Zie ook

Wanneer u Microsoft Dynamics NAV uitbreidt met een mobiele toepassing, zoals Mobile Sales, moet u een Application Server-instance instellen voor het verwerken van aanvraagdocumenten die vanaf de mobiele apparaten binnenkomen. U kunt de Mobile Document Dispatcher of de Mobile Queue Processor gebruiken. In dit onderwerp wordt de Mobile Document Dispatcher beschreven. Zie Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Queue Processor voor informatie over de Mobile Queue Processor.

De Mobile Document Dispatcher ontvangt aanvragen van de Microsoft Dynamics® Mobile-documentservice en slaat die aanvragen in de Mobile-documentenwachtrij op waar de aanvragen direct of op een later tijdstip worden verwerkt. U kunt een verwerking plannen voor het op gezette tijden verwerken van een wachtrij met aanvraagdocumenten.

Opmerking Opmerking

Voordat u verdergaat, moet u eerst een gebruikersaccount voor Application Server maken. U kunt bijvoorbeeld een gebruikersaccount in uw Windows-domein of lokaal op een computer maken en de Application Server-service instellen om als deze account te worden uitgevoerd.

Application Server configureren voor het gebruik van de Mobile Document Dispatcher

  1. Maak een Windows-gebruikersaccount voor Application Server.

    Maak bijvoorbeeld een Active Directory-account in uw Windows-domein of een lokale account op een computer en stel vervolgens de Application Server-service in om als deze account te worden uitgevoerd.

  2. Maak in Microsoft Dynamics NAV een Windows-aanmelding voor de gebruikersaccount en wijs de volgende rollen aan de Application Server-aanmelding toe:

    • ALL

      Deze standaardrol verleent toegang tot fundamentele tabellen en functies.

    • MOB-SERVER-NAS

      Mobile-beveiligingsrol voor Application Server.

    • De juiste rollen voor elke documentsoort die door Application Server wordt verwerkt.

  3. Stel in Application Server Manager de Application Server-instance zo in, dat deze wordt uitgevoerd met de opstartparameter MOB PORT=poortnummer.

  4. Stel eventueel in Microsoft Dynamics NAV de verwerkingen in die de aanvraagdocumenten in de wachtrij verwerken.

Beveiliging

Om de implementatie veiliger te maken kunt u een toepassingsserver instellen voor elke Microsoft Dynamics NAV-rol waarmee documenten vanaf mobiele apparaten moeten worden verzonden, zodat Application Server alleen de toegang heeft die door de rol wordt bepaald. Als u bijvoorbeeld een rol, zoals S&R-Q/O/I/R/C, toewijst aan een groep Mobile-gebruikers, kunt u een Application Server-instance maken en die instance toewijzen aan de rol S&R-Q/O/I/R/C.

In de configuratie van de Microsoft Dynamics Mobile-documentservice voor Serveronderdelen moet u eindpunten definiëren die specifiek voor elk van de relevante rollen zijn. Deze eindpunten moeten wijzen naar de juiste Application Server-instance. Zie de installatie- en configuratiehandleiding van Microsoft Dynamics Mobile online voor meer informatie.

Zie ook

Taken

Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile-wachtrijprocessor
Procedure: Verwerkingen plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Procedure: Verwerkingen plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic

Concepten

Application Server configureren voor Microsoft Dynamics NAV voor mobiele integratie


Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile-wachtrijprocessor

Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile-wachtrijprocessor
Zie ook

Wanneer u Microsoft Dynamics NAV uitbreidt met een mobiele toepassing, zoals Mobile Sales, moet u een Application Server-instance instellen voor het verwerken van aanvraagdocumenten die vanaf de mobiele apparaten binnenkomen. U kunt de Mobile Document Dispatcher of de Mobile-wachtrijprocessor gebruiken. In dit onderwerp wordt de Mobile-wachtrijprocessor beschreven. Zie Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Document Dispatcher voor informatie over de Mobile Document Dispatcher.

Opmerking Opmerking

Deze Application Server-instance is niet nodig als uw aanvraagdocumenten allemaal zijn ingesteld om direct vanuit de Mobile-documentenwachtrij te worden verwerkt.

In Microsoft Dynamics NAV kunt u instellen dat aanvraagdocumenten direct of vanuit de wachtrij worden verwerkt. Bij de directe verwerking worden aanvraagdocumenten direct naar de Microsoft Dynamics NAV-database verwerkt als deze documenten in de Mobile-documentenwachtrij worden geplaatst. Bij verwerking vanuit de wachtrij blijven de aanvraagdocumenten in de wachtrij staan totdat zij handmatig of door een geplande verwerking worden verwerkt. De volgende afbeelding is een voorbeeld van verwerking vanuit de wachtrij in Microsoft Dynamics NAV.

Application Server verwerkt mobiele aanvragen
Opmerking Opmerking

Voordat u verdergaat, moet u eerst een gebruikersaccount voor Application Server maken. U kunt bijvoorbeeld een gebruikersaccount in uw Windows-domein of lokaal op een computer maken en de Application Server-service instellen om als deze account te worden uitgevoerd.

Application Server voor het gebruik van de Mobile-wachtrijprocessor configureren

  1. Maak een Windows-gebruikersaccount voor Application Server.

    Maak bijvoorbeeld een Active Directory-account in uw Windows-domein of een lokale account op een computer en stel vervolgens de Application Server-service in om als deze account te worden uitgevoerd.

  2. Maak in Microsoft Dynamics NAV een Windows-aanmelding voor de gebruikersaccount en wijs de volgende rollen aan de Application Server-aanmelding toe:

    • ALL

      Deze standaardrol verleent toegang tot fundamentele tabellen en functies.

    • MOB-SERVER-NAS

      Mobile-beveiligingsrol voor Application Server.

    • JOBQUEUERUN

      Met deze standaardrol kunnen gebruikers verwerkingen in de verwerkingswachtrij uitvoeren.

    • De juiste rollen voor elke verwerking in de verwerkingswachtrij.

  3. Stel in Application Server Manager de Application Server-instance zo in, dat deze wordt uitgevoerd met de opstartparameter JOBQUEUE.

  4. Stel eventueel in Microsoft Dynamics NAV de verwerkingen in die de aanvraagdocumenten in de wachtrij verwerken.

Beveiliging

Om de implementatie veiliger te maken kunt u een toepassingsserver instellen voor elke Microsoft Dynamics NAV-rol waarmee documenten vanaf mobiele apparaten moeten worden verzonden, zodat Application Server alleen de toegang heeft die door de rol wordt bepaald. Als u bijvoorbeeld een rol, zoals S&R-Q/O/I/R/C, toewijst aan een groep Mobile-gebruikers, kunt u een Application Server-instance maken en die instance toewijzen aan de rol S&R-Q/O/I/R/C.

Vervolgens moet u in de configuratie van Microsoft Dynamics Mobile-documentservice voor Serveronderdelen eindpunten definiëren die specifiek zijn voor elk van de relevante rollen. Deze eindpunten moeten wijzen naar het juiste Application Server-exemplaar. Zie de Microsoft Dynamics Mobile Installation and Configuration Guide online voor meer informatie.

Zie ook

Taken

Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Document Dispatcher

Concepten

Application Server configureren voor Microsoft Dynamics NAV voor mobiele integratie


Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic
Zie ook

Microsoft Dynamics NAV 2009 bevat functionaliteit voor mobiel werken waarmee gebruikers vanaf een mobiel apparaat contact kunnen maken met de server. Om deze functionaliteit te kunnen gebruiken moet u eerst het volgende definiëren en instellen:

Mobile-gebruiker

U kunt instellen dat bestaande gebruikers mobiel kunnen werken. Zie Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Talen

U kunt de taal van de mobiele toepassing opgeven. Zie Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen voor meer informatie.

Documentsoorten

Gegevens tussen het mobiele apparaat en de server worden als XML-documenten uitgewisseld. U moet in Microsoft Dynamics NAV de documentsoorten definiëren die bepalen welke gegevens kunnen worden uitgewisseld. Zie Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Documentschema's

Om documenten te valideren kunt u documentschema's aan documentsoorten toevoegen. Zie Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven voor meer informatie.

Documenthandlers

In Microsoft Dynamics NAV worden inkomende aanvragen van mobiele apparaten door codeunits verwerkt. Zie Documenthandlers definiëren in Microsoft Dynamics NAV voor meer informatie.

Mobile Sales instellen

Op een aantal plaatsen kan Mobile Sales worden geïntegreerd met Microsoft Dynamics NAV. Mobile Sales bevat bijvoorbeeld activiteiten die kunnen communiceren met taken in Microsoft Dynamics NAV. Zie Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken voor meer informatie.

Mobile-gebruikers en toegang instellen

Om vanaf mobiele apparaten de toegang tot Microsoft Dynamics NAV in te stellen moet u Mobile-gebruikers en -gebruikersgroepen instellen. Mobile-gebruikers sturen aanvraagdocumenten voor verwerking naar Microsoft Dynamics NAV. Er zijn verschillende aanvraagdocumenten voor verschillende doeleinden, bijvoorbeeld een aanvraagdocument voor het maken van verkooporders en een aanvraagdocument voor het toevoegen van taken. U wilt waarschijnlijk niet dat alle Mobile-gebruikers aanvraagdocumentsoorten mogen versturen, dus door Mobile-gebruikers aan een Mobile-groep toe te voegen en vervolgens de groep aan een documentsoort toe te wijzen, kunt u bepalen wie aanvraagdocumenten van die soort mag versturen.

Opmerking Opmerking

Om Mobile-gebruikers te maken en te wijzigen moet uw gebruikersaccount een Super-beveiligingsrol of MOB-SERVER-SETUP-beveiligingsrol bevatten.

Voor het instellen van Mobile-gebruikers moet u de volgende taken uitvoeren:

  • Geef hun Windows-aanmelding op.

    Mobile-gebruikers moeten een Windows-aanmelding in Microsoft Dynamics NAV Classic hebben. Voordat u Mobile-gebruikers kunt instellen, moet u eerst een of meer gebruikers in het venster Windows-aanmeldingen instellen. Zie Windows-aanmeldingen maken voor meer informatie. U kunt echter ook database-aanmeldingen maken en via Windows-groepen machtigingen aan gebruikers toewijzen alvorens die als Mobile-gebruikers in te stellen en aan Mobile-groepen toe te voegen.

  • Wijs Mobile-beveiligingsrollen toe.

    Net zoals andere gebruikers in Microsoft Dynamics NAV worden voor Mobile-gebruikers beveiligingsrollen aan hun Windows-aanmeldingen toegewezen waardoor zij bepaalde rechten krijgen. Microsoft Dynamics Mobile - Serveronderdelen in Microsoft Dynamics NAV bevat vooraf gedefinieerde beveiligingsrollen waarmee machtigingen aan Mobile-gerelateerde functionaliteit worden toegekend. Zie Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

De Mobile-taal opgeven

U moet de taal van foutmeldingen en waarden voor optievelden opgeven die Mobile-gebruikers op hun mobiele apparaten te zien krijgen. De Mobile-talen moeten van tevoren worden ingesteld en u moet opgeven welke taal iedere gebruiker gebruikt. Zie Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen voor meer informatie.

Documentsoorten instellen

In Microsoft Dynamics NAV kunnen Mobile-gebruikers gegevens van een mobiel apparaat als aanvraagdocumenten naar de server versturen. Om aanvraagdocumenten te kunnen ontvangen moet u een documentsoort voor de inkomende aanvraagdocumenten definiëren. Wanneer u een documentsoort maakt, kunt u de documentsoort aan een groep toewijzen waardoor de leden aanvraagdocumenten vanaf mobiele apparaten kunnen versturen. Zie Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie. Voor de validatie van invoer van mobiele apparaten kunt u schema's op de documentsoorten toepassen. Deze schema's valideren de inkomende XML-documenten en zorgen ervoor dat deze documenten de verwachte elementen bevatten en dat elke elementwaarde overeenkomt met de gegevenssoort voor die waarde. Zie Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven voor meer informatie.

Zie ook

Concepten

Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV
De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
Beschikbare Mobile-functionaliteit in Microsoft Dynamics NAV Classic
Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken
Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic


Beveiligingsoverzicht voor Mobile-functionaliteit in Microsoft Dynamics NAV

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Beveiligingsoverzicht voor Mobile-functionaliteit in Microsoft Dynamics NAV
Zie ook

Wanneer u Microsoft Dynamics NAV integreert met Microsoft Dynamics® Mobile, kunnen gebruikers XML-documenten verzenden die aanvraagdocumenten van mobiele apparaten aanroepen. Voor het beter beveiligen van uw gegevens kunt u in Microsoft Dynamics NAV beveiligingsrollen toepassen op Windows-aanmeldingen om gebruikers toegang tot de Mobile-functionaliteit te geven. Zie Vooraf gedefinieerde Mobile-beveiligingsrollen voor meer informatie.

Opmerking Opmerking

Voor integratie met Microsoft Dynamics Mobile moet het verbeterde beveiligingsmodel door de Microsoft Dynamics NAV-database worden uitgevoerd. Zie de Microsoft Dynamics NAV 2009 Developer and IT Pro Documentation voor meer informatie.

Overwegingen met betrekking tot beveiliging

In de handleiding Security Hardening voor Microsoft Dynamics NAV staan aanbevolen procedures waarmee u de installatie van Microsoft Dynamics NAV veiliger kunt maken. In de volgende lijst worden enkele belangrijke problemen genoemd die zich kunnen voordoen bij de integratie van Microsoft Dynamics NAV met Microsoft Dynamics Mobile:

  • Voer de SQL Server-service als de NT Authority-\Network Service-account uit.

  • Beveilig uw netwerk met firewalls.

  • Stel een Application Server-instance in voor elke Microsoft Dynamics NAV-rol waarmee documenten vanaf mobiele apparaten worden verzonden, zodat Application Server alleen de toegang heeft die door de rol wordt bepaald. Als u bijvoorbeeld een rol, zoals S&R-Q/O/I/R/C, toewijst aan een groep Mobile-gebruikers, kunt u een Application Server-instance maken en die instance toewijzen aan de rol S&R-Q/O/I/R/C.

    Vervolgens moet u in de configuratie van Microsoft Dynamics Mobile-documentservice voor serveronderdelen eindpunten definiëren die specifiek zijn voor elk van de relevante rollen. Deze eindpunten moeten wijzen naar het juiste Application Server-exemplaar. Zie de Microsoft Dynamics Mobile Installation and Configuration Guide online voor meer informatie.

  • Wijs beveiligingsrollen toe aan Mobile-gebruikers waarmee alleen toegang wordt verleend voor datgene wat absoluut noodzakelijk is. Zie Vooraf gedefinieerde Mobile-beveiligingsrollen voor meer informatie.

  • Zorg ervoor dat de documenthandlers die inkomende aanvraagdocumenten verwerken, controleren of de Mobile-gebruiker de juiste machtigingen heeft om de aanvraag te verwerken. Als het inkomende aanvraagdocument bijvoorbeeld is bedoeld voor het maken van een verkooporder, moet aan de gebruiker die het aanvraagdocument heeft verstuurd, beveiligingsrollen zijn toegewezen die toegang tot de relevante tabellen geven. Zie Documenthandlers definiëren in Microsoft Dynamics NAV voor meer informatie.

In de volgende lijst staan tips voor het definiëren van veilige Mobile-gebruikers in Microsoft Dynamics NAV:

  • De verkopers die Mobile-gebruikers zijn, worden toegevoegd aan een Active Directory-groep.

    Pas op Pas op

    Voor integratie met Microsoft Dynamics Mobile moet het verbeterde beveiligingsmodel door de Microsoft Dynamics NAV-database worden uitgevoerd. Dit betekent dat gebruikers alleen lid van beveiligingsgroepen in hun eigen domein kunnen zijn. Als er voor uw bedrijf bijvoorbeeld twee Active Directory-domeinen zijn gedefinieerd, domein A en domein B, kan een gebruiker uit domein A niet worden toegevoegd aan een beveiligingsgroep in domein B.

  • De Active Directory-groep is een Windows-aanmelding in Microsoft Dynamics NAV. Deze aanmelding heeft de juiste beveiligingsrollen waarmee leden aanvraagdocumenten vanaf mobiele apparaten kunnen versturen.

  • Ieder lid van de Active Directory-groep wordt ook toegevoegd als een Windows-aanmelding in Microsoft Dynamics NAV en aan ieder lid worden de basismachtigingen zoals de ALL-rol toegewezen.

    De groepsleden nemen de machtigingen van de Windows-aanmelding voor de Active Directory-groep over. Wijs dus niet dezelfde beveiligingsrollen aan iedere gebruiker afzonderlijk toe.

  • De afzonderlijke Windows-aanmeldingen worden als Mobile-gebruikers ingesteld.

  • Er is een Mobile-groep en de Mobile-gebruikers zijn lid van die groep.

  • Er wordt een documentsoort ingesteld en de Mobile-groep wordt aan die documentsoort toegewezen.

Zie de volgende onderwerpen voor meer informatie:

Microsoft Dynamics NAV | Microsoft Dynamics NAV Classic
Procedure: Mobile-gebruikers in Microsoft Dynamics NAV instellen | Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Procedure: Mobile-groepen in Microsoft Dynamics NAV instellen | Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV instellen | Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen
 | Documenthandlers in Microsoft Dynamics NAV definiëren

Vooraf gedefinieerde Mobile-beveiligingsrollen

Microsoft Dynamics NAV wordt geleverd met de volgende vooraf gedefinieerde beveiligingsrollen. Al deze rollen zorgen voor beveiliging op objectniveau door toegang tot tabellen te verlenen.

Rol | Omschrijving | Toewijzen aan
MOB-SERVER-NAS | Machtigt de gebruiker om inkomende aanvragen te valideren en om aanvragen aan de documentenwachtrij toe te voegen. | De gebruikersaccount waaronder Application Server wordt uitgevoerd.
MOB-SERVER-SETUP | Machtigt de gebruiker om Mobile-functionaliteit in Microsoft Dynamics NAV in te stellen en bij te werken, waaronder het instellen van Mobile-gebruikers, documentsoorten en documentschema's. | Gebruikers die Mobile-functionaliteit op servers instellen en bijwerken.
MOB-SERVER-USER | Machtigt de gebruiker met leestoegang voor mobiele tabellen. Met deze rol kunnen gebruikers ook aanvragen in de documentenwachtrij wijzigen en uit deze wachtrij verwijderen. | Gebruikers die de documentenwachtrij verwerken en bijwerken.
MOB-SALES-CUST-PRICE | Machtigt de gebruiker om klantenprijzen in Mobile Sales bij te werken. | Gebruikers die de lijst Mobile - Klantenprijs maken uitvoeren om eenheidsprijzen per artikel en per klant voor de mobiele toepassing toe te voegen.
MOB-SALES-SETUP | Machtigt de gebruiker om Mobile Sales-functionaliteit in te stellen en bij te werken, zoals of activiteiten van Mobile Sales automatisch moeten worden bijgewerkt wanneer taken worden bijgewerkt. | Gebruikers die Mobile-functionaliteit op servers instellen en bijwerken.
MOB-SALES-SYNC-TODO | Machtigt de gebruiker om de tabel Mobile-verkoopactiviteit bij te werken via de tabel Taak. | Gebruikers die het rapport Mobile - Sync. Te doen/activiteit synchr. uitvoeren om taken met activiteiten van Mobile Sales te synchroniseren

Zie Rechten voor rollen wijzigen voor meer informatie over het weergeven van de lijst met tabellen waartoe een rol toegang geeft. Zie de Microsoft Dynamics NAV 2009 Developer and IT Pro Documentation voor meer informatie over beveiligingsrollen en beveiliging.

Zie ook

Overige informatiebronnen

Toegangsrechten voor rollen wijzigen


Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen

Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Zie ook

U kunt in Microsoft Dynamics NAV instellen dat gebruikers gegevens van mobiele apparaten kunnen benaderen. In het venster Rollen moet u eerst beveiligingsrollen toewijzen aan Windows-aanmeldingen om gebruikerstoegang aan Mobile-functionaliteit toe te wijzen. Vervolgens moet u in het venster Mobile-gebruikers mobiele aanmeldingen koppelen aan de verkopercodes en de taal voor de mobiele toepassing.

Opmerking Opmerking

Voordat u Mobile-gebruikers kunt instellen, moet u eerst een of meer gebruikers in het venster Windows-aanmeldingen instellen. Zie Windows-aanmeldingen maken voor meer informatie. U kunt echter ook database-aanmeldingen maken en vervolgens de gebruikersrechten via Windows-groepen toewijzen alvorens die als Mobile-gebruikers in te stellen.

In de volgende procedures wordt beschreven hoe mobiele beveiligingsrollen aan gebruikers worden toegewezen en hoe Mobile-gebruikers worden ingesteld.

Mobiele beveiligingsrollen aan gebruikers toewijzen

  1. Klik op Extra, wijs Beveiliging aan en klik vervolgens op Rollen. Het venster Rollen wordt weergegeven.

    In het venster Rollen staan alle Microsoft Dynamics NAV-rollen, waaronder de volgende mobiele beveiligingsrollen:

    • MOB-SERVER-NAS

    • MOB-SERVER-SETUP

    • MOB-SERVER-USER

    • MOB-SALES-CUST-PRICE

    • MOB-SALES-SETUP

    • MOB-SALES-SYNC-TODO

    Zie Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV voor meer informatie.

  2. Selecteer de rol die u aan gebruikers wilt toewijzen, klik op Rol en klik vervolgens op Windows-aanmeldingen.

    Het venster Windows-aanmeldingen voor deze rol verschijnt. In dit venster staan alle Windows-gebruikers en -groepen die deze rol in Microsoft Dynamics NAV al hebben.

  3. Selecteer een lege rij als u een Windows-gebruiker of -groep aan de lijst wilt toevoegen.

  4. Klik op de AssistButton in het veld Aanmeldings-ID om het venster Windows-aanmelding te openen.

    Dit venster bevat een overzicht van alle Windows-gebruikers en -groepen die zich bij Microsoft Dynamics NAV kunnen aanmelden.

  5. Selecteer de gebruiker aan wie u deze Microsoft Dynamics NAV-rol wilt toewijzen, en klik op OK.

    Deze gebruiker of groep wordt nu toegevoegd aan de lijst die in het venster Windows-aanmelding voor de rol wordt weergegeven.

Mobile-gebruikers instellen

  1. Klik in het navigatiedeelvenster op Administratie.

  2. Klik achtereenvolgens op Applicatie-instellingen, Mobile en Gebruikers.

  3. Klik in het venster Mobile-gebruikers in het veld Gebruikers-id op de AssistButton. Het venster Windows-aanmelding Mobile-gebruikers wordt geopend. In dit venster staan alle Windows-gebruikers en -groepen waaraan een mobiele beveiligingsrol is toegewezen, zoals in de vorige sectie wordt beschreven.

  4. Selecteer de gebruiker die u wilt instellen, en klik op OK.

  5. Vul in het venster Mobile-gebruikers de volgende velden in voor de gebruiker die u zojuist hebt toegevoegd:

    Veld Omschrijving

    Verkoper

    De verkopercode waaraan de gebruiker is gekoppeld.

    Verkopernaam

    De naam van de verkoper. Dit veld is alleen-lezen.

    Taalcode

    De code voor de taal die de primaire taal voor deze gebruiker is.

    Dit veld bepaalt welke taalcode voor deze Mobile-gebruiker wordt gebruikt. Om de veldwaarden correct weer te geven moet u de vertalingen voor het optieveld instellen. Zie Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

De aanvankelijke Windows-aanmelding is nu een Mobile-gebruiker. Om gebruikers toegang tot Mobile-functionaliteit te verlenen moet u Mobile-groepen definiëren en gebruikers aan die groepen toevoegen. Mobile-groepen worden gebruikt om gebruikers de mogelijkheid te geven met Mobile-documenten te werken. Zie Procedure: Mobile-groepen in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Zie ook

Taken

Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen
Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen

Referentie

Mobile-gebruiker (tabel)
Windows-aanmelding Mobile-gebruiker (tabel)

Concepten

Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV
Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic

Overige informatiebronnen

Overzicht van Microsoft Dynamics Mobile - Mobile Development Tools - Server Components


Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen

Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen
Zie ook

Als gebruikers in Microsoft Dynamics NAV als Mobile-gebruikers worden ingesteld, kunt u die gebruikers aan Mobile-groepen toevoegen waardoor het gemakkelijker is om toegangsrechten bij te houden. Wanneer u bijvoorbeeld een documentsoort definieert, wijst u gebruikersrechten toe door een of meer Mobile-groepen aan de documentsoort toe te voegen.

Opmerking Opmerking

Voordat u gebruikers aan Mobile-groepen kunt toewijzen, moet u een of meer gebruikers in het venster Mobile-gebruikers instellen. Zie Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Een Mobile-groep definiëren

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Groepen.

  2. Vul in het venster Mobile-groepen de volgende velden in:

    Veld Omschrijving

    Code

    Een code voor de groep.

    Naam

    Een omschrijvende naam voor de groep.

    U kunt nu gebruikers aan de groep toevoegen, zoals in de volgende procedure wordt beschreven.

Gebruikers aan een Mobile-groep toevoegen

  1. Klik in het venster Mobile-groepsgebruikers in het veld Mobile-gebruikers-id op de AssistButton. Het venster Mobile-gebruikers wordt geopend.

  2. Selecteer in het venster Mobile-gebruikers de gebruikers die u aan deze groep wilt toevoegen, en klik op OK.

    Opmerking Opmerking

    Per keer kunt u slechts één gebruiker toevoegen.

  3. Herhaal stap 1 en 2 voor de overige gebruikers die u aan de groep wilt toevoegen.

    Wanneer u alle relevante gebruikers aan de groep hebt toegevoegd, kunt u met de groep gebruikersrechten aan een documentsoort toewijzen.

Zie ook

Taken

Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Procedures: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile-groep (tabel)
Mobile-groepsgebruiker (tabel)

Concepten

Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic
Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV


Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen

Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen
Zie ook

Wanneer Mobile-gebruikers mobiele toepassingen gebruiken die worden geïntegreerd met Microsoft Dynamics NAV, kunnen foutmeldingen en waarden voor optievelden worden weergegeven in de talen die door Microsoft Dynamics NAV worden ondersteund.

Om talen voor Mobile-gebruikers in te stellen moet u eerst opgeven welke talen er beschikbaar zijn. Vervolgens moet u opgeven welke taal door iedere Mobile-gebruiker wordt gebruikt. Ook moet u opgeven welke tabellen met optievelden in de mobiele toepassingen worden gebruikt om de correcte vertaling van de tekst van het optieveld te krijgen. Zie Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Talen voor Mobile-gebruikers instellen

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Talen.

  2. Klik in het venster Mobile - Talen in het veld Codes op de AssistButton. Het venster Talen wordt geopend.

    Opmerking Opmerking

    In het venster Talen staan alle talen die worden ondersteund. U moet echter alleen die talen instellen waarvoor er in de toepassing vertalingen zijn.

  3. Selecteer de primaire taal voor uw toepassing, zoals ENU voor Engels (Verenigde Staten) en klik op OK.

  4. Herhaal stap 2 en 3 voor de andere talen die u wilt definiëren.

De talen die u instelt in het venster Mobile - Talen, staan in het veld Taalcode in het venster Mobile-gebruikers. Zie Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie. Om de optieveldwaarden in de juiste talen weer te geven moet u het gebruik van het optieveld instellen. Zie Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Zie ook

Taken

Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile - Talen (tabel)

Concepten

Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic


Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen

Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Zie ook

Mobiele apparaten die worden geïntegreerd met Microsoft Dynamics NAV, kunnen velden bevatten waar de mogelijke waarden optiereeksen zijn. Deze optiereeksen bevatten tekstreeksen die in diverse talen op een mobiel apparaat kunnen worden weergegeven. Om er zeker van te zijn dat de optiereeksen correct op het mobiele apparaat worden weergegeven, moet u eerst opgeven welke talen er voor de toepassing beschikbaar zijn en vervolgens voor iedere gebruiker de gewenste taal opgeven. Zie Procedure: Talen voor Mobile-gebruikers in Microsoft Dynamics NAV instellen en Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie. Vervolgens moet u opgeven in welke tabellen de optievelden staan die in de mobiele toepassingen worden gebruikt, om er zeker van te zijn dat de veldwaarden de juiste vertaling bevatten. Als er in het optieveld geen vertaling voor een geselecteerde taal staat, is Engels (Verenigde Staten) de standaardtaal. In de volgende procedure wordt beschreven hoe het gebruik van het optieveld voor vertalingen wordt ingesteld en hoe u de vertaalde optiereeksen kunt bekijken om het ingestelde gebruik van het optieveld te verifiëren.

Gebruik van een optieveld voor Mobile-gebruikers instellen

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Optieveld instellen.

  2. Klik in het venster Mobile - Optieveld instellen in het veld Taberlnr. op de AssistButton. Selecteer in de lijst Objecten de tabel die door de mobiele toepassing wordt gebruikt en waarin de optievelden staan, en klik op OK. Een van de tabellen in die lijst is de tabel Artikel.

  3. Klik in het venster Mobile - Optieveld instellen in de rij voor de tabel die u in de vorige stap hebt geselecteerd, in het veld Veldnr. op de AssistButton. Selecteer in het veld Mobile-veldoverzicht het veld dat door de mobiele toepassing wordt gebruikt, bijvoorbeeld het veld Waarderingsmethode.

    In het venster Mobile - Optieveld instellen staan nu de volgende gegevens:

    Veld Waarde

    Tabelnr.

    De object-id van de tabel, bijvoorbeeld 27.

    Tabelnaam

    De naam van de tabel, bijvoorbeeld Artikel.

    Veldnr.

    De id van het optieveld, bijvoorbeeld 21.

    Veldnaam

    De naam van het optieveld, bijvoorbeeld Waarderingsmethode.

    Optiereeks

    De waarden voor het optieveld, zoals FIFO, LIFO, Specifiek, Gemiddeld, Standaard.

  4. Herhaal stap 2 en 3 voor de andere optievelden die u wilt definiëren.

Dit is de procedure voor het instellen van het gebruik van optievelden voor een mobiele toepassing. Als u talen voor optievelden hebt ingesteld en u hebt voor iedere Mobile-gebruiker een taal opgegeven, ziet de Mobile-gebruiker de optiereeks in die taal.

In de volgende procedure wordt beschreven hoe u de vertaalde strings voor de optievelden kunt weergegeven en kunt controleren of het gebruik voor de optiereeksen correct is ingesteld.

De vertaalde strings voor een optieveld weergeven

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Optieveld instellen.

  2. Klik in het venster Mobile - Optieveld instellen op een rij en klik vervolgens op Veld en Vertalingen.

    In het veld Overzicht Mobile-optieveldbijschriften staat voor elk optieveld de vertaling in de talen die u in het venster Mobile - Talen hebt opgegeven. Als er in het optieveld geen vertaling voor een geselecteerde taal staat, is Engels (Verenigde Staten) de standaardtaal. Zie Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen voor meer informatie.

    Opmerking Opmerking

    De strings worden alleen in de opgegeven taal weergegeven als u de strings in die taal hebt vertaald. Als uw bedrijf bijvoorbeeld in Spanje is gevestigd, kunt u de strings weergeven in het Engels (Verenigde Staten) en in het Spaans. Als u dus wilt dat uw Mobile-gebruikers de strings ook in het Portugees kunnen weergeven, moet u een taalmodule met de strings vertaald in het Portugees toevoegen.

Zie ook

Taken

Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen
Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile - Optieveld instellen (tabel)
Bijschrift Mobile-optieveld (tabel)

Concepten

Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic


Procedures: Mobile - Documentsoorten in Microsoft Dynamics NAV Classic instellen

Procedures: Mobile - Documentsoorten in Microsoft Dynamics NAV Classic instellen
Zie ook

In Microsoft Dynamics NAV kunnen Mobile-gebruikers gegevens vanaf een mobiel apparaat als aanvraagdocumenten naar de server versturen. U kunt aanvraagdocumenten ontvangen als u een aanvraagdocument als een documentsoort in het venster Mobile - Documentsoorten hebt ingesteld. Wanneer u een documentsoort definieert, hebt u het volgende nodig:

  • Reeds gedefinieerde Mobile-groepen. U kunt Mobile-groepen ook als onderdeel van het definiëren van de documentsoort maken.

  • Reeds gedefinieerde XML-schema's voor het valideren van inkomende aanvraagdocumenten. U kunt schema's ook als onderdeel van het definiëren van de documentsoort maken.

    Deze stap is optioneel.

  • Gedefinieerde codeunits voor verwerkingen van documenten.

    Opmerking Opmerking

    Documenthandlers en documentsoorten zijn nauw met elkaar verbonden. De naam van de documentsoort wordt in de codeunit gebruikt en de naam van de codeunit wordt gebruikt wanneer u de documentsoort definieert.

Microsoft Dynamics NAV bevat een aantal vooraf gedefinieerde documentsoorten voor Microsoft Dynamics® Mobile – Mobile Sales die u kunt gebruiken of wijzigen.

Een documentsoort definiëren

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentsoorten.

  2. Vul in het venster Mobile - Documentsoorten de volgende velden in:

    Veld Omschrijving

    Aanvraagsoort

    De naam van de documentsoort, bijvoorbeeld CreateCustomer.

    Omschrijving

    Een beschrijving van de documentsoort, bijvoorbeeld Maakt documenten op basis van mijn documenthandler.

    Strikte schemavalidatie

    Als dit veld op Waar is ingesteld, wordt het schema strikt gevalideerd; bij Onwaar niet. Als u dit veld niet invult en u wijst een schema aan de documentsoort toe, wordt er door de documentsoort een minder strikte schemavalidatie gebruikt. Zie Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven voor meer informatie.

    Processoort

    Bij Direct worden documenten verwerkt zodra zij de documentenwachtrij binnenkomen en bij Wachtrij worden de documenten op een later tijdstip verwerkt. Zie Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken voor meer informatie.

    Verwerkende codeunit

    De object-id voor de codeunit die het aanvraagdocument verwerkt. Zie Documenthandlers definiëren in Microsoft Dynamics NAV voor meer informatie.

    Naam verwerkende codeunit

    De naam van de codeunit. Dit veld is alleen-lezen.

    U kunt nu gebruikersgroepen en zonodig XML-schema's aan de documentsoort toevoegen.

Gebruikersgroepen aan een documentsoort toevoegen

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentsoorten.

  2. Selecteer in het venster Mobile - Documentsoorten de documentsoort die u aan de gebruikersgroepen wilt toevoegen, en klik vervolgens op Doc.-type en Groepen.

  3. Klik in het venster Mobile - Documentsoorten in het veld Groepcode op de AssistButton.

  4. Selecteer in het venster Mobile - Groepen de groep waaraan u machtigingen voor deze documentsoort wilt toewijzen, en klik op OK.

    Opmerking Opmerking

    In het venster Mobile - Groepen kunt u gedefinieerde groepen toevoegen of nieuwe groepen maken. Zie Procedure: Mobile-groepen in Microsoft Dynamics NAV Classic instellen voor meer informatie.

  5. Herhaal stap 2 t/m 4 voor alle andere groepen die u aan de documentsoort wilt toevoegen.

Een XML-schema aan een documentsoort toevoegen

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentsoorten.

  2. Selecteer in het venster Mobile - Documentsoorten de documentsoort die u aan een XML-schema wilt toevoegen, en klik vervolgens op Doc.-type en Schema's.

  3. Klik in het venster Mobile-documentsoortschema's in het veld Documentschema op de AssistButton.

  4. Selecteer in het venster Mobile - Documentschema's de schema's die u aan de documentsoort wilt toevoegen, en klik op OK.

    Opmerking Opmerking

    In het venster Mobile - Documentschema's kunt u gedefinieerde schema's toevoegen of nieuwe schema's definiëren. Zie Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven voor meer informatie.

  5. Herhaal stap 2 t/m 4 voor alle andere documentsoorten waaraan u schema's wilt toevoegen.

Zie ook

Taken

Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen
Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven
Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken

Referentie

Mobile - Documentsoort (tabel)
Mobile-documentsoortschema (tabel)

Concepten

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
Documenthandlers in Microsoft Dynamics NAV definiëren

Overige informatiebronnen

Overzicht Mobile Development Tools - Server Components


Procedure: Projecten plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic

Procedure: Projecten plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic
Zie ook

In Microsoft Dynamics NAV Classic kunt u verwerkingen plannen die op bepaalde tijden moeten worden uitgevoerd om de Mobile-documentenwachtrij te verwerken of de tabellen bij te werken die Mobile Sales nodig heeft om de gegevens op het mobiele apparaat te kunnen bijwerken met de gegevens in de Microsoft Dynamics NAV-database. Wanneer u een herhalende taak aan de verwerkingswachtrij toevoegt, wordt de codeunit of de batchverwerking automatisch uitgevoerd volgens het opgegeven schema. Zie Kaart voor verwerkingswachtrijpost (venster) voor meer informatie.

Een taak inplannen om aanvraagdocumenten te verwerken

  1. Klik in het navigatiedeelvenster op de knop Administratie en klik achtereenvolgens op Applicatie-instellingen, Verwerkingswachtrij en Verwerkingswachtrijposten.

  2. Druk in het venster Kaart voor verwerkingswachtrijpost op F3 om een nieuwe taak te maken.

  3. Vul op het tabblad Algemeen de volgende velden in:

    Veld Waarde

    Uit te voeren objectsoort

    Codeunit

    Uit te voeren object (id)

    De id van de codeunit, zoals 8702, om de codeunit Mobile Queue Processor uit te voeren.

    Parametertekenreeks

    De parameters die u wilt definiëren om de omvang van de taak te beperken, bijvoorbeeld een Mobile-gebruiker of een documentsoort.

    Maximum aantal uitvoeringspogingen

    Het toegestane aantal pogingen, bijvoorbeeld 2.

    Verloopdatum/-tijd

    De laatste dag waarop de taak wordt uitgevoerd.

    Vroegste datum/tijd

    De eerste dag waarop de taak wordt uitgevoerd.

    Prioriteit

    De prioriteit van de taak vergeleken met andere verwerkingen in de verwerkingswachtrij, bijvoorbeeld 1.

  4. Geef op het tabblad Periodiek het terugkeerpatroon van de taak op.

De taak wordt nu uitgevoerd volgens het schema dat u hebt opgegeven.

In Microsoft Dynamics NAV kunt u ook batchverwerkingen plannen om de tabellen bij te werken die Mobile Sales nodig heeft om de gegevens op het mobiele apparaat te kunnen synchroniseren met de gegevens in de Microsoft Dynamics NAV-database.

Een taak plannen voor het uitvoeren van een batchverwerking om een Mobile Sales-tabel bij te werken

  1. Klik in het navigatiedeelvenster op de knop Administratie en klik achtereenvolgens op Applicatie-instellingen, Verwerkingswachtrij en Verwerkingswachtrijposten.

  2. Druk in het venster Kaart voor verwerkingswachtrijpost op F3 om een nieuwe taak te maken.

  3. Vul op het tabblad Algemeen de volgende velden in:

    Veld Waarde

    Uit te voeren objectsoort

    Rapport

    Uit te voeren object (id)

    De id van de batchverwerking, zoals 8726, om de batchverwerking Mobile-wachtrijprocessor uit te voeren. De batchverwerking Te doen/activiteit of 8725 om de batchverwerking Mobile - Klantenprijs maken uit te voeren.

    Parametertekenreeks

    De parameters die u wilt definiëren om de omvang van de taak te beperken.

    Maximum aantal pogingen

    Het toegestane aantal pogingen, bijvoorbeeld 2.

    Vervaldatum/-tijd

    De laatste dag waarop de taak wordt uitgevoerd.

    Vroegste datum/tijd

    De eerste dag waarop de taak wordt uitgevoerd.

    Prioriteit

    De prioriteit van de taak vergeleken met andere verwerkingen in de verwerkingswachtrij, bijvoorbeeld 1.

  4. Geef op het tabblad Periodiek het terugkeerpatroon van de taak op.

De taak wordt nu uitgevoerd volgens het schema dat u hebt opgegeven.

Zie ook

Taken

Procedure: Application Server voor Microsoft Dynamics NAV configureren voor het gebruik van de Mobile Queue Processor

Referentie

Batchverwerking Mobile - Sync. Te doen/activiteit synchr.
Batchverwerkingen voor klantenprijzen mobiel maken

Concepten

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken

Overige bronnen

Kaart voor verwerkingswachtrijpost (venster)


De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
Zie ook

Microsoft Dynamics® Mobile – Serveronderdelen beheert de interactie tussen mobiele apparaten en Microsoft Dynamics NAV. Mobiele apparaten sturen gegevens en aanvragen als XML-documenten, ook wel aanvraagdocumenten genoemd, terug naar de server. In Microsoft Dynamics NAV wordt de integratie voltooid door toepassingsobjecten, die documenthandlers en documentsoorten worden genoemd. Zie Documenthandlers definiëren in Microsoft Dynamics NAV en Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven voor meer informatie.

Alle aanvraagdocumenten die van mobiele apparaten naar Microsoft Dynamics NAV worden verstuurd, worden in een documentenwachtrij opgeslagen. De documentenwachtrij geeft u een overzicht van alle verstuurde aanvragen en de verwerkingsstatus van die aanvragen. In deze sectie wordt een overzicht gegeven van de manier waarop aanvraagdocumenten kunnen worden verwerkt, en van de aanvraagdocumentenwachtrij.

Opmerking Opmerking

Om tijdens de uitvoering Mobile-functionaliteit te kunnen gebruiken moet u Microsoft Dynamics® Mobile installeren en configureren. Zie de Microsoft Dynamics Mobile Installation and Configuration Guide onl voor meer informatie.

De aanvraagdocumentenwachtrij controleren

Wanneer een gebruiker een aanvraag vanaf een mobiel apparaat verstuurt, wordt deze aanvraag door de Mobile-documentenservice aan de aanvraagdocumentenwachtrij in Microsoft Dynamics NAV toegevoegd. De mobiele toepassing op het apparaat kan gegevens aanvragen of kan aanvragen dat gegevens worden gemaakt, bijgewerkt of verwijderd.

Alle aanvraagdocumenten worden eerst naar de tabel Mobile-documentenwachtrij verstuurd en vervolgens pas verwerkt. De aanvraagdocumenten kunnen op twee manieren worden verwerkt (zie de volgende tabel).

Manier van verwerken | Omschrijving
Directe verwerking | Een aanvraagdocument wordt naar de documentenwachtrij verstuurd en onmiddellijk verwerkt. Het resultaat daarvan wordt naar het mobiele apparaat verstuurd.
Verwerking in de wachtrij | Een aanvraagdocument wordt naar de documentenwachtrij verstuurd en pas verwerkt op aangeven van de gebruiker of de documentenwachtrijprocessor.

Met het venster Documentenwachtrijoverzicht kunt u alle aanvraagdocumenten in de documentenwachtrij controleren. Dit venster is een logboek waarin de status van de aanvraagdocumenten staat. Verwerkte aanvraagdocumenten blijven met de status Voltooid in de documentenwachtrij staan totdat zij handmatig worden verwijderd. Zie Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic opnieuw instellen en verwijderen voor meer informatie.

Beveiliging

Wanneer een gebruiker een aanvraagdocument naar Microsoft Dynamics NAV verstuurt, wordt de toegang van die gebruiker tot de specifieke documentsoort door de Mobile Document Dispatcher gevalideerd. Als de Mobile-gebruiker geen lid is van een Mobile-groep die aan die documentsoort is toegewezen, wordt de aanvraag geweigerd. Aanvraagdocumenten die in de wachtrij staan, worden opnieuw gevalideerd wanneer zij worden verwerkt. Voordat een aanvraagdocument wordt verwerkt, kan de toegang van de Mobile-gebruiker tot de tabellen ook door een documenthandler worden gevalideerd.

Als de vereiste gebruikersrechten tussen de tijd van verzending en de tijd van verwerking van het document niet waren toegewezen, wordt het document niet door de documentenwachtrijprocessor verwerkt en verschijnt er een foutmelding. De beheerder moet dan de vereiste gebruikersrechten toewijzen of het aanvraagdocument verwijderen.

Mobile-documentenwachtrij

In het venster Mobile-documentenwachtrijoverzicht kunt u een aanvraagdocument wijzigen dat nog niet is verwerkt. Dit is nodig als er zich een fout voordoet wanneer u dat document voor de eerste keer probeert te verwerken. U kunt de status ook opnieuw instellen, een aanvraagdocument verwijderen en aanvraagdocumenten handmatig als XML-documenten importeren en exporteren.

Zie Mobile-documentenwachtrij (tabel) voor meer informatie over de velden van de documentenwachtrij.

Zie ook

Taken

Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken
Procedure: Een Mobile-document wijzigen voordat het in Microsoft Dynamics NAV Classic wordt verwerkt
Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic importeren en exporteren
Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic opnieuw instellen en verwijderen
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen
Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile-documentenwachtrij (tabel)

Concepten

Documenthandlers in Microsoft Dynamics NAV definiëren

Overige informatiebronnen

Microsoft Dynamics NAV Classic integreren met Microsoft Dynamics Mobile
Overzicht Mobile Development Tools - Server Components


Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven

Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven
Zie ook

In Microsoft Dynamics NAV wordt de communicatie tussen mobiele apparaten en de server verwerkt door XML-documenten die aanvraagdocumenten worden genoemd. Om aanvraagdocumenten te kunnen ontvangen moet u een aanvraagdocument als een documentsoort definiëren. Zie Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie. Voor de validatie van invoer van mobiele apparaten kunt u schema's op de documentsoorten toepassen. Deze schema's valideren de inkomende XML-documenten en zorgen ervoor dat deze documenten de verwachte elementen bevatten en dat elke elementwaarde overeenkomt met de gegevenssoort voor die waarde. Wanneer zowel de mobiele toepassing als de documentsoort zich aan dezelfde schema's houdt, worden gegevens gemakkelijker uitgewisseld.

U kunt documentschema's importeren voordat u documentsoorten definieert of u kunt de schema's tijdens het definiëren van de documentsoorten importeren.

Opmerking Opmerking

Documentsoorten werken ook zonder schema's, maar als u een schema aan een documentsoort toevoegt, worden er een validatielaag en een bepaalde mate van beveiliging aan de documentverwerking toegevoegd, omdat alleen een goed ingedeeld XML-document dat overeenkomt met het schema, door de onderliggende documenthandler kan worden verwerkt. Het alternatief is dat u de XML_validatie aan de documenthandler moet toevoegen. Zie Documenthandlers definiëren in Microsoft Dynamics NAV voor meer informatie.

Als u een documentschema importeert, hebt u een XSD-bestand nodig dat een schema definieert met een geldige naamruimte. Microsoft Dynamics NAV bevat schema's voor Microsoft Dynamics® Mobile – Mobile Sales en een voorbeeldschema voor Mobile Development Tools – Serveronderdelen.

In het venster Mobile - Documentschema's in Microsoft Dynamics NAV kunt u het volgende doen:

  • Een documentschema importeren

  • Bestaande schema's bekijken

  • Een schema exporteren, wijzigen en vervolgens weer importeren

Ook kunt u zien bij welke documentsoorten een documentschema wordt gebruikt. In de volgende procedures wordt beschreven hoe u deze taken Microsoft Dynamics NAV uitvoert.

Een documentschema importeren

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentschema's.

  2. Geef in het venster Mobile - Documentschema's in het veld Code een code voor het schema op.

  3. Klik op Schema en klik vervolgens op Importeren om een reeds gedefinieerd XML-schema te importeren.

Een bestaand documentschema weergeven

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentschema's.

  2. Selecteer in het venster Mobile - Documentschema's het documentschema dat u wilt weergeven, en klik vervolgens op Schema en Weergeven.

    Door het schema wordt er een XML-bestand in een venster van Internet Explorer geopend.

Een bestaand documentschema exporteren

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentschema's.

  2. Selecteer in het venster Mobile - Documentschema's het documentschema dat u wilt exporteren, en klik vervolgens op Schema en Exporteren.

    U kunt het schema als een XSD-bestand opslaan. Op deze manier kunt u schema's met andere databases delen of kunt u het schema wijzigen, bijvoorbeeld voor aanpassing met een andere documentsoort, en vervolgens dat schema weer importeren. Zie de eerste procedure in dit onderwerp voor meer informatie over het importeren van documenten.

Zie ook

Taken

Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile-documentschema (tabel)

Concepten

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
Documenthandlers in Microsoft Dynamics NAV definiëren

Overige informatiebronnen

Overzicht Mobile Development Tools - Server Components


Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken

Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken
Zie ook

Wanneer een mobiel apparaat een aanvraag naar de Microsoft Dynamics NAV-toepassing verstuurt, wordt de aanvraag in de tabel Mobile-documentenwachtrij opgeslagen. Afhankelijk van de documentsoort wordt de aanvraag onmiddellijk of op een later tijdstip verwerkt. Zie De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren voor meer informatie. In het venster Mobile-documentenwachtrijoverzicht kunt u de aanvraagdocumenten verwerken die in de tabel Mobile-documentenwachtrij zijn opgeslagen. In de volgende procedures wordt beschreven hoe u alle aanvragen in de Mobile-documentenwachtrij kunt bekijken die van het mobiele apparaat naar Microsoft Dynamics NAV worden verstuurd, en hoe u de aanvragen in de Mobile-documentenwachtrij handmatig kunt verwerken.

De Mobile-documentenwachtrijoverzicht weergeven

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentenwachtrijoverzicht.

  2. Stel in het venster Mobile-documentenwachtrijoverzicht het veld Alles weergeven zo in, dat alle aanvraagdocumenten worden weergegeven of pas een of meer filters toe om de desbetreffende aanvraagdocumenten weer te geven:

    1. U filtert op gebruikers-id door een gebruikers-id in het veld Mobile-gebruikersfilter te selecteren.

    2. U filtert op documentsoort door een documentsoort in het veld Documentsoortfilter te selecteren.

    3. U geeft aanvraagdocumenten op status weer door een of meer van de velden Nieuw, Verwerken, Voltooid of Fout te selecteren.

    Opmerking Opmerking

    Zie De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren voor een beschrijving van de velden in het venster Mobile-documentenwachtrijoverzicht.

Een aanvraag vanuit het venster Mobile-documentenwachtrijoverzicht verwerken

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentenwachtrijoverzicht.

  2. Selecteer in het venster Mobile-documentenwachtrijoverzicht het aanvraagdocument, klik op Functies en vervolgens op Documenten verwerken.

    Opmerking Opmerking

    U verwerkt meerdere documenten door op CTRL+SHIFT te drukken en vervolgens de documenten te selecteren die u wilt verwerken. U kunt ook een filter toepassen, zoals in de vorige sectie wordt beschreven, en alle weergegeven documenten selecteren. Alleen de geselecteerde documenten worden verwerkt.

Zie ook

Taken

Procedure: Een Mobile-document wijzigen voordat het in Microsoft Dynamics NAV Classic wordt verwerkt
Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic opnieuw instellen en verwijderen
Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven

Referentie

Mobile-documentenwachtrij (tabel)
Batchverwerking Mobile-documentprocessor

Concepten

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren
Documenthandlers in Microsoft Dynamics NAV definiëren


Procedure: Een Mobile-document wijzigen voordat het in Microsoft Dynamics NAV Classic wordt verwerkt

Procedure: Een Mobile-document wijzigen voordat het in Microsoft Dynamics NAV Classic wordt verwerkt
Zie ook

Met het venster Mobile-documentenwachtrijoverzicht kunt u een aanvraagdocument wijzigen dat nieuw is of nog niet is verwerkt, en de status wordt weergegeven als Fout. Dit komt van pas als er zich een fout voordoet wanneer u dat document voor de eerste keer probeert te verwerken.

Opmerking Opmerking

Zie Mobile-documentenwachtrij (tabel) voor een beschrijving van de velden in het venster Mobile-documentenwachtrijoverzicht.

Een aanvraagdocument wijzigen voordat het wordt verwerkt

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentenwachtrijoverzicht.

  2. Selecteer in het venster Mobile-documentenwachtrijoverzicht het aanvraagdocument dat u wilt wijzigen, bijvoorbeeld door de juiste filters toe te passen. Zie Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken voor meer informatie.

  3. Klik op Functies en vervolgens op Aanvraag-XML exporteren.

  4. Ga in het venster dat verschijnt, naar de locatie waar u het XML-bestand wilt opslaan, en klik op Opslaan.

  5. Open het geëxporteerde XML-bestand en breng de gewenste wijzigingen aan, bijvoorbeeld elementen toepassen of verwijderen of kenmerken wijzigen.

  6. U importeert het gewijzigde aanvraagdocument door in het venster Mobile-documentenwachtrijoverzicht te klikken op Functies en vervolgens te klikken op Aanvraag-XML exporteren.

    Opmerking Opmerking

    Zorg ervoor dat u het document importeert dat u hebt geëxporteerd.

  7. Ga in het venster dat verschijnt, naar de locatie waar het XML-bestand staat, en klik op Openen.

  8. U verwerkt het gewijzigde aanvraagdocument door in het venster Mobile-documentenwachtrijoverzicht het desbetreffende aanvraagdocument te selecteren en vervolgens te klikken op Functies en Documenten verwerken.

Zie ook

Taken

Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken
Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic opnieuw instellen en verwijderen
Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven
Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven

Referentie

Mobile-documentenwachtrij (tabel)

Concepten

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren


Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic opnieuw instellen en verwijderen

Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic opnieuw instellen en verwijderen
Zie ook

Met het venster Mobile-documentenwachtrijoverzicht kunt u aanvraagdocumenten controleren. Hier kunt u de verwerkingsstatus bijwerken als de verwerking is gestopt, bijvoorbeeld als tijdens de verwerking de verbinding met de database is verbroken. U kunt ook aanvraagdocumenten uit de wachtrij verwijderen, zoals alle verwerkte aanvraagdocumenten met de status Voltooid. Zie De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren voor meer informatie over de pagina Mobile-documentenwachtrijoverzicht.

De status voor een aanvraagdocument opnieuw instellen

  1. Klik in het navigatiedeelvenster in de sectie Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentenwachtrijoverzicht.

  2. Selecteer in het venster Mobile-documentenwachtrijoverzicht het aanvraagdocument waarvoor u de status opnieuw wilt instellen, en klik vervolgens op Functies en Documenten opnieuw instellen.

  3. Klik in het dialoogvenster dat verschijnt, op Ja om de status opnieuw in te stellen. De status van het document wordt ingesteld op Nieuw.

    Doe dit als tijdens het verwerken van een aanvraagdocument de verbinding met de database is verbroken. De status van het document blijft Verwerken, maar de verwerking zelf is gestopt.

Een aanvraagdocument verwijderen

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentenwachtrijoverzicht.

  2. Selecteer in het venster Mobile-documentenwachtrijoverzicht het aanvraagdocument dat u wilt verwijderen, en klik vervolgens op Functies en Documenten verwijderen. Er verschijnt een dialoogvenster waarin u kunt aangeven dat u het aanvraagdocument wilt verwijderen.

    Opmerking Opmerking

    Documenten met de status Verwerken kunnen niet worden verwijderd.

    Pas op Pas op

    Als u een document met de status Nieuw of Fout verwijdert, gaan de gegevens verloren die niet in de database zijn opgeslagen.

Zie ook

Taken

Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken
Procedure: Een Mobile-document wijzigen voordat het in Microsoft Dynamics NAV Classic wordt verwerkt
Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic importeren en exporteren

Referentie

Mobile-documentenwachtrij (tabel)

Concepten

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren


Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic importeren en exporteren

Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic importeren en exporteren
Zie ook

Met het venster Mobile-documentenwachtrijoverzicht kunt u een aanvraagdocument wijzigen dat nog niet is verwerkt. Dit kan van pas komen als er zich een fout voordoet wanneer u probeert dat aanvraagdocument voor de eerste keer te verwerken. Aanvraagdocumenten kunnen handmatig worden gewijzigd, bijvoorbeeld door aanvraagdocumenten handmatig als XML-bestanden te exporteren en vervolgens de XML-bestanden te wijzigen voordat de gewijzigde aanvraagdocumenten opnieuw te importeren. Zie Procedure: Een Mobile-document wijzigen voordat het in Microsoft Dynamics NAV Classic wordt verwerkt voor meer informatie. In de volgende procedures wordt beschreven hoe u aanvraagdocumenten in de Mobile-documentenwachtrij in Microsoft Dynamics NAV importeert en exporteert.

Een XML-bestand van een aanvraagdocument exporteren

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentenwachtrijoverzicht.

  2. Selecteer in het venster Mobile-documentenwachtrijoverzicht het relevante aanvraagdocument, klik op Functies en vervolgens op Aanvraag-XML exporteren.

  3. Selecteer in het venster dat verschijnt, de locatie waar u het XML-bestand wilt opslaan, en klik op Opslaan.

Een XML-bestand van een aanvraagdocument importeren

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Documentenwachtrijoverzicht.

  2. Selecteer in het venster Mobile-documentenwachtrijoverzicht het relevante aanvraagdocument, klik op Functies en vervolgens op Aanvraag-XML exporteren.

  3. Selecteer in het venster dat verschijnt, het XML-bestand en klik vervolgens op Openen.

Zie ook

Taken

Procedures: Mobile-documenten in Microsoft Dynamics NAV Classic verwerken
Procedure: Een Mobile-document wijzigen voordat het in Microsoft Dynamics NAV Classic wordt verwerkt
Procedures: Mobile-aanvraagdocumenten in Microsoft Dynamics NAV Classic opnieuw instellen en verwijderen
Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven

Referentie

Mobile-documentenwachtrij (tabel)

Concepten

De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren


Documenthandlers in Microsoft Dynamics NAV definiëren

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Documenthandlers in Microsoft Dynamics NAV definiëren
Zie ook

Mobiele apparaten kunnen diverse typen aanvraagdocumenten naar Microsoft Dynamics NAV verzenden die door het product moeten kunnen worden verwerkt. De mobiele toepassing kan bijvoorbeeld een aanvraagdocument voor het maken van een nieuwe klant en een aanvraagdocument voor het versturen van een order hebben. Het aanvraagdocument is een XML-bestand. U moet dus een verwerkende codeunit maken die het XML-bestand leest, toegangsrechten verifieert en de desbetreffende bedrijfslogica in Microsoft Dynamics NAV uitvoert. Deze codeunits zijn documenthandlers. Elke documenthandler komt overeen met een of meer documentsoorten. Voordat u de documentverwerkende codeunit maakt, moet u eerst bepalen welke documentsoorten er voor uw toepassing nodig zijn.

Bij een standaardinstallatie bevat Microsoft Dynamics NAV de volgende documenthandlers:

  • Codeunit 8703 Mobile Document Handler

  • Codeunit 8725 Mobile Sales Document Handler

Richtlijnen voor het definiëren van documenthandlers in Microsoft Dynamics NAV

Een documenthandler bevat code die een of meer typen inkomende documenten verwerkt. In de standaardimplementatie bevat de voorbeelddocumenthandler, codeunit 8703 Mobile - Documenthandler, een functie voor het verwerken van documenten, CreateCustomerHandle genaamd, die één type aanvraagdocument dat van een mobiel apparaat is verstuurd, kan verwerken. Codeunit 8725 Mobile Sales Document Handler bevat vier functies voor het verwerken van documenten en kan vier typen aanvraagdocumenten verwerken.

Vereiste code

Een codeunit voor het verwerken van documenten moet code bevatten die het volgende doet:

  • Zorgt ervoor dat de database tijdens het verwerken van het document consistent blijft. Dit wordt doorgaans gedaan door aan het begin van de sectie OnRun de instructie CONSISTENT(FALSE) en aan het eind van de sectie OnRun de instructie CONSISTENT(TRUE) te plaatsen.

  • Geeft op welke documentsoorten door documenthandlers in de codeunit worden verwerkt. Dit wordt doorgaans gedaan door de instructie CASE in de sectie OnRun te plaatsen om elk inkomend XML-document van een bepaalde documentsoort naar de desbetreffende functie voor het verwerken van documenten te sturen.

  • Slaat de resultaten in de Mobile-documentenwachtrij op en verstuurt eventueel een antwoorddocument naar het mobiele apparaat.

Bovendien moet elke functie voor het verwerken van documenten, zoals CreateCustomerHandle in codeunit 8703 Mobile - Documenthandler, het volgende doen:

  • De toegangsrechten controleren van de Mobile-gebruiker die het aanvraagdocument heeft verstuurd. Gebruik de functie CheckPermission van de codeunit Mobile Permission Management om te controleren of de Mobile-gebruiker de juiste toegangsrechten heeft voor elke tabel die door het aanvraagdocument wordt benaderd.

    De codeunit wordt uitgevoerd op de gebruikersaccount voor Microsoft Dynamics NAV Application Server. Over het algemeen zult u de code willen uitvoeren met beperkte toegangsrechten. Met de functie CheckPermission kunt u de toegang tot tabellen beperken.

  • De XML-code in het aanvraagdocument lezen. Gebruik de functie LoadXMLRequestDoc uit de tabel Mobile-documentenwachtrijen om het XML-document te openen. Met de automatiseringsserver Microsoft XML v6.0 moet u lokale variabelen voor het verwerken van het XML-document toevoegen. Zie AUTOMATION in de Microsoft Dynamics NAV 2009 Developer and IT Pro Documentation voor meer informatie.

    In de XML-code staan de taakfuncties die het aanvraagdocument hebben gegenereerd. Doorgaans zult u elke taakfunctie in een afzonderlijke functie willen verwerken. Gebruik de instructie CASE om elk taakfunctiegedeelte van het aanvraagdocument voor verdere verwerking naar een afzonderlijke functie te versturen.

  • De wijzigingen eventueel in het logboek vastleggen. Mobile Sales Document Handler gebruikt de functie LogInsertion uit codeunit 8701 Mobile Document Management om de wijzigingen aan het logboek toe te voegen.

Afhankelijk van het type aanvraagdocument moet u code opnemen die nieuwe records maakt, bestaande records leest of bijwerkt of records voor verwijdering markeert. U kunt deze code in een afzonderlijke functie plaatsen of in dezelfde functie die het XML-document verwerkt. Het maakt niet uit waar u de code plaatst, maar u moet wel de namen van de XML-elementen in het aanvraagdocument en in de Microsoft Dynamics NAV-tabellen weten.

Opmerking Opmerking

Als door Microsoft Dynamics NAV eerst logica moet worden uitgevoerd om de database door het aanvraagdocument te kunnen laten bijwerken, kunt u een tijdelijke tabel voor naverwerking posten voordat de eigenlijke tabellen worden bijgewerkt.

Microsoft Dynamics NAV bevat een voorbeeld van een documenthandler, codeunit 8703 Mobile - Documenthandler, die verzoeken voor het maken van nieuwe klanten kan verwerken. Zie Documentverwerking in Codeunit 8703 voor meer informatie.

Beveiliging

De documenthandler moet ervoor zorgen dat de Mobile-gebruikers de juiste rechten hebben om de aanvraag te kunnen uitvoeren. Als het inkomende aanvraagdocument bijvoorbeeld is bedoeld voor het maken van een verkooporder, moeten aan de gebruiker die het aanvraagdocument heeft verstuurd, beveiligingsrollen zijn toegewezen die toegang tot de desbetreffende tabellen verlenen. Gebruik de functie CheckPermission van de codeunit Mobile Permission Management om te controleren of de Mobile-gebruiker de juiste toegangsrechten heeft voor elke tabel die door het aanvraagdocument wordt benaderd. De functie CheckPermission roept een uitgebreide opgeslagen procedure in de SQL Server-database aan waarmee de toegangsrechten die op Active Directory-groepen zijn gebaseerd, worden gecontroleerd.

Pas op Pas op

Voor integratie met Microsoft Dynamics Mobile moet het verbeterde beveiligingsmodel door de Microsoft Dynamics NAV-database worden uitgevoerd. Dit betekent dat gebruikers alleen lid van beveiligingsgroepen in hun eigen domein kunnen zijn. Als er voor uw bedrijf bijvoorbeeld twee Active Directory-domeinen zijn gedefinieerd, domein A en domein B, kan een gebruiker uit domein A niet worden toegevoegd aan een beveiligingsgroep in domein B. Zie Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV voor meer informatie.

Zie ook

Concepten

Documentverwerking in Codeunit 8703
Documentverwerking voor Mobile Sales

Overige informatiebronnen

Microsoft Dynamics NAV Classic integreren met Microsoft Dynamics Mobile


Documentverwerking in Codeunit 8703

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Documentverwerking in Codeunit 8703
Zie ook

Microsoft Dynamics NAV bevat een voorbeeld van een documenthandler, codeunit 8703 Mobile - Documenthandler, die verzoeken voor het maken van nieuwe klanten verwerkt. Deze voorbeelddocumenthandler ontvangt aanvraagdocumenten van mobiele apparaten waarop de voorbeeldtoepassingen vanuit Microsoft Dynamics® Mobile worden uitgevoerd. In Microsoft Dynamics Mobile worden inkomende aanvraagdocumenten die door documentsoorten zijn gedefinieerd, door documenthandlers verwerkt. Microsoft Dynamics NAV wordt geleverd met vijf voorbeeldocumentsoorten. Zie Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Deze codeunit is een voorbeeld van een eenvoudige documenthandler die een enkel aanvraagdocument verwerkt, maar Microsoft Dynamics NAV bevat ook een complexe documenthandler, codeunit 8725 Mobile Sales Document Handler genaamd, die u in Object Designer kunt bekijken. Zie Documentverwerking voor Mobile Sales voor meer informatie.

In dit onderwerp vindt u voorbeelden van de manier waarop u een documenthandler in Microsoft Dynamics NAV kunt definiëren. Zie Documenthandlers definiëren in Microsoft Dynamics NAV voor meer informatie.

Documentverwerking in Codeunit 8703 Mobile - Documenthandler

Een documenthandler bevat code die een of meer typen inkomende documenten verwerkt. In de standaardimplementatie bevat codeunit 8703 Mobile - Documenthandler een functie voor het verwerken van documenten, CreateCustomerHandle genaamd, die één type aanvraagdocument dat van een mobiel apparaat is verstuurd, kan verwerken. In deze sectie wordt beschreven op welke manier de codeunit voldoet aan de vereisten voor documenthandlers die worden beschreven in Documenthandlers definiëren in Microsoft Dynamics NAV.

In de volgende tabel staan omschrijvingen van de algemene functies in de codeunit.

Naam | Omschrijving
CreateCustomerHandle | Verwerkt de aanvraagdocumenten door toegangsrechten te controleren, de XML te lezen en elk taakfunctiegedeelte aan een afzonderlijke functie door te geven.
CustomerNodeHandle | Verwerkt het gedeelte van het aanvraagdocument waarin een omschrijving van de naam, het e-mailbericht en de kortingsgroep van de klant staat.
CreditLimitNodeHandle | Verwerkt het gedeelte van het aanvraagdocument waarin informatie over het kredietlimiet van klanten staat.
ContactNodeHandle | Verwerkt het gedeelte van het aanvraagdocument waarin een omschrijving van de contactpersoon van de klant staat.
SaveResult | Werkt de Mobile-documentenwachtrij bij en verstuurt een antwoorddocument naar het mobiele apparaat.

Ter illustratie van de manier waarop een inkomend document door deze codeunit wordt verwerkt, worden in dit onderwerp de sectie OnRun en de volgende functies beschreven:

  • CreateCustomerHandle

  • CustomerNodeHandle

  • SaveResult

De functies CreditLimitNodeHandle en ContactNodeHandle zijn gelijk aan de functie CustomerNodeHandle.

De sectie OnRun

Het volgende codevoorbeeld bevat de sectie OnRun van Mobile - Documenthandler.

Afbeelding van code kopiëren Code kopiëren
OnRun(VAR Rec : Record "Mobile-documentenwachtrij")
CONSISTENT(FALSE);

CASE "Documentsoort" OF
  'CreateCustomer':
    CreateCustomerHandle(Rec);
  ELSE
    ERROR(Text000,"Documentsoort");
END;

CONSISTENT(TRUE);

In de sectie OnRun wordt de code op een record in de tabel Mobile-documentenwachtrij uitgevoerd. De code zorgt er met de functie CONSISTENT in C/SIDE voor dat de codeunit als een enkele transactie wordt uitgevoerd. Zie CONSISTENT in de Microsoft Dynamics NAV 2009 Developer and IT Pro Documentation voor meer informatie.

In de switch CASE is CreateCustomer de naam van de documentsoort die door deze codeunit wordt verwerkt. Als de codeunit meerdere documentsoorten ondersteunt, worden die documentsoorten weergegeven in de switch. CreateCustomerHandle is de functie voor het verwerken van documenten waarmee het aanvraagdocument wordt verwerkt.

De functie CreateCustomerHandle

Het volgende codevoorbeeld bevat delen van de functie CreateCustomerHandle van Mobile - Documenthandler.

Eerst worden door de functie de machtigingen gecontroleerd voor de Mobile-gebruiker die het aanvraagdocument heeft verstuurd.

Afbeelding van code kopiëren Code kopiëren
WITH Permission DO
  MobPermissionMgt.CheckPermission(
    MobDocQueue."Mobile-gebruikers-id","Objectsoort"::"Gegevenstabel",DATABASE::Customer,
    "Leesrechten"::" ","Invoegrechten"::Yes,"Wijzigrechten"::" ",
    "Verwijderrechten"::" ","Uitvoerrechten"::" ");

De code laat zien hoe door de functie voor het verwerken van documenten de functie CheckPermission van de codeunit Mobile Permission Management wordt gebruikt om te controleren of de Mobile-gebruiker de juiste toegangsrechten heeft voor elke tabel die door het aanvraagdocument wordt benaderd. In dit voorbeeld moet de Mobile-gebruiker toegangsrechten hebben voor het invoegen van records in de tabel Klant, omdat het aanvraagdocument is bedoeld voor het maken van klanten.

Opmerking Opmerking

Bij deze controle van de toegangsrechten wordt het beveiligingssysteem van Microsoft Dynamics NAV niet vervangen. U moet de juiste beveiligingsrollen aan de Mobile-gebruikers hebben toegewezen.

Vervolgens leest de functie de XML van het aanvraagdocument.

Afbeelding van code kopiëren Code kopiëren
MobDocQueue.LoadXMLRequestDoc(XMLRequestDoc);

XMLRootNode := XMLRequestDoc.documentElement;

XMLNodeList := XMLRootNode.childNodes;

FOR i := 1 TO XMLNodeList.length DO BEGIN
  XMLCurrNode := XMLNodeList.item(i - 1);
  MobXMLMgt.GetAttribute(XMLCurrNode,'name',AttributeValue);
  CASE AttributeValue OF
    'CustomerDetailTasklet': XMLCustomerNode := XMLCurrNode.firstChild;
    'CustomerCreditLimitDetailTasklet': XMLCreditlimitNode := XMLCurrNode.firstChild;
    'CustomerContactDetailTasklet': XMLContactNode := XMLCurrNode.firstChild;
    ELSE
      ERROR(Text001,AttributeValue);
  END;
END;

In de code zijn CustomerDetailTasklet, CustomerCreditLimitDetailTasklet en CustomerContactDetailTasklet namen van taakfuncties in het bestand UserRole.xml voor de mobiele toepassing. In dit voorbeeld is de toepassing de voorbeeldtoepassing Microsoft Dynamics Mobile. Zie de Microsoft Dynamics Mobile Orchestration Guide online voor meer informatie.

De functie CreateCustomerHandle verdeelt het XML-documenten in gedeelten die overeenkomen met de taakfuncties. Elk gedeelte wordt doorgegeven aan een afzonderlijke functie die de bedrijfslogica voor die taakfunctie verwerkt. XMLCustomerNode is bijvoorbeeld het gedeelte van het XML-document dat overeenkomt met de taakfunctie CustomerDetailTasklet. Verderop zult u zien hoe dit wordt verwerkt door de functie CustomerNodeHandle.

Vervolgens voegt de functie een record in de tabel Klant in, roept de drie functies voor het verwerken van elk van de drie taakfunctiegedeelten aan en slaat de gewijzigde records in de tabellen Klant en Mobile-documentenwachtrij op.

Afbeelding van code kopiëren Code kopiëren
Customer.INIT;
Customer.INSERT(TRUE);

CustomerNodeHandle(XMLCustomerNode,Customer);
CreditLimitNodeHandle(XMLCreditlimitNode,Customer);
ContactNodeHandle(MobDocQueue,XMLContactNode,Customer);

Customer.MODIFY(TRUE);

RecRef.GETTABLE(Customer);
MobDocMgt.LogInsertion(MobDocQueue,RecRef);

SaveResult(MobDocQueue,Customer);

In het voorbeeld roept de instructie CustomerNodeHandle(XMLCustomerNode,Customer); de functie CustomerNodeHandle aan en geeft de XML-sectie met de klantgegevens door. SaveResult is een functie waarmee de Mobile-documentenwachtrij wordt bijgewerkt met de resultaten van de verwerking. Dit komt verderop aan de orde.

De functie CustomerNodeHandle

In het volgende codevoorbeeld wordt een taakfunctiegedeelte van het XML-document door een functie verwerkt. In dit voorbeeld is dat de functie CustomerNodeHandle van Mobile - Documenthandler. In Mobile - Documenthandler geeft de functie CreateCustomerHandle het gedeelte van het aanvraagdocument waarin gegevens over de klant staan, door aan de functie CustomerNodeHandle. Dit gedeelte komt overeen met de taakfunctie CustomerDetailTasklet in de voorbeeldtoepassing Microsoft Dynamics Mobile.

Afbeelding van code kopiëren Code kopiëren
MobXMLMgt.FindNode(XMLCustomerNode,'name',XMLCurrNode);
Customer.VALIDATE(Name,XMLCurrNode.text);

MobXMLMgt.FindNode(XMLCustomerNode,'email',XMLCurrNode);
Customer.VALIDATE("E-Mail",XMLCurrNode.text);

MobXMLMgt.FindNode(XMLCustomerNode,'type',XMLCurrNode);
Customer.VALIDATE("Klantenkortingsgroep",XMLCurrNode.text);

In de code is MobXMLMgt is een algemene variabele voor codeunit 8704 Mobile XML DOM Management. De functie CustomerNodeHandle gebruikt de functie FindNode om gegevens over de naam, het e-mailadres en de kortingsgroep van de klant op te halen. Vervolgens roept de functie VALIDATE voor de nieuwe record in de tabel Klant aan om de juiste veldwaarden voor de nieuwe klant in te stellen en die waarden te valideren. Zie VALIDATE in de Microsoft Dynamics NAV 2009 Developer and IT Pro Documentation voor meer informatie.

Opmerking Opmerking

De code in de CustomerNodeHandle geeft beide elementen in het inkomende XML-document en de overeenkomende velden in de tabel Klant op. U kunt het XML-document alleen verwerken als u de structuur ervan kent. De structuur kunt u bekijken in het schema voor de mobiele toepassing. Zie de Microsoft Dynamics Mobile Orchestration Guide online voor meer informatie.

De functie SaveResult

In het volgende codevoorbeeld maakt een functie een antwoord voor een Mobile-gebruiker en werkt de Mobile-documentenwachtrij met de nieuwe status voor het aanvraagdocument bij. In Mobile - Documenthandler wordt de functie SaveResult aangeroepen vanuit de functie CreateCustomerHandle wanneer het aanvraagdocument is verwerkt.

Afbeelding van code kopiëren Code kopiëren
WITH MobDocQueue DO BEGIN  MobDocMgt.CreateXMLResponseDocCompleted(XMLResultDoc,"Bericht-id",STRSUBSTNO(Text002,Customer.TABLECAPTION,Customer."Nr."));  XMLRootNode := XMLResultDoc.documentElement;  MobXMLMgt.AddElement(XMLRootNode,'responseData','',XMLRootNode.namespaceURI,XMLCreatedNode);  MobXMLMgt.AddElement(XMLCreatedNode,'newCustomerAccount',Customer."Nr.",XMLRootNode.namespaceURI,XMLCreatedNode);  SaveXMLResultDoc(XMLResultDoc);  Status := Status::Completed;  MODIFY; END;

De code gebruikt functies van codeunits 8701 Mobile Document Management en 8704 Mobile XML DOM Management om een XML-document te maken dat als een antwoord naar de Mobile-gebruiker wordt verzonden, en werkt vervolgens de record in de tabel Mobile-documentenwachtrij bij.

Zie ook

Referentie

Mobile-documentenwachtrij (tabel)

Concepten

Documenthandlers in Microsoft Dynamics NAV definiëren

Overige informatiebronnen

Klant


Documentverwerking voor Mobile Sales

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Documentverwerking voor Mobile Sales
Zie ook

Microsoft Dynamics NAV bevat vooraf gedefinieerde documenthandlers die inkomende berichten verwerken van mobiele apparaten waarop Microsoft Dynamics® Mobile – Mobile Sales wordt uitgevoerd. De documenthandlers worden als algemene functies in een codeunit gedefinieerd. U kunt de vooraf gedefinieerde documenthandlers aanpassen of nieuwe documenthandlers maken. Zie Documenthandlers definiëren in Microsoft Dynamics NAV voor meer informatie.

Documenthandlers voor activiteiten en verkooporders

Microsoft Dynamics NAV bevat vier vooraf gedefinieerde documenthandlers voor verkoopdocumenten. De documenthandlers worden gedefinieerd in codeunit 8725 Mobile Sales Document Handler. Elke documenthandler bestaat uit twee functies: een functie voor het lezen van het inkomende XML-document en een functie voor het uitvoeren van de bedrijfslogica in Microsoft Dynamics NAV. In de volgende tabel vindt u een beschrijving van de voorgedefinieerde documenthandlers.

Documenthandler Omschrijving

CreateActivityHandle

Verwerkt aanvragen om nieuwe activiteiten te maken.

CreateActivityHandle leest het inkomende XML-document, verifieert toegangsrechten, slaat het document als een nieuwe record in de Mobile-documentenwachtrij op en roept vervolgens CreateActivityNodeHandle met het aanvraagdocument uit die wachtrij, de XML-inhoud en een variabele voor de tabel Taak aan.

CreateActivityNodeHandle voegt in de tabel Taak een nieuwe record met de gegevens uit het aanvraagdocument in en maakt een nieuwe record in de tabel Deelnemer.

ModifyActivityHandle

Verwerkt aanvragen om bestaande activiteiten bij te werken.

ModifyActivityHandle leest het inkomende XML-document, verifieert toegangsrechten, slaat het document als een nieuwe record in de Mobile-documentenwachtrij op en roept vervolgens ModifyActivityNodeHandle met het aanvraagdocument uit die wachtrij, de XML-inhoud en een variabele voor de tabel Taak aan.

ModifyActivityNodeHandle haalt uit de tabel Taak de record op die moet worden gewijzigd, en valideert vervolgens de veldwaarden in het aanvraagdocument met de waarden in de bestaande record. Als de taak door de functie moet worden bijgewerkt, wordt de record als gewijzigd gemarkeerd.

DeleteActivityHandle

Verwerkt aanvragen voor het verwijderen van activiteiten.

DeleteActivityHandle leest het inkomende XML-document, verifieert toegangsrechten, slaat het document als een nieuwe record in de Mobile-documentenwachtrij op en roept vervolgens DeleteActivityNodeHandle met het aanvraagdocument uit die wachtrij, de XML-inhoud en een variabele voor de tabel Taak aan.

DeleteActivityNodeHandle haalt uit de tabel Taak de record op die moet worden verwijderd, en stelt het veld Geannuleerd op Waar in.

CreateOrderHandle

Verwerkt aanvragen voor het maken van nieuwe verkooporders, waaronder handtekening- en verkooporderregels.

ModifyActivityHandle leest het inkomende XML-document, verifieert toegangsrechten, slaat het document als een nieuwe record in de Mobile-documentenwachtrij op en roept vervolgens CreateOrderNodeHandle met het aanvraagdocument uit die wachtrij, de XML-inhoud en een variabele voor de tabel Verkoopkop aan.

CreateOrderNodeHandle voegt in de tabel Verkoopkop een nieuwe record met gegevens uit het aanvraagdocument in, waaronder klantnummer, datums, valuta en de code van de verkoper. Deze code wordt opgehaald uit de tabel Mobile-gebruiker. Als de klant de verkooporder ondertekent, wordt de handtekening als een BLOB in het veld Handtekening opgeslagen. CreateOrderNodeHandle maakt vervolgens voor elke orderregel in het aanvraagdocument een record in de tabel Verkoopregel.

Voordat inkomende aanvraagdocumenten door een documenthandler kunnen worden verwerkt, moet u eerst een documentsoort opgeven. Zie Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie. Microsoft Dynamics NAV bevat een aantal vooraf gedefinieerde documentsoorten voor Mobile Sales die u kunt gebruiken of wijzigen.

Zie ook

Taken

Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile-gebruiker (tabel)

Concepten

Documenthandlers in Microsoft Dynamics NAV definiëren


Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken
Zie ook

In Microsoft Dynamics NAV breidt Mobile Sales gebieden in Verkoop & Marketing uit, zodat een verkoper die bij een klant is, de Microsoft Dynamics NAV-toepassing vanaf een mobiel apparaat kan bijwerken. Gebruikers krijgen zo een mobiele werkplek waarmee zij op allerlei manieren gegevens kunnen benaderen en verzenden wanneer zij niet op hun werk zijn.

Beschikbare Mobile Sales-functionaliteit

Met Mobile Sales kunt u verkooporders op een mobiel apparaat voor bestaande Microsoft Dynamics NAV-toepassingen maken en wijzigen. Mobile Sales breidt ook de toepassing uit door nieuwe functionaliteit aan het gebied Sales & Marketing toe te voegen.

Activiteiten en taken

Taken in Microsoft Dynamics NAV worden als activiteiten in Mobile Sales weergegeven. In Microsoft Dynamics NAV bevat een taak vaak diverse activiteiten, maar in Mobile Sales staat een activiteit los van andere activiteiten en worden taken als activiteiten weergegeven. Om voor Mobile Sales een taak uit Microsoft Dynamics NAV te kunnen gebruiken moet de taak aan de volgende eisen voldoen:

  • De taak moet van het type Vergadering zijn.

  • De taak moet aan een verkoper zijn toegewezen.

  • De taak moet voor een enkel contact van het type Bedrijf zijn.

  • De taak mag geen gebeurtenis zijn die de hele dag duurt.

  • De taak kan niet worden geannuleerd.

U kunt Microsoft Dynamics NAV zo instellen, dat alle taken die voldoen aan deze eisen, automatisch worden verstuurd naar de tabel Mobile-verkoopactiviteit. Door Mobile Sales kan de tabel vervolgens worden gesynchroniseerd met de mobiele apparaten. Om Microsoft Dynamics NAV zo in te stellen dat taken naar de tabel Mobile-verkoopactiviteit worden verstuurd, moet u dit in het venster Mobile Sales instellen opgeven. Alle toekomstige taken worden dan naar de tabel verstuurd. Zie Procedure: Mobile-verkoopactiviteiten activeren in Microsoft Dynamics NAV Classic.

Als u alle bestaande taken naar de tabel Mobile-verkoopactiviteit wilt sturen, voert u de batchverwerking Mobile - Sync. Te doen/activiteit synchr. uit. U kunt dit rapport ook uitvoeren als de tabellen Taak en Mobile-verkoopactiviteit nog niet zijn gesynchroniseerd. Ook kunt u een verwerkingswachtrijpost maken om de batchverwerking op gezette tijden te laten uitvoeren.

Opmerking Opmerking

U moet de batchverwerking Mobile - Sync. Te doen/activiteit synchr. in de verwerkingswachtrij uitvoeren of Microsoft Dynamics NAV zo instellen, dat nieuwe taken automatisch als onderdeel van de Mobile Sales-instelling worden verstuurd. Als u Microsoft Dynamics NAV echter zo instelt dat nieuwe taken automatisch worden verzonden, hoeft u de batchverwerking slechts één keer uit te voeren om de tabel Mobile/verkoopactiviteit met gegevens te vullen.

Zie Taken maken voor meer informatie over taken.

Campagnes

Mobile Sales breidt campagnes uit met het concept van inkoopperioden en zichtbare datums. Als er binnen uw bedrijf campagnes zijn gecreëerd, kunt u verkopers informeren wanneer een campagne kan worden gepromoot door de inkoopperiode voor de campagne op te geven. Zie Procedure: Een inkoopperiode aan een campagne in Microsoft Dynamics NAV Classic toevoegen voor meer informatie. Zie Campagne (tabel) voor meer informatie over campagne.

Prijzen van klantartikelen bijwerken

Microsoft Dynamics NAV berekent prijzen op verkooporders door kortingen en campagnes op te nemen. Op een mobiel apparaat gebruiken dergelijke ingewikkelde berekeningen te veel geheugen. De prijzen die door Mobile Sales op het mobiele apparaat worden weergegeven, staan in feite op de server. In Microsoft Dynamics NAV moet u voor Mobile Sales de batchverwerking Mobile - Klantenprijs maken uitvoeren om de prijs per artikel per klant te berekenen en deze gegevens in een tabel te plaatsen. Vervolgens stelt u de gefaseerde database van Mobile Sales in om de gegevens met het mobiele apparaat te synchroniseren, waarop door Mobile Sales alleen de berekende prijs wordt weergegeven wanneer de gebruiker een verkooporder voor een klant maakt.

De batchverwerking Mobile - Klantenprijs maken berekent op het moment van de uitvoering een prijs per artikel per klant. De berekening bevat de volgende gegevens:

  • Verkoopprijzen zoals gedefinieerd voor een bepaalde klant, alle klanten, een bepaalde klantenprijsgroep of een campagne.

  • Regelkortingen zoals gedefinieerd voor een bepaalde klant, alle klanten, een bepaalde klantenprijsgroep of een campagne.

Als er voor een artikel van een klant twee prijzen zijn, geeft de batchverwerking de laagste prijs op. De volgende gegevens worden niet door de batchverwerking Mobile - Klantenprijs maken toegepast:

  • Hoeveelheidkortingen bij hoeveelheden groter dan 1.

  • Prijzen en regelkortingen waarvoor de begindatum later valt dan de datum en tijd waarop de batchverwerking wordt uitgevoerd.

  • Vervallen prijzen en regelkortingen.

U kunt een verwerkingswachtrijpost instellen die de batchverwerking Mobile - Klantenprijs maken uitvoert volgens een schema dat u opgeeft. Zie Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV en Procedure: Projecten plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic.

Handtekening van klant op verkooporders

Wanneer een verkoper een verkooporder met Mobile Sales maakt, kan de klant de verkooporder op het mobiele apparaat ondertekenen om de order te bevestigen. De handtekening wordt in een afzonderlijke tabel opgeslagen wanneer het mobiele apparaat met de server wordt gesynchroniseerd. Standaard is de handtekening niet beschikbaar in het venster Verkooporder in Microsoft Dynamics NAV, omdat de prijzen tussen het moment van ondertekening door de klant en het moment van synchroniseren van het mobiele apparaat met de server kunnen veranderen. Als de instelling echter ervoor zorgt dat de prijzen op het mobiele apparaat correct zijn, kunt u handtekeningen op verkooporders activeren. Zie Procedure: Handtekeningen op verkooporders in Microsoft Dynamics NAV Classic activeren.

Documenthandlers, documentsoorten en documentschema's

Mobiele apparaten sturen gegevens en aanvragen als XML-documenten, ook wel aanvraagdocumenten genoemd, terug naar de server. In Microsoft Dynamics NAV wordt de integratie voltooid door toepassingsobjecten, die documenthandlers en documentsoorten worden genoemd. Microsoft Dynamics NAV wordt geleverd met documenthandlers in een verwerkende codeunit en vier documentsoorten die door XML-schema's worden ondersteund.

Een documentsoort beheert de gebruikerstoegang en validatie voor inkomende aanvraagdocumenten. De Mobile Sales-documentsoorten in Microsoft Dynamics NAV verwerken aanvragen om verkooporders te maken en om taken en activiteiten te maken, te wijzigen en te verwijderen.

Zie Documentverwerking voor Mobile Sales en Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Zie ook

Taken

Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen
Procedure: Een inkoopperiode aan een campagne in Microsoft Dynamics NAV Classic toevoegen
Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic
Procedure: Verwerkingen plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic
Procedure: Handtekeningen op verkooporders in Microsoft Dynamics NAV Classic inschakelen

Referentie

Mobile-verkoopactiviteit (tabel)
Mobile Sales instellen (tabel)
Batchverwerking voor Mobile - Klantenprijs maken
Batchverwerking Mobile - Sync. Te doen/activiteit synchr.
Mobile-klantenprijs (tabel)

Concepts

Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV
Documentverwerking voor Mobile Sales

Overige informatiebronnen

Microsoft Dynamics NAV Classic integreren met Microsoft Dynamics Mobile
Mobile Sales - Overzicht


Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen

Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen
Zie ook

Microsoft Dynamics® Mobile – Mobile Sales wordt geïntegreerd met Microsoft Dynamics NAV door de verkoop- en marketingfuncties op mobiele apparaten beschikbaar te maken. Een van deze functies zijn de taken. Taken en activiteiten van Microsoft Dynamics NAV worden als activiteiten in Mobile Sales weergegeven. Als onderdeel van het instellen van de Mobile-functionaliteit in Microsoft Dynamics NAV moet u opgeven wanneer taken en activiteiten tussen de mobiele apparaten en de server worden gesynchroniseerd.

U kunt instellen dat door Microsoft Dynamics NAV taken automatisch naar de tabel Mobile-verkoopactiviteit worden verstuurd. Mobile Sales kan vervolgens de tabel met de mobiele apparaten synchroniseren. U kunt op een van de volgende manieren Microsoft Dynamics NAV-taken met Mobile-verkoopactiviteiten synchroniseren:

  • Door in het venster Mobile Sales instellen Microsoft Dynamics NAV in te stellen voor het versturen van alle nieuwe taken naar de tabel Mobile-verkoopactiviteit.

  • Door bestaande taken te plannen voor synchronisatie met de tabel Mobile-verkoopactiviteit door de verwerkingswachtrij in te stellen om de batchverwerking Mobile - Sync. Te doen/activiteit synchr. uit te voeren. Hiermee worden alle bestaande taken naar de tabel Mobile-verkoopactiviteit verstuurd. Zie Procedure: Projecten plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic voor meer informatie over het plannen van een verwerking.

Opmerking Opmerking

Als u gebruikers Mobile Sales met Microsoft Dynamics NAV vanaf een mobiel apparaat wilt laten gebruiken, moet u de juiste beveiligingsrollen aan die gebruikers toewijzen. Zie Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV voor meer informatie.

Mobile Sales in Microsoft Dynamics NAV instellen

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile en Mobile Sales.

  2. Als u nieuwe taken met Mobile Sales wilt laten synchroniseren, schakelt u de optie Activiteit automatisch bijwerken in.

    Wanneer u nieuwe taken maakt, worden deze taken automatisch toegevoegd aan de tabel Mobile-verkoopactiviteit die de activiteitsgegevens voor mobiele apparaten levert. U kunt ook de batchverwerking Mobile - Sync. Te doen/activiteit synchr. uitvoeren wanneer de tabel met bestaande taken is gevuld, zodat Mobile-gebruikers op hun mobiele apparaten toegang tot activiteiten hebben.

    Opmerking Opmerking

    Als u de optie Activiteit automatisch bijwerken in het venster Mobile Sales instellen uitschakelt en u wilt activiteiten in Mobile Sales gebruiken, moet u met de verwerkingswachtrij inplannen dat bestaande taken met de tabel Mobile-verkoopactiviteit worden gesynchroniseerd.

U kunt ook inplannen dat bestaande taken met de tabel Mobile-verkoopactiviteit worden gesynchroniseerd. Zie Procedure: Verwerkingen voor Mobile-functionaliteit Microsoft Dynamics NAV Classic plannen voor meer informatie.

Zie ook

Taken

Procedure: Een inkoopperiode aan een campagne in Microsoft Dynamics NAV Classic toevoegen
Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic
Procedure: Verwerkingen plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic

Referentie

Batchverwerking Mobile - Sync. Te doen/activiteit synchr.
Mobile-verkoopactiviteit (tabel)
Mobile Sales instellen (tabel)

Concepten

Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken
Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV


Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic

Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic
Zie ook

Microsoft Dynamics NAV berekent prijzen op verkooporders door kortingen en campagnes op te nemen. Op een mobiel apparaat gebruiken dergelijke ingewikkelde berekeningen te veel geheugen. De prijzen die door Mobile Sales op het mobiele apparaat worden weergegeven, staan in feite op de server. In Microsoft Dynamics NAV moet u voor Mobile Sales de batchverwerking Mobile - Klantenprijs maken uitvoeren om de prijs per artikel per klant te berekenen en deze gegevens in een tabel te plaatsen. Vervolgens stelt u de gefaseerde database van Mobile Sales in om de gegevens met het mobiele apparaat te synchroniseren, waarop door Mobile Sales alleen de berekende prijs wordt weergegeven wanneer de gebruiker een verkooporder voor een klant maakt.

Opmerking Opmerking

Om prijzen naar mobiele apparaten te synchroniseren moet u de Mobile Sales-databaseonderdelen installeren en configureren. Zie online de installatie- en configuratiehandleiding van Microsoft Dynamics Mobile voor meer informatie.

De batchverwerking Mobile - Klantenprijs maken maakt records in de tabel Mobile - Klantenprijs. In deze tabel staat één record per artikel per klant. Als er in de Microsoft Dynamics NAV-database bijvoorbeeld 1000 klanten en 100 artikelen staan, maakt de batchverwerking 100.000 records. Zie Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken voor meer informatie over de berekeningen.

In het aanvraagformulier voor de batchverwerking Mobile - Klantenprijs maken kunt u opgeven of de batchverwerking voor een bepaalde klant of voor een bepaald artikel moet worden uitgevoerd. U kunt ook een verwerkingswachtrijpost voor de batchverwerking maken, zodat deze verwerking op gezette tijden wordt uitgevoerd. In de volgende procedure wordt beschreven hoe u met deze batchverwerking klantenprijzen van artikelen bijwerkt. Zie Procedure: Projecten plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic voor meer informatie over het plannen van de batchverwerking in een verwerkingswachtrij.

Klantenprijzen van artikelen bijwerken

  1. Klik in het navigatiedeelvenster op Administratie en klik achtereenvolgens op Applicatie-instellingen, Mobile, Mobile Sales en Klantenprijs maken.

  2. U werkt prijzen voor een bepaalde klant bij door in het venster Mobile - Klantenprijs maken op het tabblad Klant in het veld Filter te klikken op de AssistButton en een klant te selecteren.

    Opmerking Opmerking

    Als u de prijzen voor alle klanten wilt bijwerken, laat u dit tabblad leeg.

  3. U werkt prijzen voor een bepaald artikel bij door in het venster Mobile - Klantenprijs maken op het tabblad Artikel in het veld Filter te klikken op de AssistButton en een artikel te selecteren.

    Opmerking Opmerking

    Als u de prijzen voor alle artikelen wilt bijwerken, laat u dit tabblad leeg.

  4. Klik op OK om de prijzen bij te werken.

Zie ook

Taken

Procedure: Verwerkingen plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic
Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen
Procedure: Handtekeningen op verkooporders in Microsoft Dynamics NAV Classic inschakelen
Procedure: Een inkoopperiode aan een campagne in Microsoft Dynamics NAV Classic toevoegen

Referentie

Batchverwerking voor Mobile - Klantenprijs maken
Mobile-klantenprijs (tabel)

Concepten

Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken
Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic


Procedure: Een inkoopperiode aan een campagne in Microsoft Dynamics NAV Classic toevoegen

Procedure: Een inkoopperiode aan een campagne in Microsoft Dynamics NAV Classic toevoegen
Zie ook

Met Microsoft Dynamics® Mobile – Mobile Sales kunnen campagnes worden uitgebreid met het concept van inkoopperioden. U kunt de verkoper informeren wanneer een campagne actief is door de inkoopperiode voor de campagne op te geven. Zie Campagne (tabel) voor meer informatie. Wanneer u een inkoopperiode aan een campagne toevoegt, wordt de campagne naar de mobiele apparaten verstuurd op de datum die u hebt opgegeven. Vervolgens kunnen de verkopers de campagne gaan promoten. In de volgende procedure wordt beschreven hoe u een inkoopperiode aan de campagne toevoegt.

Een inkoopperiode aan een campagne toevoegen

  1. Klik in het navigatiedeelvenster op Sales & Marketing, klik op Marketing en klik vervolgens op Campagnes om een campagnekaart te openen.

  2. Klik op Campagne en vervolgens op Overzicht.

  3. Selecteer in het venster Campagneoverzicht de campagne die u aan een inkoopperiode wilt toevoegen, en klik op Campagne, Kaart.

  4. Vul in het venster Campagnekaart op het tabblad Mobile de volgende velden in:

    Veld Omschrijving

    Zichtbare datum

    De datum waarop de campagne beschikbaar is voor mobiele apparaten. Mobile-gebruikers kunnen pas op deze datum de campagne op hun mobiele apparaten bekijken. Wanneer de campagne zichtbaar is, kunnen de verkopers de campagne aan hun klanten laten zien.

    Begindatum (selling-in)

    De startdatum waarop de campagne actief wordt. Mobile-gebruikers kunnen de campagne bekijken en deze gebruiken wanneer zij bij hun klanten en contacten zijn.

    Einddatum (selling-in)

    De einddatum waarop de campagne niet meer actief is. Mobile-gebruikers kunnen de campagne nog steeds bekijken, maar niet meer gebruiken.

    Wanneer u een inkoopperiode aan een campagne toevoegt, wordt de campagne naar de mobiele apparaten verstuurd op de datum die u in het veld Zichtbare datum hebt opgegeven. Mobile-gebruikers kunnen de campagneprijzen gebruiken in de inkoopperiode die u in de velden Begindatum (selling-in) en Einddatum (selling-in) hebt opgegeven. Als u de inkoopperiode naderhand wilt wijzigen, wijzigt u de datums in deze velden op het tabblad Mobile.

Zie ook

Taken

Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen
Procedure: Handtekeningen op verkooporders in Microsoft Dynamics NAV Classic inschakelen
Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic

Concepten

Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken
Mobile-functionaliteit configureren in Microsoft Dynamics NAV Classic

Overige informatiebronnen

Mobile Sales - Overzicht


Procedure: Handtekeningen op verkooporders in Microsoft Dynamics NAV Classic inschakelen

Procedure: Handtekeningen op verkooporders in Microsoft Dynamics NAV Classic inschakelen
Zie ook

Wanneer een verkoper een verkooporder met Mobile Sales maakt, kan de klant de verkooporder op het mobiele apparaat ondertekenen om de order te bevestigen. De handtekening wordt in een afzonderlijke tabel opgeslagen wanneer het mobiele apparaat met de server wordt gesynchroniseerd. Standaard is de handtekening niet beschikbaar in het venster Verkooporder in Microsoft Dynamics NAV, omdat de prijzen tussen het moment van ondertekening door de klant en het moment van synchroniseren van het mobiele apparaat met de server kunnen veranderen. Als de instelling echter ervoor zorgt dat de prijzen op het mobiele apparaat correct zijn, kunt u handtekeningen op verkooporders activeren. In de volgende procedure wordt beschreven hoe u dit doet.

Handtekeningen op verkooporders activeren

  1. Klik in Microsoft Dynamics NAV-Classic op Extra en klik op Object Designer.

  2. Selecteer formulier 42 Verkooporder en klik op Ontwerpen om het formulier in Form Designer te openen.

  3. Klik in het venster Form Designer met de rechtermuisknop op de menuknop Order en klik vervolgens op Menu-items.

  4. Schuif in het venster Menu Designer omlaag naar een nieuwe rij en vul de volgende velden in:

    Veld Waarde

    Zichtbaar

    Waar

    Bijschrift

    Handtekening

    Actie

    RunObject

    RunObject

    Formulier Mobile-orderhandtekening

  5. Typ Document Soort=VELD(Documentsoort),Nr.=VELD(Nr.) in het veld RunFormLink in het venster Eigenschappen voor de nieuwe menu-opdracht.

  6. Sluit de vensters Menu Designer en Form Designer, sla eventuele wijzigingen op en compileer het formulier vervolgens opnieuw.

  7. Voer het formulier Verkooporder uit.

  8. Klik in het venster Verkooporder op Order en vervolgens op Handtekening.

    Het venster Mobile-orderhandtekening wordt geopend. Als de geselecteerde order door een klant is ondertekend, wordt die handtekening in dit venster weergegeven.

Zie ook

Taken

Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen
Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic
Procedure: Een inkoopperiode aan een campagne in Microsoft Dynamics NAV Classic toevoegen

Concepten

Mobile Sales bij Microsoft Dynamics NAV Classic gebruiken


Referentie voor de Mobile-functionaliteit in Microsoft Dynamics NAV

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV
Zie ook

Door de Mobile-functionaliteit in Microsoft Dynamics NAV worden XML-documenten verwerkt die vanaf mobiele apparaten worden verzonden, en wordt de Microsoft Dynamics NAV-database bijgewerkt volgens de specificaties in de Mobile-documentsoorten. In deze sectie wordt referentiemateriaal over de onderliggende objecten gegeven.

In deze sectie

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV

Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV

Zie ook

Concepten

Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV


Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Zie ook

De Mobile-functionaliteit in Microsoft Dynamics NAV bevat tabellen voor het instellen van Mobile-gebruikers, Mobile-documentsoorten en andere tabellen. In deze sectie staat referentiemateriaal over specifieke tabellen voor mobiliteit.

In deze sectie komen de volgende onderwerpen aan bod

Mobile-klantenprijs (tabel)

Mobile-documentgroep (tabel)

Mobile-documentenwachtrij (tabel)

Mobile-documentschema (tabel)

Mobile - Documentsoort (tabel)

Mobile-documentsoortschema (tabel)

Mobile-groep (tabel)

Mobile-groepsgebruikers (tabel)

Mobile - Talen (tabel)

Bijschrift Mobile-optieveld (tabel)

Mobile - Optieveld instellen (tabel)

Mobile Sales-activiteit (tabel)

Mobile Sales instellen (tabel)

Mobile-gebruiker (tabel)

Windows-aanmelding Mobile-gebruiker (tabel)

Referentie

Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV

Zie ook

Overige informatiebronnen

Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-klantenprijs (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-klantenprijs (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel worden de berekende prijzen voor voorraadartikelen per klant opgeslagen. Microsoft Dynamics NAV berekent de prijzen op verkooporders door kortingen en campagnes op te nemen. Op een mobiel apparaat gebruiken dergelijke ingewikkelde berekeningen te veel geheugen. De prijzen die door Mobile Sales op het mobiele apparaat worden weergegeven, staan in feite op de server. In Microsoft Dynamics NAV moet u voor Mobile Sales de batchverwerking Mobile - Klantenprijs maken uitvoeren om de prijs per artikel per klant te berekenen en deze gegevens in een tabel te plaatsen. Vervolgens stelt u de gefaseerde database van Mobile Sales in om de gegevens met het mobiele apparaat te synchroniseren, zodat door Mobile Sales alleen de berekende prijs wordt weergegeven wanneer de gebruiker een verkooporder voor een klant maakt.

U kunt de tabel op een rolgerichte client of een Classic-client vullen met de berekende artikelprijzen per klant. Zie Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV en Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8725 Mobile Sales instellen.

Veld | Omschrijving
Artikelnr. | De unieke id voor het voorraadartikel, die kan worden opgezocht in tabel 27 Artikel.
Klantnr. | De unieke id voor de klant, die kan worden opgezocht in tabel 18 Klant.
Artikelprijs | De berekende prijs voor het opgegeven artikel voor de opgegeven klant.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV
Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic

Referentie

Batchverwerking voor Mobile - Klantenprijs maken

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-documentgroep (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-documentgroep (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de Mobile-gebruikersgroepen die aan een documentsoort in Microsoft Dynamics NAV zijn toegewezen. U kunt met Mobile-groepen Mobile-gebruikers beheren en machtigingen aan aanvraagdocumentsoorten toewijzen. Zie Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV voor meer informatie. In deze tabel staan ook de documentsoorten die in de tabel Mobile - Documentsoort zijn gedefinieerd, en die ze koppelt aan de groepen die in de tabel Mobile-groep zijn gedefinieerd.

U kunt Mobile-documentsoorten op een rolgerichte client of een Classic-client definiëren. Zie Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV instellen en Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8702 Mobile-documentgroep.

Veld | Omschrijving
Mobile - Documentsoort | De unieke id voor de documentsoort die kan worden opgezocht in tabel 8704 Mobile - Documentsoort.
Groepscode | De unieke id voor de groep Mobile-gebruikers die kan worden opgezocht in tabel 8701 Mobile-groep.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV instellen
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile - Documentsoort (tabel)
Mobile-groep (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-documentenwachtrij (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-documentenwachtrij (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de documenten die vanaf een mobiel apparaat naar Microsoft Dynamics NAV zijn verstuurd. De gegevens worden weergegeven in het venster Mobile-documentenwachtrijoverzicht, waar u een aanvraagdocument dat nog niet is verwerkt, kunt wijzigen. Dit is nodig als er zich een fout voordoet wanneer u dat document voor de eerste keer probeert te verwerken. U kunt de status ook opnieuw instellen, een aanvraagdocument verwijderen en aanvraagdocumenten handmatig als XML-documenten importeren en exporteren.

U kunt de Mobile-documentenwachtrij op een rolgerichte client of een Classic-client controleren. Zie De interactie tussen mobiele apparaten en Microsoft Dynamics NAV beheren en De interactie tussen mobiele apparaten en Microsoft Dynamics NAV Classic beheren voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8705 Mobile-documentenwachtrijen.

Veld Omschrijving

Bericht-id

De unieke id van het verstuurde XML-document.

Apparaat-id

De unieke id van het mobiele apparaat dat het XML-document heeft verstuurd.

Id Mobile-gebruiker

De unieke id van de Mobile-gebruiker die kan worden opgezocht in tabel 8700 Mobile-gebruiker.

Documentsoort

De unieke naam van de documentsoort.

Processoort

Geeft het type verwerking op dat bij het aanvraagdocument wordt gebruikt:

Direct

Inkomende aanvraagdocumenten van dit type worden onmiddellijk verwerkt.

In wachtrij

Inkomende aanvraagdocumenten van dit type worden aan de documentenwachtrij toegevoegd en naderhand verwerkt.

Status

Geeft de status van aanvraagdocumenten weergeven:

Nieuw

Het aanvraagdocument is nog niet verwerkt.

Verwerken

Het aanvraagdocument wordt momenteel verwerkt.

Voltooid

Het aanvraagdocument is verwerkt.

Fout

Er is een fout opgetreden tijdens het verwerken van het aanvraagdocument.

Datum/tijd aangemaakt

De datum en tijd waarop het aanvraagdocument in de documentenwachtrij is opgeslagen.

Datum/tijd antwoord

De datum en tijd waarop het retourbericht in de documentenwachtrij is opgeslagen.

Datum/tijd resultaat

De datum en tijd waarop het document is verwerkt.

Aanvraag-XML

Geeft de XML-bron van het aanvraagdocument weer.

Antwoord-XML

Het bericht dat is geretourneerd naar het mobiele apparaat wanneer het aanvraagdocument in de wachtrij is geregistreerd.

Als Processoort is ingesteld op Direct, is de waarde van Antwoord-XML identiek aan de waarde van Resultaat-XML.

Resultaat-XML

Het bericht dat wordt geretourneerd wanneer het aanvraagdocument wordt verwerkt. Alle fouten die zich voordoen, worden in dit veld weergegeven.

NAS-gebruikers-id

De Windows-aanmelding voor de gebruikersaccount voor de Application Server voor de Microsoft Dynamics NAV-instance. Zie Application Server configureren voor Microsoft Dynamics NAV voor mobiele integratie voor meer informatie.

NAS-hostnaam

De naam van de Application Server-instance.

NAS-poort

De poort voor de Application Server-instance.

Afbeelding van uitvouwen Zie ook

Referentie

Mobile - Documentsoort (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-documentschema (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-documentschema (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de schema's voor Mobile-documentsoorten in Microsoft Dynamics NAV. Deze schema's bepalen de lay-out en de inhoud van de XML-documenten die vanaf een mobiel apparaat worden verstuurd. Elke documentsoort heeft een documentschema en de documentsoort bepaalt of inkomende aanvraagdocumenten moeten overeenkomen met het opgegeven schema voor een strikte of een losse validatie.

U kunt documentschema's op een rolgerichte client of een Classic-client definiëren en bewerken. Zie Procedures: Documentschema's in Microsoft Dynamics NAV importeren, exporteren en weergeven en Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8710 Mobile-documentschema.

Veld Omschrijving

Code

De unieke id voor het documentschema.

Naamruimte

De naamruimte voor het schema, zoals http://schemas.microsoft.com/Dynamics/Mobile/2007/12/Tasklets/Activity/Create.

Schema

De inhoud van het schema.

Opmerking Opmerking

De inhoud van dit veld is een BLOB die de XML bevat waarmee het schema wordt bepaald. In het venster Mobile - Documentschema's kunt u het schema importeren, exporteren en weergeven.

Afbeelding van uitvouwen Zie ook

Taken

Procedures: Documentschema's in Microsoft Dynamics NAV importeren, exporteren en weergeven
Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV instellen
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile - Documentsoort (tabel)
Mobile-documentsoortschema (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile - Documentsoort (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile - Documentsoort (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de documentsoorten van Microsoft Dynamics NAV waarmee instellingen kunnen worden opgegeven voor de typen XML-documenten die vanaf een mobiel apparaat kunnen worden verstuurd. De documentsoort bepaalt wanneer inkomende aanvraagdocumenten worden verwerkt en ook in welke codeunit de code staat die het XML-document verwerkt.

Opmerking Opmerking

Documentsoorten en documentverwerking in codeunits zijn nauw met elkaar verbonden. Zie Documenthandlers definiëren in Microsoft Dynamics NAV voor meer informatie.

U kunt Mobile-documentsoorten op een rolgerichte client of een Classic-client definiëren. Zie Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV instellen en Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8704 Mobile - Documentsoort.

Veld Omschrijving

Documentsoort

De unieke naam van de documentsoort.

Omschrijving

De omschrijvende tekst van de documentsoort.

Processoort

Geeft het type verwerking op dat bij het aanvraagdocument wordt gebruikt:

Direct

Inkomende aanvraagdocumenten van dit type worden onmiddellijk verwerkt.

In wachtrij

Inkomende aanvraagdocumenten van dit type worden aan de documentenwachtrij toegevoegd en naderhand verwerkt.

Zie Mobile-documentenwachtrij (tabel) voor meer informatie.

Verwerkende codeunit

De unieke id van de codeunit die de documentverwerkingscode bevat en die kan worden opgezocht in de lijst met objecten.

Naam verwerkende codeunit

De naam van de codeunit die de documentverwerkingscode bevat. Wordt ingesteld door de waarde van de verwerkende codeunit.

Strikte schemavalidatie

Is Waar als de inkomende aanvraagdocumenten volledig moeten overeenkomen met het opgegeven schema en is Onwaar als dat niet zo is. Zie Mobile-documentschema (tabel) en Mobile-documentsoortschema (tabel) voor meer informatie.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV instellen
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile-documentgroep (tabel)
Mobile-documentschema (tabel)
Mobile-documentsoortschema (tabel)
Mobile-documentenwachtrij (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-documentsoortschema (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-documentsoortschema (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de schema's die horen bij de Mobile-documentsoorten in Microsoft Dynamics NAV. Deze schema's bepalen de lay-out en de inhoud van de XML-documenten die vanaf een mobiel apparaat worden verstuurd. Elke documentsoort heeft een documentschema en de documentsoort bepaalt of inkomende aanvraagdocumenten moeten overeenkomen met het opgegeven schema voor een strikte of een losse validatie.

U kunt documentschema's op een rolgerichte client of een Classic-client definiëren en bewerken. Zie Procedures: Documentschema's in Microsoft Dynamics NAV importeren, exporteren en weergeven en Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8711 Mobile - Documenttypeschema's.

Veld | Omschrijving
Documentsoort | De unieke naam voor de documentsoort die kan worden opgezocht in tabel 8704 Mobile - Documentsoort.
Documentschemacode | De unieke id voor het documentschema die kan worden opgezocht in tabel 8710 Mobile-documentschema.
Documentbeschrijving | De omschrijvende tekst van de documentsoort. Deze wordt ingesteld door de waarde van Documentsoort.
Documentschemanaamruimte | De naamruimte voor het schema, zoals http://schemas.microsoft.com/Dynamics/Mobile/2007/12/Tasklets/Activity/Create. Deze wordt ingesteld door de waarde van Documentschemacode.

Afbeelding van uitvouwen Zie ook

Taken

Procedures: Documentschema's in Microsoft Dynamics NAV importeren, exporteren en weergeven
Procedures: Documentschema's in Microsoft Dynamics NAV Classic importeren, exporteren en weergeven
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV instellen
Procedure: Mobile-documentsoorten in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile - Documentsoort (tabel)
Mobile-documentschema (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-groep (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-groep (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de groepen Mobile-gebruikers in Microsoft Dynamics NAV. U gebruikt Mobile-groepen voor het beheren van Mobile-gebruikers en het toewijzen van machtigingen voor het aanvragen van documentsoorten. Zie Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV voor meer informatie. In deze tabel worden de groepen gedefinieerd. Vervolgens voegt u de Mobile-gebruikers toe aan de individuele groep uit de tabel Mobile-groepsgebruiker.

U kunt Mobile-groepen op een rolgerichte client of een Classic-client definiëren. Zie Procedure: Mobile-groepen in Microsoft Dynamics NAV instellen en Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8701 Mobile-groep.

Veld | Omschrijving
Code | De unieke id voor de groep Mobile-gebruikers.
Naam | De unieke naam voor de groep Mobile-gebruikers.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Mobile-groepen in Microsoft Dynamics NAV instellen
Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen

Referentie

Mobile-groepsgebruiker (tabel)

Overige bronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-groepsgebruiker (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-groepsgebruiker (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de Mobile-gebruikers die lid zijn van een Mobile-groep in Microsoft Dynamics NAV. U kunt met Mobile-groepen Mobile-gebruikers beheren en machtigingen aan aanvraagdocumentsoorten toewijzen. Zie Overzicht van de beveiliging voor Mobile-functionaliteit in Microsoft Dynamics NAV voor meer informatie. In deze tabel staan ook de Mobile-gebruikers die in de tabel Mobile-gebruiker zijn gedefinieerd. Bovendien kunt u nieuwe Mobile-gebruikers definiëren.

U kunt Mobile-groepen op een rolgerichte client of een Classic-client definiëren. Zie Procedure: Mobile-groepen in Microsoft Dynamics NAV instellen en Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8702 Mobile-groepsgebruiker.

Veld | Omschrijving
Groepscode | De unieke id voor de groep Mobile-gebruikers die kan worden opgezocht in tabel 8701 Mobile-groep.
Id Mobile-gebruiker | De unieke id voor de Mobile-gebruiker die kan worden opgezocht in tabel 8700 Mobile-gebruiker.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Mobile-groepen in Microsoft Dynamics NAV instellen
Procedures: Mobile-groepen in Microsoft Dynamics Classic instellen

Referentie

Mobile-groep (tabel)
Mobile-gebruiker (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile - Talen (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile - Talen (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de talen die in Microsoft Dynamics NAV voor Mobile-gebruikers beschikbaar zijn. Met de talen kan ervoor worden gezorgd dat de gegevens op het mobiele apparaat in de juiste taal worden weergegeven. U kunt de tabel Mobile - Talen gebruiken wanneer u Mobile-gebruikers en bijschriften opgeeft. Zie Mobile-gebruiker (tabel) en Bijschrift Mobile-optieveld (tabel) voor meer informatie.

U kunt talen op een rolgerichte client of een Classic-client instellen. Zie Procedure: Talen voor Mobile-gebruikers in Microsoft Dynamics NAV instellen en Procedure: Talen voor Mobile-gebruikers in Microsoft Dynamics Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8706 Mobile - Talen.

Veld | Omschrijving
Code | De taalcode die kan worden opgezocht in tabel 8 Talen.
Naam | De naam van de taal die wordt ingesteld door de waarde van Code.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Talen voor Mobile-gebruikers in Microsoft Dynamics NAV instellen
Procedure: Talen voor Mobile-gebruikers in NAV Classic instellen

Referentie

Mobile-gebruiker (tabel)
Bijschrift Mobile-optieveld (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Talen (tabel)


Bijschrift Mobile-optieveld (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Bijschrift Mobile-optieveld (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de vertalingen van de optielijstwaarden in Microsoft Dynamics NAV die zijn ingesteld om te worden gesynchroniseerd met mobiele apparaten. Mobiele apparaten die worden geïntegreerd met Microsoft Dynamics NAV, kunnen velden bevatten waar de mogelijke waarden optiereeksen zijn. Om er zeker van te zijn dat de opties op de juiste manier op het mobiele apparaat worden weergegeven, moet u opgeven welke talen beschikbaar zijn en vervolgens opgeven welke tabellen met optievellen in de mobiele toepassingen worden gebruikt. In het venster Overzicht Mobile-optieveldbijschriften staan de optiereekswaarden die eerst op taal en vervolgens op optienummer zijn gesorteerd.

U kunt het gebruik van een optieveld op een rolgerichte client of een Classic-client instellen. Zie Procedure: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV instellen en Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8709 Bijschrift Mobile-optieveld.

Veld | Omschrijving
Tabelnr. | De unieke id van de tabel, die kan worden opgezocht in de lijst met objecten.
Tabelnaam | De naam van de tabel, die wordt ingesteld door de waarde van Tabelnr.
Taalcode | De taalcode die kan worden opgezocht in tabel 8706 Mobile - Talen.
Optienr. | Het nummer in de optiereeks voor de geselecteerde optiereekswaarde, dat wordt opgezocht in de veldenlijst.
Optiebijschrift | Het bijschrijft voor de optiereekswaarde in de taal die is opgegeven in Taalcode.
Taalnaam | De naam van de taal die wordt ingesteld door de waarde van Taalcode.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV instellen
Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen

Referentie

Mobile - Optieveld instellen (tabel)
Batchverwerking Mobile-optievertaling

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile - Optieveld instellen (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile - Optieveld instellen (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de tabellen uit Microsoft Dynamics NAV die optievelden bevatten en die met mobiele apparaten moeten worden gesynchroniseerd. Mobiele apparaten die worden geïntegreerd met Microsoft Dynamics NAV, kunnen velden bevatten waar de mogelijke waarden optiereeksen zijn. Om er zeker van te zijn dat de opties op de juiste manier op het mobiele apparaat worden weergegeven, moet u opgeven welke talen beschikbaar zijn en vervolgens opgeven welke tabellen met optievelden in de mobiele toepassingen worden gebruikt.

U kunt het gebruik van een optieveld op een rolgerichte client of een Classic-client instellen. Zie Procedure: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV instellen en Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8708 Mobile - Optieveld instellen.

Veld | Omschrijving
Tabelnr. | De unieke id van de tabel, die kan worden opgezocht in de lijst met objecten.
Tabelnaam | De naam van de tabel, die wordt ingesteld door de waarde van Tabelnr.
Veldnr. | De unieke id van het optieveld, die kan worden opgezocht in de lijst met velden.
Veldnaam | De naam van het optieveld, die wordt ingesteld door de waarde van Veldnr.
Optiereeks | De optiereeks, die kan worden opgezocht in 8709 Bijschrift Mobile-optieveld.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV instellen
Procedures: Gebruik van optieveld voor Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen

Referentie

Bijschrift Mobile-optieveld (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile Sales-activiteit (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile Sales-activiteit (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de Microsoft Dynamics NAV-taken die naar Mobile Sales-apparaten worden verstuurd wanneer er weer wordt gesynchroniseerd met Microsoft Dynamics NAV.

Opmerking Opmerking

Rijen in de tabel Mobile-verkoopactiviteit worden gevuld met gegevens vanuit tabel 5080 Taak.

U kunt op een van de volgende manieren Microsoft Dynamics NAV-taken met Mobile-verkoopactiviteiten synchroniseren:

  • Door in het venster Mobile Sales instellen Microsoft Dynamics NAV in te stellen voor het versturen van alle nieuwe taken naar de tabel Mobile-verkoopactiviteit.

  • Door bestaande taken te plannen voor synchronisatie met de tabel Mobile-verkoopactiviteit door de verwerkingswachtrij in te stellen om de batchverwerking Mobile - Sync. Te doen/activiteit synchr. uit te voeren. Hiermee worden alle bestaande taken naar de tabel Mobile-verkoopactiviteit verstuurd.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8727 Mobile-verkoopactiviteit.

Veld Omschrijving

Taaknr.

De unieke id voor de taak.

Omschrijving

De omschrijving van de taak.

Klantnr.

De unieke id voor de contract van het bedrijf.

Contactnr.

De unieke id voor de contact.

Datum

De datum van de activiteit.

Begintijd

De begintijd van de activiteit.

Eindtijd

De eindtijd van de activiteit.

Voltooid

Dit is Waar als de activiteit is voltooid en Onwaar als de activiteit niet is voltooid.

Soort

Leeg, Vergadering of Telefoongesprek.

Opmerking Opmerking

In de huidige release van Mobile Sales moet het type van de taak Vergadering zijn.

Datum afgesloten

De datum waarop de taak is gesloten.

Gewijzigd op

De datum waarop de taak het laatst is gewijzigd.

Gewijzigd om

Het tijdstip waarop de taak het laatst is gewijzigd.

Voltooid door

De verkoper die deze teamtaak heeft voltooid.

Verkoper

Dit unieke id van de verkoper die is toegewezen aan de taak.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV inschakelen
Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen

Referentie

Batchverwerking Mobile - Sync. Te doen/activiteit synchr.

Overige informatiebronnen

Tabel Taak


Mobile Sales instellen (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile Sales instellen (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel wordt informatie opgeslagen over de manier waarop Mobile Sales is ingesteld in Microsoft Dynamics NAV. De Mobile Sales-instelling bepaalt de synchronisatie van taken in Microsoft Dynamics NAV met activiteiten op mobiele apparaten waarop Mobile Sales wordt uitgevoerd. U kunt instellen dat door Microsoft Dynamics NAV taken automatisch naar de tabel Mobile-verkoopactiviteit worden verstuurd. Door Mobile Sales kan de tabel vervolgens worden gesynchroniseerd met de mobiele apparaten. U kunt op een van de volgende manieren Microsoft Dynamics NAV-taken met Mobile-verkoopactiviteiten synchroniseren:

  • Door in het venster Mobile Sales instellen Microsoft Dynamics NAV in te stellen voor het versturen van alle nieuwe taken naar de tabel Mobile-verkoopactiviteit.

  • Door bestaande taken te plannen voor synchronisatie met de tabel Mobile-verkoopactiviteit door de verwerkingswachtrij in te stellen om de batchverwerking Mobile - Sync. Te doen/activiteit synchr. uit te voeren. Hiermee worden alle bestaande taken naar de tabel Mobile-verkoopactiviteit verstuurd.

U kunt Mobile Sales voor Microsoft Dynamics NAV op een rolgerichte client of een Classic-client instellen. Zie Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV activeren en Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic activeren voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8725 Mobile Sales instellen.

Veld | Omschrijving
Primaire sleutel | Dit veld wordt intern door het systeem ingesteld.
Activiteit automatisch bijwerken | Bij Waar worden alle nieuwe taken automatisch naar de tabel Mobile-verkoopactiviteit verstuurd; bij Onwaar gebeurt dat niet.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV inschakelen
Procedure: Mobile-verkoopactiviteiten in Microsoft Dynamics NAV Classic inschakelen

Referentie

Mobile-verkoopactiviteit (tabel)
Batchverwerking Mobile - Sync. Te doen/activiteit synchr.

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Mobile-gebruiker (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Mobile-gebruiker (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de gebruikers die aanvraagdocumenten vanaf mobiele apparaten in Microsoft Dynamics NAV kunnen versturen. Deze tabel koppelt Windows-aanmeldingen aan verkopercodes. Zie Verkoper/Inkoper (tabel) voor meer informatie.

U kunt Mobile-gebruikers op een rolgerichte client of een Classic-client definiëren. Zie Procedure: Mobile-gebruikers in Microsoft Dynamics NAV instellen en Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8700 Mobile-gebruiker.

Veld | Omschrijving
Gebruikers-ID | De unieke id voor de Mobile-gebruiker die kan worden opgezocht in tabel 8707 Windows-aanmelding Mobile-gebruiker.
Verkoper | De unieke id voor de verkoper, die kan worden opgezocht in tabel 13 Verkoper/Inkoper.
Verkopernaam | De naam van de verkoper, die wordt ingesteld door de waarde van Verkopercode.
Taalcode | De taalcode die kan worden opgezocht in tabel 8706 Mobile - Talen.

Afbeelding van uitvouwen Zie ook

Taken

Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Procedure: Mobile-gebruikers in Microsoft Dynamics NAV instellen

Referentie

Mobile - Talen (tabel)
Windows-aanmelding Mobile-gebruiker (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Inkoper/Verkoper (tabel)


Windows-aanmelding Mobile-gebruiker (tabel)

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Windows-aanmelding Mobile-gebruiker (tabel)
Zie ook
Afbeelding van alles samenvouwen

In deze tabel staan de gebruikers die in Microsoft Dynamics NAV als Windows-aanmeldingen zijn gedefinieerd. Door Windows-aanmeldingen als Mobile-gebruikers in te stellen kunnen deze gebruikers vanaf mobiele apparaten aanvraagdocumenten versturen. Zie Mobile-gebruiker (tabel) voor meer informatie.

U kunt Mobile-gebruikers op een rolgerichte client of een Classic-client definiëren. Zie Procedure: Mobile-gebruikers in Microsoft Dynamics NAV instellen en Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen voor meer informatie.

Afbeelding van uitvouwen Velden in deze tabel

In de volgende tabel staan de velden uit tabel 8707 Windows-aanmelding Mobile-gebruiker.

Veld | Omschrijving
Windows-aanmeldings-id | Bevat reeds gedefinieerde Windows-aanmeldingen. Zie Windows-aanmeldingen voor meer informatie.

Afbeelding van uitvouwen Zie ook

Taken

Procedures: Mobile-gebruikers in Microsoft Dynamics NAV Classic instellen
Procedure: Mobile-gebruikers in Microsoft Dynamics NAV instellen

Referentie

Windows-aanmelding Mobile-gebruiker (tabel)

Overige informatiebronnen

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV


Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Zie ook

De Mobile-functionaliteit in Microsoft Dynamics NAV bevat batchverwerkingen die gegevens voor de integratie tussen Microsoft Dynamics NAV en mobiele apparaten verwerken. In deze sectie staat referentiemateriaal over specifieke batchverwerking voor mobiliteit.

In deze sectie komen de volgende onderwerpen aan bod

Batchverwerking voor Mobile - Klantenprijs maken

Batchverwerking Mobile-documentprocessor

Batchverwerking Mobile-optievertaling

Batchverwerking Mobile - Sync. Te doen/activiteit synchr.

Referentie

Tabellen voor Mobile-functionaliteit in Microsoft Dynamics NAV

Zie ook

Overige informatiebronnen

Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV


Batchverwerking voor Mobile - Klantenprijs maken

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Batchverwerking voor Mobile - Klantenprijs maken
Zie ook
Afbeelding van alles samenvouwen

Deze batchverwerking genereert berekende prijzen voor voorraadartikelen met inbegrip van klantkortingen en campagnes. Microsoft Dynamics NAV berekent prijzen op verkooporders door kortingen en campagnes op te nemen. Op een mobiel apparaat gebruiken dergelijke ingewikkelde berekeningen te veel geheugen. De prijzen die door Mobile Sales op het mobiele apparaat worden weergegeven, staan in feite op de server. In Microsoft Dynamics NAV moet u voor Mobile Sales de batchverwerking Mobile - Klantenprijs maken uitvoeren om de prijs per artikel per klant te berekenen en deze gegevens in een tabel te plaatsen. Vervolgens stelt u de gefaseerde database van Mobile Sales in om de gegevens met het mobiele apparaat te synchroniseren, zodat door Mobile Sales alleen de berekende prijs wordt weergegeven wanneer de gebruiker een verkooporder voor een klant maakt.

U kunt de batchverwerking op een rolgerichte client of een Classic-client uitvoeren. Zie Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV en Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic voor meer informatie.

Afbeelding van uitvouwen Opties

In de volgende tabellen staan de standaardfilters voor batchverwerking 8725 Mobile - Klantenprijs maken.

Pas op Pas op

Als u geen filters toepast, worden door Mobile - Klantenprijs maken klantspecifieke prijzen voor alle voorraadartikelen en alle klanten gemaakt.

Tabel | Veld | Omschrijving
Klant | Nr. | De unieke id voor de klant, die kan worden opgezocht in tabel 18 Klant.
Artikel | Nr. | De unieke id voor het voorraadartikel, die kan worden opgezocht in tabel 27 Artikel.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV
Procedure: Klantartikelprijzen bijwerken voor Mobile Sales in Microsoft Dynamics NAV Classic

Referentie

Mobile-klantenprijs (tabel)

Overige bronnen

Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV


Batchverwerking Mobile-documentprocessor

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Batchverwerking Mobile-documentprocessor
Zie ook
Afbeelding van alles samenvouwen

Deze batchverwerking verwerkt XML-documenten vanuit de documentenwachtrij in Microsoft Dynamics NAV. In de documentenwachtrij staan aanvraagdocumenten die vanaf een mobiel apparaat naar Microsoft Dynamics NAV zijn verstuurd. Elk aanvraagdocument wordt gedefinieerd door een documentsoort die een verwerkende codeunit en een verwerkingstype specificeert. Als het aanvraagdocument is ingesteld om direct na de ontvangst ervan te worden verwerkt, roept de codeunit die de documentenwachtrij beheert, de batchverwerking Mobile-documentprocessor aan. Deze batchverwerking roept op zijn beurt de codeunit aan die voor deze soort aanvraagdocument is opgegeven. Als het aanvraagdocument is ingesteld om op een later tijdstip te worden verwerkt en u hebt codeunit 8702 Mobile-documentprocessor gepland om te worden uitgevoerd als een geplande verwerking, roept de codeunit de batchverwerking Mobile-documentprocessor aan om alle nieuwe documenten in de documentenwachtrij te verwerken.

Afbeelding van uitvouwen Opties

Batchverwerking 8700 Mobile-documentprocessor heeft geen aanvraagformulier. Als u codeunit 8702 Mobile-documentprocessor echter instelt om als een geplande bewerking te worden uitgevoerd, kunt u parameters instellen om de omvang van de verwerking terug te brengen, bijvoorbeeld een Mobile-gebruiker of een documentsoort.

Afbeelding van uitvouwen Zie ook

Referentie

Mobile-documentenwachtrij (tabel)

Overige informatiebronnen

Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV


Batchverwerking Mobile-optievertaling

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Batchverwerking Mobile-optievertaling
Zie ook
Afbeelding van alles samenvouwen

Deze batchverwerking genereert vertalingsitems voor waarden in optievelden in Microsoft Dynamics NAV wanneer de velden worden ingesteld voor gebruik op mobiele apparaten. Mobiele toepassingen die worden geïntegreerd met Microsoft Dynamics NAV, kunnen velden bevatten waar de mogelijke waarden optiereeksen zijn. Om er zeker van te zijn dat de opties op de juiste manier op het mobiele apparaat worden weergegeven, moet u opgeven welke talen beschikbaar zijn en vervolgens opgeven welke tabellen met optievelden in de mobiele toepassingen worden gebruikt. In het venster Overzicht Mobile-optieveldbijschriften staan de optiewaarden die eerst op taal en vervolgens op optienummer zijn gesorteerd. Door de batchverwerking Mobile-optievertaling worden voor elke taal die in de tabel Mobile - Talen is opgegeven, items in de tabel Bijschrift Mobile-optieveld gemaakt.

Opmerking Opmerking

De strings worden alleen in de opgegeven taal weergegeven als u de strings in die taal hebt vertaald. Als uw bedrijf bijvoorbeeld in Spanje is gevestigd, kunt u de strings weergeven in het Engels (Verenigde Staten) en in het Spaans. Als u dus wilt dat uw Mobile-gebruikers de strings ook in het Portugees kunnen zien, moet u een taalmodule met de strings vertaald in het Portugees toevoegen.

Afbeelding van uitvouwen Opties

Batchverwerking 8701 Mobile-optievertaling heeft geen aanvraagformulier. In de volgende tabel staan de filters die automatisch op de batchverwerking worden toegepast.

Gegevensitem | Waarde
Mobile - Optieveld instellen | Een rij uit tabel 8708. Zie Mobile - Optieveld instellen (tabel) voor meer informatie.
Mobile-taal | Een rij uit tabel 8706. Zie Mobile - Talen (tabel) voor meer informatie.

Afbeelding van uitvouwen Zie ook

Referentie

Mobile - Optieveld instellen (tabel)
Mobile - Talen (tabel)
Bijschrift Mobile-optieveld (tabel)

Overige bronnen

Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV


Batchverwerking Mobile - Sync. Te doen/activiteit synchr.

 Afbeelding van vervolgkeuzelijst Afbeelding van muiscursor op vervolgkeuzelijst Afbeelding van samenvouwen Afbeelding van uitvouwen Afbeelding van alles samenvouwen Afbeelding van alles uitvouwen Afbeelding van kopiëren Afbeelding van kopiëren en aanwijzen
Documentatie van Microsoft Dynamics NAV
Batchverwerking Mobile - Sync. Te doen/activiteit synchr.
Zie ook
Afbeelding van alles samenvouwen

Deze batchverwerking synchroniseert Microsoft Dynamics NAV-taken met activiteiten op mobiele apparaten waarop Mobile Sales wordt uitgevoerd. De batchverwerking Mobile - Sync. Te doen/activiteit synchr. vult tabel 8727 Mobile-verkoopactiviteit met rijen uit tabel 5080 Taak. Mobile Sales kan vervolgens de tabel met de mobiele apparaten synchroniseren. Standaard worden door Mobile - Sync. Te doen/activiteit synchr. alle rijen uit de tabel Taak opgehaald die nieuw zijn of zijn gewijzigd na de vorige uitvoering van de batchverwerking. U kunt echter ook filters toepassen voordat de batchverwerking wordt uitgevoerd.

Opmerking Opmerking

De eerste keer dat u Mobile - Sync. Te doen/activiteit synchr. uitvoert, is de tabel Mobile-verkoopactiviteit leeg. Alle bestaande taken worden dus naar de tabel Mobile-verkoopactiviteit verzonden. Daarna worden alleen nieuwe of gewijzigde taken naar de tabel Mobile-verkoopactiviteit verzonden.

Mobile Sales kan alleen een taak van Microsoft Dynamics NAV gebruiken als die taak aan het volgende voldoet:

  • De taak moet van het type Vergadering zijn.

  • De taak moet aan een verkoper zijn toegewezen.

  • De taak moet voor een enkel contact van het type Bedrijf zijn.

  • De taak mag geen gebeurtenis zijn die de hele dag duurt.

  • De taak kan niet worden geannuleerd.

De synchronisatie van Microsoft Dynamics-taken verloopt op de volgende manieren:

  • In het venster Mobile Sales instellen kunt u Microsoft Dynamics NAV instellen voor het versturen van alle nieuwe taken naar de tabel Mobile-verkoopactiviteit.

  • U plant bestaande taken voor synchronisatie met de tabel Mobile-verkoopactiviteit door de verwerkingswachtrij in te stellen om de batchverwerking Mobile - Sync. Te doen/activiteit synchr. uit te voeren. Hiermee worden alle bestaande taken naar de tabel Mobile-verkoopactiviteit verstuurd.

U kunt instellen dat Mobile - Sync. Te doen/activiteit synchr. wordt uitgevoerd volgens het schema op een rolgerichte client of een Classic-client. Zie Procedure: Projecten plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV en Procedure: Projecten plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic voor meer informatie.

Afbeelding van uitvouwen Opties

In de volgende tabellen staan de standaardfilters voor batchverwerking 8726 Mobile - Sync. Te doen/activiteit synchr..

Opmerking Opmerking

Als u geen filters toepast, worden door Mobile - Sync. Te doen/activiteit synchr. alleen de taken gesynchroniseerd die nieuw zijn of na de laatste synchronisatie zijn gewijzigd.

Veld | Omschrijving
Nr. | De unieke id voor de taak.
Begindatum | De begindatum voor de taak.
Opmerking Opmerking

Een taak in Microsoft Dynamics NAV wordt in Mobile Sales een activiteit.

Afbeelding van uitvouwen Zie ook

Taken

Procedure: Verwerkingen plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Procedure: Verwerkingen plannen voor Mobile-functionaliteit in Microsoft Dynamics NAV Classic

Referentie

Mobile-verkoopactiviteit (tabel)

Overige informatiebronnen

Batchverwerkingen voor Mobile-functionaliteit in Microsoft Dynamics NAV
Referentie voor Mobile-functionaliteit in Microsoft Dynamics NAV