Class Library

Microsoft Dynamics NAV Documentation
Client Extensibility Reference for Microsoft Dynamics NAV 2009 SP1
CollapseAll image

Expand image Namespaces

Namespace
Microsoft.Dynamics.Framework.UI.Extensibility
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms

© 2010 Microsoft Corporation. All rights reserved.


Microsoft.Dynamics.Framework.UI.Extensibility Namespace

Microsoft.Dynamics.Framework.UI.Extensibility Namespace
CollapseAll image

The Microsoft.Dynamics.Framework.UI.Extensibility namespace contains types that define the model for creating RoleTailored client control add-ins for Microsoft Dynamics NAV 2009 SP1.

Expand image Classes

 | Class | Description
Public class | ControlAddInExportAttribute | Declares a class to be a control add-in that can be used in the RoleTailored client.
Public class | ValidationResult | Defines the data for a validation result from the IControlAddInSite interface. This class cannot be inherited.

Expand image Interfaces

 | Interface | Description
Public interface | IControlAddIn | Defines the interface for the control add-in.
Public interface | IControlAddInSite | Defines the interface that allows a control add-in to get information about the container of the add-in control.
Public interface | IEventControlAddInDefinition | Base interface for a control add-in definition interface that defines a ControlAddInEventHandler event.
Public interface | IObjectControlAddInDefinition | Base interface for a control add-in definition interface that binds the control add-in with a System.Object data type and raises a Microsoft.Dynamics.Framework.UI.Extensibility.ControlAddInEventHandler event.
Public interface | IStringControlAddInDefinition | Base interface for a control add-in definition interface with a String value type and a ControlAddInEventHandler event.
Public interface | IValueControlAddInDefinition | Base interface for a control add-in definition that binds the control add-in with System.String or System.Object data types to the Microsoft Dynamics NAV database.

Expand image Delegates

 | Delegate | Description
Public delegate | ControlAddInEventHandler | Specifies a control add-in event.

Expand image Enumerations

 | Enumeration | Description
Public enumeration | Style | Defines the style enumeration for the control add-in as determined by the Style property of the RoleTailored client page control that is applied with the control add-in.
Public enumeration | ValidationState | Defines the state of a validation result.


ControlAddInEventHandler Delegate

ControlAddInEventHandler Delegate
See Also
CollapseAll image DropDown image

Specifies a control add-in event.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public delegate void ControlAddInEventHandler (
    int index,
    string data
)

Parameters

index

Generic integer.

data

Generic string.

Expand image Remarks

An event calls the OnControlAddIn trigger on the field control of the RoleTailored client page in the Microsoft Dynamics NAV Server.

Expand image See Also

Reference

Microsoft.Dynamics.Framework.UI.Extensibility Namespace


ControlAddInExportAttribute Class

ControlAddInExportAttribute Class
See Also Members
CollapseAll image DropDown image

Declares a class to be a control add-in that can be used in the RoleTailored client.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Interface, AllowMultiple=false, Inherited=false)]
public sealed class ControlAddInExportAttribute : Attribute

Expand image Inheritance Hierarchy

System.Object
System.Attribute
Microsoft.Dynamics.Framework.UI.Extensibility.ControlAddInExportAttribute

Expand image Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Expand image See Also

Reference

ControlAddInExportAttribute Members


ControlAddInExportAttribute Members

ControlAddInExportAttribute Members
See Also Constructors Methods Properties Explicit Interface Implementations
CollapseAll image DropDown image

Declares a class to be a control add-in that can be used in the RoleTailored client.

The following tables list the members exposed by the ControlAddInExportAttribute type.

Expand image Public Constructors

 | Name | Description
Public method | ControlAddInExportAttribute | Overloaded. Initializes a new instance of the ControlAddInExportAttribute class.
Top

Expand image Public Properties

 | Name | Description
Public property | Name | Gets the control add-in name.
Public property | TypeId | (Inherited from Attribute.)
Top

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Equals | Overloaded. (Inherited from Attribute.)
 | GetCustomAttribute | Overloaded. (Inherited from Attribute.)
 | GetCustomAttributes | Overloaded. (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
 | IsDefined | Overloaded. (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | Finalize | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Top

Expand image Explicit Interface Implementations

 | Name | Description
Explicit interface implementation | System.Runtime.InteropServices._Attribute.GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | System.Runtime.InteropServices._Attribute.GetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | System.Runtime.InteropServices._Attribute.Invoke | (Inherited from Attribute.)
Top

Expand image See Also

Reference

ControlAddInExportAttribute Class


ControlAddInExportAttribute Constructor

ControlAddInExportAttribute Constructor
CollapseAll image DropDown image

Initializes a new instance of the ControlAddInExportAttribute class.

Expand image Overload List

Name | Description
ControlAddInExportAttribute () | Initializes a new instance of the ControlAddInExportAttribute class.
ControlAddInExportAttribute (String) | Initializes a new instance of the ControlAddInExportAttribute class.

Expand image See Also

Reference

ControlAddInExportAttribute Class
ControlAddInExportAttribute Members


ControlAddInExportAttribute Constructor ()

ControlAddInExportAttribute Constructor ()
See Also
CollapseAll image DropDown image

Initializes a new instance of the ControlAddInExportAttribute class.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public ControlAddInExportAttribute ()

Expand image See Also

Reference

ControlAddInExportAttribute Class
ControlAddInExportAttribute Members


ControlAddInExportAttribute Constructor (String)

ControlAddInExportAttribute Constructor (String)
See Also
CollapseAll image DropDown image

Initializes a new instance of the ControlAddInExportAttribute class.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public ControlAddInExportAttribute (
    string name
)

Parameters

name

A String that contains the control add-in name.

Expand image See Also

Reference

ControlAddInExportAttribute Class
ControlAddInExportAttribute Members


ControlAddInExportAttribute Methods

ControlAddInExportAttribute Methods
CollapseAll image DropDown image

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Equals | Overloaded. (Inherited from Attribute.)
 | GetCustomAttribute | Overloaded. (Inherited from Attribute.)
 | GetCustomAttributes | Overloaded. (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
 | IsDefined | Overloaded. (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | Finalize | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Top

Expand image Explicit Interface Implementations

 | Name | Description
Explicit interface implementation | System.Runtime.InteropServices._Attribute.GetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | System.Runtime.InteropServices._Attribute.GetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | System.Runtime.InteropServices._Attribute.Invoke | (Inherited from Attribute.)
Top

Expand image See Also

Reference

ControlAddInExportAttribute Class


ControlAddInExportAttribute Properties

ControlAddInExportAttribute Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Public property | Name | Gets the control add-in name.
Public property | TypeId | (Inherited from Attribute.)
Top

Expand image See Also

Reference

ControlAddInExportAttribute Class


ControlAddInExportAttribute.Name Property

ControlAddInExportAttribute.Name Property
CollapseAll image DropDown image

Gets the control add-in name.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public string Name { get; }

Property Value

A String that contains the control add-in name.

Expand image See Also

Reference

ControlAddInExportAttribute Class
ControlAddInExportAttribute Members


IControlAddIn Interface

IControlAddIn Interface
See Also Members
CollapseAll image DropDown image

Defines the interface for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public interface IControlAddIn

Expand image Remarks

All RoleTailored client control add-ins must implement IControlAddIn. The IControlAddIn interface enables the control add-in to call the Microsoft Dynamics NAV framework to get additional information about the control add-ins behavior.

Expand image See Also

Reference

IControlAddIn Members


IControlAddIn Members

IControlAddIn Members
See Also Methods
CollapseAll image DropDown image

Defines the interface for the control add-in.

The following tables list the members exposed by the IControlAddIn type.

Expand image Public Methods

 | Name | Description
Public method | Initialize | Sets the Initialize for the control add-in.
Top

Expand image See Also

Reference

IControlAddIn Interface


IControlAddIn Methods

IControlAddIn Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Public method | Initialize | Sets the Initialize for the control add-in.
Top

Expand image See Also

Reference

IControlAddIn Interface


IControlAddIn.Initialize Method

IControlAddIn.Initialize Method
collapseAll image DropDown image

Sets the Initialize for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
void Initialize (
    IControlAddInSite controlAddInSite
)

Parameters

controlAddInSite

The IControlAddIn in which the control add-in runs.

Expand image See Also

Reference

IControlAddIn Interface
IControlAddIn Members


IControlAddInSite Interface

IControlAddInSite Interface
See Also Members
CollapseAll image DropDown image

Defines the interface that allows a control add-in to get information about the container of the add-in control.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public interface IControlAddInSite

Expand image Remarks

The IControlAddIn interface is initialized with a control add-in site object, which implements the IControlAddInSite interface. The IControlAddInSite interface provides information to control add-in across all display targets and allows the control add-in to call functionality inside the Microsoft Dynamics NAV framework. For example, a control can retrieve metadata information.

Expand image See Also

Reference

IControlAddInSite Members


IControlAddInSite Members

IControlAddInSite Members
See Also Events Methods Properties
CollapseAll image DropDown image

Defines the interface that allows a control add-in to get information about the container of the add-in control.

The following tables list the members exposed by the IControlAddInSite type.

Expand image Public Properties

 | Name | Description
Public property | Caption | Gets the caption text of the control add-in.
Public property | Editable | Gets a value indicating whether the control add-in is editable.
Public property | Enabled | Gets a value indicating whether the control add-in is enabled.
Public property | Style | Gets the style of the control add-in.
Public property | ValidationResult | Gets the result of the latest validation of the control add-in's value.
Public property | Visible | Gets a value indicating whether the control add-in is visible.
Top

Expand image Public Methods

 | Name | Description
Public method | SaveValue | Tells the RoleTailored client to save the value of the control add-in.
Top

Expand image Public Events

 | Name | Description
Public event | CaptionChanged | Occurs when the Caption property has changed.
Public event | EditableChanged | Occurs when the Editable property has changed.
Public event | EnabledChanged | Occurs when the Enabled property has changed.
Public event | StyleChanged | Occurs when the Style property has changed.
Public event | ValidationResultChanged | Occurs when the site has validated the control add-in value.
Public event | VisibleChanged | Occurs when the Visible property has changed.
Top

Expand image See Also

Reference

IControlAddInSite Interface


IControlAddInSite Methods

IControlAddInSite Methods
CollapseAll image DropDown image

Expand image Public Methods

 | Name | Description
Public method | SaveValue | Tells the RoleTailored client to save the value of the control add-in.
Top

Expand image See Also

Reference

IControlAddInSite Interface


IControlAddInSite.SaveValue Method

IControlAddInSite.SaveValue Method
collapseAll image DropDown image

Tells the RoleTailored client to save the value of the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
void SaveValue ()

Expand image Remarks

The value is read by the RoleTailored client from the control add-in.

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite Properties

IControlAddInSite Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Public property | Caption | Gets the caption text of the control add-in.
Public property | Editable | Gets a value indicating whether the control add-in is editable.
Public property | Enabled | Gets a value indicating whether the control add-in is enabled.
Public property | Style | Gets the style of the control add-in.
Public property | ValidationResult | Gets the result of the latest validation of the control add-in's value.
Public property | Visible | Gets a value indicating whether the control add-in is visible.
Top

Expand image See Also

Reference

IControlAddInSite Interface


IControlAddInSite.Caption Property

IControlAddInSite.Caption Property
CollapseAll image DropDown image

Gets the caption text of the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
string Caption { get; }

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.Editable Property

IControlAddInSite.Editable Property
CollapseAll image DropDown image

Gets a value indicating whether the control add-in is editable.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
bool Editable { get; }

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.Enabled Property

IControlAddInSite.Enabled Property
CollapseAll image DropDown image

Gets a value indicating whether the control add-in is enabled.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
bool Enabled { get; }

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.Style Property

IControlAddInSite.Style Property
CollapseAll image DropDown image

Gets the style of the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
Style Style { get; }

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.ValidationResult Property

IControlAddInSite.ValidationResult Property
CollapseAll image DropDown image

Gets the result of the latest validation of the control add-in's value.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
ValidationResult ValidationResult { get; }

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.Visible Property

IControlAddInSite.Visible Property
CollapseAll image DropDown image

Gets a value indicating whether the control add-in is visible.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
bool Visible { get; }

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite Events

IControlAddInSite Events
CollapseAll image DropDown image

Expand image Public Events

 | Name | Description
Public event | CaptionChanged | Occurs when the Caption property has changed.
Public event | EditableChanged | Occurs when the Editable property has changed.
Public event | EnabledChanged | Occurs when the Enabled property has changed.
Public event | StyleChanged | Occurs when the Style property has changed.
Public event | ValidationResultChanged | Occurs when the site has validated the control add-in value.
Public event | VisibleChanged | Occurs when the Visible property has changed.
Top

Expand image See Also

Reference

IControlAddInSite Interface


IControlAddInSite.CaptionChanged Event

IControlAddInSite.CaptionChanged Event
CollapseAll image DropDown image

Occurs when the Caption property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
event EventHandler CaptionChanged

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.EditableChanged Event

IControlAddInSite.EditableChanged Event
CollapseAll image DropDown image

Occurs when the Editable property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
event EventHandler EditableChanged

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.EnabledChanged Event

IControlAddInSite.EnabledChanged Event
CollapseAll image DropDown image

Occurs when the Enabled property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
event EventHandler EnabledChanged

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.StyleChanged Event

IControlAddInSite.StyleChanged Event
CollapseAll image DropDown image

Occurs when the Style property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
event EventHandler StyleChanged

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.ValidationResultChanged Event

IControlAddInSite.ValidationResultChanged Event
CollapseAll image DropDown image

Occurs when the site has validated the control add-in value.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
event EventHandler ValidationResultChanged

Expand image Remarks

The validation can succeed or fail. This event is raised when the validation result has changed.

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IControlAddInSite.VisibleChanged Event

IControlAddInSite.VisibleChanged Event
CollapseAll image DropDown image

Occurs when the Visible property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
event EventHandler VisibleChanged

Expand image See Also

Reference

IControlAddInSite Interface
IControlAddInSite Members


IEventControlAddInDefinition Interface

IEventControlAddInDefinition Interface
See Also Members
CollapseAll image DropDown image

Base interface for a control add-in definition interface that defines a ControlAddInEventHandler event.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public interface IEventControlAddInDefinition

Expand image Remarks

IEventControlAddInDefinition uses events to call the OnControlAddin trigger of a page field control. The StringControlAddInBase class implements this interface.

Expand image See Also

Reference

IEventControlAddInDefinition Members


IEventControlAddInDefinition Members

IEventControlAddInDefinition Members
See Also Events
CollapseAll image DropDown image

Base interface for a control add-in definition interface that defines a ControlAddInEventHandler event.

The following tables list the members exposed by the IEventControlAddInDefinition type.

Expand image Public Events

 | Name | Description
Public event | ControlAddIn | IEventControlAddInDefinition event that invokes the OnControlAddIn trigger on the field of a RoleTailored client page.
Top

Expand image See Also

Reference

IEventControlAddInDefinition Interface


IEventControlAddInDefinition Events

IEventControlAddInDefinition Events
CollapseAll image DropDown image

Expand image Public Events

 | Name | Description
Public event | ControlAddIn | IEventControlAddInDefinition event that invokes the OnControlAddIn trigger on the field of a RoleTailored client page.
Top

Expand image See Also

Reference

IEventControlAddInDefinition Interface


IEventControlAddInDefinition.ControlAddIn Event

IEventControlAddInDefinition.ControlAddIn Event
CollapseAll image DropDown image

IEventControlAddInDefinition event that invokes the OnControlAddIn trigger on the field of a RoleTailored client page.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
event ControlAddInEventHandler ControlAddIn

Expand image See Also

Reference

IEventControlAddInDefinition Interface
IEventControlAddInDefinition Members


IObjectControlAddInDefinition Interface

IObjectControlAddInDefinition Interface
See Also Members
CollapseAll image DropDown image

Base interface for a control add-in definition interface that binds the control add-in with a System.Object data type and raises a Microsoft.Dynamics.Framework.UI.Extensibility.ControlAddInEventHandler event.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public interface IObjectControlAddInDefinition : IValueControlAddInDefinition<Object>, IEventControlAddInDefinition

Expand image Remarks

IObjectControlAddInDefinition displays binary data from a Microsoft Dynamics NAV database and uses events to call the OnControlAddin trigger of a field control on a RoleTailored client page.

Expand image See Also

Reference

IObjectControlAddInDefinition Members


IObjectControlAddInDefinition Members

IObjectControlAddInDefinition Members
CollapseAll image DropDown image

Base interface for a control add-in definition interface that binds the control add-in with a System.Object data type and raises a Microsoft.Dynamics.Framework.UI.Extensibility.ControlAddInEventHandler event.

Expand image See Also

Reference

IObjectControlAddInDefinition Interface


IStringControlAddInDefinition Interface

IStringControlAddInDefinition Interface
See Also Members
CollapseAll image DropDown image

Base interface for a control add-in definition interface with a String value type and a ControlAddInEventHandler event.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public interface IStringControlAddInDefinition : IValueControlAddInDefinition<string>, IEventControlAddInDefinition

Expand image Remarks

IStringControlAddInDefinition displays text strings from Microsoft Dynamics NAV database and uses events to call the OnControlAddin trigger of field control on a RoleTailored client page.

Expand image See Also

Reference

IStringControlAddInDefinition Members


IStringControlAddInDefinition Members

IStringControlAddInDefinition Members
CollapseAll image DropDown image

Base interface for a control add-in definition interface with a String value type and a ControlAddInEventHandler event.

Expand image See Also

Reference

IStringControlAddInDefinition Interface


IValueControlAddInDefinition Generic Interface

IValueControlAddInDefinition Generic Interface
See Also Members
CollapseAll image DropDown image

Base interface for a control add-in definition that binds the control add-in with System.String or System.Object data types to the Microsoft Dynamics NAV database.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public interface IValueControlAddInDefinition<T>

Type Parameters

T

The type of the data that the control add-in definition interface exposes. Only data of type String and Object are supported currently.

Expand image Remarks

Displays text strings or binary data from the Microsoft Dynamics NAV database.

Expand image See Also

Reference

IValueControlAddInDefinition Members


IValueControlAddInDefinition Members

IValueControlAddInDefinition Members
See Also Properties
CollapseAll image DropDown image

Base interface for a control add-in definition that binds the control add-in with System.String or System.Object data types to the Microsoft Dynamics NAV database.

The following tables list the members exposed by the IValueControlAddInDefinition generic type.

Expand image Public Properties

 | Name | Description
Public property | HasValueChanged | Gets a value indicating whether the Value property has changed its value.
Public property | Value | Gets or sets the value of the control add-in.
Top

Expand image See Also

Reference

IValueControlAddInDefinition Generic Interface


IValueControlAddInDefinition Properties

IValueControlAddInDefinition Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Public property | HasValueChanged | Gets a value indicating whether the Value property has changed its value.
Public property | Value | Gets or sets the value of the control add-in.
Top

Expand image See Also

Reference

IValueControlAddInDefinition Generic Interface


IValueControlAddInDefinition.HasValueChanged Property

IValueControlAddInDefinition.HasValueChanged Property
CollapseAll image DropDown image

Gets a value indicating whether the Value property has changed its value.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
bool HasValueChanged { get; }

Property Value

true if Value property has changed its value; otherwise, false. The default is false.

Expand image See Also

Reference

IValueControlAddInDefinition Generic Interface
IValueControlAddInDefinition Members


IValueControlAddInDefinition.Value Property

IValueControlAddInDefinition.Value Property
CollapseAll image DropDown image

Gets or sets the value of the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
T Value { get; set; }

Expand image See Also

Reference

IValueControlAddInDefinition Generic Interface
IValueControlAddInDefinition Members


Style Enumeration

Style Enumeration
CollapseAll image DropDown image

Defines the style enumeration for the control add-in as determined by the Style property of the RoleTailored client page control that is applied with the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public enum Style

Expand image Members

Member name | Description
Attention | Attention
Favorable | Favorable
None | None
Strong | Strong
Unfavorable | Unfavorable

Expand image See Also

Reference


ValidationResult Class

ValidationResult Class
See Also Members
CollapseAll image DropDown image

Defines the data for a validation result from the IControlAddInSite interface. This class cannot be inherited.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public sealed class ValidationResult

Expand image Inheritance Hierarchy

System.Object
Microsoft.Dynamics.Framework.UI.Extensibility.ValidationResult

Expand image Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Expand image See Also

Reference

ValidationResult Members


ValidationResult Members

ValidationResult Members
See Also Constructors Methods Properties
CollapseAll image DropDown image

Defines the data for a validation result from the IControlAddInSite interface. This class cannot be inherited.

The following tables list the members exposed by the ValidationResult type.

Expand image Public Constructors

 | Name | Description
Public method | ValidationResult | Initializes a new instance of the ValidationResult class.
Top

Expand image Public Properties

 | Name | Description
Public property | State | Gets the ValidationState for the validation result.
Public property | Text | Gets the text message for the validation result.
Top

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Equals | Overloaded. (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | Finalize | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Top

Expand image See Also

Reference

ValidationResult Class


ValidationResult Constructor

ValidationResult Constructor
CollapseAll image DropDown image

Initializes a new instance of the ValidationResult class.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public ValidationResult (
    ValidationState validationState,
    string validationStateText
)

Parameters

validationState

A ValidationState for the validation result.

validationStateText

A text message for the validation result.

Expand image See Also

Reference

ValidationResult Class
ValidationResult Members


ValidationResult Methods

ValidationResult Methods
CollapseAll image DropDown image

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Equals | Overloaded. (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | Finalize | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Top

Expand image See Also

Reference

ValidationResult Class


ValidationResult Properties

ValidationResult Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Public property | State | Gets the ValidationState for the validation result.
Public property | Text | Gets the text message for the validation result.
Top

Expand image See Also

Reference

ValidationResult Class


ValidationResult.State Property

ValidationResult.State Property
CollapseAll image DropDown image

Gets the ValidationState for the validation result.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public ValidationState State { get; }

Expand image See Also

Reference

ValidationResult Class
ValidationResult Members


ValidationResult.Text Property

ValidationResult.Text Property
CollapseAll image DropDown image

Gets the text message for the validation result.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public string Text { get; }

Expand image See Also

Reference

ValidationResult Class
ValidationResult Members


ValidationState Enumeration

ValidationState Enumeration
CollapseAll image DropDown image

Defines the state of a validation result.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public enum ValidationState

Expand image Members

Member name | Description
Error | An error occurred in validation.
Info | The validation issues an informational message.
Valid | The validation succeeded.
Warning | The validation state issued a warning message.

Expand image See Also

Reference


Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace

Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace
CollapseAll image

The Microsoft.Dynamics.Framework.UI.Extensibility.WinForms namespace contains types for creating RoleTailored client control add-ins for Microsoft Dynamics NAV 2009 SP1 that have a user interface that is based on System.Window.Forms.

Expand image Classes

 | Class | Description
Public class | StringControlAddInBase | Base class for a Windows Forms control add-in that binds System.String type data with the Microsoft Dynamics NAV database and uses events to call the OnControlAddin trigger on RoleTailored client page controls.
Public class | WinFormsControlAddInBase | Base class for a Window Forms control add-in as an alternative to the explicit implementation of the IWinFormsControlAddIn interface.

Expand image Interfaces

 | Interface | Description
Public interface | IWinFormsControlAddIn | Defines the IWinFormsControlAddIn interface.


IWinFormsControlAddIn Interface

IWinFormsControlAddIn Interface
See Also Members
CollapseAll image DropDown image

Defines the IWinFormsControlAddIn interface.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public interface IWinFormsControlAddIn : IControlAddIn

Expand image Remarks

Use IWinFormsControlAddIn to develop control add-ins that target Windows Forms–based displays You can implement this interface explicitly and override its members, or you can implement WinFormsControlAddInBase or StringControlAddInBase abstract base classes that implements the interface for you.

Expand image See Also

Reference

IWinFormsControlAddIn Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


IWinFormsControlAddIn Members

IWinFormsControlAddIn Members
See Also Properties
CollapseAll image DropDown image

Defines the IWinFormsControlAddIn interface.

The following tables list the members exposed by the IWinFormsControlAddIn type.

Expand image Public Properties

 | Name | Description
Public property | AllowCaptionControl | Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in.
Public property | Control | Gets the Windows Forms control for the control add-in.
Top

Expand image See Also

Reference

IWinFormsControlAddIn Interface
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


IWinFormsControlAddIn Properties

IWinFormsControlAddIn Properties
CollapseAll image DropDown image

Expand image Public Properties

 | Name | Description
Public property | AllowCaptionControl | Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in.
Public property | Control | Gets the Windows Forms control for the control add-in.
Top

Expand image See Also

Reference

IWinFormsControlAddIn Interface
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


IWinFormsControlAddIn.AllowCaptionControl Property

IWinFormsControlAddIn.AllowCaptionControl Property
CollapseAll image DropDown image

Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
bool AllowCaptionControl { get; }

Property Value

true to display a caption control; otherwise, false to omit the caption control and use the available space for the entire control.

Expand image See Also

Reference

IWinFormsControlAddIn Interface
IWinFormsControlAddIn Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


IWinFormsControlAddIn.Control Property

IWinFormsControlAddIn.Control Property
CollapseAll image DropDown image

Gets the Windows Forms control for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
Control Control { get; }

Expand image See Also

Reference

IWinFormsControlAddIn Interface
IWinFormsControlAddIn Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase Class

StringControlAddInBase Class
See Also Members
CollapseAll image DropDown image

Base class for a Windows Forms control add-in that binds System.String type data with the Microsoft Dynamics NAV database and uses events to call the OnControlAddin trigger on RoleTailored client page controls.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public abstract class StringControlAddInBase : WinFormsControlAddInBase, IValueControlAddInDefinition<string>, IEventControlAddInDefinition

Expand image Remarks

You can use this base class for a control add-in that displays text strings from a simple text box control and supports events that call the C/AL trigger on the page.

Expand image Inheritance Hierarchy

System.Object
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms.WinFormsControlAddInBase
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms.StringControlAddInBase

Expand image Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Expand image See Also

Reference

StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase Members

StringControlAddInBase Members
See Also Events Methods Properties Constructors
CollapseAll image DropDown image

Base class for a Windows Forms control add-in that binds System.String type data with the Microsoft Dynamics NAV database and uses events to call the OnControlAddin trigger on RoleTailored client page controls.

The following tables list the members exposed by the StringControlAddInBase type.

Expand image Protected Constructors

 | Name | Description
Protected method | StringControlAddInBase | Initializes a new instance of the StringControlAddInBase class.
Top

Expand image Public Properties (see also Protected Properties )

 | Name | Description
Public property | AllowCaptionControl | Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in. (Inherited from WinFormsControlAddInBase.)
Public property | Control | Gets the Windows Forms control for the control add-in. (Inherited from WinFormsControlAddInBase.)
Public property | HasValueChanged | Gets a value indicating whether the Value property has changed its value.
Public property | Value | Gets or sets the value of the control add-in as a String.
Top

Expand image Protected Properties

 | Name | Description
Protected property | Site | Gets the IControlAddInSite for the control add-in. (Inherited from WinFormsControlAddInBase.)
Top

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase. (Inherited from WinFormsControlAddInBase.)
Public method | Equals | Overloaded. (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Sets the IControlAddInSite for the control add-in. (Inherited from WinFormsControlAddInBase.)
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | CreateControl | Creates the Windows Forms control for the control add-in. (Inherited from WinFormsControlAddInBase.)
Protected method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase. (Inherited from WinFormsControlAddInBase.)
Protected method | Finalize | Finalizes an instance of the WinFormsControlAddInBase class. (Inherited from WinFormsControlAddInBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCaptionChanged | Called when the Caption property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnEditableChanged | Overridden. Called when the Editable property on the Site property has changed.
Protected method | OnEnabledChanged | Called when the Enabled property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnInitialize | Overridden. Called when Initialize is initialized.
Protected method | OnStyleChanged | Called when the Style property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnValidationResultChanged | Called when the ValidationResult property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnVisibleChanged | Called when the Visible property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | RaiseControlAddInEvent | Raises the ControlAddIn event.
Top

Expand image Public Events

 | Name | Description
Public event | ControlAddIn | Invokes the OnControlAddIn trigger of the RoleTailored client page control on which the control add-in is applied.
Top

Expand image See Also

Reference

StringControlAddInBase Class
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase Constructor

StringControlAddInBase Constructor
CollapseAll image DropDown image

Initializes a new instance of the StringControlAddInBase class.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected StringControlAddInBase ()

Expand image See Also

Reference

StringControlAddInBase Class
StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase Methods

StringControlAddInBase Methods
CollapseAll image DropDown image

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase. (Inherited from WinFormsControlAddInBase.)
Public method | Equals | Overloaded. (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Sets the IControlAddInSite for the control add-in. (Inherited from WinFormsControlAddInBase.)
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | CreateControl | Creates the Windows Forms control for the control add-in. (Inherited from WinFormsControlAddInBase.)
Protected method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase. (Inherited from WinFormsControlAddInBase.)
Protected method | Finalize | Finalizes an instance of the WinFormsControlAddInBase class. (Inherited from WinFormsControlAddInBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCaptionChanged | Called when the Caption property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnEditableChanged | Overridden. Called when the Editable property on the Site property has changed.
Protected method | OnEnabledChanged | Called when the Enabled property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnInitialize | Overridden. Called when Initialize is initialized.
Protected method | OnStyleChanged | Called when the Style property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnValidationResultChanged | Called when the ValidationResult property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | OnVisibleChanged | Called when the Visible property on the Site property has changed. (Inherited from WinFormsControlAddInBase.)
Protected method | RaiseControlAddInEvent | Raises the ControlAddIn event.
Top

Expand image See Also

Reference

StringControlAddInBase Class
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase.OnEditableChanged Method

StringControlAddInBase.OnEditableChanged Method
collapseAll image DropDown image

Called when the Editable property on the Site property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected override void OnEditableChanged (
    bool editable
)

Parameters

editable

The new editable value.

Expand image Remarks

If the control add-in's Windows Forms control is a TextBox, then its ReadOnly property will be set; otherwise the control add-in should override this method and display its content as editable or non-editable.

Expand image See Also

Reference

StringControlAddInBase Class
StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase.OnInitialize Method

StringControlAddInBase.OnInitialize Method
collapseAll image DropDown image

Called when Initialize is initialized.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected override void OnInitialize ()

Expand image See Also

Reference

StringControlAddInBase Class
StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase.RaiseControlAddInEvent Method

StringControlAddInBase.RaiseControlAddInEvent Method
collapseAll image DropDown image

Raises the ControlAddIn event.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected void RaiseControlAddInEvent (
    int index,
    string data
)

Parameters

index

Generic integer.

data

Generic string.

Expand image Remarks

An event calls the OnControlAddIn trigger of the RoleTailored client page control on which the control add-in is applied.

Expand image See Also

Reference

StringControlAddInBase Class
StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase Properties

StringControlAddInBase Properties
CollapseAll image DropDown image

Expand image Public Properties (see also Protected Properties )

 | Name | Description
Public property | AllowCaptionControl | Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in. (Inherited from WinFormsControlAddInBase.)
Public property | Control | Gets the Windows Forms control for the control add-in. (Inherited from WinFormsControlAddInBase.)
Public property | HasValueChanged | Gets a value indicating whether the Value property has changed its value.
Public property | Value | Gets or sets the value of the control add-in as a String.
Top

Expand image Protected Properties

 | Name | Description
Protected property | Site | Gets the IControlAddInSite for the control add-in. (Inherited from WinFormsControlAddInBase.)
Top

Expand image See Also

Reference

StringControlAddInBase Class
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase.HasValueChanged Property

StringControlAddInBase.HasValueChanged Property
CollapseAll image DropDown image

Gets a value indicating whether the Value property has changed its value.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public virtual bool HasValueChanged { get; }

Property Value

true if Value property has changed its value; otherwise, false. The default is false.

Expand image See Also

Reference

StringControlAddInBase Class
StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase.Value Property

StringControlAddInBase.Value Property
CollapseAll image DropDown image

Gets or sets the value of the control add-in as a String.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public virtual string Value { get; set; }

Expand image See Also

Reference

StringControlAddInBase Class
StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase Events

StringControlAddInBase Events
CollapseAll image DropDown image

Expand image Public Events

 | Name | Description
Public event | ControlAddIn | Invokes the OnControlAddIn trigger of the RoleTailored client page control on which the control add-in is applied.
Top

Expand image See Also

Reference

StringControlAddInBase Class
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


StringControlAddInBase.ControlAddIn Event

StringControlAddInBase.ControlAddIn Event
CollapseAll image DropDown image

Invokes the OnControlAddIn trigger of the RoleTailored client page control on which the control add-in is applied.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public event ControlAddInEventHandler ControlAddIn

Expand image See Also

Reference

StringControlAddInBase Class
StringControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase Class

WinFormsControlAddInBase Class
See Also Members
CollapseAll image DropDown image

Base class for a Window Forms control add-in as an alternative to the explicit implementation of the IWinFormsControlAddIn interface.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public abstract class WinFormsControlAddInBase : IWinFormsControlAddIn, IControlAddIn, IDisposable

Expand image Inheritance Hierarchy

System.Object
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms.WinFormsControlAddInBase
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms.StringControlAddInBase

Expand image Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Expand image See Also

Reference

WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase Members

WinFormsControlAddInBase Members
See Also Methods Properties Constructors
CollapseAll image DropDown image

Base class for a Window Forms control add-in as an alternative to the explicit implementation of the IWinFormsControlAddIn interface.

The following tables list the members exposed by the WinFormsControlAddInBase type.

Expand image Protected Constructors

 | Name | Description
Protected method | WinFormsControlAddInBase | Initializes a new instance of the WinFormsControlAddInBase class.
Top

Expand image Public Properties (see also Protected Properties )

 | Name | Description
Public property | AllowCaptionControl | Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in.
Public property | Control | Gets the Windows Forms control for the control add-in.
Top

Expand image Protected Properties

 | Name | Description
Protected property | Site | Gets the IControlAddInSite for the control add-in.
Top

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase.
Public method | Equals | Overloaded. (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Sets the IControlAddInSite for the control add-in.
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | CreateControl | Creates the Windows Forms control for the control add-in.
Protected method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase.
Protected method | Finalize | Overridden. Finalizes an instance of the WinFormsControlAddInBase class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCaptionChanged | Called when the Caption property on the Site property has changed.
Protected method | OnEditableChanged | Called when the Editable property on the Site property has changed.
Protected method | OnEnabledChanged | Called when the Enabled property on the Site property has changed.
Protected method | OnInitialize | Called when Initialize is called.
Protected method | OnStyleChanged | Called when the Style property on the Site property has changed.
Protected method | OnValidationResultChanged | Called when the ValidationResult property on the Site property has changed.
Protected method | OnVisibleChanged | Called when the Visible property on the Site property has changed.
Top

Expand image See Also

Reference

WinFormsControlAddInBase Class
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase Constructor

WinFormsControlAddInBase Constructor
CollapseAll image DropDown image

Initializes a new instance of the WinFormsControlAddInBase class.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected WinFormsControlAddInBase ()

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase Methods

WinFormsControlAddInBase Methods
CollapseAll image DropDown image

Expand image Public Methods (see also Protected Methods )

 | Name | Description
Public method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase.
Public method | Equals | Overloaded. (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Initialize | Sets the IControlAddInSite for the control add-in.
 | ReferenceEquals | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top

Expand image Protected Methods

 | Name | Description
Protected method | CreateControl | Creates the Windows Forms control for the control add-in.
Protected method | Dispose | Overloaded. Releases the resources used by the WinFormsControlAddInBase.
Protected method | Finalize | Overridden. Finalizes an instance of the WinFormsControlAddInBase class.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnCaptionChanged | Called when the Caption property on the Site property has changed.
Protected method | OnEditableChanged | Called when the Editable property on the Site property has changed.
Protected method | OnEnabledChanged | Called when the Enabled property on the Site property has changed.
Protected method | OnInitialize | Called when Initialize is called.
Protected method | OnStyleChanged | Called when the Style property on the Site property has changed.
Protected method | OnValidationResultChanged | Called when the ValidationResult property on the Site property has changed.
Protected method | OnVisibleChanged | Called when the Visible property on the Site property has changed.
Top

Expand image See Also

Reference

WinFormsControlAddInBase Class
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.CreateControl Method

WinFormsControlAddInBase.CreateControl Method
collapseAll image DropDown image

Creates the Windows Forms control for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected abstract Control CreateControl ()

Return Value

Returns the Windows Forms control.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.Dispose Method

WinFormsControlAddInBase.Dispose Method
CollapseAll image DropDown image

Releases the resources used by the WinFormsControlAddInBase.

Expand image Overload List

Name | Description
WinFormsControlAddInBase.Dispose () | Releases all resources used by the WinFormsControlAddInBase.
WinFormsControlAddInBase.Dispose (Boolean) | Releases the unmanaged resources used by the WinFormsControlAddInBase and optionally releases the managed resources.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.Dispose Method ()

WinFormsControlAddInBase.Dispose Method ()
See Also
collapseAll image DropDown image

Releases all resources used by the WinFormsControlAddInBase.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public void Dispose ()

Expand image Remarks

Implements the System.IDisposable.Dispose method.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.Dispose Method (Boolean)

WinFormsControlAddInBase.Dispose Method (Boolean)
See Also
collapseAll image DropDown image

Releases the unmanaged resources used by the WinFormsControlAddInBase and optionally releases the managed resources.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void Dispose (
    bool disposing
)

Parameters

disposing

true to release both managed and unmanaged resources; false to release only unmanaged resources.

Expand image Remarks

Dispose executes in two distinct scenarios:

  • If disposing is true, then the method is called directly or indirectly by a user's code. Managed and unmanaged resources can be disposed.

  • If disposing is false, the method is called at runtime and you should not reference other objects. Only unmanaged resources can be disposed.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.Finalize Method

WinFormsControlAddInBase.Finalize Method
collapseAll image DropDown image

Finalizes an instance of the WinFormsControlAddInBase class.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
~WinFormsControlAddInBase()

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.Initialize Method

WinFormsControlAddInBase.Initialize Method
collapseAll image DropDown image

Sets the IControlAddInSite for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public void Initialize (
    IControlAddInSite controlAddInSite
)

Parameters

controlAddInSite

The IControlAddInSite in which the control add-in runs.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.OnCaptionChanged Method

WinFormsControlAddInBase.OnCaptionChanged Method
collapseAll image DropDown image

Called when the Caption property on the Site property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void OnCaptionChanged (
    string caption
)

Parameters

caption

A String containing the new caption.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.OnEditableChanged Method

WinFormsControlAddInBase.OnEditableChanged Method
collapseAll image DropDown image

Called when the Editable property on the Site property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void OnEditableChanged (
    bool editable
)

Parameters

editable

The new editable value.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.OnEnabledChanged Method

WinFormsControlAddInBase.OnEnabledChanged Method
collapseAll image DropDown image

Called when the Enabled property on the Site property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void OnEnabledChanged (
    bool enabled
)

Parameters

enabled

The new enabled value.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.OnInitialize Method

WinFormsControlAddInBase.OnInitialize Method
collapseAll image DropDown image

Called when Initialize is called.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void OnInitialize ()

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.OnStyleChanged Method

WinFormsControlAddInBase.OnStyleChanged Method
collapseAll image DropDown image

Called when the Style property on the Site property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void OnStyleChanged (
    Style style
)

Parameters

style

A Style containing the new style.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.OnValidationResultChanged Method

WinFormsControlAddInBase.OnValidationResultChanged Method
collapseAll image DropDown image

Called when the ValidationResult property on the Site property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void OnValidationResultChanged (
    ValidationResult validationResult
)

Parameters

validationResult

A ValidationResult that contains the new validation result.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.OnVisibleChanged Method

WinFormsControlAddInBase.OnVisibleChanged Method
collapseAll image DropDown image

Called when the Visible property on the Site property has changed.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected virtual void OnVisibleChanged (
    bool visible
)

Parameters

visible

The new visible value.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase Properties

WinFormsControlAddInBase Properties
CollapseAll image DropDown image

Expand image Public Properties (see also Protected Properties )

 | Name | Description
Public property | AllowCaptionControl | Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in.
Public property | Control | Gets the Windows Forms control for the control add-in.
Top

Expand image Protected Properties

 | Name | Description
Protected property | Site | Gets the IControlAddInSite for the control add-in.
Top

Expand image See Also

Reference

WinFormsControlAddInBase Class
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.AllowCaptionControl Property

WinFormsControlAddInBase.AllowCaptionControl Property
CollapseAll image DropDown image

Gets a value indicating whether the RoleTailored client displays a caption control for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public virtual bool AllowCaptionControl { get; }

Property Value

true to display a caption control; false tonot display the caption control and use available space for the entire Windows Forms control.

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.Control Property

WinFormsControlAddInBase.Control Property
CollapseAll image DropDown image

Gets the Windows Forms control for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
public Control Control { get; }

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace


WinFormsControlAddInBase.Site Property

WinFormsControlAddInBase.Site Property
CollapseAll image DropDown image

Gets the IControlAddInSite for the control add-in.

Namespace: Microsoft.Dynamics.Framework.UI.Extensibility.WinForms
Assembly: Microsoft.Dynamics.Framework.UI.Extensibility (in microsoft.dynamics.framework.ui.extensibility.dll)

Expand image Syntax

C#
protected IControlAddInSite Site { get; }

Expand image See Also

Reference

WinFormsControlAddInBase Class
WinFormsControlAddInBase Members
Microsoft.Dynamics.Framework.UI.Extensibility.WinForms Namespace