Actie WO-aanvraagtabel EP (tabel)

Tabel Actie WO-aanvraagtabel EP

Lijst met velden in de tabel

De tabel Actie WO-verzoektabel WP bevat alle acties die u hebt ingesteld voor webonderdeelverzoeken en informatie over het gedrag van deze acties in het webonderdeel.

© 2009 Microsoft Corporation. Alle rechten voorbehouden.


Actiefilter WO-aanvraagtabel EP (tabel)

Tabel Actiefilter WO-aanvraagtabel EP

Lijst met velden in de tabel

De tabel Actiefilter WO-verzoektabel EP bevat alle filters die zijn geconfigureerd voor acties waarmee andere webonderdeelverzoeken worden aangeroepen. In de tabel Actiefilter WO-verzoektabel EP kunt u gebruikmaken van waarden uit het aanroepende webonderdeelverzoek en van vaste waarden die geen deel uitmaken van het aanroepende webonderdeelverzoek. Zo kunt u bijvoorbeeld filteren op documentsoort.


Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Tabel Bewerkingscriteria WO-aanvraagtabel EP

Lijst met velden in de tabel

Deze tabel bevat criteria voor records die door de gebruiker kunnen worden bewerkt.


Employee Portal-instellingen (tabel)

Tabel Employee Portal-instellingen

Lijst met velden in de tabel

Deze tabel bevat het bijschrift dat u hebt gedefinieerd voor de aangepaste eigenschapsvelden in het toolsvenster SharePoint. De aangepaste eigenschappen zijn gemaakt om Employee Portal-functionaliteit toe te voegen aan het webonderdeel. De aangepaste eigenschapsvelden zijn de toepassingsvelden. De aangepaste eigenschapsvelden zijn specifiek voor Microsoft Dynamics NAV en de bijschriften voor deze velden moeten worden gedefinieerd in de EP-instellingenkaart in Microsoft Dynamics NAV.


EP-bijschrift (tabel)

Tabel EP-bijschrift

Lijst met velden in de tabel

Alle bijschriften voor de Employee Portal die niet kunnen worden overgenomen uit de bestaande objectbijschriften van Microsoft Dynamics NAV worden in deze tabel opgeslagen. Deze bijschriften worden weergegeven op de portaalpagina afhankelijk van de geconfigureerde taal voor de gebruiker of groep. Alle bijschriften voor groepen, acties, webonderdeelverzoeken, tabbladen en webonderdeeleigenschappen moeten in deze tabel worden gemaakt.


EP-gebruiker (tabel)

Tabel EP-gebruiker

Lijst met velden in de tabel

De tabel Gebruiker bevat de gebruikers die Employee Portal gaan gebruiken om toegang te krijgen tot Microsoft Dynamics NAV. U kunt deze tabel ook gebruiken om een taal-id voor de gebruiker te definiëren.


EP-gebruikerslogin (tabel)

Tabel EP-gebruikerslogin

Lijst met velden in de tabel

Wanneer u nieuwe gebruikersaccounts configureert voor Employee Portal, wordt deze tabel alleen tijdelijk gebruikt om toegang te krijgen tot de reeds bestaande Windows-aanmeldingen in de beveiligingsconfiguratie van de Microsoft Dynamics NAV-database.


EP-groep (tabel)

Tabel EP-groep

Lijst met velden in de tabel

In de tabel EP-groep groepeert u uw webonderdeelverzoeken en stelt u deze beschikbaar aan de gebruikers van Employee Portal.

U kunt de webonderdeelverzoeken op elke gewenste manier groeperen. U kunt bijvoorbeeld een groep maken die alle webonderdeelverzoeken bevat die u gebruikt wanneer u contact opneemt met een klant.

U kunt voor alle groepen bijschriften invoeren zodat de gebruiker over de juiste taal beschikt.


EP-groep/-gebruiker (tabel)

Tabel EP-groep/-gebruiker

Lijst met velden in de tabel

Deze tabel bevat de gebruikers die u hebt gemaakt voor uw Employee Portal.

Voordat u Employee Portal-gebruikers kunt maken in Microsoft Dynamics NAV, moet u de gebruikers eerst maken en configureren als Windows-gebruikers en als SharePoint Server-gebruikers.


EP-zoekresultaat (tabel)

Tabel EP-zoekresultaat

Lijst met velden in de tabel

Deze tabel wordt alleen intern gebruikt door het programma om de zoekresultaten tijdelijk op te slaan. Nadat de zoekresultaten zijn weergegeven worden alle gegevens uit de tabel verwijderd.


Filtersleutel WO-aanvraagtabel EP (tabel)

Tabel Filtersleutel WO-aanvraagtabel EP

Lijst met velden in de tabel

Deze tabel bevat de sleutelvelden die u kunt instellen voor de filtervelden. Het instellen van sleutels voor filtervelden heeft een positief effect op de prestaties, vooral als u de SQL Server Option gebruikt en de database veel records bevat.

Alle velden in deze tabel worden automatisch ingevuld door het programma wanneer u een sleutel selecteert in het venster Overzicht filtervelden WO-tabel EP.


Filterveld WO-aanvraagtabel EP (tabel)

Tabel Filterveld WO-aanvraagtabel EP

Lijst met velden in de tabel

Deze tabel bevat de filters die u hebt gedefinieerd voor uw webonderdeelverzoeken.

U gebruikt het filterveld om ervoor te zorgen dat in een webonderdeel alleen de records die aan bepaalde condities voldoen worden weergegeven. U kunt bijvoorbeeld opgeven dat alleen klanten worden weergegeven waarvoor Peter Schmidt is opgegeven in het veld Verkoper.


Instellingen Application Server EP (tabel)

Tabel Instellingen Application Server EP

Lijst met velden in de tabel

In de tabel Instellingen Application Server EP kunt u instellen hoe de Application Server de communicatie tussen Microsoft Dynamics NAV en SharePoint verwerkt.

Voordat u aan de slag gaat met Employee Portal geeft u de Application Server en de wachtrijen voor de front-end en de vertrouwde sites op die worden gebruikt voor de communicatie.


Kop-/regelverbinding WO-aanvraag EP (tabel)

Tabel Kop-/regelverbinding WO-aanvraag EP

Lijst met velden in de tabel

De tabel Kop-/regelverbinding WO-verzoek EP bevat alle verbindingen die u hebt gedefinieerd tussen de kop- en regelsecties voor webonderdelen van het soort Kop-Regel. Deze verbindingen kunnen echte databaseverwijzingen zijn of bevatten criteria om het aantal weergegeven records te reduceren.


Kopmaakcriteria WO-aanvraag EP (tabel)

Tabel Kopmaakcriteria WO-aanvraag EP

Lijst met velden in de tabel

Deze tabel bevat alle standaardwaarden voor acties die zijn gebaseerd op het systeemwebonderdeelverzoek INSERTHEAD. Het systeemwebonderdeelverzoek INSERTHEAD geeft de basiswaarden, maar u kunt een extra criterium definiëren door een standaardwaarde in te stellen. Als u bijvoorbeeld wilt dat met de actie een nieuwe verkoopofferte wordt gemaakt in de tabel Verkoopkop, moet u 1 invoeren in het veld Veldnr. voor documentsoort en 1 invoeren in het veld Standaardwaarde voor verkoopofferte.

De rest van de velden in de tabel Kopmaakcriteria WO-verzoek EP worden automatisch ingevuld door het programma wanneer u het criterium definieert.


Pad SharePoint-systeemkopie EP (tabel)

Tabel Pad SharePoint-systeemkopie EP

Lijst met velden in de tabel

Deze tabel bevat het pad naar de afbeeldingen die u hebt gedefinieerd in uw webonderdeelverzoeken. De afbeeldingen die zijn opgeslagen in het relatieve afbeeldingspad van SharePoint kunnen worden toegewezen aan de acties in Microsoft Dynamics NAV zodat deze naast de actie worden weergegeven in het webonderdeel.


Sorteersleutel WO-aanvraagtabel EP (tabel)

Tabel Sorteersleutel WO-aanvraagtabel EP

Lijst met velden in de tabel

Deze tabel bevat alle sorteersleutels die u hebt gedefinieerd voor de tabellen. Sorteersleutels kunnen alleen worden gedefinieerd voor webonderdeelverzoeken van het soort Lijst.


Tabbladveld WO-aanvraag EP (tabel)

Tabel Tabbladveld WO-aanvraag EP

Lijst met velden in de tabel

In de tabel Employee Portal-veld kunt u definiëren welke velden u beschikbaar wilt stellen aan de gebruikers van uw webonderdeel. De beschikbare velden zijn identiek aan de velden van de tabel die u hebt geselecteerd in de tabel Tabeltabblad WO-verzoek EP.


Tabeltabblad WO-aanvraag EP (tabel)

Tabel Tabeltabblad WO-aanvraag EP

Lijst met velden in de tabel

In de tabel Tabeltabblad WO-verzoek EP kunt u definiëren hoe de tabbladen eruitzien die zichtbaar zijn voor de gebruikers.


Tijdelijk filter EP (tabel)

Tabel Tijdelijk filter EP

Lijst met velden in de tabel

Deze tabel wordt intern door het programma gebruikt.

Wanneer een verzoek om aanpassing van een aantal gegevens in de toepassing wordt ontvangen van de front-end, wordt de informatie over het verzoek opgeslagen in deze tabel zodat deze informatie kan worden gebruikt voor het antwoord aan de front-end.


Vertrouwde site EP (tabel)

Tabel Vertrouwde site EP

Lijst met velden in de tabel

Deze tabel bevat de sites waarvoor erkenning als vertrouwde site gaande is of die reeds als vertrouwde sites zijn erkend.

Wanneer beveiligde communicatie (oftewel gecodeerde communicatie door middel van certificaten) wordt gebruikt, moeten alle front-endportalen worden vertrouwd in de back-end.

De front-endservice maakt een zogenaamd verzoek tot vertrouwen en verzendt dit aan Microsoft Dynamics NAV. In Microsoft Dynamics NAV moet de beheerder dit verzoek accepteren en een antwoord verzenden.

Vervolgens kan de communicatie worden gecodeerd door middel van certificaten.


Voorwaarde zoekveld WO-aanvraag EP (tabel)

Tabel Voorwaarde zoekveld WO-aanvraag EP

Lijst met velden in de tabel

Deze tabel bevat de condities voor de zoekacties die zijn geconfigureerd voor een veld. De waarde in het veld Veldwaarde wordt vergeleken met de waarde in het veld dat u hebt gedefinieerd in het veld Veldnr. in de brontabel. Zodra er sprake is van een vergelijking waarbij de waarden identiek zijn, zal de front-end om deze zoekactie verzoeken.


WO-aanvraag EP (tabel)

Tabel WO-aanvraag EP

Lijst met velden in de tabel

De tabel WO-verzoek EP wordt gebruikt om alle informatie over uw sjablonen voor webonderdeelverzoeken en uw webonderdeelverzoeken op te slaan.

Een webonderdeelverzoek definieert de indeling van het webonderdeel, de gegevens die door het webonderdeel worden gepresenteerd, de basiseigenschappen van de gegevens en de besturingselementen die worden gebruikt voor interactie en navigatie tussen webonderdelen. Alle webonderdeelverzoeken zijn gebaseerd op een sjabloon. Dit betekent dat u verschillende webonderdeelverzoeken voor verschillende gebruikersgroepen kunt maken op basis van dezelfde websjabloon. Deze webonderdeelverzoeken vormen tezamen het Employee Portal.

Een sjabloon kan in alle Employee Portal-groepen worden gebruikt, terwijl een webonderdeelverzoek bij één Employee Portal-groep hoort en alleen met die groep kan worden gebruikt.


WO-aanvraagtabel EP (tabel)

Tabel WO-aanvraagtabel EP

Lijst met velden in de tabel

Deze tabel wordt gebruikt om de tabel te verbinden met het webonderdeelverzoek en de basisdefinities van het webonderdeelverzoek.


Zoek-/weergaveveld EP (tabel)

Tabel Zoek-/weergaveveld EP

Lijst met velden in de tabel

Deze tabel bevat de velden die worden weergegeven in de zoekresultaten.

U kunt maximaal vijf velden aan een lijst toewijzen. De velden worden weergegeven in de zoekresultaten van het zoekwebonderdeel.


Zoekconfiguratie EP (tabel)

Tabel Zoekconfiguratie EP

Lijst met velden in de tabel

Deze tabel bevat de zoekconfiguratie die is gedefinieerd voor de tabellen waarin de gebruikers kunnen zoeken. De configuratie bepaalt welke velden de gebruikers kunnen doorzoeken en welke velden worden weergegeven in de zoekresultaten.


Zoektabel EP (tabel)

Tabel Zoektabel EP

Lijst met velden in de tabel

Deze tabel bevat de tabellen die u hebt geconfigureerd voor zoekacties door de gebruikers.


Zoekveld EP (tabel)

Tabel Zoekveld EP

Lijst met velden in de tabel

Deze tabel bevat de velden van de geconfigureerde tabellen waarin een zoekactie kan worden uitgevoerd.


Zoekveld WO-aanvraag EP (tabel)

Tabel Zoekveld WO-aanvraag EP

Lijst met velden in de tabel

Deze tabel bevat de zoekacties die u hebt gedefinieerd in het webonderdeelverzoek.

U kunt alleen zoekacties maken in webonderdeelverzoeken van het soort Lijst, waarbij het webonderdeelverzoek moet zijn toegewezen aan dezelfde groep als het webonderdeelverzoek van waaruit u de zoekactie maakt.


Zoekveldkoppeling WO-aanvraag EP (tabel)

Tabel Zoekveldkoppeling WO-aanvraag EP

Lijst met velden in de tabel

Deze tabel bevat de koppeling tussen het huidige webonderdeel en het webonderdeel dat het doel is van een zoekactie die u hebt gedefinieerd. U kunt definiëren vanuit welk veld in het huidige webonderdeel u de zoekactie wilt maken en aan welk veld in het andere webonderdeel u de zoekactie wilt koppelen.


Overzicht EP-talen (venster)

Venster Overzicht EP-talen

De lijst Overzicht EP-talen bevat de talen die u voor uw gebruikers kunt selecteren. De talen worden gebruikt voor de bijschriften van de verschillende elementen van de webonderdelen, zoals de namen van tabbladen, acties en webonderdelen. U kunt talen definiëren voor uw gebruikers op gebruikers- of groepniveau.

U kunt alleen de talen selecteren waarvoor u een licentie hebt.

Verwante taken

Meer informatie


Zoeklimiet, Employee Portal-instellingen (tabel)

Veld Zoeklimiet

De tabel Employee Portal-instellingen

Voer het maximumaantal records in dat u op elk tabblad wilt weergeven als resultaat van een zoekopdracht.


Openbare sleutel van back-end, Employee Portal-instellingen (tabel)

Veld Openbare sleutel van back-end

De tabel Employee Portal-instellingen

Dit veld bevat de openbare sleutel die wordt gebruikt voor gecodeerde berichten. De sleutel is door het programma gemaakt.


Privésleutel van back-end, Employee Portal-instellingen (tabel)

Veld Privésleutel van back-end

De tabel Employee Portal-instellingen

Dit veld bevat de privésleutel die wordt gebruikt voor gecodeerde berichten. De sleutel is door het programma gemaakt.


Info foutopsporing schrijven, Employee Portal-instellingen (tabel)

Veld Info foutopsporing schrijven

De tabel Employee Portal-instellingen

Als dit selectievakje is ingeschakeld, worden alle inkomende en uitgaande berichten naar het bestandssysteem gedumpt.


Bijschrift-id toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift-id toolsvenster config.

De tabel Employee Portal-instellingen

Dit veld bevat de bijschrift-id die in Microsoft Dynamics NAV wordt gebruikt voor identificatie van het bijschrift dat u hebt gedefinieerd in het veld Bijschrift toolsvenster config.


Bijschrift-id WO-aanvraag toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift-id WO-aanvraag toolsvenster config.

De tabel Employee Portal-instellingen

Dit veld bevat de bijschrift-id die in Microsoft Dynamics NAV wordt gebruikt voor identificatie van het bijschrift dat u hebt gedefinieerd in het veld Bijschrift WO-verzoek toolsvenster config.


Bijschrift-id eerste aanvraag toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift-id eerste aanvraag toolsvenster config.

De tabel Employee Portal-instellingen

Dit veld bevat de bijschrift-id die in Microsoft Dynamics NAV wordt gebruikt voor identificatie van het bijschrift dat u hebt gedefinieerd in het veld Bijschrift eerste verzoek toolsvenster config.


Bijschrift-id groep toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift-id groep toolsvenster config.

De tabel Employee Portal-instellingen

Dit veld bevat de bijschrift-id die in Microsoft Dynamics NAV wordt gebruikt voor identificatie van het bijschrift dat u hebt gedefinieerd in het veld Bijschrift groep toolsvenster config.


Bijschrift-id toolsvenster zoeken, Employee Portal-instellingen (tabel)

Veld Bijschrift-id toolsvenster zoeken

De tabel Employee Portal-instellingen

Dit veld bevat de bijschrift-id die in Microsoft Dynamics NAV wordt gebruikt voor identificatie van het bijschrift dat u hebt gedefinieerd in het veld Bijschrift toolsvenster zoeken.


Configuratietabel-id zoeken, Employee Portal-instellingen (tabel)

Veld Configuratietabel-id zoeken

De tabel Employee Portal-instellingen

Dit veld bevat de bijschrift-id die in Microsoft Dynamics NAV wordt gebruikt voor identificatie van het bijschrift dat u hebt gedefinieerd in het veld Bijschrift alle tabellen toolsvenster zoeken.


Bijschrift-id alle tabellen toolsvenster zoeken, Employee Portal-instellingen (tabel)

Veld Bijschrift-id alle tabellen toolsvenster zoeken

De tabel Employee Portal-instellingen

Dit veld bevat de bijschrift-id die in Microsoft Dynamics NAV wordt gebruikt voor identificatie van het bijschrift dat u hebt gedefinieerd in het veld Bijschrift alle tabellen toolsvenster zoeken.


Bijschrift toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift toolsvenster config.

De tabel Employee Portal-instellingen

Als u een webonderdeel toevoegt aan uw portaalpagina, moet u het webonderdeel configureren door op te geven welk webonderdeelverzoek moet worden gebruikt. U doet dit door de configuratie te selecteren in de velden in de aangepaste eigenschap in het toolsvenster SharePoint. De bijschriften voor deze velden moeten worden gedefinieerd in Microsoft Dynamics NAV.

Dit veld bevat het bijschrift dat in het toolsvenster wordt weergegeven als kop bij het gebied van de aangepaste eigenschap van Employee Portal voor webonderdelen van het soort Kaart, Lijst en Kop-Regel.


Bijschrift WO-aanvraag toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift WO-aanvraag toolsvenster config.

De tabel Employee Portal-instellingen

Als u een webonderdeel toevoegt aan uw portaalpagina, moet u het webonderdeel configureren door op te geven welk webonderdeelverzoek moet worden gebruikt. U doet dit door de configuratie te selecteren in de velden in de aangepaste eigenschap in het toolsvenster SharePoint. De bijschriften voor deze velden moeten worden gedefinieerd in Microsoft Dynamics NAV.

Dit veld bevat het bijschrift dat wordt weergegeven als de kop van het veld waarin u kunt selecteren welk verzoek wordt gebruikt door het webonderdeel.


Bijschrift eerste aanvraag toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift eerste aanvraag toolsvenster config.

De tabel Employee Portal-instellingen

Als u een webonderdeel toevoegt aan uw portaalpagina, moet u het webonderdeel configureren door op te geven welk webonderdeelverzoek moet worden gebruikt. U doet dit door de configuratie te selecteren in de velden in de aangepaste eigenschap in het toolsvenster SharePoint. De bijschriften voor deze velden moeten worden gedefinieerd in Microsoft Dynamics NAV.

Dit veld bevat het bijschrift dat wordt weergegeven als de kop van het veld waarin u kunt instellen of het webonderdeel een eerste verzoek uitvoert.


Bijschrift groep toolsvenster config., Employee Portal-instellingen (tabel)

Veld Bijschrift groep toolsvenster config.

De tabel Employee Portal-instellingen

Als u een webonderdeel toevoegt aan uw portaalpagina, moet u het webonderdeel configureren door op te geven welk webonderdeelverzoek moet worden gebruikt. U doet dit door de configuratie te selecteren in de velden in de aangepaste eigenschap in het toolsvenster SharePoint. De bijschriften voor deze velden moeten worden gedefinieerd in Microsoft Dynamics NAV.

Dit veld bevat het bijschrift dat wordt weergegeven als de kop van het veld waarin u de verzoekgroep kunt selecteren.


Bijschrift toolsvenster zoeken, Employee Portal-instellingen (tabel)

Veld Bijschrift toolsvenster zoeken

De tabel Employee Portal-instellingen

Als u een webonderdeel Zoeken toevoegt aan uw portaalpagina, moet u het webonderdeel configureren door op te geven in welke tabellen moet worden gezocht. U doet dit door de tabel te selecteren in het veld in de aangepaste eigenschap in het toolsvenster SharePoint. De bijschriften voor dit veld moeten worden gedefinieerd in Microsoft Dynamics NAV.

Dit veld bevat het bijschrift dat in het toolsvenster wordt weergegeven als kop bij het gebied van de aangepaste eigenschap van Employee Portal voor webonderdelen van het soort Zoeken.


Bijschrift configuratietabel zoeken, Employee Portal-instellingen (tabel)

Veld Bijschrift configuratietabel zoeken

De tabel Employee Portal-instellingen

Als u een webonderdeel Zoeken toevoegt aan uw portaalpagina, moet u het webonderdeel configureren door op te geven in welke tabellen moet worden gezocht. U doet dit door de tabel te selecteren in het veld in de aangepaste eigenschap in het toolsvenster SharePoint. De bijschriften voor dit veld moeten worden gedefinieerd in Microsoft Dynamics NAV .

Dit veld bevat het bijschrift dat wordt weergegeven als de kop van het veld waarin u de tabel kunt selecteren waarin de zoekopdracht wordt uitgevoerd.


Bijschrift alle tabellen toolsvenster zoeken, Employee Portal-instellingen (tabel)

Veld Bijschrift alle tabellen toolsvenster zoeken

De tabel Employee Portal-instellingen

Als u een webonderdeel Zoeken toevoegt aan uw portaalpagina, moet u het webonderdeel configureren door op te geven in welke tabellen moet worden gezocht. U doet dit door de tabel te selecteren in het veld in de aangepaste eigenschap in het toolsvenster SharePoint. De bijschriften voor dit veld moeten worden gedefinieerd in Microsoft Dynamics NAV.

Dit veld bevat het bijschrift dat wordt weergegeven in het veld waarin u de tabel selecteert als een optie om alle tabellen te doorzoeken. U kunt bijvoorbeeld Alle tabellen opgeven.


Pad foutopsporing, Employee Portal-instellingen (tabel)

Veld Pad foutopsporing

De tabel Employee Portal-instellingen

Voer het pad in van de map op de webserver waarin u uw inkomende en uitgaande berichten wilt plaatsen voor foutopsporing.


Code, EP-groep (tabel)

Veld Code

De tabel EP-groep

Dit veld bevat de code waarmee de groep wordt geïdentificeerd.

Het programma gebruikt deze code wanneer webonderdelen worden verbonden met de groep.


Aantal WO-aanvragen, EP-groep (tabel)

Veld Aantal WO-aanvragen

De tabel EP-groep

Dit veld bevat het aantal webonderdeelverzoeken dat is verbonden met de Employee Portal-groep.


Taal-id, EP-groep (tabel)

Veld Taal-id

De tabel EP-groep

Dit veld bevat de taal-id waarmee wordt bepaald in welke taal het webonderdeel dat is gekoppeld aan deze groep op de portaalpagina wordt gepresenteerd. Als u een taal-id instelt voor één groepslid, wordt de taal-id van de groep overschreven door de taal-id van dat lid.

Als u het veld Taal-id in de tabel met EP-gebruikers èn dit veld niet invult, worden de webonderdelen weergegeven in de standaardtaal van de Microsoft Dynamics NAV Application Server.


Bijschrift-id, EP-groep (tabel)

Veld Bijschrift-id

De tabel EP-groep

Dit veld bevat het nummer dat door het programma is toegewezen aan de bijschriftdefinitie. Het veld wordt automatisch ingevuld door het programma.


Bijschrift, EP-groep (tabel)

Veld Bijschrift

De tabel EP-groep

Dit veld bevat het bijschrift dat wordt weergegeven in het toolsvenster wanneer u het webonderdeel op de portaalpagina configureert. Het bijschrift wordt weergegeven als een optie in het veld waarin u de groep kunt selecteren waarvan u een verzoek wilt toevoegen.


Groepcode, WO-aanvraag EP (tabel)

Veld Groepcode

De tabel WO-aanvraag EP

In dit veld wordt, voor zover van toepassing, de code weergegeven van de groep waar dit webonderdeelverzoek bij hoort. Het veld bevat alleen een groepcode als het webonderdeelverzoek bij een groep hoort.

Wanneer het webonderdeelverzoek wordt toegevoegd aan de groep, wordt de naam in het veld Code in het venster EP-groep automatisch door het programma opgehaald.


Code, WO-aanvraag EP (tabel)

Veld Code

De tabel WO-aanvraag EP

Dit veld bevat de code waarmee het webonderdeelverzoek wordt geïdentificeerd.

Deze code wordt gebruikt wanneer onderdelen worden verbonden met het webonderdeelverzoek.


Bewerkbaar, WO-aanvraag EP (tabel)

Veld Bewerkbaar

De tabel WO-aanvraag EP

Schakel dit selectievakje in als u wilt dat het webonderdeel kan worden bewerkt. Dit is alleen mogelijk bij webonderdelen van het soort Kop-Regel en Kaart. Webonderdelen van het soort Lijst kunnen nooit worden bewerkt.


Soort, WO-aanvraag EP (tabel)

Veld Soort

De tabel WO-aanvraag EP

Hier kunt u het soort webonderdeelverzoek definiëren. Het soort dat u selecteert in dit veld is bepalend voor de basisindeling van het webonderdeel.

De soorten zijn: Lijst (een lijst van records weergeven), Kaart (een record in een kaart weergeven), Kop-Regel (een kop met bijbehorende regels weergeven) en Systeem (voor acties). Een systeemverzoek is een speciaal soort verzoek voor het uitvoeren van acties op de database.


Gedefinieerd door systeem, WO-aanvraag EP (tabel)

Veld Gedefinieerd door systeem

De tabel WO-aanvraag EP

Dit selectievakje is ingeschakeld als het webonderdeelverzoek vooraf op het systeem is geconfigureerd. De beheerder van het systeem kan de tabellen, tabbladen en velden van een vooraf geconfigureerd webonderdeelverzoek wijzigen. Maar het soort vooraf geconfigureerd webonderdeelverzoek kan niet worden gewijzigd. Het verzoek kan ook niet worden verwijderd.


Aantal waar-gebruiktgroepen, WO-aanvraag EP (tabel)

Veld Aantal waar-gebruiktgroepen

De tabel WO-aanvraag EP

Dit veld bevat het aantal groepen waaraan het webonderdeelverzoek is toegewezen.


Bijschrift-id, WO-aanvraag EP (tabel)

Veld Bijschrift-id

De tabel WO-aanvraag EP

Dit veld bevat het nummer dat door het programma is toegewezen aan de bijschriftdefinitie. Het veld wordt automatisch ingevuld door het programma.


Bijschrift, WO-aanvraag EP (tabel)

Veld Bijschrift

De tabel WO-aanvraag EP

Dit veld bevat het bijschrift dat wordt weergegeven in het toolsvenster wanneer u het webonderdeel op de portaalpagina configureert. Het bijschrift wordt weergegeven als een optie in het veld waarin u het verzoek selecteert dat u aan het webonderdeel wilt toevoegen.


Tabelnr., Tabeltabblad WO-aanvraag EP (tabel)

Veld Tabelnr.

De tabel Tabeltabblad WO-aanvraag EP

Dit veld bevat het nummer van de tabel waar de velden die op dit tabblad worden weergegeven oorspronkelijk vandaan komen.


Kop of regel, Tabeltabblad WO-aanvraag EP (tabel)

Veld Kop of regel

De tabel Tabeltabblad WO-aanvraag EP

In dit veld moet u definiëren aan welke sectie het tabblad wordt toegewezen. Als de bovenliggende tabel wordt toegewezen aan de kop van een webonderdeel van het soort Kop-Regel of Kaart, moet u Kop selecteren. Als de bovenliggende tabel wordt toegewezen aan de regels van een webonderdeel van het soort Kop-Regel of Lijst, moet u Regel selecteren.


Aantal kolommen, Tabeltabblad WO-aanvraag EP (tabel)

Veld Aantal kolommen

De tabel Tabeltabblad WO-aanvraag EP

Dit veld bevat het aantal kolommen dat beschikbaar is op het tabblad. Dit veld is alleen van toepassing op webonderdeelverzoeken van het soort Kaart en Kop-Regel.


Positie, Tabeltabblad WO-aanvraag EP (tabel)

Veld Positie

De tabel Tabeltabblad WO-aanvraag EP

In dit veld kunt u definiëren in welke positie het tabblad wordt weergegeven in het webonderdeel. De volgorde van de tabbladen is oplopend, waarbij het tabblad met de positiewaarde 0 als eerste wordt weergegeven.


Bijschrift-id, Tabeltabblad WO-aanvraag EP (tabel)

Veld Bijschrift-id

De tabel Tabeltabblad WO-aanvraag EP

Dit veld bevat het nummer dat door het programma is toegewezen aan de bijschriftdefinitie. Het veld wordt automatisch ingevuld door het programma.


Bijschrift, Tabeltabblad WO-aanvraag EP (tabel)

Veld Bijschrift

De tabel Tabeltabblad WO-aanvraag EP

Dit veld bevat het bijschrift dat wordt weergegeven op het tabblad in het webonderdeel. Het bijschrift wordt alleen weergegeven bij webonderdelen van het soort Kaart en Kop-Regel, dus niet bij webonderdelen van het soort Lijst.


Tabelnr., Tabbladveld WO-aanvraag EP (tabel)

Veld Tabelnr.

De tabel Tabbladveld WO-aanvraag EP

Dit veld bevat het nummer van de tabel waarbij het veld hoort. Het tabelnummer wordt automatisch gekopieerd vanuit het veld Tabelnr. in de tabel Tabeltabblad WO-verzoek EP wanneer u het veld toevoegt aan het tabblad.


Tabbladcode, Tabbladveld WO-aanvraag EP (tabel)

Veld Tabbladcode

De tabel Tabbladveld WO-aanvraag EP

Dit veld bevat de code van het tabblad waarbij het veld hoort. Het tabelnummer wordt automatisch gekopieerd vanuit het veld Code in de tabel Tabeltabblad WO-verzoek EP wanneer u het veld toevoegt aan het tabblad.


Regelnr., Tabbladveld WO-aanvraag EP (tabel)

Veld Regelnr.

De tabel Tabbladveld WO-aanvraag EP

Het nummer in dit veld bepaalt de volgorde waarin de velden op het tabblad worden weergegeven. De velden worden in oplopende volgorde weergegeven.


Veldnr., Tabbladveld WO-aanvraag EP (tabel)

Veld Veldnr.

De tabel Tabbladveld WO-aanvraag EP

Dit veld bevat het nummer van het veld dat op het tabblad wordt weergegeven.


Naam, Tabbladveld WO-aanvraag EP (tabel)

Veld Naam

De tabel Tabbladveld WO-aanvraag EP

Dit veld bevat de naam van het veld. De naam wordt automatisch opgehaald uit de brontabel wanneer het veld Veldnr. wordt ingevuld.


Lengte, Tabbladveld WO-aanvraag EP (tabel)

Veld Lengte

De tabel Tabbladveld WO-aanvraag EP

In dit veld kunt u definiëren welke lengte het veld heeft wanneer het wordt weergegeven. De standaardlengte van het veld wordt automatisch ingevuld, maar u kunt de lengte aanpassen aan het webonderdeel.


Weergave, Tabbladveld WO-aanvraag EP (tabel)

Veld Weergave

De tabel Tabbladveld WO-aanvraag EP

In dit veld kunt u definiëren hoe het veld op het tabblad moet worden weergegeven in het webonderdeel.

U bepaalt de weergave van het veld door op de AssistButton in het veld te klikken en een van de volgende vier opties te selecteren:

Zichtbaar

Bewerkbaar

Verborgen

Bewerkbaar (indirect)

Als u Zichtbaar selecteert, wordt het veld weergegeven als tekst of als het een Boolean-veld is als een selectievakje.

Als u Bewerkbaar selecteert, kan het veld worden bewerkt en wordt het weergegeven zoals het is geconfigureerd in de HTML-indeling.

Als u Verborgen selecteert, is het veld onzichtbaar en staat het in een verborgen HTML-formulierveld. Het veld kan alleen door middel van opzoeken worden bewerkt.

Als u Bewerkbaar (indirect) selecteert, kan het veld alleen worden bewerkt door middel van een koppeling van zoekvelden.


HTML-layout, Tabbladveld WO-aanvraag EP (tabel)

Veld HTML-layout

De tabel Tabbladveld WO-aanvraag EP

In dit veld kunt u de HTML-indeling van het veld definiëren als u in het veld Weergave de optie Bewerkbaar hebt geselecteerd. Als voor het veld een andere weergaveoptie dan Bewerkbaar is geselecteerd, wordt het veld weergegeven als gewone tekst.

U bepaalt de weergave van het veld door op de AssistButton in het veld te klikken en een van de volgende vijf opties te selecteren:

Tekstveld

Tekstgebied

Vervolgkeuze

Selectievakje

Keuzerondje

Afbeeldingsindicator

Afbeelding

Als u Tekstveld selecteert, wordt het veld weergegeven als een HTML-invoervak.

Als u Tekstgebied selecteert, wordt het veld weergegeven als een HTML-tekstgebied. Tekst die wordt ingevoerd in een veld met deze indeling wordt in Microsoft Dynamics NAV opgeslagen in één tekstkolom. Het is niet mogelijk om verschillende regels of uitbreidingen in te voeren in een veld met deze indeling.

Als u Vervolgkeuze selecteert, wordt het veld weergegeven als een HTML-vervolgkeuzevak. Deze indeling kan alleen worden gebruikt voor optievelden.

Als u Selectievakje selecteert, wordt het veld weergegeven als een selectievakje. Deze indeling kan alleen worden gebruikt voor Boolean-velden.

Als u Keuzerondje selecteert, wordt het veld regel voor regel weergegeven. De gebruiker kan dan één van de regels selecteren.

Als u Afbeeldingsindicator selecteert, bevat het veld een indicator waaruit blijkt dat er een afbeelding beschikbaar is. De gebruiker kan op de indicator klikken om de afbeelding weer te geven.

Als u Afbeelding selecteert, kan in het veld een afbeelding worden weergeven die is gekoppeld aan de record.

Als u de afbeelding wilt weergeven in een ander formaat dan volledig formaat, kunt u het gewenste formaat definiëren in het veld Schaalvergroting.


Vereist, Tabbladveld WO-aanvraag EP (tabel)

Veld Vereist

De tabel Tabbladveld WO-aanvraag EP

Als dit selectievakje is ingeschakeld, moet het veld verplicht worden ingevuld door de gebruiker. Als een veld verplicht moet worden ingevuld, kan de gebruiker de actie niet voltooien voordat het veld is ingevuld.

Het programma controleert automatisch of de waarde die door de gebruiker is ingevoerd geldig is. De waarde die door de gebruiker is ingevoerd, is geldig als deze voldoet aan de indeling die is gedefinieerd in het veld HTML-indeling.


Sorteerbaar, Tabbladveld WO-aanvraag EP (tabel)

Veld Sorteerbaar

De tabel Tabbladveld WO-aanvraag EP

Dit selectievakje is ingeschakeld als er voor deze regel een sorteersleutel is gedefinieerd. Het veld wordt automatisch ingevuld door het programma wanneer u een sorteersleutel voor de tabel definieert.


Opzoeken, Tabbladveld WO-aanvraag EP (tabel)

Veld Opzoeken

De tabel Tabbladveld WO-aanvraag EP

Als dit selectievakje is ingeschakeld, is er een zoekactie gedefinieerd voor het veld. Het veld wordt automatisch ingevuld door het programma wanneer u een zoekactie voor dit veld definieert.


Schaalverhouding, Tabbladveld WO-aanvraag EP (tabel)

Veld Schaalverhouding

De tabel Tabbladveld WO-aanvraag EP

Als u Afbeelding hebt geselecteerd in het veld HTML-indeling, kunt u dit veld gebruiken om te bepalen op welk formaat de afbeelding wordt weergegeven in het webonderdeel. Het formaat dat u in dit veld opgeeft is een percentage. Dat betekent dat als u 50 invoert, de afbeelding op half formaat wordt weergegeven.

Als u geen waarde invoert in dit veld, wordt de afbeelding op volledig formaat weergegeven.


Code, Actie WO-aanvraagtabel EP (tabel)

Veld Code

De tabel Actie WO-aanvraagtabel EP

Dit veld bevat de code van het verzoek dat door de actie wordt aangeroepen.

Als voor de actie in het veld Soort een ander soort is gedefinieerd dan Verbinden met ander WO-verzoek, bevat het veld Code een Systeemverzoek. Een systeemverzoek is een speciaal soort verzoek voor het uitvoeren van acties in de database.

Als voor de actie in het veld Soort de optie Verbinden met ander WO-verzoek is gedefinieerd, bevat het veld Code het webonderdeelverzoek waarmee de actie verbinding maakt.


WO-aanvraag (Doel), Actie WO-aanvraagtabel EP (tabel)

Veld WO-aanvraag (Doel)

De tabel Actie WO-aanvraagtabel EP

In dit veld kunt u het doel van de actie definiëren.

U bepaalt het doel door op de AssistButton in het veld te klikken en een van de volgende opties te selecteren:

Huidig

Overig

Als u Huidig selecteert, wordt de actie uitgevoerd op hetzelfde webonderdeel.

Als u Overig selecteert, wordt de actie uitgevoerd op het webonderdeelverzoek dat u hebt geselecteerd in het veld Code. U kunt dit doel alleen selecteren als u in het veld Soort de optie Verbinden met ander WO-verzoek hebt geselecteerd.


HTML-layout, Actie WO-aanvraagtabel EP (tabel)

Veld HTML-layout

De tabel Actie WO-aanvraagtabel EP

In dit veld kunt u definiëren hoe de actie wordt weergegeven in het webonderdeel.

U bepaalt de weergave door op de AssistButton in het veld te klikken en een van de volgende opties te selecteren:

Koppeling

Knop

Als u Koppeling selecteert, wordt de actie weergegeven als een gewone HTML-koppeling.

Als u Knop selecteert, wordt de actie weergegeven als een HTML-knop.


Positie, Actie WO-aanvraagtabel EP (tabel)

Veld Positie

De tabel Actie WO-aanvraagtabel EP

In dit veld kunt u de positie van de actie definiëren. De actie met de laagste positie wordt uiterst links geplaatst.

De standaardwaarde van de eerste actie die u maakt is 10000. Deze waarde wordt verhoogd met 10000 voor elke nieuwe actie die u maakt. Als u wilt dat een actie tussen twee andere acties wordt geplaatst, voert u een waarde in die tussen de posities van deze twee acties ligt.


Veldvalidatie vereist, Actie WO-aanvraagtabel EP (tabel)

Veld Veldvalidatie vereist

De tabel Actie WO-aanvraagtabel EP

Als dit selectievakje is ingeschakeld, worden de gegevens die de gebruiker invoert aan de front-end gevalideerd voordat deze naar Microsoft Dynamics NAV worden verzonden.


Beperken tot bewerkbaar, Actie WO-aanvraagtabel EP (tabel)

Veld Beperken tot bewerkbaar

De tabel Actie WO-aanvraagtabel EP

Als dit selectievakje is ingeschakeld, wordt de actie alleen weergegeven als het webonderdeelverzoek bewerkbaar is.

Als de actie is gedefinieerd voor regels in een webonderdeel van het soort Kop-Regel, is dit veld niet van toepassing.


Tabelnr., Actie WO-aanvraagtabel EP (tabel)

Veld Tabelnr.

De tabel Actie WO-aanvraagtabel EP

Dit veld bevat het nummer van de tabel die door de actie wordt aangeroepen. Het tabelnummer wordt automatisch gekopieerd vanuit het veld Tabelnr. in de tabel Tabeltabblad WO-verzoek EP wanneer u de actie toevoegt aan het webonderdeelverzoek.


Kop of regel, Actie WO-aanvraagtabel EP (tabel)

Veld Kop of regel

De tabel Actie WO-aanvraagtabel EP

Dit veld definieert de positie van de actie. Het veld wordt automatisch gekopieerd vanuit het veld Kop of Regel in de tabel Tabeltabblad WO-verzoek EP.


Soort, Actie WO-aanvraagtabel EP (tabel)

Veld Soort

De tabel Actie WO-aanvraagtabel EP

In dit veld kunt u het soort actie definiëren.

U bepaalt het soort actie door op de AssistButton in het veld te klikken en een van de volgende opties te selecteren:

Kop invoegen

Regel invoegen

Record opslaan

Record verwijderen

Regel instellen op wijzigen

Wijzigen annuleren (Regel)

Verbinden met ander WO-verzoek

Lijst tonen

Als u Kop invoegen selecteert, bestaat de actie uit het maken van een nieuw webonderdeel van het soort Kaart. Deze actie kan worden gebruikt in webonderdelen van het soort Kaart en Kop-Regel.

Als u Regel invoegen selecteert, bestaat de actie uit het maken van een nieuwe regel in het webonderdeel. Deze actie kan worden gebruikt in webonderdelen van het soort Kop-Regel.

Als u Record opslaan selecteert, bestaat de actie uit het opslaan van wijzigingen die u hebt aangebracht aan het webonderdeel. Deze actie kan worden gebruikt in webonderdelen van het soort Kaart en Kop-Regel.

Als u Record verwijderen selecteert, bestaat de actie uit het verwijderen van de regel, de kop + regel of de kaart waarvoor de actie is gedefinieerd. Deze actie kan worden gebruikt in webonderdelen van het soort Kaart en Kop-Regel.

Als u Regel instellen op wijzigen selecteert, bestaat de actie uit het bewerkbaar maken van de velden in de regel, mits deze velden zijn ingesteld op Bewerkbaar in het veld Weergave in de tabel EP Web Part Field. Deze actie kan worden gebruikt voor de regels van webonderdelen van het soort Kop-Regel.

Als u Wijzigen annuleren (Regel) selecteert, bestaat de actie uit het annuleren van wijzigingen op de regel die nog niet zijn opgeslagen. Deze actie kan worden gebruikt voor de regels van webonderdelen van het soort Kop-Regel.

Als u Verbinden met ander WO-verzoek selecteert, bestaat de actie uit het aanroepen van een ander onderdeel. Deze actie kan worden gebruikt in alle webonderdelen.

Als u Lijst tonen selecteert, bestaat de actie uit het maken van de lijst die u hebt opgegeven in het veld Lijst-id. Deze actie kan worden gebruikt in alle webonderdelen.


Tonen in modus, Actie WO-aanvraagtabel EP (tabel)

Veld Tonen in modus

De tabel Actie WO-aanvraagtabel EP

Dit veld is alleen geldig voor webonderdeelverzoeken van het soort Kop-Regel. In dit veld kunt u definiëren of een actie die is gedefinieerd voor de regels in een webonderdeel van het soort Kop-Regel zichtbaar is voor de gebruiker. Een actie waarmee wijzigingen op een regel worden opgeslagen, hoeft bijvoorbeeld alleen zichtbaar te zijn als de regel bewerkbaar is.

U kunt met een van de volgende opties instellen of een actie zichtbaar is:

Weergeven

Bewerken

Beide

Als u Weergeven selecteert, is de actie alleen zichtbaar als de regel zichtbaar, maar niet bewerkbaar is.

Als u Bewerken selecteert, is de actie alleen zichtbaar als de regel bewerkbaar is.

Als u Beide selecteert, is de actie altijd zichtbaar.


WO-aanvraagsoort (Doel), Actie WO-aanvraagtabel EP (tabel)

Veld WO-aanvraagsoort (Doel)

De tabel Actie WO-aanvraagtabel EP

Dit veld bevat het soort webonderdeelverzoek waarmee de actie verbinding maakt. Het veld is alleen geldig voor acties van het soort Verbinden met ander WO-verzoek.

Het veld wordt automatisch ingevuld door het programma wanneer u een actie selecteert in het veld Actie.


Doeltabelnr., Actie WO-aanvraagtabel EP (tabel)

Veld Doeltabelnr.

De tabel Actie WO-aanvraagtabel EP

Dit veld bevat het nummer van de tabel waarin de actie wordt uitgevoerd.


Bijschrift-id, Actie WO-aanvraagtabel EP (tabel)

Veld Bijschrift-id

De tabel Actie WO-aanvraagtabel EP

Dit veld bevat het nummer dat door het programma is toegewezen aan de bijschriftdefinitie. Het veld wordt automatisch ingevuld door het programma.


Lijst-id, Actie WO-aanvraagtabel EP (tabel)

Veld Lijst-id

De tabel Actie WO-aanvraagtabel EP

Voer het objectnummer in van de lijst die u wilt weergeven op uw portaalpagina wanneer de actie wordt geactiveerd. Het veld is alleen van toepassing op acties van het soort SHOWREPORT.


Bijschrift, Actie WO-aanvraagtabel EP (tabel)

Veld Bijschrift

De tabel Actie WO-aanvraagtabel EP

In dit veld kunt u een bijschrift voor de actie definiëren. Het bijschrift wordt weergegeven om aan te geven dat een actie beschikbaar is.


Groepcode, Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Veld Groepcode

De tabel Bewerkingscriteria WO-aanvraagtabel EP

Dit veld bevat de groepcode van het webonderdeelverzoek waar de wijzigingscriteria bij horen.


WO-aanvraagcode, Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Veld WO-aanvraagcode

De tabel Bewerkingscriteria WO-aanvraagtabel EP

Dit veld bevat de code van het webonderdeelverzoek waar de wijzigingscriteria bij horen.


Tabelnr., Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Veld Tabelnr.

De tabel Bewerkingscriteria WO-aanvraagtabel EP

Dit veld bevat het nummer van de tabel waarin de vergelijking wordt uitgevoerd. Het tabelnummer wordt automatisch gekopieerd vanuit het veld Tabelnr. in de tabel EP Web Part wanneer u een nieuw criterium maakt.


Veldnr., Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Veld Veldnr.

De tabel Bewerkingscriteria WO-aanvraagtabel EP

Dit veld bevat het nummer van het veld dat u wilt gebruiken om te vergelijken.


Vergelijking, Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Veld Vergelijking

De tabel Bewerkingscriteria WO-aanvraagtabel EP

U kunt dit veld gebruiken om een vergelijking uit te voeren van de waarden die u invoert in de velden Vergelijkingswaarde 1 en Vergelijkingswaarde 2.

Het resultaat van de vergelijking wordt weergegeven in het webonderdeel dat is gemaakt door het webonderdeelverzoek dat is gedefinieerd in het veld Webonderdeelverzoek.

U kunt de volgende symbolen gebruiken:

< = getallen die kleiner zijn dan de waarde die is gedefinieerd in het veld Vergelijkingswaarde 1.

> = getallen die groter zijn dan de waarde die is gedefinieerd in het veld Vergelijkingswaarde 1.

= = getallen die gelijk zijn aan de waarde die is gedefinieerd in het veld Vergelijkingswaarde 1.

<> = alle getallen behalve de waarde die is gedefinieerd in het veld Vergelijkingswaarde 1.

.. = getallen tussen de waarden die zijn gedefinieerd in de velden Vergelijkingswaarde 1 en Vergelijkingswaarde 2.


Vergelijkingswaarde 1, Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Veld Vergelijkingswaarde 1

De tabel Bewerkingscriteria WO-aanvraagtabel EP

In dit veld voert u een waarde in als u wilt dat alleen een bepaald bereik van records zichtbaar is voor de gebruiker.

Dit veld werkt alleen als u een vergelijkingssymbool invoert in het veld Vergelijking.


Vergelijkingswaarde 2, Bewerkingscriteria WO-aanvraagtabel EP (tabel)

Veld Vergelijkingswaarde 2

De tabel Bewerkingscriteria WO-aanvraagtabel EP

In dit veld voert u een waarde in als u wilt dat alleen een bepaald bereik van records zichtbaar is voor de gebruiker.

Dit veld wordt alleen gebruikt als u het vergelijkingssymbool .. (waarden tussen) hebt ingevoerd in het veld Vergelijking.


Kop of regel, WO-aanvraagtabel EP (tabel)

Veld Kop of regel

De tabel WO-aanvraagtabel EP

In dit veld moet u definiëren aan welke sectie van het webonderdeel de tabel wordt toegewezen. Als het webonderdeelverzoeksoort Kaart is, moet u Kop selecteren. Als het webonderdeelverzoeksoort Lijst is, moet u Regel selecteren. Als het webonderdeelverzoeksoort Kop-Regel is, moet u twee tabellen toewijzen, een voor de kop en een voor de regels.


Eerste getoonde record, WO-aanvraagtabel EP (tabel)

Veld Eerste getoonde record

De tabel WO-aanvraagtabel EP

In dit veld kunt u het nummer definiëren van de record die als eerste record in de lijst moet worden weergegeven wanneer de gebruiker het webonderdeel voor het eerst opent.

Dit veld wordt alleen gebruikt voor webonderdeelverzoeken van het soort Lijst.


Aantal getoonde records, WO-aanvraagtabel EP (tabel)

Veld Aantal getoonde records

De tabel WO-aanvraagtabel EP

In dit veld kunt u definiëren hoeveel records de toepassing moet doorsturen naar de front-end zodat deze worden weergegeven als het webonderdeel wordt geopend.


Sorteervolgorde, WO-aanvraagtabel EP (tabel)

Veld Sorteervolgorde

De tabel WO-aanvraagtabel EP

Dit veld bevat de sorteermethode voor het webonderdeelverzoek. Hiermee wordt aangegeven welke volgorde wordt toegepast in de lijst wanneer een webonderdeel voor het eerst wordt geopend. Het eerste veld wordt gebruikt als sorteerveld. Later kan de gebruiker de sorteervolgorde wijzigen door te klikken op een kolomkop waarvoor een sorteersleutel is gedefinieerd.

Er zijn twee opties: Oplopend en Aflopend.

Dit veld is alleen van toepassing voor webonderdeelverzoeken van het soort Lijst.


Groepcode, Actiefilter WO-aanvraagtabel EP (tabel)

Veld Groepcode

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld bevat de groepcode van het webonderdeelverzoek waar het actiefilter bij hoort.


Actiecode, Actiefilter WO-aanvraagtabel EP (tabel)

Veld Actiecode

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld bevat de code van de actie waarvoor het actiefilter is ingesteld.


Filter toepassen op, Actiefilter WO-aanvraagtabel EP (tabel)

Veld Filter toepassen op

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld definieert het soort actiefilter.

U bepaalt het soort door op de AssistButton in het veld te klikken en een van de volgende opties te selecteren:

Veld: de waarde in het opgegeven veld moet overeenkomen in het bronwebonderdeel en in het doelwebonderdeel.

Sleutel: de waarde in de filtersleutel moet overeenkomen in het bronwebonderdeel en in het doelwebonderdeel


Regelnr., Actiefilter WO-aanvraagtabel EP (tabel)

Veld Regelnr.

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld wordt automatisch ingevuld door het programma wanneer u een nieuw filter voor een actie maakt. Het nummer begint bij 10000 en wordt automatisch verhoogd met 10000 voor elk filter dat u voor een actie definieert.


Bronveldnr., Actiefilter WO-aanvraagtabel EP (tabel)

Veld Bronveldnr.

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld bevat het nummer van het veld van het aanroepende webonderdeelverzoek waarop het actiefilter wordt toegepast. Dit veld kan alleen velden bevatten die horen bij tabellen die zijn toegewezen aan het webonderdeelverzoek dat is gedefinieerd in het veld Webonderdeelverzoek.


Doelveldnr., Actiefilter WO-aanvraagtabel EP (tabel)

Veld Doelveldnr.

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld bevat het nummer van het veld dat wordt aangeroepen en waarop het filter wordt toegepast in het doelwebonderdeelverzoek. Dit veld kan alleen velden bevatten die horen bij de tabellen die zijn toegewezen aan het aangeroepen webonderdeelverzoek.


Standaardwaarde doelveld, Actiefilter WO-aanvraagtabel EP (tabel)

Veld Standaardwaarde doelveld

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld wordt alleen gebruikt als de waarde waarop u in het bronveld wilt filteren niet bestaat in de tabellen die zijn toegewezen aan het aanroepende webonderdeelverzoek. Als u bijvoorbeeld wilt filteren op het veld Documentsoort in de tabel Verkoopkop, kunt u de waarde in dit veld instellen op "1" zodat er wordt gefilterd op aanhalingstekens.


Sleutelveldnr., Actiefilter WO-aanvraagtabel EP (tabel)

Veld Sleutelveldnr.

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld bevat het nummer van het sleutelveld in de tabel die is toegewezen aan het doelwebonderdeelverzoek. U kunt hiermee de prestaties optimaliseren als u de SQL Server Option gebruikt.


Tabelnr., Actiefilter WO-aanvraagtabel EP (tabel)

Veld Tabelnr.

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld bevat het nummer van de tabel waarop het actiefilter is gebaseerd. Het tabelnummer wordt automatisch gekopieerd vanuit het veld Tabelnr. in de tabel EP Web Part Table Tab wanneer u het actiefilter toevoegt aan het webonderdeelverzoek.


Kop of regel, Actiefilter WO-aanvraagtabel EP (tabel)

Veld Kop of regel

De tabel Actiefilter WO-aanvraagtabel EP

Dit veld bevat de kop- of regelstatus van het EP-webonderdeel waarop het actiefilter is gebaseerd. Deze status wordt automatisch gekopieerd vanuit het veld Kop of Regel in de tabel EP Web Part Tab wanneer u het actiefilter toevoegt aan het webonderdeelverzoek.


Koptabelnr., Kop-/regelverbinding WO-aanvraag EP (tabel)

Veld Koptabelnr.

De tabel Kop-/regelverbinding WO-aanvraag EP

Dit veld bevat de tabel waarmee de kop-regelverbinding is verbonden.

Het veld wordt automatisch ingevuld door het programma.


Filter toepassen op, Kop-/regelverbinding WO-aanvraag EP (tabel)

Veld Filter toepassen op

De tabel Kop-/regelverbinding WO-aanvraag EP

Dit veld geeft aan dat de verbinding deel uitmaakt van een sleutel- of verbindingsfilter. De volgende koppelingssoorten zijn mogelijk:

Veld

Sleutel

Als het koppelingssoort Veld is, maakt de verbinding deel uit van een filter.

Als het koppelingssoort Sleutel is, maakt de verbinding deel uit van een sleutel.


Kopveldnr., Kop-/regelverbinding WO-aanvraag EP (tabel)

Veld Kopveldnr.

De tabel Kop-/regelverbinding WO-aanvraag EP

In dit veld kunt u het veld definiëren op de kop waarop u de verbinding wilt instellen. U kunt alleen velden selecteren die deel uitmaken van de tabel in de kop.


Regelveldnr., Kop-/regelverbinding WO-aanvraag EP (tabel)

Veld Regelveldnr.

De tabel Kop-/regelverbinding WO-aanvraag EP

In dit veld kunt u het veld definiëren op de regels waarop u de verbinding wilt instellen. U kunt alleen velden uit de tabel op de regels selecteren.


Standaardwaarde regelveld, Kop-/regelverbinding WO-aanvraag EP (tabel)

Veld Standaardwaarde regelveld

De tabel Kop-/regelverbinding WO-aanvraag EP

Dit veld wordt gebruikt als de waarde van het veld Regel niet bestaat in de koptabel die is geselecteerd in het veld Koptabelnr.

Dit veld wordt alleen gebruikt als de waarde waarop u wilt filteren in het veld Regel niet bestaat in de tabellen die zijn toegewezen aan het aanroepende webonderdeelverzoek. Als u bijvoorbeeld wilt filteren op Regelsoort, kunt u de standaardwaarde instellen op “1” (wat “Artikel” betekent) zodat alleen de regels van het soort Artikel worden opgehaald.


Regelsleutelveldnr., Kop-/regelverbinding WO-aanvraag EP (tabel)

Veld Regelsleutelveldnr.

De tabel Kop-/regelverbinding WO-aanvraag EP

In dit veld kunt u het veld definiëren in de sleutel op de regels waarop u de verbinding wilt instellen. U kunt alleen velden selecteren die deel uitmaken van de tabel op de regels.


Tabbladcode, Sorteersleutel WO-aanvraagtabel EP (tabel)

Veld Tabbladcode

De tabel Sorteersleutel WO-aanvraagtabel EP

Dit veld bevat de code van het tabblad waar de sorteersleutel bij hoort. Het veld maakt deel uit van de primaire sleutel.


Veldregelnr., Sorteersleutel WO-aanvraagtabel EP (tabel)

Veld Veldregelnr.

De tabel Sorteersleutel WO-aanvraagtabel EP

Dit veld wordt automatisch ingevuld door het programma wanneer u de eerste sorteersleutel voor een tabel maakt. Het nummer begint bij 10000 en wordt automatisch verhoogd met 10000 voor elke nieuwe tabel waarvoor u een sorteersleutel definieert.

Het veld maakt deel uit van de primaire sleutel.


Regelnr., Sorteersleutel WO-aanvraagtabel EP (tabel)

Veld Regelnr.

De tabel Sorteersleutel WO-aanvraagtabel EP

Dit veld wordt automatisch ingevuld door het programma wanneer u een nieuwe sorteersleutel maakt voor een tabel. Het nummer begint bij 10000 en wordt automatisch verhoogd met 10000 voor elk nieuw veld dat u definieert voor dezelfde tabel.


Sleutelveldnr., Sorteersleutel WO-aanvraagtabel EP (tabel)

Veld Sleutelveldnr.

De tabel Sorteersleutel WO-aanvraagtabel EP

Dit veld bevat het nummer van het veld dat u hebt geselecteerd als sorteersleutelveld. Dit veld kan alleen velden bevatten die horen bij de tabellen die zijn toegewezen aan het webonderdeelverzoek. Wanneer u het veld selecteert in het venster Overzicht sorteersleutels WO-tabel EP, wordt het veldnummer gekopieerd vanuit het juiste veld in de tabel die is aangegeven in het veld Tabelnr.


Veldnr., Kopmaakcriteria WO-aanvraag EP (tabel)

Veld Veldnr.

De tabel Kopmaakcriteria WO-aanvraag EP

In dit veld kunt u het nummer invoeren van het veld waarvoor u een criterium wilt definiëren. Dit veld kan alleen velden bevatten die horen bij de tabellen die zijn toegewezen aan het webonderdeelverzoek.


Standaardwaarde, Kopmaakcriteria WO-aanvraag EP (tabel)

Veld Standaardwaarde

De tabel Kopmaakcriteria WO-aanvraag EP

In dit veld kunt u de waarde van het criterium invoeren.


Tabbladcode, Zoekveld WO-aanvraag EP (tabel)

Veld Tabbladcode

De tabel Zoekveld WO-aanvraag EP

Dit veld bevat de code van het tabblad waar de zoekactie bij hoort. Het veld maakt deel uit van de primaire sleutel.


Regelnr., Zoekveld WO-aanvraag EP (tabel)

Veld Regelnr.

De tabel Zoekveld WO-aanvraag EP

Dit veld wordt automatisch ingevuld door het programma wanneer u een nieuwe zoekactie voor een tabel maakt. Het nummer begint bij 10000 en wordt automatisch verhoogd met 10000 voor elke nieuwe zoekactie die u voor dezelfde tabel definieert.


Positie, Zoekveld WO-aanvraag EP (tabel)

Veld Positie

De tabel Zoekveld WO-aanvraag EP

In dit veld kunt u definiëren in welke volgorde de zoekacties worden verwerkt als u meer dan één zoekactie hebt gedefinieerd voor hetzelfde veldnummer.


WO-aanvraagcode opzoeken, Zoekveld WO-aanvraag EP (tabel)

Veld WO-aanvraagcode opzoeken

De tabel Zoekveld WO-aanvraag EP

In dit veld kunt u instellen naar welke webonderdeelverzoeken de zoekactie leidt. U kunt alleen een zoekactie maken in webonderdeelverzoeken van het soort Lijst die zijn toegewezen aan dezelfde groep.

Het veld maakt deel uit van de primaire sleutel.


Veldnr., Voorwaarde zoekveld WO-aanvraag EP (tabel)

Veld Veldnr.

De tabel Voorwaarde zoekveld WO-aanvraag EP

Voer het veldnummer in van de brontabel waarmee de conditiewaarde van de huidige record moet worden vergeleken.


Veldwaarde, Voorwaarde zoekveld WO-aanvraag EP (tabel)

Veld Veldwaarde

De tabel Voorwaarde zoekveld WO-aanvraag EP

Voer de waarde in die in de records moet worden vergeleken.

Als de waarde identiek is aan de waarde in de huidige record, wordt dit zoekactieverzoek aangeroepen. Anders wordt de volgende zoekactieconditie gecontroleerd.


Bronveldnr., Zoekveldkoppeling WO-aanvraag EP (tabel)

Veld Bronveldnr.

De tabel Zoekveldkoppeling WO-aanvraag EP

Voer het veldnummer in waarop u de zoekactie wilt baseren. De waarde van het veld wordt automatisch gekopieerd naar het veld Doelveldnr.


Doelveldnr., Zoekveldkoppeling WO-aanvraag EP (tabel)

Veld Doelveldnr.

De tabel Zoekveldkoppeling WO-aanvraag EP

De waarde in dit veld wordt automatisch gekopieerd vanuit het veld Bronveldnr., maar u kunt deze waarde wijzigen als u wilt dat de zoekactie naar een ander veld leidt.


Filterveldnr., Filterveld WO-aanvraagtabel EP (tabel)

Veld Filterveldnr.

De tabel Filterveld WO-aanvraagtabel EP

In dit veld kunt u het nummer definiëren van het veld waarvoor u een filter wilt instellen.

Het veld maakt deel uit van de primaire sleutel.


Filterveldwaarde, Filterveld WO-aanvraagtabel EP (tabel)

Veld Filterveldwaarde

De tabel Filterveld WO-aanvraagtabel EP

U kunt dit veld gebruiken om een filter toe te passen op de records die worden weergegeven in het webonderdeel dat is gedefinieerd in het veld Webonderdeelverzoek.

U kunt de volgende symbolen gebruiken:

< = nummers kleiner dan, gecombineerd met een waarde. Voorbeeld: <5000. Als u "1" hebt gedefinieerd voor Klantnr. in de tabel Klant, worden in het webonderdeel alleen klanten met een klantnummer lager dan 5000 weergegeven.

> = nummers groter dan, gecombineerd met een waarde. Voorbeeld: >5000. Als u "1" hebt gedefinieerd voor Klantnr. in de tabel Klant, worden in het webonderdeel alleen klanten met een klantnummer hoger dan 5000 weergegeven.

= = nummers gelijk aan, gecombineerd met een waarde. Voorbeeld: =5000. Als u "1" hebt gedefinieerd voor Klantnr. in de tabel Klant, wordt in het webonderdeel alleen de klant met klantnummer 5000 weergegeven.

<> = alle nummers behalve de opgegeven waarde, gecombineerd met een waarde. Voorbeeld: <>5000. Als u "1" hebt gedefinieerd voor Klantnr. in de tabel Klant, worden in het webonderdeel alle klanten weergegeven met uitzondering van klantnummer 5000.

.. = nummers tussen de waarden. Voorbeeld: 5000..6000. Als u "1" hebt gedefinieerd voor Klantnr. in de tabel Klant, worden in het webonderdeel alleen klanten met een klantnummer tussen 5000 en 6000 weergegeven.


Tabelnr., Filterveld WO-aanvraagtabel EP (tabel)

Veld Tabelnr.

De tabel Filterveld WO-aanvraagtabel EP

Dit veld bevat het nummer van de tabel waar het veld in het veld Filterveldnr. bij hoort. Het nummer wordt automatisch ingevuld door het programma.


Pad, Pad SharePoint-systeemkopie EP (tabel)

Veld Pad

De tabel Pad SharePoint-systeemkopie EP

Voer het pad in van de afbeelding die u wilt definiëren voor de actie.


Tabelnr., Zoektabel EP (tabel)

Veld Tabelnr.

De tabel Zoektabel EP

Dit veld bevat het nummer van de tabel die u hebt geconfigureerd voor zoekacties.


Tabelbijschrift, Zoektabel EP (tabel)

Veld Tabelbijschrift

De tabel Zoektabel EP

Dit veld bevat het bijschrift dat wordt weergegeven in het toolsvenster wanneer u een webonderdeel van het soort Zoeken op de portaalpagina configureert. Het bijschrift wordt weergegeven als een optie in het veld waarin u de tabel selecteert waarin de zoekactie moet worden uitgevoerd.


Tabelnr., Zoekveld EP (tabel)

Veld Tabelnr.

De tabel Zoekveld EP

Dit veld bevat het nummer van de tabel die u hebt geconfigureerd voor zoekacties.


Veldnr., Zoekveld EP (tabel)

Veld Veldnr.

De tabel Zoekveld EP

Dit veld bevat het nummer van het veld waarop een zoekactie kan worden uitgevoerd.


Veldbijschrift, Zoekveld EP (tabel)

Veld Veldbijschrift

De tabel Zoekveld EP

Dit veld bevat het bijschrift van het veld dat is gedefinieerd in het veld Veldnr.


Veldnr., Zoek-/weergaveveld EP (tabel)

Veld Veldnr.

De tabel Zoek-/weergaveveld EP

Dit veld bevat het nummer van het veld dat wordt weergegeven in de zoekresultaten.


Weergaveveld, Zoek-/weergaveveld EP (tabel)

Veld Weergaveveld

De tabel Zoek-/weergaveveld EP

In dit veld kunt u definiëren in welke volgorde de velden worden weergegeven in de zoekresultaten. De opties zijn Veld 1..Veld 5. De velden worden in oplopende volgorde weergegeven, waarbij het veld met de waarde Veld 1 als eerste in de lijst wordt weergegeven.


Veldbijschrift, Zoek-/weergaveveld EP (tabel)

Veld Veldbijschrift

De tabel Zoek-/weergaveveld EP

Dit veld bevat het bijschrift dat wordt weergegeven in de zoekresultaten voor het veld.


Gebruikers-id, Zoekconfiguratie EP (tabel)

Veld Gebruikers-id

De tabel Zoekconfiguratie EP

Dit veld bevat de gebruikers-id van de gebruiker waaraan de zoekconfiguratie is toegewezen.


Tabelnr., Zoekconfiguratie EP (tabel)

Veld Tabelnr.

De tabel Zoekconfiguratie EP

Selecteer het nummer van de tabel waarvoor u een zoekconfiguratie wilt toewijzen aan de gebruiker.


Groepcode, Zoekconfiguratie EP (tabel)

Veld Groepcode

De tabel Zoekconfiguratie EP

Voer de groepcode in van het webonderdeelverzoek voor het webonderdeel waarin u de zoekresultaten wilt weergeven.


WO-aanvraagcode, Zoekconfiguratie EP (tabel)

Veld WO-aanvraagcode

De tabel Zoekconfiguratie EP

Selecteer het webonderdeelverzoek dat moet worden aangeroepen wanneer de gebruiker op een onderdeel van de zoekresultaten klikt.

U kunt alleen webonderdeelverzoeken gebruiken die dezelfde tabel bevatten als de tabel die is gedefinieerd in het veld Tabelnr.


WO-aanvraagsoort, Zoekconfiguratie EP (tabel)

Veld WO-aanvraagsoort

De tabel Zoekconfiguratie EP

Dit veld wordt automatisch gekopieerd vanuit het veld Soort in de tabel WO-verzoek EP.


Doelkoppeling, Zoekconfiguratie EP (tabel)

Veld Doelkoppeling

De tabel Zoekconfiguratie EP

Voer het pad in naar de webonderdeelpagina waar u het webonderdeel hebt geconfigureerd waarin u afzonderlijke onderdelen van de zoekresultaten van een zoekactie wilt weergeven.


Groepcode, EP-groep/-gebruiker (tabel)

Veld Groepcode

De tabel EP-groep/-gebruiker

Dit veld bevat de code van de EP-groep waaraan de gebruiker is toegewezen. De groepcode wordt gekopieerd vanuit het veld Groepcode in de tabel EP-groep.


Gebruikers-id, EP-groep/-gebruiker (tabel)

Veld Gebruikers-id

De tabel EP-groep/-gebruiker

Dit veld bevat de gebruikers-id. De id wordt gekopieerd vanuit het veld Gebruikers-id in de tabel EP-gebruikers wanneer u de gebruiker toewijst aan de groep.


Windows-aanmeldings-id, EP-gebruikerslogin (tabel)

Veld Windows-aanmeldings-id

De tabel EP-gebruikerslogin

Dit veld bevat de Logon Security Identifier (SID) van de gebruiker. De Logon SID is een unieke id voor de aanmeldingssessie van de gebruiker.


Naam, EP-gebruikerslogin (tabel)

Veld Naam

De tabel EP-gebruikerslogin

Dit veld bevat de Windows-aanmeldingsnaam van de gebruiker.


Gebruikers-id, EP-gebruiker (tabel)

Veld Gebruikers-id

De tabel EP-gebruiker

In dit veld kunt u de gebruikers-id van de gebruiker definiëren. Zorg ervoor dat de id identiek is aan de id die voor de gebruiker is gedefinieerd in SharePoint. De indeling van de gebruikers-id moet DOMAIN\USERID zijn.


Taal-id, EP-gebruiker (tabel)

Veld Taal-id

De tabel EP-gebruiker

Dit veld bevat de id van de taal die is gedefinieerd voor deze gebruiker.

De taal-id kan worden geconfigureerd op gebruikers- of groepniveau. Als u het veld Taal-id in de tabel EP-groep en dit veld niet invult, worden de webonderdelen weergegeven in de standaardtaal van de Microsoft Dynamics NAV Application Server.

U kunt alleen de talen selecteren waarvoor u een licentie hebt.


Bijschrift-id, EP-bijschrift (tabel)

Veld Bijschrift-id

De tabel EP-bijschrift

Dit veld bevat het nummer dat door het programma is toegewezen aan de bijschriftdefinitie. Het veld wordt automatisch ingevuld door het programma.


Tabelnr., EP-bijschrift (tabel)

Veld Tabelnr.

De tabel EP-bijschrift

Dit veld bevat het nummer van de tabel waaraan het bijschrift is toegewezen. Het veld wordt automatisch ingevuld door het programma.


Taal-id, EP-bijschrift (tabel)

Veld Taal-id

De tabel EP-bijschrift

Dit veld bevat de code van de taal waarvoor dit bijschrift is gedefinieerd.

De taal-id kan worden geconfigureerd op gebruikers- of groepniveau. Als u het veld Taal-id in de tabel EP-groep en dit veld niet invult, worden de webonderdelen weergegeven in de standaardtaal van de Microsoft Dynamics NAV Application Server.

U kunt alleen de talen selecteren waarvoor u een licentie hebt.


Bijschrift, EP-bijschrift (tabel)

Veld Bijschrift

De tabel EP-bijschrift

Dit veld bevat de waarde die zichtbaar is voor de gebruiker.


Taalnaam, EP-bijschrift (tabel)

Veld Taalnaam

De tabel EP-bijschrift

Dit veld bevat de naam van de taal waarvoor dit bijschrift is gedefinieerd.


Code, Instellingen Application Server EP (tabel)

Veld Code

De tabel Instellingen Application Server EP

Dit veld bevat de code voor de Application Server. De code moet gelijk zijn aan de opstartparameter voor de Application Server.


Front-end verwerking, Instellingen Application Server EP (tabel)

Veld Front-end verwerking

De tabel Instellingen Application Server EP

Schakel dit selectievakje in als u wilt dat de Application Server de communicatie tussen Microsoft Dynamics NAV en de front-end verwerkt.


Aanvraagwachtrij, Instellingen Application Server EP (tabel)

Veld Aanvraagwachtrij

De tabel Instellingen Application Server EP

Dit veld bevat het label van de wachtrij voor inkomende berichten.


Antwoordenwachtrij, Instellingen Application Server EP (tabel)

Veld Antwoordenwachtrij

De tabel Instellingen Application Server EP

Dit veld bevat het label van de wachtrij voor uitgaande berichten.


Time-out antwoordenwachtrij, Instellingen Application Server EP (tabel)

Veld Time-out antwoordenwachtrij

De tabel Instellingen Application Server EP

Geef op hoe lang antwoorden in de wachtrij mogen blijven. Als antwoorden niet worden ontvangen door de front-end (bijvoorbeeld omdat de gebruiker de browser sluit), worden ze verwijderd nadat deze tijd is verstreken.


Wachtrijprioriteit antwoorden, Instellingen Application Server EP (tabel)

Veld Wachtrijprioriteit antwoorden

De tabel Instellingen Application Server EP

Geef een prioriteitsniveau op voor uw antwoorden. De wachtrijprioriteit van de antwoorden bepaalt hoe snel berichten tussen Microsoft Dynamics NAV en de Employee Portal worden verwerkt wanneer andere berichten worden verzonden naar dezelfde berichtenwachtrij.


Compressie gebruiken, Instellingen Application Server EP (tabel)

Veld Compressie gebruiken

De tabel Instellingen Application Server EP

Schakel dit selectievakje in als u wilt dat berichten die door deze Application Server worden verwerkt worden gecomprimeerd. De bijbehorende waarden moeten worden ingesteld in de front-end in het bestand Web.config.


Codering gebruiken, Instellingen Application Server EP (tabel)

Veld Codering gebruiken

De tabel Instellingen Application Server EP

Schakel dit selectievakje in als u wilt dat berichten die door deze Application Server worden verwerkt worden gecodeerd. De bijbehorende waarden moeten worden ingesteld in de front-end in het bestand Web.config.


Sleuteluitwisseling verwerken, Instellingen Application Server EP (tabel)

Veld Sleuteluitwisseling verwerken

De tabel Instellingen Application Server EP

Schakel dit selectievakje in als u wilt dat de Application Server vertrouwde verzoeken van de front-end verwerkt.


Aanvraagwachtrij sleuteluitwisseling, Instellingen Application Server EP (tabel)

Veld Aanvraagwachtrij sleuteluitwisseling

De tabel Instellingen Application Server EP

Voer het label in van de wachtrij voor inkomende berichten die wordt gebruikt voor vertrouwde sites.


Antwoordenwachtrij sleuteluitwisseling, Instellingen Application Server EP (tabel)

Veld Antwoordenwachtrij sleuteluitwisseling

De tabel Instellingen Application Server EP

Voer het label in van de wachtrij voor uitgaande berichten die wordt gebruikt voor vertrouwde sites.


Time-out antwoordenwachtrij sleuteluitwisseling, Instellingen Application Server EP (tabel)

Veld Time-out antwoordenwachtrij sleuteluitwisseling

De tabel Instellingen Application Server EP

Geef op hoe lang antwoorden in de wachtrij mogen blijven. Als antwoorden niet worden ontvangen door de front-end (bijvoorbeeld omdat de gebruiker de browser sluit), worden ze verwijderd nadat deze tijd is verstreken.


Prioriteit antwoordenwachtrij sleuteluitwisseling, Instellingen Application Server EP (tabel)

Veld Prioriteit antwoordenwachtrij sleuteluitwisseling

De tabel Instellingen Application Server EP

Geef een prioriteitsniveau op voor uw antwoorden. De wachtrijprioriteit voor antwoorden bepaalt hoe snel berichten tussen Microsoft Dynamics NAV en SharePoint worden verwerkt wanneer andere berichten worden verzonden naar dezelfde berichtenwachtrij.


Sitenaam, Vertrouwde site EP (tabel)

Veld Sitenaam

De tabel Vertrouwde site EP

Dit veld bevat de naam van de vertrouwde site.


Aanvraagdatum, Vertrouwde site EP (tabel)

Veld Aanvraagdatum

De tabel Vertrouwde site EP

Dit veld bevat de datum van het verzoek om vertrouwen. De inhoud van dit veld is alleen ter informatie.


Aanvraagtijd, Vertrouwde site EP (tabel)

Veld Aanvraagtijd

De tabel Vertrouwde site EP

Dit veld bevat de tijd van het verzoek om vertrouwen. De inhoud van dit veld is alleen ter informatie.


Openbare sleutel partner, Vertrouwde site EP (tabel)

Veld Openbare sleutel partner

De tabel Vertrouwde site EP

Dit veld bevat het openbare gedeelte van het certificaat van de site. De openbare sleutel van de site wordt gebruikt om de handtekening van de inkomende berichten van de vertrouwde site te controleren.


Aanvraagbericht GUID, Vertrouwde site EP (tabel)

Veld Aanvraagbericht GUID

De tabel Vertrouwde site EP

Dit veld bevat de GUID van het verzoek. De GUID wordt geretourneerd als deel van het antwoord aan de front-endservice zodat het verzoekende portaal kan worden geïdentificeerd.


Site-identificatie, Vertrouwde site EP (tabel)

Veld Site-identificatie

De tabel Vertrouwde site EP

Dit veld bevat de unieke id van het portaal. Deze wordt aan elk antwoord aan de site toegevoegd zodat de Application Server de juiste sleutels voor codering en decodering kan identificeren.


Vertrouwen site, Vertrouwde site EP (tabel)

Veld Vertrouwen site

De tabel Vertrouwde site EP

Als u dit veld inschakelt, geeft u aan dat u het verzoek om vertrouwen hebt geaccepteerd.


Datum vertrouwen, Vertrouwde site EP (tabel)

Veld Datum vertrouwen

De tabel Vertrouwde site EP

Dit veld bevat de datum waarop u het verzoek om vertrouwen hebt geaccepteerd. De inhoud van dit veld is alleen ter informatie.


Tijd vertrouwen, Vertrouwde site EP (tabel)

Veld Tijd vertrouwen

De tabel Vertrouwde site EP

Dit veld bevat de tijd waarop u het verzoek om vertrouwen hebt geaccepteerd. De inhoud van dit veld is alleen ter informatie.


Antwoord verzonden, Vertrouwde site EP (tabel)

Veld Antwoord verzonden

De tabel Vertrouwde site EP

Als dit selectievakje is ingeschakeld, is de acceptatie van het verzoek om vertrouwen verzonden naar de front-end.


Datum verzonden, Vertrouwde site EP (tabel)

Veld Datum verzonden

De tabel Vertrouwde site EP

Dit veld bevat de datum waarop u het verzoek om vertrouwen hebt geaccepteerd. De inhoud van dit veld is alleen ter informatie.


Tijd verzonden, Vertrouwde site EP (tabel)

Veld Tijd verzonden

De tabel Vertrouwde site EP

Dit veld bevat de tijd waarop u het verzoek om vertrouwen hebt geaccepteerd. De inhoud van dit veld is alleen ter informatie.