Meer te weten komen over Business Notification

Met Business Notification kunt u werknemers en zakenpartners automatisch inlichten over wijzigingen binnen Navision. Als een stuklijst bijvoorbeeld door een productontwerper wordt gewijzigd, moeten andere afdelingen op de hoogte worden gesteld van de wijzigingen. De inkoopafdeling moet aanpassingen doorvoeren op basis van de nieuwe of gewijzigde onderdelen, de verkoopafdeling wil klanten wellicht op de hoogte stellen van vertragingen, enzovoort. Zonder een automatisch proces kan deze belangrijke informatie gemakkelijk verloren gaan.

In het onderwerp Aan de slag in drie minuten wordt beschreven hoe snel u met het gezamenlijk gebruik van Navision en Business Notification kunt beginnen. In Hoe werkt het? wordt uitgebreid beschreven hoe Navision en Business Notification met elkaar samenwerken en in het onderwerp Kennisgevingen ontwerpen en gebruiken wordt aangegeven wat er in de tools van Business Notification moet worden ingesteld. Deze onderwerpen bevatten voldoende informatie om aan de slag te kunnen. In het hoofdstuk Concepten vindt u een uitleg van de belangrijkste concepten die in Business Notification worden toegepast. Dit hoofdstuk is bedoeld voor eenvoudige naslagdoeleinden, maar is zo ingedeeld dat het ook van begin tot einde kan worden gelezen.

De naslaggidsen voor de Notification Manager en de Notification Designer kunt u gebruiken wanneer u met de tools zelf gaat werken. Beide gidsen bevatten naslaginformatie over de gebruikersinterface, naast op onderwerp gesorteerde gebruiksrichtlijnen voor de tools. In het hoofdstuk Gebeurtenissen maken in Navision wordt beschreven wat er in Navision moet worden gedaan (door een C/AL-ontwikkelaar) om nieuwe oplossingen te maken. In het onderwerp Beschrijving van sjablonen vindt u een korte beschrijving van de zes vooraf gedefinieerde oplossingen die bij Business Notification worden geleverd.


Aan de slag in drie minuten

De gemakkelijkste manier om te beginnen is door gebruik te maken van een sjabloon. Een sjabloon bevat alles wat u nodig hebt, maar er moeten toch nog enkele kleine wijzigingen in worden doorgevoerd die specifiek betrekking hebben op de werkwijze van uw bedrijf.

U gaat als volgt te werk om een sjabloon te gebruiken:

  1. Maak een kopie van de sjabloon die u wilt gebruiken in de Business Notification Designer (de sjabloon zelf is tegen schrijven beveiligd) door te klikken op Nieuw van sjabloon. De kopie van de sjabloon wordt geopend in de Business Notification Designer, waarin deze kan worden bewerkt.

  2. In het schema kunt u de filters, het e-mailbericht, enzovoort, controleren en wijzigen.

  3. Als u verder niets wilt doen, moet u ten minste één gebruiker registratierechten voor de kennisgeving verlenen.

  4. Sla het schema op wanneer u klaar bent.

  5. Klik op Voltooien om het schema te voltooien. Het schema wordt dan naar de lijst van voltooide schema's verplaatst.

  6. Als u het schema wilt starten, selecteert u het schema en klikt u op Starten.

Nu kan de gebruiker aan wie u registratietoestemming hebt verleend zich registreren voor deze kennisgeving.

Vanuit Navision kunt u ervoor zorgen dat een gebeurtenis zich voordoet, wanneer ten minste één gebruiker is geregistreerd voor kennisgevingen. Wanneer u dit hebt gedaan, moet de geregistreerde gebruiker een e-mailbericht ontvangen. Klik hier voor meer informatie over de manier waarop u een kennisgeving veroorzaakt en over sjablonen.

De volgende onderwerpen bevatten meer informatie over de werking van Business Notification:


Hoe werkt het?

Hoe weten Navision en Business Notification waar gebruikers kennisgevingen over moeten ontvangen en wanneer dit moet gebeuren? Het antwoord op deze vraag is dat er in Navision en in Business Notification iets moet gebeuren.

Navision ondersteunt Business Notification door te voorzien in bedrijfsentiteiten en gebeurtenissen (klik hier voor meer informatie over de manier waarop Business Notification wordt ondersteund door Navision). Een bedrijfsentiteit kan bijvoorbeeld een verkooporder of stuklijst zijn. Aan elke bedrijfsentiteit zijn een of meer gebeurtenissen gekoppeld. Gebeurtenissen voor een verkooporder kunnen bijvoorbeeld 'Orderbedrag boven 10.000' of 'Kredietlimiet van klant overschreden' zijn. Voor een stuklijst kunnen gebeurtenissen bijvoorbeeld 'Stuklijst gewijzigd' of 'Status stuklijst gewijzigd' zijn.

Wanneer er in Navision iets gebeurt dat ervoor zorgt dat zich een gebeurtenis voordoet (er wordt bijvoorbeeld een verkooporder opgeslagen met een orderbedrag van meer dan 10.000), wordt er een document naar Business Notification verzonden. Het document bevat gegevens van de bedrijfsentiteit. Voor de gebeurtenis 'Orderbedrag boven 10.000' voor een verkooporder zouden deze gegevens waarschijnlijk de ID van de verkooporder en het orderbedrag omvatten.

Business Notification leest het document, en alle gebruikers die zich hebben geregistreerd voor deze gebeurtenis van de bedrijfsentiteit ontvangen een kennisgeving in de vorm van een e-mailbericht. De gegevens in het document kunnen in het e-mailbericht worden opgenomen, zodat de kennisgeving de geadresseerde van het e-mailbericht niet alleen meldt dat er iets is gebeurd maar ook wat er precies is gebeurd.

De onderdelen

In de installatiegids op de distributie-cd wordt beschreven wat er moet worden geïnstalleerd van Business Notification en hoe dit moet worden gedaan. Kort gezegd bestaat Business Notification uit twee hoofdonderdelen:

  1. De Business Notification Manager op de client (inclusief de Business Notification Designer). De Business Notification Manager wordt geïnstalleerd door de Navision Installer. Het clientonderdeel kan op meerdere computers worden geïnstalleerd. De Navision-client moet lokaal worden uitgevoerd voordat de Business Notification Manager wordt gestart.

  2. Het Business Notification-onderdeel op de server wordt afzonderlijk geïnstalleerd. Dit onderdeel wordt als een service uitgevoerd en wordt zo ingesteld dat het automatisch wordt gestart zodra het besturingssysteem wordt opgestart. Normaal gesproken is er slechts één instantie van dit onderdeel actief, zoals er normaal gesproken ook slechts één instantie van de Navision-databaseserver actief is.

In het onderstaande diagram worden de onderdelen geïllustreerd:

Op elke client moeten de volgende elementen aanwezig zijn:

  • Een Navision 4.0-client die is verbonden met de Navision-databaseserver

  • De Business Notification-client (de Manager en de Designer)

  • Microsoft Internet Explorer 6.0

Op de server moeten de volgende elementen aanwezig zijn:

  • Een Navision-databaseserver

  • Een Business Notification-server

  • Een SQL-server

  • Een SMTP-server of een verbinding met een SMTP-server

  • Internet Information Server

De vier computers die in het diagram worden weergegeven, moeten worden beschouwd als virtuele servers. Het hoeven dus niet per se vier verschillende computers te zijn. Alle onderdelen op de server kunnen op dezelfde computer of op meerdere computers worden uitgevoerd, afhankelijk van de reeds aanwezige installatie, specifieke distributievereisten, enzovoort.


Kennisgevingen ontwerpen en gebruiken

Kennisgevingen worden verzonden naar interne gebruikers die zich er specifiek voor hebben geregistreerd of naar externe geadresseerden zoals zakenpartners. Wanneer een interne gebruiker via een browser naar de registratietool gaan, ziet deze een lijst met kennisgevingen waarvoor registratie mogelijk is. Deze tool kan ook worden gebruikt om registraties op te heffen. Externe geadresseerden worden toegevoegd tijdens het opstellen van een schema.

Ontwerpen

De lijst met kennisgevingen wordt gemaakt in de Business Notification Designer.

Hier volgt een beschrijving van de voornaamste principes van de Designer:

  • Een gebruiker registreert zich voor een kennisgeving om e-mailberichten te ontvangen.

  • Een schema is de verzameling regels op basis waarvan in Business Notification een kennisgeving wordt gemaakt.

  • Een filter maakt deel uit van een schema. Het zorgt ervoor dat het programma kan bepalen of er een bericht moet worden verzonden, op basis van de gegevens in het van Navision ontvangen document.

  • Een sjabloon is een voorgedefinieerde kennisgevingsoplossing die zowel het Navision-deel (bedrijfsentiteit en gebeurtenis) als het schema bevat.

Deze lijst met kennisgevingen waarvoor registratie mogelijk is, wordt gemaakt op basis van alle bedrijfsentiteiten en gebeurtenissen die in Navision zijn ingesteld. Als u meer wilt weten over het toevoegen van nieuwe bedrijfsentiteiten en gebeurtenissen in Navision, klikt u hier. Houd er echter rekening mee dat dit niet met de tools van Business Notification gebeurt en dat er een Navision-ontwikkelaarslicentie voor nodig is.

Als onderdeel van de instelling van Business Notification definieert een ervaren gebruiker de kennisgevingen. Een kennisgeving wordt gemaakt door:

  1. Een bedrijfsentiteit te selecteren, bijvoorbeeld Stuklijst.

  2. Een gebeurtenis voor deze bedrijfsentiteit te selecteren, bijvoorbeeld Stuklijst gewijzigd.

  3. Een filter voor de kennisgeving in te stellen, bijvoorbeeld 'alleen een kennisgeving verzenden als de wijziging bepaalde belangrijke onderdelen betreft, zoals de wielen van een fiets'.

  4. Het e-mailbericht te maken dat geregistreerde gebruikers ontvangen.

  5. De gebruikers of groepen gebruikers te bepalen die zich voor de kennisgeving kunnen registreren.

  6. De kennisgeving een beschrijvende naam te geven, bijvoorbeeld Fietswielen gewijzigd.

  7. De kennisgeving te publiceren.

Gebruiken

Een eindgebruiker hoeft maar weinig te doen om Business Notification te kunnen gebruiken. De eindgebruiker dient zich te registreren (aan te melden) voor kennisgevingen waarvoor deze toegangrechten heeft en die deze wil ontvangen. Later kan een eerdere registratie desgewenst worden geannuleerd.

Als een eindgebruiker zich eenmaal heeft geregistreerd, ontvangt deze een e-mailbericht wanneer de kennisgeving wordt geactiveerd (wanneer er in Navision iets gebeurt dat ervoor zorgt dat zich een gebeurtenis voordoet).

Voor bepaalde oplossingen dienen er mogelijk bepaalde procedures in Navision te worden uitgevoerd voordat een gebeurtenis zich voordoet en de corresponderende kennisgeving wordt geactiveerd. Dit maakt deel uit van de functionaliteit van het Navision-deel van de oplossing (de bedrijfslogica van Navision) en wordt in de Navision-documentatie beschreven.


Bedrijfsentiteit

Een bedrijfsentiteit vertegenwoordigt een concreet object. In een ERP-systeem kunnen relevante bedrijfsentiteiten bijvoorbeeld Klant, Verkooporder of Factuur zijn.

Een bedrijfsentiteit (of liever gezegd een instantie van een bedrijfsentiteit) bevat gegevensvelden (zoals 'Jan Smit', de naam van een klant) en metagegevens die de gegevensvelden beschrijven (bijvoorbeeld de naam van het gegevensveld, zoals Klant, en het soort gegevensveld, zoals Tekst).

Bij de integratie tussen Business Notification en Navision heeft een bedrijfsentiteit een extra kenmerk: een gebeurtenis. Aan een bedrijfsentiteit genaamd 'Klant' kunnen bijvoorbeeld de volgende gebeurtenissen zijn gekoppeld: 'Klant geblokkeerd' en 'Kredietlimiet klant gewijzigd'. Als een van deze gebeurtenissen zich voordoet in Navision, dat wil zeggen als er 'iets gebeurt', bijvoorbeeld omdat er een klant wordt geblokkeerd of omdat een kredietlimiet wordt gewijzigd, wordt er een document met zowel de naam van de gebeurtenis ('Klant geblokkeerd') als de bedrijfsentiteit 'Klant' naar Business Notification verzonden.


Gebeurtenis

U kunt het beste inzicht krijgen in gebeurtenissen door een gebeurtenis te beschouwen als het mechanisme dat Navision en Business Notification met elkaar verbindt. Een gebeurtenis is gekoppeld aan een bedrijfsentiteit en elke kennisgeving is gebaseerd op één gebeurtenis van één bedrijfsentiteit. Wanneer er 'iets' gebeurt, zal zich een gebeurtenis voordoen in de bedrijfslogica van Navision (de C/AL-code), zoals bepaald door een Navision-ontwikkelaar.

Bijvoorbeeld:

  • U wilt kennisgevingen wanneer een klant wordt geblokkeerd.

  • De ontwikkelaar maakt een bedrijfsentiteit (bijvoorbeeld 'Klant').

  • De ontwikkelaar voegt een gebeurtenis aan deze bedrijfsentiteit toe (bijvoorbeeld 'Klant geblokkeerd').

  • De ontwikkelaar test steeds wanneer de klantentabel wordt bijgewerkt of de blokkeringsstatus van een klant in Navision van niet geblokkeerd is gewijzigd in een van de geblokkeerde statussen (voor 'Verzenden', 'Factuur' of 'Alles').

  • Als de status Geblokkeerd is gewijzigd, doet zich de gebeurtenis 'Klant geblokkeerd' van de bedrijfsentiteit 'Klant' voor.

  • Hierdoor wordt er een document naar Business Notification verzonden. Dit document bevat de naam van de gebeurtenis en de gegevens van de klant die in de bedrijfsentiteit 'Klant' zijn opgenomen.

  • De gegevens in het document worden vervolgens in Business Notification verwerkt. Afhankelijk van de filters die in Business Notification zijn ingesteld, kunnen er een of meer e-mailberichten worden verzonden.


Externe geadresseerde

Interne gebruikers melden zich zelf via registratie aan voor de ontvangst van kennisgevingen. Als u echter kennisgevingen wilt verzenden aan externe geadresseerden (bijvoorbeeld zakenpartners), kunnen deze externe geadresseerden niet op dezelfde wijze gebruikmaken van registratie. De reden hiervan is dat ze (normaal gesproken) geen toegang hebben tot uw intranet en ook niet als Windows-gebruikers binnen uw bedrijf zijn geregistreerd.

Externe geadresseerden moeten dus expliciet worden toegevoegd in de Notification Designer. Dit betekent dat u de namen van deze geadresseerden specifiek in de schema's moet vastleggen. Als er kennisgevingen naar een relevante zakenpartner moeten worden verzonden wanneer een gebeurtenis zich in Navision voordoet, moet het e-mailadres waarnaar de kennisgeving moet worden verzonden, deel uitmaken van de gegevens die Navision verzendt (de bedrijfsentiteit). De Navision-klantentabel kent een standaardveld met de naam 'E-mail' voor dit doel voor bijvoorbeeld klanten.


Filter

Wanneer een gebeurtenis zich in Navision voordoet, ontvangt Business Notification een document met de betreffende bedrijfsentiteit. Vervolgens kan er op basis van een filter in Business Notification worden beslist of er een kennisgeving moet worden verzonden. Bijvoorbeeld:

Voor de bedrijfsentiteit 'Klant' doet zich een gebeurtenis genaamd 'Klant geblokkeerd' voor. De gebeurtenis doet zich voor wanneer de blokkeringsstatus van een klant van een niet-geblokkeerde status in een van de geblokkeerde statussen (Verzenden, Factuur of Alles) verandert. U wilt echter alleen kennisgevingen als de nieuwe status 'Verzenden' is. Daarvoor kunt u in Business Notification een filter gebruiken.

U kunt meer dan een kennisgeving op een en dezelfde gebeurtenis baseren. Als vervolg op het bovenstaande (zeer eenvoudige) voorbeeld zou u drie verschillende kennisgevingen kunnen maken door gebruik te maken van drie verschillende filters: een waarmee wordt gefilterd op de waarde 'Verzenden' in het veld Geblokkeerd, een waarmee wordt gefilterd op de waarde 'Factuur' en ten slotte een waarmee wordt gefilterd op de waarde 'Alles'.

Belangrijk: met een filter in Business Notification wordt op geen enkele wijze een query of nieuwe query op Navision toegepast: Navision verzendt een document met de gegevens die de ontwikkelaar van de bedrijfsentiteit in Navision heeft geselecteerd. Een filter in Business Notification kan alleen worden gebruikt om deze gegevens te 'verfijnen' en niet om de door Navision verzonden gegevens uit te breiden of te wijzigen.

Dit betekent dat u geen filter voor 'tijdsberekeningen' kunt maken in Business Notification (u kunt dus geen filter maken waarmee een expressie als 'vandaag plus 7 dagen' kan worden geëvalueerd). Datums uit Navision zijn al 'definitief' en de enige manier waarop u deze kunt filteren is door te evalueren aan de hand van de exacte datum die uit Navision wordt verkregen (zoals: 'als Orderdatum na 24 december 2004 ligt'.)

Voor deze onderwerpen is meer informatie beschikbaar: Het formulier Filter en Meer info over filters.


Kennisgeving

Kennisgeving is het basisconcept van Business Notification. In grote lijnen bestaat een kennisgeving uit:

  • Bedrijfslogica in Navision

  • Een 'document' dat Navision naar Business Notification verzendt

  • Bedrijfslogica in Business Notification

  • Een e-mailbericht

De bedrijfslogica van Navision: het startpunt voor de kennisgeving is de bedrijfslogica van Navision (de programmacode op basis waarvan Navision werkt). Een Navision-ontwikkelaar maakt een test waardoor er een 'document' naar Business Notification wordt verzonden wanneer er aan een vooraf gedefinieerde voorwaarde wordt voldaan. De test wordt gebruikt om ervoor te zorgen dat 'een gebeurtenis zich voordoet'. Er zou bijvoorbeeld kunnen worden getest of het totaalbedrag van een verkooporder boven een bepaald niveau ligt. Zo ja, dan doet de gebeurtenis zich voor.

Een 'document' wordt naar Business Notification verzonden: wanneer de gebeurtenis zich voordoet, verzendt Navision automatisch een document naar Business Notification. Dit document bevat zowel gegevens over de gebeurtenis als gegevens waar de Navision-ontwikkelaar in Business Notification toegang toe wil hebben.

Bedrijfslogica in Business Notification: wanneer Business Notification een document van Navision ontvangt, wordt op basis van de interne bedrijfslogica van Business Notification bepaald of er een kennisgevings-e-mail moet worden verzonden en naar wie dit moet worden verzonden. Deze bedrijfslogica, ofwel 'regels', worden ingesteld in de Business Notification Designer.

Samenvattend kan worden gesteld dat er een kennisgevings-e-mail wordt verzonden wanneer:

  1. De bedrijfslogica van Navision ervoor zorgt dat zich een gebeurtenis voordoet.

  2. Business Notification een (gestart) schema heeft dat reageert op deze gebeurtenis.

  3. Voor deze specifieke gebeurtenis is ingesteld dat een kennisgeving moet worden verzonden met de gegevens in deze specifieke instantie.

  4. En er ten minste één interne gebruiker voor het schema is geregistreerd , of er ten minste één externe geadresseerde is ingesteld.

Als het systeem eenmaal actief is, kan het e-mailbericht vanuit het perspectief van de eindgebruiker in veel opzichten worden beschouwd als de kennisgeving zelf, en zal ook vaak zo worden genoemd.


Schema

Een schema is de naam voor de 'regels' die Business Notification toepast om te bepalen wanneer en hoe kennisgevingen moeten worden verzonden. Een schema wordt gemaakt in de Business Notification Designer en schema's worden beheerd in de Business Notification Manager.

De volgende gegevens worden in een schema opgeslagen:

  • Een naam voor het schema

  • De bedrijfsentiteit en gebeurtenis die erdoor wordt geactiveerd

  • Filters die worden toegepast op ontvangen bedrijfsentiteiten

  • De tekst van het e-mailbericht dat wordt verzonden om gebruikers in te lichten

  • Toegangsrechten die beschrijven welke gebruikers zich voor de kennisgeving kunnen registreren

  • Een titel en een omschrijving van de kennisgeving die worden gebruikt in de browserinterface voor de registratie van eindgebruikers

  • Gegevens over externe geadresseerden

Een schema kan 'in ontwikkeling' zijn, wat betekent dat het momenteel wordt ontwikkeld of gewijzigd. Wanneer het schema gereed is voor gebruik, is het 'voltooid'. Een voltooid schema kan worden gestart of gestopt. Zolang een schema actief is, kunnen gebruikers zich ervoor registreren en ontvangen zij kennisgevingen wanneer dit nodig is.


Registratie

Interne gebruikers, dat wil zeggen gebruikers binnen uw eigen bedrijf die toegang tot uw intranet hebben, ontvangen niet automatisch kennisgevings-e-mailberichten. Zij moeten zich specifiek registreren voor een kennisgeving om kennisgevingen te ontvangen. Het is erg belangrijk te letten op de volgende punten:

  • Bij het ontwerpen van een kennisgeving in de Notification Designer machtigt u gebruikers of gebruikersgroepen om zich te registreren voor (of zich aan te melden voor) kennisgevingen.

  • De gebruikers zelf moeten de browsertoepassing voor registratiebeheer gebruiken om zich te registreren voor kennisgevingen (en ook om registraties te verwijderen).

  • Gebruikers worden niet automatisch ingelicht over nieuwe kennisgevingen waarvoor ze zich kunnen registreren. Als u dergelijke informatie wilt distribueren, moet u dit zelf doen.

Kennisgevingen kunnen ook worden verzonden naar externe geadresseerden, zoals zakenpartners. Deze geadresseerden moeten in tegenstelling tot interne geadresseerden specifiek worden ingesteld.

In het onderwerp Registreren wordt de registratie-interface beschreven en kunt u lezen wat eindgebruikers hierover moeten weten.


Sjabloon

Een sjabloon is een volledige kennisgevingsoplossing die bijna gereed is voor gebruik. Een sjabloon bestaat uit:

  • Een of meer Navision-objecten die bedrijfsentiteiten en gebeurtenissen definiëren, en de bedrijfslogica die ervoor zorgt dat de gebeurtenissen zich voordoen.

  • Een of meer schema's in Business Notification die worden geactiveerd door de gebeurtenis of gebeurtenissen in Navision.

Wanneer u werkt in de Notification Manager of de Notification Designer, lijkt het bijna of een schema en een sjabloon aan elkaar gelijk zijn. Er zijn echter belangrijke verschillen:

  • Het schema van een sjabloon is gebaseerd op een specifieke bedrijfsentiteit en gebeurtenis, en op een specifieke voorwaarde in de bedrijfslogica van Navision die ervoor zorgt dat de gebeurtenis zich voordoet.

  • Het schema van een sjabloon is alleen-lezen: wanneer u een sjabloon hebt geïmporteerd, kunt u een nieuw schema maken op basis van het schema in de sjabloon, maar kunt u de sjabloon zelf niet wijzigen.

Wanneer Business Notification is geïnstalleerd, is er altijd een aantal sjablonen beschikbaar. Zowel het Business Notification-deel (de schema's) als het Navision-deel (de Navision-objecten) is al geïnstalleerd en kan worden gebruikt.

In dit onderwerp wordt uitgelegd hoe u extra sjablonen kunt toevoegen aan Business Notification en hoe u er sjablonen uit kunt verwijderen, als en wanneer u extra oplossingen aanschaft. De procedure voor installatie van het Navision-deel van een sjabloon is afhankelijk van de wijze waarop de ontwikkelaar dit deel van de oplossing heeft ontwikkeld. De specifieke instructies voor installatie van de Navision-objecten maakt deel uit van de documentatie voor de oplossing.

Een sjabloon gebruiken

Voordat u (de kopie van) een sjabloon gebruikt, moet u het volgende doen in de Notification Designer:

  1. U moet toegangsrechten instellen (deze taak is niet optioneel).

  2. U dient de standaardnaam te wijzigen in een naam die betekenis voor u heeft.

  3. U dient te bepalen of u een filter wilt gebruiken. Omdat het Navision-deel mogelijk redelijk algemeen is, wilt u het aantal situaties waarin kennisgevingen worden verzonden misschien beperken.

  4. U moet beslissen of u het e-mailbericht wilt wijzigen, als de sjabloon een e-mailbericht bevat. Als de sjabloon geen e-malbericht bevat, moet u er een maken.

  5. U dient een titel en een omschrijving in te voeren die betekenis hebben voor uw gebruikers (als u bijvoorbeeld een filter hebt gebruikt, kunt u een titel en omschrijving maken waarin duidelijk aan personen die zich willen registreren wordt uitgelegd welke kennisgevingen zij kunnen verwachten).


Het Navision-perspectief

Binnen Navision kan een ontwikkelaar opgeven welke voorwaarden ervoor zorgen dat gebeurtenissen zich voordoen.

Dit gebeurt door een bedrijfsentiteit te maken. Een bedrijfsentiteit is een document dat bepaalde Navision-gegevens vertegenwoordigt. Hoewel de meeste gegevens in Navision die concrete objecten vertegenwoordigen, zoals een verkooporder of stuklijst, intern in verschillende tabellen zijn opgeslagen, integreert een bedrijfsentiteit alles in één object dat het concrete object dichter benadert.

Dit document wordt in Navision gemaakt als een XMLport. Een bedrijfsentiteit Stuklijst bevat bijvoorbeeld zowel velden die de stuklijst identificeren als velden die de wijzigingen in de stuklijst beschrijven.

De ontwikkelaar voegt ook een gebeurtenis aan de XMLport toe. Een gebeurtenis in een XMLport is een soort functie, maar dan zonder functiebody. Wanneer de gebeurtenis wordt aangeroepen (op dezelfde wijze als een normale functie), wordt de XMLport geserialiseerd en naar Business Notification verzonden.

Een gebeurtenis hoort bij één bedrijfsentiteit. Voor een bedrijfsentiteit genaamd 'Stuklijst' kan er bijvoorbeeld een gebeurtenis genaamd 'Stuklijst gewijzigd' bestaan. Er kunnen meerdere gebeurtenissen aan dezelfde bedrijfsentiteit zijn gekoppeld. De Stuklijst zou ook een gebeurtenis genaamd Stuklijst inactief gemaakt kunnen hebben. Deze gebeurtenissen doen zich uiteraard in verschillende situaties voor.

Als een gebeurtenis is toegevoegd, kan de ontwikkelaar bepalen onder welke voorwaarden de bedrijfslogica van Navision ervoor moet zorgen dat de gebeurtenis zich voordoet. In het geval van een wijziging in de stuklijst zou de ontwikkelaar een stuklijst steeds wanneer deze wordt opgeslagen met de vorige versie vergelijken. Als een of meer relevante velden zijn gewijzigd, wordt er een instantie van de XMLport gemaakt en treedt de C/AL-aanroep op die ervoor zorgt dat de gebeurtenis zich voordoet. Daardoor wordt er een document naar Business Notification verzonden.


Notification Manager - Overzicht

De Notification Manager wordt gebruikt voor het installeren van nieuwe schema's, het starten van geïnstalleerde schema's, het importeren van sjablonen, enzovoort.

De Notification Manager wordt gestart via het menu Start: Alle programma's, Microsoft Business Solutions-Navision, Business Notification Manager.

Opmerking:
de Navision-client moet worden gestart voordat u de Notification Manager start en er moeten in Navision een database en een bedrijf zijn geselecteerd.

Het meeste werk gebeurt in het hoofdformulier van Notification Manager. Er is een apart formulier voor sjabloonbeheer.


Hoofdformulier van Notification Manager

Het hoofdformulier van de Notification Manager bevat twee lijsten met schema's:

  1. De lijst in het bovenste deel van het venster: Te maken schema's

  2. De lijst in het onderste deel van het venster: Voltooide schema's

Een schema uit de lijst Te maken schema's is geïnstalleerd maar is momenteel niet actief. U kunt zich er niet voor registreren en er worden geen kennisgevingen voor verzonden. Het schema kan echter wel worden gewijzigd.

Een schema in de lijst Voltooide schema's is gereed voor gebruik. Als het schema ook is gestart (status is Gestart), worden registraties geaccepteerd en worden er kennisgevingen verzonden. Een schema in deze lijst, al dan niet gestart, kan niet worden gewijzigd.

Een schema kan van de lijst Te maken schema's naar de lijst Voltooide schema's worden verplaatst door het te selecteren en op Voltooien te klikken.

Een schema kan van de lijst Voltooide schema's naar de lijst Te maken schema's worden gekopieerd door het te selecteren en op Kopiëren om te maken te klikken.

Via de volgende koppelingen kunt u snel naar een specifiek onderdeel binnen dit onderwerp gaan:

Te maken schema's
Voltooide schema's
Opdrachten
Knoppen
Snelmenu's

Klik hier om het onderwerp te openen over de tool voor sjabloonbeheer.

Te maken schema's

De schema's in deze lijst zijn geïnstalleerd of gemaakt (bijvoorbeeld door te klikken op Bestand, Nieuw of op Bestand, Nieuw van sjabloon). Een geïnstalleerd schema is beschikbaar in de Notification Manager maar is niet actief. Wanneer een schema deze status heeft, kan het worden geopend voor wijziging in de Notification Designer. Een schema kan van deze lijst naar de lijst Voltooide schema's worden verplaatst door het te selecteren en vervolgens op Schema voltooien te klikken.

Voor elk schema in de lijst worden de volgende gegevens weergegeven:

Naam
De naam van het schema. Dit is de naam die u aan het schema geeft wanneer u het installeert.

Bijgewerkt
De datum waarop het schema voor het laatst is bijgewerkt.

Waarschuwing
Het veld Waarschuwing wordt gebruikt om aan te geven dat er een fout is opgetreden waar aandacht aan moet worden besteed. Voor een schema in deze lijst betekent dit dat de bedrijfsentiteit zodanig is gewijzigd (in Navision) dat er bedrijfsentiteitsvelden zijn verwijderd of gewijzigd. (Het toevoegen van velden levert geen problemen op.)

Wanneer een schema in de lijst met een waarschuwing is gemarkeerd, kunt u klikken op Bestand, Logbestanden bekijken om het logbestand te openen en meer informatie te verkrijgen.

Voltooide schema's

De schema's in deze lijst zijn gereed voor gebruik. Deze kunnen worden gestart, gestopt en naar Te maken schema's worden gekopieerd.

Een schema in de lijst kan worden gestart door het te selecteren en vervolgens op Start te klikken. Nadat een schema is gestart, is het beschikbaar voor registratie en worden er kennisgevingen verzonden.

Een schema kan worden gestopt door het te selecteren en vervolgens op Stop te klikken. Wanneer een schema is gestopt, worden er geen nieuwe registraties geaccepteerd en worden er geen kennisgevingen verzonden.

Een schema kan worden gekopieerd naar de lijst Te maken schema's door het te selecteren en te klikken op Kopiëren om te maken.

Wanneer een schema dat is voltooid naar de lijst Te maken schema's wordt gekopieerd en daar wordt gewijzigd, kan het net als een splinternieuw schema weer naar de lijst Voltooide schema's worden verplaatst. Er zijn hierbij echter twee verschillende mogelijkheden:

  1. Als onderdeel van de wijziging is er een nieuwe naam aan het schema gegeven. Het schema kan net als andere nieuwe schema's naar de lijst Voltooide schema's worden verplaatst.

  2. Als onderdeel van de wijziging, wijzigt u de naam van het schema niet. Als u het terugplaatst in de lijst Voltooide schema's, overschrijft het het 'oude schema'. Er wordt een bevestigingsdialoogvenster weergegeven voordat de verplaatsing wordt uitgevoerd.

Voor elk schema in de lijst worden de volgende gegevens weergegeven:

Naam
De naam van het schema. Dit is de naam die u aan het schema gaf toen u het installeerde.

Bijgewerkt
De datum waarop het schema voor het laatst is bijgewerkt

Status
De status van het schema. Er zijn drie opties:

  • Gestart- het schema is actief.

  • Gestopt - het schema is niet actief.

  • Wordt gestart - het schema wordt gestart maar dit proces is nog niet voltooid (de status verandert automatisch in Gestart zodra dit proces is voltooid).

  • Wordt gestopt - het schema wordt gestopt maar dit proces is nog niet voltooid (de status verandert automatisch in Gestopt zodra dit proces is voltooid).

Waarschuwing
Het veld Waarschuwing wordt gebruikt om aan te geven dat er een fout is opgetreden waar aandacht aan moet worden besteed. Voor een schema in deze lijst kunnen twee fouten optreden:

  • Er is geprobeerd om het schema te starten, maar dit was niet mogelijk vanwege een technische fout (bijvoorbeeld vanwege problemen in de communicatie met de distributieserver) of omdat het schema een interne indelingsfout bevat.

  • De bedrijfsentiteit is zodanig gewijzigd (in Navision) dat er bedrijfsentiteitsvelden zijn verwijderd of gewijzigd, of dat de gebeurtenis is verwijderd. (Het toevoegen van velden levert geen problemen op.)

Wanneer een schema in de lijst met een waarschuwing is gemarkeerd, kunt u klikken op Bestand, Logbestanden bekijken gebruiken om het logbestand te openen en meer informatie te verkrijgen.

Menu-items

Hierna volgt een beschrijving van de menu-items in het vervolgkeuzemenu Bestand:

  • Nieuw - Klik op Bestand, Nieuw om een nieuw schema te maken. De Business Notification Designer wordt geopend met een nieuw, leeg schema. Wanneer het schema in de Business Notification Designer wordt opgeslagen, wordt het in de lijst Te maken schema's weergegeven.

  • Nieuw van sjabloon - Klik op Bestand, Nieuw van sjabloon voor een lijst van geïnstalleerde sjablonen. Wanneer u klikt op een van deze sjablonen, wordt er een kopie van het corresponderende schema geopend in de Business Notification Designer (met de standaardnaam 'Nieuw van <sjabloonnaam>").

  • Openen - Als u een schema wilt openen in de lijst Te maken schema's, selecteert u het schema en klikt u vervolgens op Bestand, Openen.

  • Nieuw van bestaand schema - Als u een nieuw schema wilt maken gebaseerd op een schema dat al is geïnstalleerd, selecteert u het schema dat u wilt gebruiken als basis voor een nieuw schema (het kan in de lijst Te maken schema's of in de lijst Voltooide schema's staan) en klikt u op Bestand, Nieuw van bestaand schema. Een kopie van het geselecteerde schema wordt in de Business Notification Designer geopend (met de standaardnaam 'Nieuw van <schemanaam>”).

  • Logbestanden bekijken - Als u het logbestand wilt bekijken voor een schema, selecteert u het schema en klikt u op Bestand, Logbestanden bekijken. Het huidige logbestand voor het schema wordt weergegeven in een venster. Het logbestand bevat vermeldingen voor alle acties met betrekking tot het schema sinds het is gemaakt, waaronder: wanneer het is gemaakt, gewijzigd, gepubliceerd en wanneer de publicatie ongedaan is gemaakt, naast eventuele waarschuwingen (bijvoorbeeld het mislukken van het publiceren van een schema of het wijzigen van de XMLport in Navision).

  • Verwijderen - Als u een schema wilt verwijderen, selecteert u het schema en klikt u op Bestand, Verwijderen.

  • Afsluiten - Klik op Bestand, Afsluiten om de Business Notification Manager af te sluiten.

Hierna volgt een beschrijving van de menu-items in het vervolgkeuzemenu Extra:

  • Importeren - Klik op Extra, Importeren om een schema te importeren uit een bestand in het bestandssysteem. Selecteer het bestand in het standaardbestandsdialoogvenster van Windows dat wordt weergegeven.

  • Exporteren - Klik op Extra, Exporteren om een schema te exporteren naar een bestand. Selecteer een map en geef een naam op in het standaardbestandsdialoogvenster van Windows dat wordt weergegeven.

  • Met server verbinden - Klik op Extra,Met server verbinden om een server te selecteren waarmee u een verbinding wilt maken. Wanneer dit eenmaal is gebeurd, brengt Business Notification Manager automatisch een verbinding tot stand met deze server wanneer het programma wordt gestart (totdat een andere server wordt geselecteerd).

  • Beveiliging - Klik op Extra, Beveiliging om het formulier Gebruikersbeheer te openen. Via dit formulier kunt u Windows-gebruikers toevoegen en hun machtigingen verlenen voor het gebruik van de Notification Manager en de Notification Designer. U dient er rekening mee te houden dat u, door gebruikers machtigingen te verlenen in Business Notification, deze gebruikers de mogelijkheid biedt gevoelige informatie vanuit Navision te distribueren. Let er daarom op dat u op deze manier geen achterdeur naar gevoelige Navision-gegevens openzet.

  • Sjabloonbeheer - Klik op Extra,Sjabloonbeheer om de tool voor sjabloonbeheer te openen.

Hierna volgt een beschrijving van de menu-items in het vervolgkeuzemenu Help:

  • Business Notification Guide - Klik op Help, Business Notification Guide om de Business Notification Guide te openen (het Help-bestand dat u nu aan het lezen bent).

  • Info - Voor informatie over Microsoft Business Solutions–Navision Business Notification (versie, copyrightgegevens, enzovoorts), klikt u op Help, Info.

Knoppen

Het hoofdformulier bevat de volgende knoppen:

  • Nieuw - Klik op Nieuw om een nieuw schema te maken.

  • Nieuw van sjabloon - Klik op Nieuw van sjabloon om op basis van een sjabloon een nieuw schema te maken.

  • Kopiëren om te maken - Klik op Kopiëren om te maken om het huidige geselecteerde schema te kopiëren van de lijst Voltooid naar de lijst Te maken.

  • Voltooien - Klik op Voltooien om een schema te verplaatsen van de lijst Te maken schema's naar de lijst Voltooide schema's .

  • Start - Klik op Start om een schema te starten, dat wil zeggen om het actief te maken en ervoor te zorgen dat gebruikers kennisgevingen ontvangen en nieuwe gebruikers zich kunnen registreren.

  • Stop - Klik op Stop om een schema te stoppen en om kennisgevingen en nieuwe registraties tijdelijk te blokkeren. Dit is ook de eerste stap die u moet uitvoeren voordat u een schema kunt wijzigen (de tweede stap is het verplaatsen van het gestopte schema naar de lijst Te maken schema's).

  • Inleiding - Klik op Inleiding om direct naar het onderwerp Aan de slag van dit Help-bestand te gaan.

Snelmenu's

In beide schemalijsten, zowel de lijst Te maken schema's als de lijst Voltooide schema's, is een snelmenu beschikbaar voor de meestgebruikte taken. Klik met de rechtermuisknop op een schema in de lijst om het snelmenu op te roepen.

Snelmenu in de lijst Te maken schema's:

  • Openen
    Het schema openen om het te kunnen wijzigen

  • Nieuw van bestaand schema
    Een nieuw schema maken door het geselecteerde schema te kopiëren

  • Verwijderen
    Het geselecteerde schema verwijderen.

  • Historie weergeven
    De historie voor het geselecteerde schema weergeven

  • Exporteren
    Het geselecteerde schema naar een bestand exporteren.

Snelmenu in de lijst Voltooide schema's:

  • Openen
    Het geselecteerde schema openen om het weer te geven (alleen-lezen)

  • Nieuw van bestaand schema
    Een nieuw schema maken door het geselecteerde schema te kopiëren

  • Verwijderen
    Het geselecteerde schema verwijderen

  • Historie weergeven
    Het logbestand voor het geselecteerde schema weergeven

  • Exporteren
    Het geselecteerde schema naar een bestand exporteren


Sjabloonbeheer van Notification Manager

Het formulier Sjabloonbeheer wordt gebruikt voor het werken met sjablonen. In dit venster kunt u sjablonen uit het bestandssysteem importeren en eerder geïnstalleerde sjablonen verwijderen. Klik in het hoofdformulier van Notification Manager op Extra, Sjabloonbeheer om het formulier voor sjabloonbeheer te openen.

Een sjabloon importeren:

De sjabloon moet zich op een locatie bevinden waar u vanaf de computer toegang toe kunt krijgen (in een lokale map, op een netwerkserver, enzovoort).

  1. Open de tool Sjabloonbeheer door te klikken op Extra, Sjabloonbeheer.

  2. Klik op Toevoegen.

  3. Selecteer in het standaarddialoogvenster van Windows voor het bladeren door mappen het bestand dat de sjabloon bevat en klik op Openen.

De sjabloon wordt geïmporteerd en vermeld in de lijst met bestaande/geïnstalleerde sjablonen.

Als het geselecteerde bestand geen geldig sjabloonbestand is, wordt het niet geïmporteerd en wordt in plaats hiervan een foutbericht weergegeven. Als er al een sjabloon is met dezelfde naam als de naam van de sjabloon (in het bestand - niet de naam van het bestand zelf), moet de ontwikkelaar van de sjabloon de naam wijzigen. Dit is niet mogelijk vanuit Notification Manager.

Een sjabloon verwijderen:

  1. Open de tool Sjabloonbeheer door te klikken op Extra, Sjabloonbeheer.

  2. Selecteer de sjabloon die u wilt verwijderen.

  3. Klik op Verwijderen.

  4. Er wordt een bevestigingsdialoogvenster weergegeven. Klik op Ja om te bevestigen dat u de sjabloon wilt verwijderen.

De sjabloon wordt verwijderd uit de lijst met bestaande/geïnstalleerde sjablonen.


Incompatibele bedrijfsentiteit

Een bedrijfsentiteit kan om verschillende redenen incompatibel worden. De algemene betekenis hiervan is dat de bedrijfsentiteit (XMLport) in Navision niet meer gelijk is aan de bedrijfsentiteit die is gebruikt voor het ontwerpen van een schema in Business Notification.

De drie specifieke redenen voor incompatibiliteit zijn:

  1. De bedrijfsentiteit die bestond toen het schema werd gemaakt is er nog wel op dezelfde manier, maar de velden zijn niet meer hetzelfde. Dit betekent dat er velden uit de onderliggende XMLport in Navision zijn verwijderd of dat de naam ervan is gewijzigd. (Het toevoegen van een veld levert overigens geen problemen op.) De volgende waarschuwing wordt weergegeven: 'Er is sprake is van incompatibiliteit met bedrijfsentiteitsvelden in Navision'.

  2. De gebeurtenis die voor het schema is gebruikt is verwijderd of de naam ervan is gewijzigd in de bedrijfsentiteit in Navision. De volgende waarschuwing wordt weergegeven: 'Er is sprake is van incompatibiliteit. De geselecteerde gebeurtenis is niet beschikbaar in Navision.'

  3. De bedrijfsentiteit zelf is verwijderd of de naam ervan is gewijzigd in Navision. De volgende waarschuwing wordt weergegeven: 'Er is sprake van incompatibiliteit. De geselecteerde bedrijfsentiteit is niet beschikbaar in Navision."

Het probleem kan hoe dan ook niet worden opgelost in Business Notification. Het onderliggende probleem moet worden opgelost in Navision.


Historie weergeven

Met Historie weergeven kunt u een historielogbestand weergeven van een schema in de Notification Manager. De weergegeven informatie omvat:

  • Een activiteit (zoals Gemaakt, Voltooid)

  • De tijd waarop de activiteit heeft plaatsgevonden

  • De gebruiker die de activiteit heeft uitgevoerd

  • De bron van de activiteit: Voltooid of Configuratie (dit onderscheid is noodzakelijk aangezien een schema dat is voltooid weer naar de constructiefase kan worden gekopieerd, zodat dezelfde naam op beide plaatsen voorkomt)

  • Details: voor sommige activiteiten bevat dit veld informatie, met name als er een fout optreedt

De lijst kan op een bepaalde kolom worden gesorteerd door op de kolomlabel te klikken.


Notification Designer - Overzicht

De Notification Designer wordt gebruikt voor het maken en wijzigen van schema's. De Designer word gestart vanuit de Notification Manager. Als u een nieuw schema wilt maken, klikt u op Bestand, Nieuw. Als u een bestaand schema wilt wijzigen, selecteert u het schema in de lijst Te maken schema's en klikt u vervolgens op Bestand, Openen. (Er zijn ook andere manieren. Deze worden beschreven in het onderwerp Notification Manager.)

Op het eerste formulier dat u te zien krijgt, het hoofdformulier, moet u het schema een naam geven. Als het nieuwe schema op basis van een sjabloon of een kopie van een bestaand schema is gemaakt, wordt er een standaardnaam voorgesteld. U kunt deze standaardnaam aan uw wensen aanpassen.

Onder aan het hoofdformulier bevinden zich vier knoppen:

Valideren: klik op Valideren om te testen of het schema geldig is, wat wil zeggen dat het Business Notification-systeem het begrijpt en het schema kan gebruiken.
OK: klik op OK om wijzigingen op te slaan en de Notification Designer af te sluiten.
Annuleren: klik op Annuleren om de Notification Designer af te sluiten zonder wijzigingen op te slaan.
Help: klik op Help om de on line Help voor het formulier te openen.

Via het hoofdformulier van de Notification Designer kunt u vier formulieren aanroepen:

Gebeurtenis: het formulier voor gebeurtenisselectie waarop u de (Navision-)gebeurtenis selecteert die dit schema opstart wanneer deze zich voordoet. U kunt de formulieren Filter, Bericht en Geadresseerden pas invoeren als u een gebeurtenis hebt geselecteerd.

Filter: het formulier waarop u bepaalt of een gebeurtenis die van Navision wordt ontvangen ertoe moet leiden dat er een kennisgeving wordt verzonden op basis van de concrete gegevens uit het gebeurtenisdocument dat van Navision afkomstig is.

Bericht: het formulier waarop u het e-mailbericht kunt maken dat naar geregistreerde gebruikers wordt verzonden wanneer deze worden ingelicht. U kunt ook gegevens invoegen in het bericht uit documenten die u hebt ontvagen van Navision.

Geadresseerden: dit formulier wordt gebruikt om interne gebruikers registratierechten te verlenen voor kennisgevingen, om de interface te maken die interne gebruikers te zien krijgen wanneer deze zich registreren en om externe geadresseerden (die de registratietool op het intranet niet kunnen gebruiken) specifiek toe te voegen voor een kennisgeving.


Het formulier Gebeurtenisselectie

Dit formulier wordt gebruikt om een gebeurtenis in Navision te selecteren. Daarbij zijn twee concepten van belang:

  • Bedrijfsentiteit: een bedrijfsentiteit vertegenwoordigt een of meer Navision-objecten die corresponderen met concrete objecten. Terwijl een verkooporder in Navision uit twee tabellen bestaat (een tabel met de kop en een tabel met de regels), bevat een verkooporder-bedrijfsentiteit gegevens uit zowel de koptabel als de regeltabel. Hier vindt u meer informatie over hoe dit werkt in Navision.

  • Gebeurtenis: voor elke bedrijfsentiteit in Navision worden een of meer gebeurtenissen gekoppeld. Een gebeurtenis is een beschrijvende naam voor iets wat in de bedrijfslogica van Navision gebeurt dat ervoor zorgt dat er een document met de gegevens van een bedrijfsentiteit naar Business Notification wordt verzonden. Voor een verkooporder zou een gebeurtenis bijvoorbeeld 'Orderbedrag boven 10.000' kunnen zijn. Wanneer er in Navision een verkooporder wordt gemaakt voor een bedrag van meer dan 10.000, doet deze gebeurtenis zich voor. Er kunnen nog meer gebeurtenissen aan de verkooporder zijn gekoppeld, bijvoorbeeld 'Kredietlimiet klant overschreden'.

Een gebeurtenis selecteren:

  1. Selecteer een bedrijfsentiteit. Zodra u dit hebt gedaan, wordt de lijst met gebeurtenissen bijgewerkt zodat de gebeurtenissen voor de geselecteerde bedrijfsentiteit worden weergegeven.

  2. Selecteer een gebeurtenis in de lijst met gebeurtenissen voor de geselecteerde bedrijfsentiteit.

  3. Klik op OK.

Wanneer u een bedrijfsentiteit hebt geselecteerd, kunt u klikken op Velden in bedrijfsentiteit weergeven om een (alleen-lezen) lijst met de gegevensvelden in de bedrijfsentiteit weer te geven. Hiermee kunt u bepalen of u de juiste bedrijfsentiteit hebt geselecteerd. Dit zijn ook de velden die in een latere fase kunnen worden ingevoegd in de kennisgeving die automatisch wordt verzonden naar geregistreerde gebruikers, wanneer de gebeurtenis zich voordoet in Navision.

Waarschuwing

Als u een bestaand schema wijzigt, worden alle instellingen (filters, berichten, enzovoort) ingesteld op de standaardwaarde als u de bedrijfsentiteit en/of de gebeurtenis wijzigt. Wanneer u een bestaand schema wijzigt, kunt u de informatie het beste altijd in dit formulier controleren, waarna u op OK kunt klikken zonder iets te wijzigen. Als u wel iets wijzigt, wordt er een waarschuwing weergegeven voordat u kunt doorgaan.


Veldweergave

In dit formulier worden de velden weergegeven die beschikbaar zijn in de bedrijfsentiteit. Aan de hand hiervan kunt u bepalen of dit de juiste bedrijfsentiteit is voor de kennisgeving die u aan het maken bent. Dit zijn namelijk de velden die in berichten kunnen worden ingevoegd en die in filters kunnen worden gebruikt.


Het filterformulier

Wanneer u een gebeurtenis hebt geselecteerd, kunt u een filter gebruiken om in nader detail te bepalen of er kennisgevingen moeten worden verzonden als de gebeurtenis zich voordoet.

Als u bijvoorbeeld de gebeurtenis 'Orderbedrag meer dan 10.000' voor de bedrijfsentiteit Verkooporder hebt geselecteerd, ontvangt Business Notification elke keer dat deze gebeurtenis zich voordoet een document van Navision. U kunt echter ook besluiten dat er in uw bedrijf alleen kennisgevingen naar geregistreerde gebruikers moeten worden verzonden als de verkooporder, in aanvulling op het orderbedragcriterium dat al in Navision is toegepast, voor een klant in Denemarken bestemd is. U kunt hiervoor zorgen door een filter op de landcode toe te passen.

Elke groep vervolgkeuzelijsten en tekstvakken in het filterformulier staat voor een filter op een gegevensveld uit het document dat van Navision is ontvangen. Er kunnen extra regels, met extra filterinstellingen, worden toegevoegd door op Toevoegen te klikken. Een bestaande regel kan worden verwijderd door op Verwijderen te klikken.

Hierna volgt een beschrijving van de elementen van elke regel in het filterformulier.

Bedrijfsentiteitsvelden: een lijst met velden uit de bedrijfsentiteit, bijvoorbeeld Landcode.

Operator: hoe de parameter (bedrijfsentiteitsveld) moet worden vergeleken met de waarde. De beschikbare opties zijn afhankelijk van het soort parameter (Datum/tijd, Tekst, Getal of Boolean).

  • Datum/Tijd-velden, zoals het veld Orderdatum, kunnen de volgende operatoren hebben: Gelijk aan; Gelijk aan of na; Gelijk aan of voor; Voor; Na.

  • Tekstvelden, zoals het veld Naam leverancier, kunnen de volgende operator hebben: Is exact.

  • Getalvelden, zoals het veld Bedrag, kunnen de volgende operatoren hebben: Gelijk aan; Niet gelijk aan; Gelijk aan of meer dan; Gelijk aan of minder dan; Meer dan; Minder dan.

  • Boolean-velden zijn velden die slechts twee waarden kunnen hebben: Ja of Nee. Ze kunnen de volgende operatoren hebben: Is; Is niet.

Waarde: de feitelijke waarde uit Navision waarmee de parameter moet worden vergeleken, bijvoorbeeld:

De gebeurtenis is 'Verkooporderbedrag boven 10.000', maar u wilt alleen kennisgevingen verzenden als de betreffende klant zich in de Verenigde Staten bevindt.

  1. Selecteer 'Landcode' als parameter. Aangezien dit een tekstwaarde is, kunt u kiezen uit de operatoren die van toepassing zijn op tekstvelden.

  2. U wilt een exacte overeenkomst met een specifieke landcode, dus kiest u ' Is exact' als operator.

  3. Ten slotte voert u VS als waarde in, omdat u alleen kennisgevingen wilt verzenden voor klanten in de Verenigde Staten.

Opmerking: u kunt de waarde niet in de Navision-database opzoeken vanuit de Notification Designer. U kunt de mogelijke waarden in Navision controleren als u twijfelt over bijvoorbeeld de spelling (door de standaardinterface van de Navision-client te gebruiken).

Relatie: de relatie is is alleen relevant als u regels toevoegt aan het filter. U voegt een regel toe door op Toevoegen te klikken. De relatie bepaalt hoe de instellingen op de verschillende regels met elkaar worden gecombineerd. Er zijn twee mogelijke waarden:

  • EN: aan alle instellingen op regels die zijn verbonden met een EN-relatie, moet worden voldaan.

Als u bijvoorbeeld een filter wilt maken waarbij er alleen kennisgevingen worden verzonden als de Landcode VS is en als de Vestiging 1 is, maakt u deze twee regels op de wijze die hierboven is beschreven en koppelt u deze vervolgens aan elkaar met een EN-relatie.

  • OF: aan een van de instellingen op regels die met een OF-relatie zijn verbonden, moet worden voldaan.

Als u bijvoorbeeld een filter wilt maken waarbij er alleen kennisgevingen worden verzonden als de Landcode VK of DK is, maakt u deze twee regels op de wijze die hierboven is beschreven en koppelt u deze vervolgens aan elkaar met een OF-relatie.

Tips voor logische operatoren

Wat gebeurt er als u meer dan twee regels hebt en u deze met relaties aan elkaar wilt koppelen?

Als u dezelfde relatie wilt gebruiken om alle regels met elkaar te verbinden, is dit geen probleem. Door alleen de EN-relatie te gebruiken, kunt u opgeven dat tegelijkertijd de Landcode VS, de Vestiging 1, de Status Open en de Projectcode Blauw moet zijn.

Een reeks EN-relaties wordt meestal (maar niet alleen) gebruikt wanneer u wilt filteren op een groep verschillende velden.

Als u wilt opgeven dat de Landcode VS, DK of VK moet zijn, gebruikt u de OF-relatie om de drie regels aan elkaar te koppelen.

Een reeks OF-relaties wordt meestal (en nagenoeg alleen) gebruikt om bepaalde waarden uit een groep mogelijke waarden voor hetzelfde veld te kiezen.

Het probleem doet zich voor wanneer u EN en OF met elkaar wilt combineren. Kort gezegd heeft EN voorrang boven OF en worden de relaties van links naar rechts verwerkt (wat gezien de indeling van het formulier neerkomt op van boven naar beneden). Het gebruik van een gemengde groep relaties kan verwarrend zijn maar kan vaak worden vermeden door meer dan een schema te maken. Klik hier voor meer informatie over het effect van een combinatie van EN- en OF-relaties.


Meer info over filters

In het volgende voorbeeld wordt het gebruik van een combinatie van EN- en OF-relaties nader uitgelegd.

Stel, u hebt dit filter:

Landcode = DK EN Vestiging = 1 OF Status = Open

Als een bedrijfsentiteit gegeven is waarvoor de betreffende velden de volgende waarden hebben:

Landcode = CA
Vestiging = 2
Status = Open

wordt het filter als True geëvalueerd, wat betekent dat deze bedrijfsentiteit door het filter zou worden geselecteerd. Was dat echter wel de bedoeling? Mogelijk was de bedoeling eigenlijk het volgende uit te drukken:

Landcode = DK EN (Vestiging = 1 OF Status = Open)

of, in duidelijkere bewoordingen: de bedrijfsentiteit selecteren als de landcode DK is en de vestiging 1 of de status Open is

Aangezien het niet mogelijk is om haakjes te gebruiken, is het niet mogelijk om de tweede versie in Business Notification uit te drukken.

De oplossing bestaat uit het maken van twee schema's:

  1. Een schema met een filter dat er als volgt uitziet: Landcode = DK EN Vestiging = 1.

  2. En een schema met een filter dat er zo uitziet: Landcode = DK EN Status = Open.

In het bovenstaande voorbeeld zou, door het maken van twee schema's, de bedrijfsentiteit door beide filters niet worden geselecteerd (en dat was precies de bedoeling). Gebruikers moeten zich voor beide schema's registreren om de betreffende kennisgevingen te ontvangen.


Het formulier Bericht

Het formulier Bericht wordt gebruikt voor het maken van de kennisgevings-e-mails voor een schema.

Boven aan het formulier bevindt zich het veld Van:, waarin u een geldig e-mailadres moet invoeren. Als iemand een kennisgevings-e-mail beantwoordt, worden de antwoorden verzonden naar dit adres.

Aan de linkerkant van het formulier staan het veld Onderwerp en het veld Inhoud.

In het veld Onderwerp definieert u het onderwerp van het e-mailbericht. In het veld Inhoud definieert u de hoofdtekst van het e-mailbericht.

Aan de rechterkant van het formulier staat een lijst met alle velden die van Navision zijn ontvangen. U kunt een veld in het onderwerp of de hoofdtekst van het bericht invoegen door de cursor te plaatsen op de locatie waarop u het veld wilt invoegen, het veld te selecteren en op Veld invoegen te klikken. Het veld wordt ingevoegd op de positie waar de cursor zich bevond toen u het veld selecteerde.

De veldenlijst heeft een boomstructuur, vergelijkbaar met de weergave van mappen en bestanden in Windows Verkenner. De lijst bevat drie verschillende soorten items: velden, herhaalde groepen en groepen. Deze items worden hieronder beschreven, met de verschillende pictogrammen die voor de soorten items worden gebruikt:

Het pictogram [image] duidt een veld aan. Het gaat hierbij om een veld zoals dat van Navision wordt ontvangen, bijvoorbeeld 'Ordernr.' Wanneer u een veld hebt ingevoegd, kunt u er tekst omheen plaatsen, tekst verplaatsen, enzovoort. Bijvoorbeeld:

U kunt velden met bijvoorbeeld de volgende strekking invoegen in de hoofdtekst van een e-mailbericht:

Geachte [contactpersoon_leverancier]

En wanneer de concrete gegevens van Navision binnenkomen, voegt het programma tekst met bijvoorbeeld de volgende strekking in:

Geachte mevrouw Van Leeuwen

Geachte heer Dagelet

Het pictogram [image] duidt een herhaalde groep aan. Een herhaalde groep is een groep velden die een aantal maal (of helemaal niet) kunnen voorkomen. De groep wordt als zodanig gemarkeerd wanneer deze wordt ingevoegd. Bijvoorbeeld:

Een verkooporder zou een herhaalde groep als Verkooporderregels kunnen bevatten. Wanneer deze groep in een e-mailbericht wordt ingevoegd (het is waarschijnlijk alleen zinvol om deze in de hoofdtekst van het bericht in te voegen), betekent dit dat de velden in de groep worden herhaald voor elk gegeven in het document dat van Navision is ontvangen.

Het pictogram [image] duidt een groep aan. Een groep is een kop die wordt gebruikt om een aantal velden bij elkaar te plaatsen. Bijvoorbeeld:

Voor een verkooporder zouden alle velden die betrekking hebben op betalingen in een groep genaamd Verkooporderbetalingen kunnen worden ondergebracht. Als er een groep wordt ingevoegd, worden alle velden in deze groep (en eventuele onderliggende groepen) ingevoegd in het e-mailbericht. Het wordt niet aanbevolen om een groep aan het onderwerp van een bericht toe te voegen.

Info over het lokaliseren van berichten:

Als u berichten wilt sturen naar zakenpartners in verschillende landen in de taal van de zakenpartner, moet u een schema maken voor elke taal en vervolgens filters gebruiken om ervoor te zorgen dat het juiste schema wordt gebruikt voor het verzenden van het bericht.


Het formulier Geadresseerden

Het formulier Geadresseerden wordt gebruikt voor drie taken:

  • Interne gebruikers registratierechten verlenen voor kennisgevingen

  • Een beschrijving maken die een interne gebruiker te zien krijgt wanneer deze de browsertoepassing voor registratie gebruikt

  • Externe geadresseerden toevoegen (bijvoorbeeld zakenpartners)

Voor elke taak bevat het formulier een apart tabblad.

De tab Interne geadresseerden

Een gebruiker kan de browserinterface voor registratie alleen gebruiken om zich voor kennisgevingen te registreren als u de gebruiker daartoe expliciet rechten verleent.

Hiervoor wordt het bovenste gedeelte van dit tabblad, Registratietoestemming, gebruikt.

U voegt een gebruiker toe door op Toevoegen te klikken. Het standaardformulier van Windows voor het selecteren van gebruikers vanuit de Active Directory wordt dan geopend. Dit formulier wordt ook weergegeven wanneer u klikt op Configuratiescherm, Gebruikersaccounts, Toevoegen, Bladeren.

De gemakkelijkste manier om een gebruiker te vinden is door de volledige naam (bijvoorbeeld Jan Smit) te typen in het tekstvak Gewenste objectnaam opgeven en vervolgens te klikken op Naam controleren. Controleer vervolgens of u de juiste gebruiker hebt gevonden en klik op OK. De gebruiker wordt toegevoegd aan de lijst van gebruikers die zich mogen registreren. U kunt zowel afzonderlijke gebruikers als groepen toevoegen.

Als u een gebruiker wilt verwijderen (de registratierechten intrekken), selecteert u de gebruiker in de lijst met gebruikers en klikt u vervolgens op Verwijderen.

Hieronder, in het gedeelte Registratie-informatie, geeft u de titel en de beschrijving van de kennisgeving op die een gebruiker te zien krijgt bij het selecteren van kennisgevingen waarvoor registratie mogelijk is.

De titel is niet hetzelfde als de naam die u in de Notification Designer aan het schema geeft (deze naam is ook te zien in de Notification Manager). Het is evenmin de naam van een sjabloon. De relaties tussen deze verschillende namen worden in het volgende voorbeeld duidelijk:

Het is aan te raden om de naam van een sjabloon als volgt samen te stellen: naam bedrijfsentiteit - naam gebeurtenis, bijvoorbeeld: Verkooporder - Kredietlimiet overschreden.

Op basis van deze sjabloon kunt u een aantal schema's maken. U kunt bijvoorbeeld een schema maken op basis waarvan er kennisgevingen worden verzonden als de klant zich in de VS bevindt, en een schema op basis waarvan er kennisgevingen worden verzonden als de klant zich in Canada bevindt. U zou deze twee schema's de namen 'Verkooporder - Kredietlimiet overschreven (VS)' en 'Verkooporder - Kredietlimiet overschreden (Canada)' kunnen geven. Houd er rekening mee dat deze namen alleen zichtbaar zijn in de Notification Manager en de Designer.

Voor gebruikers die zich voor deze twee schema's kunnen registreren moet u ten slotte als volgt een titel en omschrijving maken, bijvoorbeeld:

Titel Kredietlimiet klant VS overschreden

Omschrijving: aan de hand van deze kennisgeving wordt u op de hoogte gesteld wanneer er een verkooporder voor een klant in de VS wordt gemaakt en de kredietlimiet voor die klant wordt overschreden.

(U kunt een soortgelijke titel en omschrijving voor het Canadese voorbeeld maken.)

De titel en omschrijving kunnen dus veel gebruikersvriendelijker en duidelijker zijn dan de namen in de Notification Manager en de Designer.

Het tabblad Externe geadresseerden

Als u een externe geadresseerde (zoals een zakenpartner) voor een kennisgeving wilt registreren, dient u dit expliciet via dit formulier te doen. Externe geadresseerden zijn namelijk normaal gesproken niet in uw bedrijf geregistreerd als Windows-gebruikers, wat betekent dat hun geen toegangsrechten kunnen worden verleend op basis waarvan ze zichzelf kunnen registreren. Bovendien is de registratietoepassing bedoeld voor uitvoering op het intranet, waar externe geadresseerden geen toegang toe hebben.

Een externe geadresseerde toevoegen:

  1. Schakel het selectievakje Bericht verzenden naar externe geadresseerden in om ervoor te zorgen dat externe geadresseerden zich kunnen registreren.

  2. Plaats de cursor in het tekstvak Geadresseerden: , selecteer een veld uit de lijst met velden en klik op Veld invoegen. Het veld moet een e-mailadres zijn, zoals 'E-mail leverancier'.

  3. U kunt 'vast gecodeerde' adressen ook rechtstreeks opgeven in het tekstvak Geadresseerden:.

  4. Meerdere adressen moeten hoe dan ook worden gescheiden door puntkomma's.

Het feitelijke e-mailbericht dat naar externe geadresseerden wordt verzonden, is identiek aan het bericht dat voor interne geregistreerde personen wordt gebruikt. Als u voor een externe geadresseerde een ander bericht wilt gebruiken, dient u daartoe een apart schema te maken. Als u al een schema voor interne geregistreerde gebruikers hebt gemaakt, kunt u dit schema kopiëren en het bericht bewerken.


Beheer

Nadat Business Notification is geïnstalleerd, moet u op het volgende letten:

Wachtwoord wijzigen
Als het wachtwoord wordt gewijzigd van de gebruikersaccount waaronder Business Notification wordt uitgevoerd, moet u de procedures uitvoeren die in dit onderwerp worden beschreven. Als u dat niet doet, werkt Business Notification niet meer.

Reservekopie
U moet een reservekopie maken van Business Notification als onderdeel van uw normale routine voor het maken van reservekopieën. In dit onderwerp wordt beschreven van welke onderdelen reservekopieën moeten worden gemaakt.

Configuratiebestanden
Mogelijk moeten enkele waarden worden gewijzigd in een configuratiebestand nadat u Business Notification hebt geïnstalleerd en bent gaan gebruiken. Als u een andere SMTP-server bent gaan gebruiken voor het verzenden van e-mailberichten, is het van het grootste belang deze wijziging ook in de configuratie van Business Notification op te nemen. Ook zult u wellicht de logboekregistratie willen wijzigen


Wachtwoord wijzigen

Wachtwoord gewijzigd

Tijdens de installatie van Business Notification Server moet u de naam en het wachtwoord opgeven van een Windows-gebruiker (domeingebruiker). Deze gebruikersaccount wordt gebruikt voor de volgende doeleinden:

  • De servertoepassingen van Business Notification worden uitgevoerd onder deze gebruikersaccount.

  • Het aanmelden op de SQL Server-computer vindt plaats met deze gebruikersaccount.

Wanneer het wachtwoord wordt gewijzigd (wellicht kent uw bedrijf een beleid waarin regelmatige wachtwoordwijzigingen verplicht zijn), moet u de volgende procedure uitvoeren om ervoor te zorgen dat het nieuwe wachtwoord wordt gebruikt door de Business Notification-toepassingen en -services:

  • Ga op de computer waarop de Business Notification Server-onderdelen worden uitgevoerd naar de map waarin deze onderdelen zijn geïnstalleerd (standaard is dit 'Program Files\MicrosoftBusinessSolutions\Navision\BusinessNotification\InstallUtility'. Deze map bevat een klein hulpprogramma met de naam 'aspnet_setreg.exe'.

  • Open het venster met de opdrachtprompt in deze map.

  • Typ bij de opdrachtprompt:
    'aspnet_setreg.exe -k:SOFTWARE\Microsoft\BusinessSolutions\BN\identity -u:domein\gebruikersnaam -p:wachtwoord'
    waarbij u 'domein\gebruikersnaam' en 'wachtwoord' vervangt door het domein en de gebruikersnaam van de desbetreffende account en het nieuwe wachtwoord.

Hierdoor wordt het in de cache opgeslagen wachtwoord dat de serveronderdelen gebruiken, opnieuw ingesteld op het nieuwe wachtwoord.

Meer informatie hierover vindt u hier.

Bovendien moet u op de computer waarop de Business Notification Server-onderdelen worden uitgevoerd, het nieuwe wachtwoord handmatig instellen voor twee services: :

  • Open het onderdeel Services (klik op Configuratiescherm, Systeemwerkset, Services, of de overeenkomstige opdracht - de locatie in de menu's varieert per besturingssysteem).

  • Ga naar de service met de naam Notification Service Deployment Manager.

  • Klik met de rechtermuisknop op deze naam en klik vervolgens op Eigenschappen.

  • Klik op de tab Aanmelden en wijzig het wachtwoord.

  • Ga naar de service met de naam NS$BusinessNotificationInstance.

  • Klik met de rechtermuisknop op deze naam en klik vervolgens op Eigenschappen.

  • Klik op de tab Aanmelden en wijzig het wachtwoord.


Reservekopieën maken

U moet regelmatig reservekopieën maken van de voorzieningen voor gegevensopslag die door Business Notification worden gebruikt (of deze voorzieningen opnemen in uw bestaande schema voor reservekopieën). Van de volgende onderdelen moeten reservekopieën worden gemaakt:

  • De SQL Server-databases. Deze hebben de volgende namen:
    BusinessNotification
    BusinessNotificationInstanceMBSBN

  • BusinessNotificationInstanceNSMain
    Op de computer waarop Business Notification Server wordt uitgevoerd, moet een reservekopie worden gemaakt van het volgende bestand: appADF.xml
    Als u Business Notification Server hebt geïnstalleerd op de standaardlocatie, staat dit bestand in de volgende map:
    \ProgramFiles\MicrosoftBusinessSolutions\Navision\BusinessNotification\BusinessNotificationServices\AppDefinition


Configuratiebestanden

Er zijn twee instellingen in het bestand Web.config die u mogelijk moet wijzigen. Op de computer waarop Business Notification Server is geïnstalleerd, staat dit bestand in de map \ProgramFiles\MicrosoftBusinessSolutions\Navision\BusinessNotification\DeploymentServer (als u de standaardlocatie hebt gebruikt voor de installatie; anders staat het bestand in de map op uw systeem die overeenkomt met deze map).

Als u na de installatie een andere SMTP-server bent gaan gebruiken, moet u:

De instelling 'localhost' in de sectie <appSettings> wijzigen in de naam van de (nieuwe) SMTP-server:

<add key="SmtpServer" value="localhost"/>

(Opmerking: als u tijdens de installatie een andere naam dan 'localhost' hebt gebruikt voor de SMTP-server, wordt deze naam bij 'value' weergegeven in plaats van 'localhost'.)

Mogelijk wilt u het logboekregistratieniveau wijzigen. Hiertoe gaat u als volgt te werk:

Wijzig de instelling bij 'value' in de sectie <appSettings> in de volgende regel:

<add key="applicationLogLevel" value="debug"/>

in een van de volgende instellingen:

  • debug: betekent dat alles in het logboekbestand wordt geregistreerd

  • error: betekent dat alleen fouten in het logboekbestand worden geregistreerd

  • none: betekent geen logboekregistratie

Het is raadzaam 'debug' te gebruiken tenzij u gegronde redenen hebt om dit niet te doen (bijvoorbeeld omdat het logboek anders te groot wordt).


De tijd wijzigen op de SQLNS Server-computer

Het is van het grootste belang dat u de systeemtijd niet handmatig terugzet op de computer waarop de Microsoft SQL Server Notification-services worden uitgevoerd. Als u dit doet, kunnen de Microsoft SQL Server Notification-services vastlopen, met als gevolg gegevensverlies (verlies van kennisgevingen).

U moet deze computer dus zodanig instellen dat de zomertijd en wintertijd automatisch worden doorgevoerd. Ga hiervoor als volgt te werk:

  1. Open het onderdeel Datum en tijd in het Configuratiescherm.

  2. Klik op de tab Tijdzone.

  3. Controleer of Klok automatisch aanpassen aan zomertijd en wintertijd is ingeschakeld.

De tijd vooruitzetten leidt niet tot een soortgelijk vastlopen, maar heeft wel tot gevolg dat kennisgevingen niet worden verzonden.


Overzicht van gebeurtenissen

In dit onderwerp wordt beschreven hoe er via de bedrijfslogica van Navision voor kan worden gezorgd dat gebeurtenissen zich voordoen en komen achtergrondinformatie en gebruikte terminologie aan bod.

Bedrijfsentiteit: de naam die door Business Notification wordt gebruikt om een concreet object, zoals een verkooporder, te vertegenwoordigen.

In Navision wordt een bedrijfsentiteit, zoals de verkooporder, echter meestal vertegenwoordigd door een aantal tabellen (op zijn minst een koptabel en een regeltabel). Bovendien is een aantal gegevens dat in een traditionele, papieren verkooporder voorkomt, in gerelateerde tabellen opgeslagen. In een Navision-verkooporder bevat de koptabel bijvoorbeeld Betalingscondities. Dit veld heeft een tabelrelatie met Betalingscondities (in relationele databases is dit een refererende sleutel). Op de gedrukte orderbevestiging (een lijst) wordt echter de tekst uit de gerelateerde tabel gebruikt, zodat er een beter leesbare versie van de betalingscondities beschikbaar is ('1 maand/2% 8 dagen' in plaats van '1M(8D)').

In zekere zin is een Navision-lijst dus een bedrijfsentiteit. De bedrijfsentiteiten die relevant zijn voor Business Notification worden echter als XMLports in Navision gemaakt.

XMLports is een nieuwe voorziening van Navision 4.0. In het kort komt het erop neer dat u hiermee een XML-document kunt maken op basis van een of meer tabellen. Dit is te vergelijken met de mogelijkheden waarover u beschikt bij het ontwerpen van een lijst. De Navision-documentatie bevat alle informatie over het ontwerpen van een algemene XMLport.

Business Notification bevat een uitbreiding van XMLports, waarmee een dergelijk XML-document vanuit C/AL-code naar Business Notification kan worden verzonden.

Het hiervoor gebruikte mechanisme is de gebeurtenis. Een gebeurtenis heeft twee functies:

  • In de eerste plaats kan, als een gebeurtenis voor een XMLport is gedefinieerd, deze gebeurtenis in Navision op dezelfde wijze worden aangeroepen als een functie. Een gebeurtenis heeft echter geen functiebody. Wanneer een gebeurtenis wordt aangeroepen, wordt het XML-document voor de XMLport waar de gebeurtenis bij hoort naar Business Notification verzonden.

  • In de tweede plaats dienen gebeurtenissen in de Business Notification Designer voor de communicatie tussen de C/AL-ontwikkelaar en de ontwikkelaar van Business Notification-schema's. Als er goede namen voor gebeurtenissen worden gekozen, die duidelijk aangeven onder welke voorwaarden de C/AL-code ervoor zorgt dat de gebeurtenis zich voordoet, kan de schemaontwikkelaar veel gemakkelijker bepalen hoe de gebeurtenis moet worden verwerkt, welke filters moeten worden ingesteld, welke interne gebruikers toegangsrechten moeten hebben voor registratie, welke titel en omschrijving aan het schema moeten worden gegeven om interne gebruikers te helpen bij het gebruik van de registratietoepassing, en voor welke externe geadresseerden de kennisgeving relevant kan zijn.


Gebeurtenissen maken in Navision

In het volgende eenvoudige voorbeeld ziet u hoe er vanuit de bedrijfslogica van Navision voor kan worden gezorgd dat zich gebeurtenissen voordoen. Er wordt simpelweg vastgesteld dat een voorwaarde van kracht is, waarna zich onmiddellijk een gebeurtenis voordoet.

  1. Formuleer en analyseer uw bedrijfsprobleem. In dit voorbeeld gaat het erom een kennisgeving te verzenden wanneer een klant wordt geblokkeerd (wanneer de status Geblokkeerd van False in True verandert).

  2. Bepaal welke gegevens in de XMLport moeten worden opgenomen. Dit zijn bijvoorbeeld de ID en Naam van de klant, de datum waarop de wijziging heeft plaatsgevonden en de verkoper. De verkoper kan vervolgens worden gebruikt om in Business Notification te filteren, zodat elke verkoper kennisgevingen over diens eigen klanten kan ontvangen.

  3. Maak een XMLport met de gegevens die u nodig hebt. De Application Designer's Guide en de on line Help van C/SIDE bieden de benodigde informatie. In dit voorbeeld zou de XMLport 'Klant' kunnen worden genoemd. (Tenzij u een vaste naamconventie wilt toepassen. Zo zou u de XMLport bijvoorbeeld 'Kennisgeving voor klanten' kunnen noemen. Houd er rekening mee dat deze naam in de Notification Designer wordt weergegeven als de 'bedrijfsentiteit').
     TagNames mogen geen spaties bevatten en de eigenschap Format/Evaluate van de XMLport moet worden ingesteld op XML Format/Evaluate (omdat dit geen standaardnaam is, dient u deze zelf te wijzigen).

  4. Voeg een gebeurtenis aan de XMLport toe door de Events Designer te gebruiken (toegankelijk via de optie XMLport Events in het menu Beeld). In dit voorbeeld zou deze bijvoorbeeld IsGeblokkeerd kunnen worden genoemd. Deze naam is ook zichtbaar in de Notification Designer.

Nu dient u te bepalen waar de bedrijfslogica ervoor moet zorgen dat de gebeurtenis zich voordoet. In dit voorbeeld betreft dit de trigger OnModify in de klantentabel. (Uiteraard wordt dan niet het geval ondervangen waarin Geblokkeerd vanaf het moment waarop een klant wordt gemaakt op True is ingesteld, maar dat was hier ook niet de bedoeling. Het was de bedoeling om situaties te ondervangen waarin een klant die voorheen niet geblokkeerd was, wordt geblokkeerd.)

  5. Om ervoor te zorgen dat de gebeurtenis zich voordoet in de bedrijfslogica, moet u de XMLport declareren die u als een lokale variabele hebt gemaakt. Deze zou bijvoorbeeld KlantXMLDoc kunnen worden genoemd (deze naam is niet zichtbaar in de Notification Designer).

  6. Daarna voegt u het volgende toe aan de trigger OnModify:
    IF Blocked = Blocked::All THEN
    IF Blocked <> xRec.Blocked THEN
    KlantXMLDoc.IsGeblokkeerd();

  7. Nu kunt u de Notification Designer gebruiken om een schema te maken voor de verwerking van deze gebeurtenis die beschikbaar is als de gebeurtenis IsGeblokkeerd voor de bedrijfsentiteit Klant.

Testen

Dit voorbeeld is bijzonder eenvoudig, maar de meeste oplossingen zijn veel complexer. In dat geval is de vraag hoe u de oplossing kunt testen en fouten kunt opsporen. Als niemand kennisgevingen ontvangt en dit volgens u wel het geval zou moeten zijn, kunt u op ten minste drie plaatsen naar fouten zoeken: (1) in de bedrijfslogica van Navision, (2) in het schema van Business Notification, en (3) in de instelling van de infrastructuur (zoals problemen met e-mailservers, enzovoort). Ten slotte zou het ook nog kunnen gaan om een echte fout in een van de onderdelen van het systeem. Als u wilt nagaan of Navision ervoor zorgt dat de gebeurtenis zich voordoet wanneer dit naar uw mening zou moeten gebeuren, kunt u

CustXMLDoc.Blocked();

bijvoorbeeld vervangen door:

DIALOG.MESSAGE('%1 geblokkeerd', Naam);

Er wordt dan ter bevestiging een dialoogvenster weergegeven wanneer de gebeurtenis moet optreden, zodat u kunt nagaan of dit ook gebeurt. Deze aanpak is vooral geschikt als gebeurtenissen zich op interactieve wijze voordoen en niet wanneer deze als batchverwerking worden uitgevoerd. In dit tweede geval kunt u echter wel voor een vergelijkbare aanpak kiezen.


Op tijd gebaseerde gebeurtenissen

Een eenvoudig voorbeeld van een gebeurtenis is dat de gebeurtenis zich voordoet wanneer een record in Navision wordt gewijzigd. Er zijn echter, vooral in ERP-systemen, veel situaties waarin een op tijd gebaseerde gebeurtenis nodig is. Een voorbeeld van een op tijd gebaseerde gebeurtenis is:

Blader alle inkooporders door en stuur een herinnering naar de leverancier als de toegezegde ontvangstdatum over minder dan zes dagen is.

Aangezien Navision geen timer heeft die hiervoor kan worden gebruikt, dient dit probleem te worden opgelost door bijvoorbeeld een lijst te maken die de verwerking voor zijn rekening neemt. Deze lijst kan vervolgens op vaste tijden worden uitgevoerd. Dit betekent dat de verwerking een handmatig element bevat. Toch brengt het gebruik van Business Notification in een dergelijke situatie grote voordelen met zich mee. Bij de alternatieve, volledig handmatige oplossing moet een dergelijke lijst handmatig worden doorlopen en moet er met elke leverancier contact worden opgenomen. Dit zou zeer tijdrovend zijn en bovendien gemakkelijker kunnen misgaan.

Bij het ontwikkelen van een dergelijke oplossing zijn er bepaalde punten waarop moet worden gelet. Het is vooral van belang dat u moet bijhouden wie al een kennisgeving heeft ontvangen. In dit voorbeeld moet u bijhouden welke leveranciers al een kennisgeving hebben ontvangen om te voorkomen dat e-mailberichten worden gezonden aan deze leveranciers zonder dat dit nodig is.

Een aantal sjablonen dat bij Business Notification wordt geleverd, is op tijd gebaseerd. Als u iets dergelijks wilt ontwikkelen, kunt u inspiratie opdoen door deze oplossingen te bekijken. U kunt ook de structuur gebruiken die voor deze oplossingen is gebruikt. Er is tevens documentatie beschikbaar in de partnergids voor Business Notification.


Registreren

Interne gebruikers moeten zich registreren om kennisgevingen te ontvangen. U kunt zich alleen registreren als u over registratierechten beschikt of lid bent van een groep die over dergelijke rechten beschikt.

De registratie wordt uitgevoerd via een webbrowser. Daarvoor dient de URL 'http://<servernaam>/BusinessNotificationSubscribe', te worden gebruikt, waarbij <servernaam> de naam van de server is waarop het Business Notification Server-onderdeel is geïnstalleerd.

De eerste pagina is de pagina Mijn kennisgevingsregistraties. Deze pagina bevat een lijst met eventuele bestaande registraties. U kunt controleren naar welk e-mailadres de kennisgevingen worden verzonden door te klikken op Mijn informatie. Dit is het e-mailadres dat voor u is geregistreerd in Windows.

Ga als volgt te werk om een nieuwe registratie toe te voegen:

  1. Klik op Nieuw abonnement toevoegen op de pagina Mijn kennisgevingsregistraties.

  2. Klik op de pagina Nieuwe kennisgevingsregistratie selecteren die wordt weergegeven, op het keuzerondje om de kennisgeving te selecteren waarvoor u zich wilt registeren. Klik vervolgens op Selectie toevoegen. U kunt slechts één kennisgeving tegelijkertijd selecteren.

U keert automatisch terug naar de registratielijst waarin de kennisgeving wordt weergegeven die u zojuist aan de lijst hebt toegevoegd.

Ga als volgt te werk om een bestaande registratie te verwijderen:

  1. Plaats op de pagina Mijn kennisgevingsregistraties een vinkje bij een of meer registraties in de lijst.

  2. Klik op Selectie verwijderen.

  3. Er wordt een bevestigingsdialoogvenster weergegeven. Klik op Ja om te bevestigen dat u de geselecteerde registraties wilt verwijderen.


Beschrijving van sjabloon

Er wordt een aantal sjablonen geleverd bij Business Notification. Als u deze wilt gebruiken, moet u:

  1. Sjabloonbeheer van de Notification Manager gebruiken om de sjabloon in Business Notification op te nemen.

  2. In de Notification Manager klikken op Nieuw van sjabloon om een bewerkbare kopie te maken van de sjabloon die u wilt gebruiken.

De meeste maar niet alle sjablonen zijn op tijd gebaseerd. Dit betekent dat gebeurtenissen zich niet onmiddellijk in Navision voordoen. Voor elke op tijd gebaseerde sjabloon zijn bepaalde extra instellingen vereist in Navision. In het Help-onderwerp Business Notification van Navision wordt beschreven hoe ervoor kan worden gezorgd dat deze gebeurtenissen zich voordoen. Twee van de sjablonen zijn niet op tijd gebaseerd en de gebeurtenissen doen zich dan ook direct voor.

Als u echter wilt dat elke gebeurtenis, al dan niet op tijd gebaseerd, zich vanuit deze sjablonen kan voordoen in Navision, dient u te klikken op Administratie, IT-administratie, Algemene instellingen, Instellingen voor Business Notification en vervolgens een vinkje te plaatsen in het veld Berichten verzenden.

Hier volgt een korte omschrijving van de zes sjablonen.

Bedrijfsentiteit

Gebeurtenis

Omschrijving

Artikel

Status voorraad

Deze sjabloon wordt gebruik voor verzending van een kennisgeving naar leveranciers over artikelaantallen op voorraad en bestelde aantallen.

Leveranciers kunnen aan de hand van deze informatie bepalen of ze hun voorraad moeten aanvullen.

Deze sjabloon is op tijd gebaseerd. In het Help-onderwerp van Navision Business Notification, Leveranciers op de hoogte stellen van de voorraadstatus wordt uitgelegd hoe u de sjabloon kunt gebruiken.

Productieorder

Productieorder vertraagd

Deze sjabloon wordt gebruikt om een accountmanager in te lichten wanneer een productie is vertraagd. De accountmanager kan deze informatie vervolgens gebruiken om klanten op de hoogte te stellen van vertragingen bij de levering.

Deze sjabloon is op tijd gebaseerd. In het Help-onderwerp van Navision Business Notification, De productieafdeling op de hoogte stellen van vertraagde productieorders wordt uitgelegd hoe u de sjabloon kunt gebruiken.

Prod.-stuklijst

Productiestuklijst gewijzigd

Deze sjabloon wordt gebruikt om geadresseerden in te lichten over wijzigingen in een stuklijst.

De gebeurtenis doet zich onmiddellijk voor wanneer de status van de stuklijst verandert in Gecertificeerd of Afgesloten.

Prod.-stuklijstversie

Productiestuklijst gewijzigd

Deze sjabloon wordt gebruikt om geadresseerden in te lichten over wijzigingen in een stuklijstversie.

De gebeurtenis doet zich onmiddellijk voor wanneer de status van de stuklijstversie verandert in Gecertificeerd of Afgesloten.

Inkooporder

Kennisgeving over aanstaande levering

Deze sjabloon wordt gebruikt om leveranciers te herinneren aan aanstaande leveringen. De leverancier ontvangt een aantal dagen voor de toegezegde leverdatum een kennisgeving.

Het is mogelijk de kennisgeving alleen naar bepaalde leveranciers en/of alleen voor bepaalde artikelen te verzenden.

Deze sjabloon is op tijd gebaseerd. In het Help-onderwerp van Navision Business Notification, Leveranciers op de hoogte stellen van aanstaande leveringen wordt uitgelegd hoe u de sjabloon kunt gebruiken.

Inkooporder

Onbevestigde inkooporder

Deze sjabloon wordt gebruikt om een inkoper in te lichten over ontbrekende orderbevestigingen, dat wil zeggen orderbevestigingen die niet zijn ontvangen binnen een (configureerbare) tijdslimiet na publicatie van een inkooporder.

Deze sjabloon is op tijd gebaseerd. In het Help-onderwerp van Navision Business Notification, Inkoopmanagers op de hoogte stellen van onbevestigde inkooporders wordt uitgelegd hoe u de sjabloon kunt gebruiken.

Inkooporder

Niet ontvangen artikelen

Deze sjabloon wordt gebruikt om te controleren of leveranciers binnen de vervaltijd leveren en om te waarschuwen als artikelen ondanks een bevestiging van de leverancier niet zijn geleverd.

Deze sjabloon is op tijd gebaseerd. In het Help-onderwerp van Navision Business Notification, Inkoopmanagers op de hoogte stellen dat artikelen niet zijn ontvangen na de toegezegde ontvangstdatum wordt uitgelegd hoe u de sjabloon kunt gebruiken.